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 Unit-I  Fundamental of Computer, Window & DOSi 
 

Lesson: 1  
 

 Computer Concepti 
 
A computer is an electronic device that manipulates information, or "data." It has the ability to store, retrieve, and process data. You 
can use a computer to type documents, send email, and browse the internet. You can also use it to handle spreadsheets, accounting, 
database management, presentations, games, and more. In Other Words "A computer is a fast electronic device that processes the 
input data according to the instructions given by the programmer/user and provides the desired information as output." 
 
Definition of Computer In a layman language, a computer is a fast calculating device that can perform arithmetic operations. 
Although the computer was originally invented mainly for doing high speed and accurate calculations, it is not just a calculating 
device. It gets the data through an input device, processes it as per the instructions given and gives information as output. We can 
define a computer follows. 
 
Terms              Meaning 
 
Data                     A set of basic facts and entities which itself has no meaning. 
Information           Data which has some meaning or value. 
Instruction            A statement given to computer to perform a task. 
Input                     Data and Instructions given to computer. 
Process                Manipulation of data.           
 

 History of Computeri 
 
 
 The first counting device was the abacus, originally from Asia. It worked on a place-value notion meaning that the place of a bead 

or rock on the apparatus determined how much it was worth. 
 1600s : John Napier discovers logarithms. Robert Bissaker invents the slide rule which will remain in popular use. 
 1642 : Blaise Pascal, a French mathematician and philosopher, invents the first mechanical digital calculator using gears, called 

the Pascaline. Although this machine could perform addition and subtraction on whole numbers, it was too expensive and only 
Pascal himself could repare it. 

 1804 : Joseph Marie Jacquard used punch cards to automate a weaving loom. 
 1812 : Charles P. Babbage, the "father of the computer", discovered that many long calculations involved many similar, 

repeated operations. Therefore, he designed a machine, the difference engine which would be steam-powered, fully automatic 
and commanded by a fixed instruction program. In 1833, Babbage quit working on this machine to concentrate on the analytical 
engine. 

 1840s : Augusta Ada. "The first programmer" suggested that a binary system should be used for storage rather than a decimal 
system. 

 1850s : George Boole developed Boolean logic which would later be used in the design of computer circuitry. 
 1890 : Dr. Herman Hollerith introduced the first electromechanical, punched-card data-processing machine which was used 

to compile information for the 1890 U.S. census. Hollerith's tabulator became so successful that he started his own business to 
market it. His company would eventually become International Business Machines (IBM). 

 1906 : The vacuum tube is invented by American physicist Lee De Forest. 
 1939 : Dr. John V. Atanasoff and his assistant Clifford Berry build the first electronic digital computer. Their machine, the 

Atanasoff-Berry-Computer (ABC) provided the foundation for the advances in electronic digital computers. 
 1941 : Konrad Zuse (recently deceased in January of 1996), from Germany, introduced the first programmable computer 

designed to solve complex engineering equations. This machine, called the Z3, was also the first to work on the binary system 
instead of the decimal system. 

 1943 : British mathematician Alan Turing developed a hypothetical device, the Turing machine which would be designed to 
perform logical operation and could read and write. It would presage programmable computers. He also used vacuum technology 
to build British Colossus, a machine used to counteract the German code scrambling device, Enigma. 

 1944 : Howard Aiken, in collaboration with engineers from IBM, constructed a large automatic digital sequence-controlled 
computer called the Harvard Mark I. This computer could handle all four arithmetic operations, and had special built-in programs 
for logarithms and trigonometric functions. 

 1945 : Dr. John von Neumann presented a paper outlining the stored-program concept. 
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Generations of Computeri 
 
The history of computer development is often referred to in terms of five distinct eras, or "generations" of computing devices. Each 
generation of computer is characterized by a major technological development that fundamentally changed the way computers 
operate, resulting in increasingly smaller, cheaper, more powerful and more efficient and reliable devices. 
 
The First Generation: 1946 to 1955 
 
The first computers used vacuum tubes for circuitry, magnetic drums and magnetic cores for memory, and were 
often enormous, taking up entire rooms.  They were very expensive to operate and in addition to using a great deal 
of electricity, generated a lot of heat, which was often the cause of malfunctions. 
First generation computers relied on machine language, the lowest-level programming language understood by 
computers, to perform operations, and they could only solve one problem at a time. Input was based on punched 
cards and paper tape, and output was displayed on teletype printers. The UNIVAC is the most famous first 
generation computer.  Manufactured by Sperry-Rand Corporation, the first UNIVAC was delivered to the U.S. 
Census Bureau in 1951 - becoming the first computer that was not used for military or scientific purposes. 

 

 
The Second Generation: 1956 to 1963 
 
Transistors replaced vacuum tubes and used in the second generation of computers.  The transistor was 
invented in 1947 but did not see widespread use in computers until the late 50s.  The transistor was far 
superior to the vacuum tube, allowing computers to become smaller, faster, cheaper, more energy-
efficient and more reliable than their first-generation predecessors. Though the transistor still generated a 
great deal of heat that subjected the computer to damage, it was a vast improvement over the vacuum 
tube.  Second-generation computers still relied on punched cards for input and printouts for output. 
Second-generation computers moved from cryptic binary machine language to symbolic, or assembly, 
languages, which allowed programmers to specify instructions in words.  High-level programming 
languages were also being developed at this time, such as early versions of COBOL and FORTRAN.  
It was during this era that IBM became the world-wide leader in computer manufacturing.  IBM also developed the first hard disk in 
this period - a massive device that was comprised of 50 platters, each with a 2-foot diameter.  The entire hard disk could store a 
whopping 5MB. 
 
The Third Generation:  1964 to 1970 
 
The third generation is characterized by the development of the integrated circuit - a complete 
electrical circuit whose components (transistors, capacitors, etc.) are fabricated onto a small "chip" 
made of silicon ... otherwise known as an integrated circuit chip, or IC chip.  IC chips drastically 
increased the speed and efficiency of computers. 
Instead of punched cards and printouts, users interacted with third generation computers through 
keyboards and monitors and interfaced with an operating system, which allowed the device to run 
many different applications at one time with a central program that monitored the memory.  Although 
still large by today's standards, third-generation computers were smaller and cheaper than their 
predecessors, and were now being mass-produced (primarily by IBM) for commercial use around the 
world. 
 
The Fourth Generation: 1971 to 1991 
   
The fourth generation is distinguished primarily as the generation in which the personal computer first 
appeared.  This was made possible by the development of the microprocessor by Intel Corp.  A 
microprocessor is a single IC chip that contains an entire computer processor - essentially, an entire 
first-generation computer that can fit in the palm of your hand. 
The second breakthrough was a series of improvements in IC design and manufacturing methods 
which allowed engineers to create IC chips with tens of thousands of transistors, a process now known 
as large scale integration (LSI).  This allowed more complex systems to be produced using smaller 
circuit boards, and at a reduced cost.  Solid-state electronics began to make their way into everyday 
life. home appliances, radios, TVs, games, and more. 
In 1981 IBM introduced its first computer for the home user, and in 1984 Apple introduced the 
Macintosh.  As these small computers became more powerful, they could be linked together to form 
networks, which eventually led to the development of the Internet.  Fourth generation computers also 
saw the development of GUIs, the mouse and handheld devices. 
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The Fifth Generation: 1992 to present 
 
In the computing world, there is no real consensus on the timeline (or even the existence of) a fifth generation of computers.  It can be 
argued that while microprocessors have become more powerful, and integrated circuits have become smaller, the underlying 
technology has not really changed since the fourth generation. 
If we wish to recognize a "fifth generation" at all, then perhaps it reflects a shift in computer use, rather than computer technology.  
The emergence of the Internet, and particular, the World Wide Web has forever changed the way computers are used in society.   
Artificial intelligence - a field of study that predates the first generation - is now a reality, with devices that are capable of learning, self-
organization, and natural language input. 
If a "true" fifth generation (based on technology only) emerges, it will probably be based upon quantum computation, molecular / 
nanotechnology, or some other innovation that will enhance (or replace) the integrated circuit, and once again radically change the 
face of computers 
 

 
Classification of Computeri 

 
The classification of computers is based on the following four criteria: 

 
1.    According to Purpose 
2.    According to Technology Used  
3.    According to Size and Storage Capacity  
 
1. According to Purpose Computers are of following two types: 

 
I.     General Purpose Computers 

Computers that follow instructions for general requirements such as sale  
analysis, financial accounting, invoicing, inventory, and Management information etc. are called general computers. Almost all 
computers used in offices for commercial, educational and the applications are general-purpose computers. 

 
II.    Special Purpose Computers 

Computers that are designed from scratch to perform special tasks like scientific applications and research, whether forecasting, 
space applications, medical diagnostics, etc. are called special purpose computers. 

 
2. According To Technology Used Computers are of the following three types: 

 
I       Analog Computer 

Analog computers are special purpose computer that represent and store data in continuously varying physical quantities such 
as current, voltage or frequency. These computers are programmed for measuring physical quantities like pressure, temperature, 
speed etc. and to perform computations on these measurements. Analog computers are mainly used for scientific and 
engineering applications. Some of the examples of analog computers are :- (a) Thermometer: It is a simple analog computer 
used to measure temperature. In thermometer, the mercury moves up or down as the temperature varies. (b) Speedometer:  
Car's speedometer is another example of analog computer where the position of the needle on dial represents the speed of the 
car. 

 
II.    Digital Computer 

Digital computers are mainly general-purpose computers that   represent and store data in discrete quantities or numbers. In 
these computers, all processing is done in terms of numeric representation (Binary Digits) of data and information. Although the 
user enters data in decimal or character form, it is converted into binary digits (O's and 1's). Almost all the computers used 
nowadays are digital computers. 

 
III.   Hybrid Computers 

Hybrid computers in corporate the technology of both analog and digital computers. These computers store and process analog 
signals, which have been converted, into discrete numbers using analog-to-digital converters. They can also convert the digital 
numbers into analog signals or physical properties using digital-to-analog converters. Hybrid computers are mainly used in 
artificial intelligence (robotics) and computer aided manufacturing (e.g. process control). 

 
3.    According to Size and Storage Capacity Computers are of the following four types: 

 
I.      Micro Computer:  

Micro Computers are the smallest category of computer consisting of a microprocessor and associated storage and input/ output 
elements. They are designed to be used by one person at a time, meaning they are single user oriented ones. 

 
II.     Mini Computers:  
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Mini computers are relatively fast but small and expensive Computers with some what limited input/output capabilities. Mini 
systems are designed to simultaneously handle the processing needs of multiple user. Mini Computer provides the facility of 
more stored capacity and communication link between users. 

 

III. Mainframe Computers :  
Mainframe computers are large computer systems that have the   capability to support many powerful peripheral devices 
 

IV. Super computers :  
Computer system characterized by their very large size and very high processing speed. Generally used for complex scientific 
applications. 

   
 Other Different Types of Computersi 

 
When most people hear the word "computer" they think of a personal computer such as a desktop or laptop computer. However, 
computers come in many shapes and sizes, and they perform many different functions in our daily lives. When you withdraw cash 
from an ATM, scan groceries at the store, or use a calculator, you're using a type of computer. 
 

Desktop Computers: Many people use desktop computers at work, home, school, or the library. They can be 
small, medium, or large in style, and usually sit on a desk. Once you add a monitor, mouse, and a keyboard, you 
have what is typically known as a desktop computer. Most desktop computers are easy to upgrade and expand, 
or add new parts. Another benefit of desktop computers is the cost. If you compare a desktop and a laptop with 
the same features, you will most likely find that the desktop computer is priced lower. Some desktop computers 
have a built-in monitor to save space. These are often called all-in-one desktop computers. 

 
Laptop Computers: You may be familiar with is a laptop computer or laptops as they are often referred to. Laptops 
are battery or AC-powered personal computers that are more portable than desktop computers, allowing you to use 
them almost anywhere. Since a laptop is smaller than a desktop, it's more difficult to access the internal components. 
That means you may not be able to upgrade them as much as a desktop. However, it's usually possible to add 
more RAM or a bigger hard drive. A laptop computer is sometimes called a notebook computer because of its size. 
 
Servers: A server is a computer that "serves up" information to other computers on a network. Many businesses have file servers that 
employees can use to store and share files. A server can look like a regular desktop computer, or it can be much larger. Servers also 
play an important role in making the internet work: they are where web pages are stored. When you use your browser to click a link, 
a web server delivers the page you requested. 
 
Tablet Computers: These use a touch-sensitive screen for typing and navigation. Since they don't require a 
keyboard or mouse, tablet computers are even more portable than laptops. The iPad is an example of a tablet 
computer. 
 
Game Consoles: A game console is a specialized kind of computer that is used for playing video games. Although they are not as 
fully-featured as a desktop computer, many newer consoles, such as the Nintendo Wii, allow you to do non-gaming tasks like 
browsing the internet. 
 
PC: This type of computer began with the original IBM PC that was introduced in 1981. Other companies began to create similar 
computers, which were called IBM PC Compatible (often shortened to PC). Today, this is the most common type of personal 
computer, and it typically includes the Microsoft Windows operating system. 
 
Mac: The Macintosh computer was introduced in 1984, and it was the first widely sold personal computer with a Graphical User 
Interface, or GUI (pronounced gooey). All Macs are made by one company, Apple Inc., and they almost always use the Mac OS 
X operating system.  
 

 Characteristic of Computeri 
 
Fast:  A computer is so fast that it can perform the given task (arithmetical of logical) in few seconds as compared to man who can 
spend many months for doing the same task. A computer can process millions of instructions per second. 
Accurate: While doing calculations, a computer is more accurate than a man. Man can make mistakes in calculations but a computer 
does not, if it is provided with accurate instructions. 
High Memory: A computer has much more memory of storage capacity than human beings. It can store millions of data and 
instructions, which can be retrieved and recalled even after number of years. This is not possible in cast of human brain. 
Diligence: A computer does not suffer from the human traits of tiredness and boredom. Man will be tired and bored while doing 
millions of calculations but computer, being a machine, does this jobs very efficiently and without any tiredness and boredom. 
No Intelligence: A computer is a machine and obviously has no intelligence of its own. Each and every instruction must be given to 
the computer for doing a task.  
 

_______________________________ 
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Lesson: 2  
 

 CPU (Input/Output Unit)i 
 
We know that the computer is machine that processes the input data according to a given set of instructions and gives the output. 
Before a computer does processing, it must be given data and instructions. 
After processing, the output must be displayed or printed by the computer. The unit used for getting the data and instructions into the 
computer and displaying or printing output is known as an Input/Output (I/O unit) .The Input Unit is used to enter data and instructions 
into a computer. There are many peripheral devices which are used as Input/Output unit for the computer. The most common form of 
input device is known as a terminal. A terminal has an electronic typewriter like device, called keyboard along with a display screen, 
called Visual Display Unit (VDU) or monitor. Keyboard is the main input device while the monitor can be considered both as input as 
well as an output device. There are some other common input devices like mouse, punched card, tape, joystick, scanner, modem etc. 
Monitor, Printer and Plotter are the main peripheral devices used as output units for the computer. 

 
Central Processing Unit (CPU) 
 
CPU is the main component or "brain" of a computer, which performs all the processing of input data, its function is to 
fetch, examine and then execute the instructions stored in the main memory of a computer. In microcomputers, the CPU 
is built on a single chip or Integrated Circuit (IC) and is called as a Microprocessor.  
                               
 

The CPU consists of the following distinct parts: 
 
1.      Arithmetic Logic Unit (ALU)  
2.      Control Unit (CU) 
3.      Registers 
4.      Buses 
5.      Clock 
 
1.     Arithmetic Logic Unit (ALU) 

The arithmetic logic unit of CPU is responsible for all arithmetic 
operations like addition, subtraction, multiplication and division 
as well as logical operations such as less than, equal  to and 
greater than. Actually, ail calculations and comparisons are 
performed in the arithmetic logic unit. 

 
2.    Control Unit (CU)   
       The control unit is responsible for controlling the transfer of data and instructions among other units of a computer. It is 

considered as the "Central Nervous System" of computer, as it manages and coordinates all the units of the computer. It obtains 
the instructions from the memory, interprets them and directs the operation of the computer. It also performs the physical data 
transfer between memory and the peripheral device.   

 
3.    Registers 
       Registers are small high speed circuits (memory locations) which are used to store data, instructions and memory addresses 

(memory location numbers), when ALU performs arithmetic and logical operations. Registers can store one word of data (1 word 
= 2 bytes & 1 byte = 8 bits) until it is overwritten by another word. Depending on the processor's capability, the number and type 
of registers vary from one CPU to another. Registers can be divided into six categories viz. General Purpose Registers, Pointer 
Registers, Segment Registers, Index Registers, Flag Register and Instruction Pointer Register, depending upon their functions. 

 
4.    Buses 
       Data is stored as a unit of eight bits (BIT stands for Binary Digit i.e. 0 or 1) in a Register. Each bit is transferred from one register 

to another by means of a separate wire. This group of eight wires, which is used as a common way to transfer data between 
registers, is known as a bus. In general terms, bus is a connection between two components to transmit signal between them. 
Bus can be of three major types viz. Data Bus, Control Bus and Address Bus. The data bus is used to move data, address bus to 
move address or memory location and control bus to send control signals between various components of computer. 

 
5.    Clock   
       Clock is another important component of CU, which measures and allocates a fixed time slot for processing each and every 

micro-operation (smallest functional operation). In simple terms, CPU is allocated one or more clock cycles to complete a micro-
operation. CPU executes the instructions in synchronization with the clock pulse. The clock-speed of CPU is measured in terms 
of Mega Hertz (MHz) or Millions of Cycles per second. The clock speed of CPU varies from one model to another in the range 
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4.77 MHz (in 8088 processor) to 266 MHz (in Pentium II). CPU speed is also specified in terms of Millions of Instructions Per 
Second (MIPS) or Million of Float-ing-Point Operations Per Second (MFLOPS) 

 
 

 About Front of CPUi 
 
1. Optical Disc Drive: Often called a CD-ROM or DVD-ROM drive, these let your computer read 
CDs and DVDs. Most optical disc drives can also write (or "burn") data to CD-R and DVD-R discs. 
More recent drives can read Blu-ray Discs and write to BD-R (Blu-ray Disc recordable) discs, and 
these drives are often called BD-ROM, BD-RE, or Blu-ray drives. 
2. Power Button: The power button is used to power the computer on and off. Additionally, you can 
use the power button on some computers to place the computer in different energy-saving 
modes such as hibernate, sleep, and standby. It is a good idea to read your manual to learn how 
these features work on your computer. 
3. Audio In/Audio Out: Many computers include audio ports on the front of the computer case that 
allow you to easily connect speakers, microphones and headsets, without fumbling with the back of 
the computer. 
4. USB (Universal Serial Bus) Port: Most desktop computers have several USB ports. These can 
be used to connect almost any type of device, including mice, keyboards, printers, digital cameras 
and more. They will often appear on the front and back of the computer. A typical Blu-ray disc can 
hold 25 gigabytes of data, and some can hold 50 gigabytes or more. This is much more 
than CDs or DVDs, making BD-R discs ideal for storage. 
 
 
 

 Back of CPUi 
 
On the back of the computer case are connection ports that are made to fit specific 
devices. The arrangement of these vary from computer to computer, and many companies 
have their own special connectors for the specific devices. Some of the ports may be color 
coded to match a color on the device, which will help you determine which port is used with 
a particular device. 
 

1. Power Socket: This is where you'll connect the power cord to the computer. 
2. Audio In/Audio Out: Almost every computer has two or more audio 

ports where you can connect various devices, including speakers, microphones, 
headsets, and more. 

3. Ethernet Port: This port looks a lot like the modem or telephone port but it is a 
little bit wider. You can use this port for networking and also connecting to the 
internet. 

4. USB Ports: On most desktop computers, most of the USB ports are on the back 
of the computer case. Generally, you'll want to connect your mouse and 
keyboard to these ports, and keep the front USB ports free so that they can be 
used for digital cameras or other devices. 

5. Monitor Port: This is where you'll connect your monitor cable. In this example, 
the computer has both a Display Port and a VGA port. Other computers may 
have other types of monitor ports, such as DVI (Digital Visual 
Interface) or HDMI (High-Definition Multimedia Interface). 

6. Expansion Slots: These empty slots are where expansion cards are added to 
computers. For example, if your computer did not come with a video card, you 
could purchase one and install it here.  

The following ports are less common today: 

7. Serial Port: This is an older port that was frequently used to 
connect peripherals such as digital cameras, but today it has been replaced by 
USB and other types of ports. 

8. PS/2: These ports are sometimes used for connecting the mouse and keyboard. 
Typically, the mouse port is green, and the keyboard port is purple. 

9. Parallel Port (or Printer Port): This is an older port that is less common on new 
computers. Like the serial port, it has now been replaced by USB. 
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 Inside of CPUi 
 
CPU/Processor 

 
The Central Processing Unit (CPU), also called a processor, is located inside the computer case on 
the motherboard. It is sometimes called the brain of the computer, and its job is to carry out 
commands. Whenever you press a key, click the mouse, or start an application, you're sending 
instructions to the CPU. 
The CPU is generally a 2-inch ceramic square with a silicon chip located inside. The chip is usually 
about the size of a thumbnail. The CPU fits into the motherboard's CPU socket, which is covered by 

the heat sink, an object that absorbs heat from the CPU. 
A processor's speed is measured in megahertz (MHz), or millions of instructions per second, and gigahertz (GHz), or billions of 
instructions per second. A faster processor can execute instructions more quickly. However, the actual speed of the computer 
depends on the speed of many different components - not just the processor. There are many processor manufacturers for personal 
computers, but the most well-known ones are Intel and AMD. 
 
Motherboard 
 
The motherboard is the computer's main circuit board. It's a thin plate that holds the CPU, 
memory, connectors for the hard drive and optical drives, expansion cards to control the video 
and audio, as well as connections to your computer's ports (such as the USB ports). The 
motherboard connects directly or indirectly to every part of the computer. 
 
Power Supply Unit 

 
The power supply unit in a computer converts the power from the wall outlet to the type of power 
needed by the computer. It sends power through the cables to the motherboard and other 
components. 
If you decide to open the computer case and take a look, make sure to unplug the computer first. 
Before touching the inside of the computer, you should touch a grounded metal object (or a metal 
part of the computer casing) to discharge any static buildup. Static electricity can be transmitted 
through the computer circuits and ruin them. 
 
 

 
RAM (Random Access Memory) 
 
RAM is your system's short-term memory. Whenever your computer performs 
calculations, it temporarily stores the data in the RAM until it is needed. 
This short-term memory disappears when the computer is turned off. If you're 
working on a document, spreadsheet, or other type of file, you'll need to save it 
to avoid losing it. When you save a file, the data is written to the hard drive, 
which acts as long-term storage. RAM is measured in megabytes (MB) or 
gigabytes (GB). The more RAM you have, the more things your computer can do at the same time. If you don't have enough RAM, 
you may notice that your computer is sluggish when you have several programs open. Because of this, many people add extra 
RAM to their computers to improve performance. A bit is the smallest unit of data in computer processing. A byte is a group of eight 
bits. A megabyte contains about one million bytes, and a gigabyte is about one billion bytes. 
 
Hard Drive 

 
 
The hard drive is the data center of the computer. This is where the software is installed, and it's 
also where your documents and other files are stored. The hard drive is long-term storage, which 
means the data is still saved even if you turn the computer off or unplug it. 
When you run a program or open a file, the computer copies some of the data from the hard 
drive onto the RAM so that it can access the data more easily. When you save a file, the data is 
copied back to the hard drive. The faster the hard drive is, the faster your computer can start 
up and load programs. 
Most hard drives are hard disk drives, which store data on a magnetic platter. Some computers 
now use solid-state drives (also called flash hard drives). These are faster and more durable 
than hard disk drives, but they are also more expensive. A USB flash drive is basically a small, 
removable flash hard drive that plugs into a USB port. These are a convenient way to bring your 
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files with you and open them on a different computer. 
 
If you're using Windows, you can view information about your computer's RAM and processor speed without opening up your 
computer. Just go to the Control Panel (in the Start menu) and click System and Security. In Mac OS X, you can view this information 
by clicking the Apple icon and selecting About This Mac. 
 
 
Expansion Cards 
 
Most computers have expansion slots on the motherboard that allow you to add various types of expansion cards. These are 
sometimes called PCI (Peripheral Component Interconnect) cards. You may never have to add any PCI cards, as most motherboards 
have built-in video, sound, network, and other capabilities. However, if you want to boost the performance of your computer or update 
the capabilities of an older computer, you can always add one or more cards.  
 
Below are some of the most common types of expansion Cards:-  
 
Video card- 
 
The video card is responsible for what you see on the monitor. Most computers have a GPU 
(Graphics Processing Unit) built into the motherboard, instead of having a separate video 
card. If you like playing graphics-intense games on the computer, you can add a faster video 
card to one of the expansion slots to get better performance.   
 
 
Sound Card- 
 

 
The sound card, also called an audio card, is responsible for what you hear in the 
speakers or headphones. Most motherboards have integrated sound, but you can upgrade 
to a dedicated sound card for higher quality sound.   
 
 
 
 

 
 
Network Card- 
 
 
The network card allows your computer to communicate over a network and access the 
internet. It can either connect with an Ethernet cable or through a wireless connection 
(often called Wi-Fi). Many motherboards have built-in network connections, and a 
network card can also be added to an expansion slot.   
 
 
Bluetooth Card- 
 

 
 
Bluetooth is a technology for wireless communication over short distances. It's often used in computers to 
communicate with wireless keyboards, mice, and printers. It's often built into the motherboard or included in 
a wireless network card. For computers that don't have Bluetooth, a USB adapter (called a dongle) can be 
purchased.   
 
 
 

 
 

______________________________________ 
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Lesson: 3  
 

Bit, Byte & Number Systemi 
 
Computers only understand the binary number system based on the unit 2 denary. Programming often uses the hexadecimal system 
base on a unit of 16 denary. For example HTML uses hexadecimal numbering in the color attribute, e.g. color="FF00FF". Another less 
common system is octal based on 8 denary. 
You should know how to convert between the different systems. The ASCII table at the foot of this page is useful for a quick 
conversions up to 127 denary. The windows calculator (in scientific mode) can be used for conversions. College and University 
students may find that calculators are not allowed in the exam, OU course T223 is an example of this, there fore manual conversion 
calculations must be made. This should be practiced to speed up the process, the calculator only used to check your manual 
conversion. 
 
Bit 
 
A binary digit is called a bit. Usually expressed as 0 and 1 the two numbers of the binary numbering system. 
A bit is the smallest unit of information a computer can use. A 16 bit computer would process a series of 16 bits, such as 
0100111101011000 in one go, repeating the process thousands or millions of times per second. 
Reading a series of bits is very difficult and to make this process easier they are often displayed in groups of 4 bits 
0100 1111 0101 1000. This grouping is quite interesting in that a group of 4 bits can be replaced by a single hexadecimal digit 
Two groups of 4 bits, i.e. 8 bits (a byte) can be replaced by 2 hexadecimal digits, and 4 hexadecimal digits are required to replace all 
16 bits. 
 

Binary 0100 1111 0101 1000 

Hexadecimal 4 F 5 8 

Byte 
A group of 8 bits are in a byte. With 8 bits (binary digits), there exist 256 possible denary combinations. If you remember that 
1 byte can store one alphabetical letter, single digit, or a single character/symbol, such as #. Large numbers of bytes can be 
expressed by kilobyte and megabyte. 
 
Kilobyte 
The value of a kilobyte is 1024. Worked out as 2^10. Normally Kilo refers to 1000 but in computing kilobyte is 1024. 
 
Megabyte 
Likewise, 1024Kb is referred to as a "Megabyte". Normally a Mega refers to a million. In computing 1 Mega byte is 1,048,576 
bytes. Worked out as 1024*1024. 
 
1 byte of memory can normally hold one of the following: 
A single alphabetical letter (upper or lower case), 
A single number 0-9 
A symbol ( _ + £ # > etc. 
A further 127 alternative characters. These could be the letters used in foreign languages, lines to produce boxes etc. 
In every day life we usually use the denary number system which has a base of 10. But we also use other number systems, think 
of time (base 60, and base 10 within it), imperial distance yards and feet (base 3), there are many others, dates probably being the 
hardest number system to do calculations with. 
 

Number Systemsi 
 

The every day number system we use is the denary system, sometimes called the decimal system. In programming three number 
systems are commonly used, binary, hexadecimal and to a lesser extent octal. In the denary, binary, octal, hexadecimal systems, the 
value of any digit in a number depends on its position within that number. I.e. which column it is in. 
 
How do numbering systems work? 
 
To understand this we will examine the Denary system in more detail. Because you are so used to the denary system and because it 
is very easy to multiply by 10, 100, or a 1000 etc you calculate the number in your head.  Let’s use the number 256 as an example. 
The calculation that is automatically done is the following 
The most important calculation to do is to work out the positional values for that system. The positional value is based on the powers 
of the number systems base value. 
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Power of the base 104 103 102 101 100 

Calculation 10x10x10x10 10x10x10 10x10 The value of the base 
number 

Any number to the power 0 
is always 1 

= Position value 10,000 1000 100 10 1 

  
Write down the Positional values for the number system you are using so for Denary we would write: 
 

Position value 10,000 1000 100 10 1 

 
Underneath the correct positional value write in your number: 
 

Position value 10,000 1000 100 10 1 

Enter Number   2 5 6 

 
The calculation that is done: 
 

Position value 10,000 1000 100 10 1 

Enter Number   2 5 6 

Required Calculation     100x2 10x5 1x6 

This equals     200 50 6 

 
Add the 3 results 200 + 50 + 6= 256. 
 

 

 
You can convert a number in any number system to a denary number using this calculation. Ensure you use the positional values for 
the number system you are using. 
  
Denary Numbering (base 10) sometimes called Decimal system 
 
The decimal system name should not be used because of confusion that this could be thought as introducing the decimal point and 
money systems. Uses numbers 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, that's 10 numbers. Hence base 10. Radix is another name for base 10. 
Adding 1 to 9 we must introduce an additional column to the left i.e. 10 
 

Power of the base 104 103 102 101 100 

Position value 10,000 1000 100 10 1 

 
A byte of memory can store a number in the range 0 to 255 Denary. 
 
Binary Numbering (base 2) 
 
A series of eight bits strung together makes a byte, much as 12 makes a dozen. With 8 bits, or 8 binary digits, there exist 2^8=256 
possible combinations 
Uses numbers 0, 1, that's 2 numbers. Hence base 2. Binary numbering is the number system that is used by computers. 
Note: The positional value doubles as you go to the next positional on the left. 
 

Power of the base 24 23 22 21 20 

Positional value 16 8 4 2 1 

 
A binary digit is called a bit. There are two possible states in a bit, usually expressed as 0 and 1, the two numbers used in the binary 
number system. But the bit could represent on / off of an electrical circuit, yes / no, true / false, -1 / 0, -1 / +1, zero / non zero, or 
similar 2 state binary wording. 
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A byte of memory can store a number in the range 00000000 to 11111111 binary. 
Numbers are often displayed in groups of 4, as follows, to make them easier to read 0000 0000 to 1111 1111 binary. 
 
How to Convert Binary to Denary?  
 
Convert 1011 binary to denary: 
 
 

Positional value 16 8 4 2 1 

Enter Number   1 0 1 1 
Required Calculation   8x1 4x0 2x1 1x1 

This equals   8 0 2 1 

 
Add the 3 results 8 + 0 + 2 + 1=11. 
 
Therefore 1011(One Zero One One) binary = 11 (Eleven) Denary 
 
Hexadecimal Numbering (base 16) 
 
Uses numbers 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, A, B, C, D, E, F, that's 16 numbers. Hence base 16.. 
A=10 Dec, B=11 DEC, C=12 DEC, D=13 DEC, E=14 DEC, F=15 Dec. By using the letters A-F a single digit only requires a single 
position (column). 
 

Power of the base 164 163 162 161 160 

Positional value 65536 4,096 256 16 1 

 
A byte of memory can store a number in the range 00 to FF Hex. 
  
Hexadecimal numbers are often displayed in groups of 2, to make them easier to read. E.g. 
10 AF 3C 9F 
 
A single hexadecimal number requires 4 units of binary numbers. This makes it reasonably easy to convert between these two 
numbering systems. E.g. 
1 = 0001 
9 = 0101 
A = 1010 
  
Octal (base 8) 
 
Uses numbers 0, 1, 2, 3, 4, 5, 6, 7, , that's 8 numbers. Hence base 8.. 
 
A byte of memory can store a number in the range 0 to 377 Oct. 
 

Power of the base 84 83 82 81 80 

Positional value 4096 512 64 8 1 

 
Binary Systems 
 
The Binary system is used by digital devices such as computers. 
 
Consists of two possible states such as On - Off, Yes - No, True - False, Zero - Non Zero and possibly more confusing in 
programming -1 and 0. 
 
These states are usually represented by either the number 0 or 1 of the binary number system. 
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Lesson: 4  
 

 Computer Hardware: Input & Output Devicesi 
 
Input and Output Devices 
 
The input device can accept data in some suitable form and translate it into sequence of electrical pulses for inputting into the central 
processor. Similarly output devices accept data from CPU in sequence of electrical pulses and represent it in suitable form for 
human beings. So the input and output unit of a computer system establish the communication between the system and its users. 
 
1. Key-board 
 

The keyboard is the most important input device of the computer. The computer and its other peripherals are mostly used with 
the help of a keyboard only. All commands are given through the keyboard. The keyboard of a computer is similar in many ways 
to keyboard of typewriter except that a computer's keyboard has many more keys, more capable and can do several more 
functions. Keyboards are mainly of three types (on the basis of number of keys). 84,87,101,106 keys keyboard. 

 
       The standard IBM-PC keyboard can be divided into three general areas:  
 

 Typewriter area:  Having the standard set of alphabet letters and number keys. 
 Function keys: F1 through F10 or F12 which have different functions de pending on the software. 
 Numeric Keypad: Having cursor control and number keys some keys on this pad has dual roles. 
 Cursor Control Key: by this button we can leave. Right, upper and down side. By using M line or one character to second 

character easily. Other four control 
key (HOME, END, PGDN, PGUP). 
HOME key is use to transfer cursor 
on top .END key is use to transfer the 
control on the end of page. PGUp key 
is use to transfer the control on top of 
the page. PGDN is use to transfer the 
control on the next page. 

 NUMERIC KEY: In right side of 
keyboard numeric key pad. These 
Key pad like a calculator but some 
key use a double function for example 
(.) key use as Del. (1) key is use as 
END, (9) key use as PGDN, (7) key is 
use as HOME . When the on of num 
Lock the key pad work as calculator 
and off position the pad perform 
special function. 

 CAPSLOCK: Generally,any character 
type in small letter. On the Position of 
CapsLock on, the Character type in 
Capital letters. On the off the 
character type in small letter. 

 Shift key: In every key board print two characters on the key. One is upper side and second is lower side. By press the shift 
key, we type the upper letter of key. On the position of Caps Lock all the character will type in small letter. 

 Ctrl & Alt: For perform special function use these key with the combination of other key. use of These key are depend on 
different software. For example the CTRL key use with C for terminate any command in DOS. By pressing CTRL, ALT and 
DEL key we can restart of computer.  

 ENTER KEY: At the ending time of instruction, we use these key. In other side   we use   these key for changing the line at the 
typing time. 

 PAUSE KEY: By using these key, we can break the scrolling of computer Screen. 
 TAB KEY: By using of these key we can skip the cursor on decided point, by default setting these point on half inch position. 

We can change these as per our requirement. For Paragraph, Column, Text and Table Setting time use these Tab Key.  
 ESCAP KEY: By using these key we prevent to execute rest of command. 
 PRINT SCREEN: By using these key we can print the information of the screen. 
 DELETE KEY: By these key we erase the character. By using these key, the character erased on cursor position. 
 Back Space Key: By these key we can erase the character. But the last character will be erased not inside character.  
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2.    Mouse 
 

The Invention of Mouse in 1977 by the PRAGLUSH C ENJELVART on stefoun 
Laboratory. Mouse is an input device shown in Fig. that is used with your personal 
computer. It rolls on a small ball and has two or three buttons on the top. When you rolls 
the mouse across a flat surface the screen censor mouse in the direction of mouse 
movement. The cursor moves very fast with mouse giving you more freedom to work in 
any direction. In mouse there are two metal wheels whose axes are at right angles. 
Each wheel of the mouse is connected to encoder which emits electrical pulses for 
every incremental rotation of wheel. When the mouse is rolled, its movement is sensed 
by the two wheels in two perpendicular directions. The visual feedback is given by the 
censor on the monitor screen.  

 
3.    Light Pen 

 
 A light pen is a pointing device. It is used to select a displayed menu option on the CRT. It is a 
photosensitive pen like device. It is capable of sensing a position on the CRT screen when its tip 
touches the screen. When its top is moved over the screen surface, its photocell sensing element 
detects the light coming from the screen and the corresponding signals are sent to the processor. 
The menu us a set of programmed choices offered to the user. The user indicates his choice by 
touching light pen against a desired description of the menu. The signals sent by the light pen to the 
processor identify the menu option.  
 

 

4.    Joystick 
 
       The joystick is mostly used in children's games. It is an input device with me-chanica push button. It is used to 

control the cursor and for issuing commands. It consists of a long handle with four switches arranged in four 
directions. (East, West, North, South) The switch is activated in that directions and the cursor which moves on 
the screen in the directions in which the Handle moved. 

 
1. Track Ball 

        
Trackball is another type of input device, which is used in lap-top computers. It is fixed on the board, cursor on 
the screen is moved in a direction according to the Trackball is moved. Trackball is a circular ball. 
 
                       
 

2. Scanner 
 

       The keyboard can input only text through keys provided in it. If we want to input a picture the 
keyboard cannot do that. Scanner is an optical device that can input any graphical matter and 
display it back. The common optical scanner devices are Magnetic Ink Character Reader (MICR), 
Optical Mark Reader (OMR) and Optical Character Reader (OCR) as discussed below:-  

 
 Magnetic Ink Character Reader (MICR) 
       This is widely used by banks to process volumes of Cheque and drafts. Cheque is put inside the MICR. As they enter the, reading 

unit the Cheque pass through the magnetic field which causes the read head to recognize the character of the Cheque. 
 
  
 
 
 
 
 
 
  
 
                                                                                                                                
                             
 
 
                                      MICR 
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 Optical Mark Reader (OMR)  
An optical mark reader (OMR) is able to rapidly read specially designed 
candidate answer sheets, such as the double sided sheet in use at Curtin.  
Optical mark readers look for the presence or absence of shaded areas on 
the form, in specified fields filled in by students to indicate their choice of 
answer.  Other information such as student name / ID number can also be 
captured this way.  Note that although they are often called scanners, such 
readers don’t usually produce an image of the form.  Instead, they produce 
an output file containing data obtained from reading the form fields. 

        
 Optical Character Reader (OCR) 

 
This techniques units the direct reading of any printed character. Suppose you have 
a set of hand written characters on a piece of paper. You put it inside the scanner 
of the computer. This pattern is compared with a site of patterns store inside the 
computer. Whichever pattern is matched is called a character read. Patterns that 
cannot be identified are rejected. OCRs are expensive though better the MICR. 
  

 
 

 Optical Bar Code Readers (OBCR) 
This method uses a number of bars (lines) of varying thickness 
and spacing between them to indicate the desired information. 
Bar codes are used on most manufactured retail products. 
Optical bar reader can read such bars and convert them into 
electrical pulses to be processed by a computer. The most 
commonly used bar code is Universal Product Code (UPC). The 
UPC code uses series vertical bars of varying widths. These 
bars are detected as ten digits. The first five digits identify the 
supplier or manufacturer of the item. The second five digits 
identify the product. 

 
 
7.    Visual Display Unit (VDU) 
 
       It is nothing but a high resolution TV without sound section and tuner. It is used to display text entered through keyboard. Each 

character is displayed by the matrix 5, 7 dots. A display unit normally has 80 characters per horizontal lines and 24 such lines on 
the screen. The VDC consists of a Cathode Ray Tube (CRT) which produces a brain of electrons that makes the picture on the 
screen. 

 
       The monitor or VDU available in various forms: 
 

 Monochrome monitor 
 RGB monitor (Red, Green and Blue)  
 Color Monitor                                                                  
                                                                                              Monochrome Monitor                        RGB Monitor                      Color Monitor 

                                                                                                 
8.    Printer 
 

Here is the information about different types of printers you should be 
aware of. The main categories are: - laser printers, ink-jets, dot-matrix, 
multifunctional, etc. Normally home computer users will use ink-jets as 
they are relatively cheap but superior in quality to dot-matrix. Laser jets 
and other printers created by new technology are more expensive and 
more commonly found in the offices.  

  

 Ink-jets (bubble-jets): printers spray ionized tiny drops of ink onto a 
page to create an image.  This is achieved by using magnetized plates 
which direct the ink's path onto the paper in the desired pattern. Almost 
all ink-jets offer a color option as standard, in varying degrees of 
resolution. Ink-jet printers are capable of producing high quality print 
which almost matches the quality of a laser printer. A standard ink-jet printer has a resolution of 300 dots per inch, although 
newer models have improved on that.  As a rule color link-jet printers can also be used as a regular black and white printer. 
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 Laser printers: operate by shining a laser beam to produce an image on a drum. The drum is then rolled through a pool, or 
reservoir, or toner, and the electrically charged portions of the drum pick up ink. Finally, using a combination of heat and 
pressure, the ink on the drum is transferred onto the page. Laser printers print very fast, and the supply cartridges work a long 
time. Color laser printers use the same toner-based printing process as black and white (B/W) laser printers, except that they 
combine four different toner colors.  Color laser printers can also be used as a regular black and white laser printer. 

 LED/LCD printers: are types of electro photographic printers that are identical to laser printers in most ways. Both LCD (liquid 
crystal display) and LED (light-emitting diode) printers use a light source instead of a laser to create an image on a drum. In most 
contexts, "laser printer" covers LCD and LED printers as well.  The print process is almost identical, but LED printers use Light 
Emitting Diodes to charge the drum, and the other uses Liquid Crystals. These printers produce a very high quality text and 
graphics print out.  

 Impact (Dot-matrix) printers: use a set of closely spaced pins and a ribbon to print letters or other characters on a page. These 
printers actually impact the page to print a character, much like a typewriter. Dot-matrix printers vary in terms of speed and the 
number of pins they have. They can run at a speed anywhere between 50 and 500 CPS (Characters Per Second). The number 
of pins, which can vary between 9 to 24, determines the quality of the print job.  Dot matrix printers are commonly used for 
printing invoices, purchase orders, shipping forms, labels, and other multi-part forms. Dot matrix printers can print through multi-
part forms in a single pass, allowing them to produce more pages than even high-speed laser printers.  

 Solid Ink printers: are page printers that use solid wax ink sticks in a "phase-change" process. They work by liquefying wax ink 
sticks into reservoirs, and then squirting the ink onto a transfer drum, from where it is cold-fused onto the paper in a single pass.   
Solid-ink printers offer better color consistency than do most technologies, with little variation caused by changes in temperature, 
humidity, or type of paper. Solid ink machines have better reliability, because they have fewer components in comparison, for 
example with color laser printers. 

 Dye Sublimation printers: are professional devices widely used in demanding graphic arts and photographic applications. True 
these printers work by heating the ink so that it turns from a solid into a gas. The heating element can be set to different 
temperatures, thus controlling the amount of ink laid down in one spot. In practice, this means that color is applied as a 
continuous tone, rather than in dots, as with an inkjet. One color is laid over the whole of one sheet at a time, starting with yellow 
and ending with black. The ink is on large rolls of film which contain sheets of each color, so for an A4 print it will have an A4-size 
sheet of yellow, followed by a sheet of cyan, and so on. Dye sublimation requires particularly expensive special paper, as the 
dyes are designed to diffuse into the paper surface, mixing to create precise color shades. 

 Portable printers:  are usually fairly lightweight and sometimes carry the option of using a battery instead of drawing power from 
the computer. Usually they realize basic print resolutions suitable for plain text printing. You can find on the market the following 
types of the portable printers:  Thermal printer, Thermal transfer printer and Ink-Jet printer. The main advantage of thermal and 
thermal transfer printers is that they can be very small. The smallest thermal and thermal transfer printers weigh approximately 
one pound. Usually the ink-jet portable printer weighs more than 2 pounds. Thermal printers require a special type of paper. 

 Plotters: are large-scale printers that are very accurate at reproducing line drawings. They are commonly used for technical 
drawings such as engineering drawings or architectural blueprints. The two basic types of plotters are called flatbed plotters and 
drum plotters. Flatbed plotters are horizontally aligned with a flat surface to which a piece of paper is attached. The paper 
remains stationary and the printer moves pens across the paper to draw the image. Drum plotters, also called upright plotters, 
are vertically positioned. They have a drum that the paper rolls on. Drum plotters usually make more noise and are more 
compact than flatbed plotters. 

 Digital Photo printers: Many middle range printers are now able to print photo quality images. Usually an option with color 
printers, specialist photo print heads allow a greater resolution to be achieved to improve photo image quality. Photo ink jet 
printers expand their gamuts by adding additional ink colors, usually light cyan and light magenta. 

 Network printer; is a printer that provides output capabilities to all network users. 
 Multifunction printers: combine top-quality color ink-jet or laser printing with plain-paper and PC faxing, color copying and color 

scanning, telephoning- all in one convenient, space-saving machine. If you work from home or have a small office a 
multifunctional device may be ideal.   

 Bravo Auto Printer: is the world’s first automated CD/DVD printing system that can truly be called innovative. It combines 
automatic, robotic-based CD or DVD printing along with full-color, 2400 dpi disc printing all in one compact, desktop unit. 

 Printers for banking: these printers realize innovative technology and functionality to increase productivity, and reduce costs. 
 EZ CD/DVD Printers: provide a low cost way to create professional printed CD-Rs and DVD-Rs. Instead of writing on the CD or 

applying labels, you can print directly on the CD surface! With high speed capabilities, a full color image can be printed directly 
on the top surface of your CDs in less than 1 minute.  

 Label Printers: are the smartest way to print labels one at a time.  The printers allow easy installation.  You can get high-quality, 
professional results every time.  

 VersaLaser:  (Universal Laser Systems Inc.) is peripheral tool, that  can transform images or drawings on your computer screen 
into real items made out of an amazing variety of materials… wood, plastic, fabric, paper, glass, leather, stone, ceramic, rubber… 
and it’s as easy to use as your printer. 2 models of VersaLaser have  16"x12"(VL-200) and 24"x12"  (VL-300) work areas.   

 3D Printers: (Z Corporation). The ZPrinter 310 System creates physical models directly from computer-aided design system  
(“CAD”) and other digital data in hours instead of days.  
The printer is fast, versatile and simple, allowing engineers to produce a range of concept models and functional test parts 
quickly and inexpensively. The system is ideal for an office environment or educational institution, providing product developers 
easy access to a 3D Printer.  
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  MEMORYi 
 

The term memory identifies data storage that comes in the form of chips, and the word storage is used for memory that exists on 
tapes or disks. Moreover, the term memory is usually used as shorthand for physical memory, which refers to the actual chips capable 
of holding data. Some computers also use virtual memory, which expands physical memory onto a hard disk.  
In other words, Memory Unit is that component of a computer system, which is used to store the data, instructions and information 
before, during and after the processing by ALU. It is actually a work area (physically a collection of integrated circuits) within the 
computer, where the CPU stores the data and instructions. It is also known as a Main/Primary/Internal Memory. Types of Memory: 
(1) Primary Memory (2) Secondary Memory (3) Cache Memory. 
 
1.  Primary memory: It has following three types:- 

 
(A)  Rom (Read Only Memory) 
 

Read only Memory is an essential component of the memory unit. We know that the computer, 
being machine, itself has no intelligence or memory and requires instructions, which are given 
by man. Whenever the computer is switched on, it searches for the required instructions. The 
memory, which has these essential instructions, is known as Read Only Memory (ROM). The 
memory is permanent and is not erased when the system is switched off. As appears with its 
name, it is read type of memory i.e. it can be read only and not be written by user/programmer. 
The memory capacity of ROM varies from 64 KB to 256 KB (1 Kilobyte = 1024 bytes) 
depending on the model of computer. 
ROM contains a number of programs (set of instructions). The most important program of ROM 
is the Basic Input Output System (BIOS, pronounced as "bye-os") which activates the 
hardware (physical components of computer) such as keyboard, monitor, floppy disk etc. in 
communicating with the system and application software (set of instructions or programs). 

 
There are following Types of ROM: 

 
Mask ROM: There are many type of ROM chip. In this type of ROM, the information is   stored at the time of its manufacturing. So, it 
cannot be altered or erased later on.  
PROM: A PROM is a memory chip on which data can be written only once, a program has been written onto a PROM, it remains 
there forever. Unlike RAM, PROMs retain their contents when the computer is turned off. The difference as between a PROM and a 
ROM (read-only memory) is that a prom is manufactured as blank memory, whereas a ROM is programmed during the manufacturing 
process. To write data onto a PROM chip, you need a special device called a PROM programmer or PROM burner. The process of 
programming a PROM is sometimes called burning the PROM. 
EPROM: EPROM is the acronym for Erasable programmable Read-Only Memory, and pronounced ee-prom, EPROM is a special 
type of memory that retains its contents until it is expos-ed to ultraviolet light. The ultraviolet light clears its contents, making it possible 
to repro-gram the memory. To write to and erase an EPROM, you need a special device called a PROM programmer or PROM 
burner. 
EEPROM: Electrically Erasable programmable Read-only Memory or EEPROM is a special type of PROM, that can be erased by 
exposing it to an electrical charge, like other types of PROM, EEPROM retains its contents even when it is turned off. Also like other 
types of ROM, EEPROM is not, as fast as RAM.EEPROM is similar to flash memory (sometimes called flash EEPROM). The Principal 
difference is that EEPROM requires data to be written or erased once byte at a time whereas flash memory allows data to be written 
or erased in blocks, this makes flash memory faster. 
 
(B)    RAM (Random Access Memory) 
 
Random Access Memory is another important component of the Memory unit. It is used to store data and 
instructions during the selection of programs. Contrary to ROM, RAM is temporary and is erased when the 
computer is switched off. RAM is a read/write type of memory, and thus can be read and written by the 
user/programmer; this memory is known as random access memory. The memory capacity of RAM varies 
from 640 KB to several megabytes (1 Megabyte = 1024 KB) with different models of PC. There are two 
types of RAM: (i) Static Ram (ii) Dynamic RAM.  
 
(i)     Static Ram: is one that can store datas long as power is supplied to chip. These memories have the properly that their contents 

are retained as long as power in kept on seconds, minutes, hours even days. The advantage of Static RAM are- No refresh 
necessary, simplified timing requirements & Higher Speed. 

(ii)   Dynamic RAM- Dynamic RAM are memory device in which the stored data will not remain    permanently stored, even with 
power applied, unless the data are periodically written into memory.  The dynamic memory cell of DRAMS retains data for only 
a limited time typically 10 nano second after which the data are lost. The advantage of Dynamic RAM are- High storage 
capacity,       less power requirements, less expensive & Data can not be stored permanent. 
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(C) Complentary Metal Oxide Semiconductor Memory (CMOS):  
 

CMOS memory is used to store the system configuration, data, time and other important data. When the computer is switched on 
BIOS matches the information of CMOS with the peripheral devices and display error in case of mismatching. 
 
2.   Secondary Memory (External Storage Devices) 
 
The purpose of external storage is to retain data and programs for future use. For example a program may be required at regular 
intervals. It such information is stored in an external storage media, then one can retrieve it as and when necessary, thus avoiding 
repeated typing. Any number of files containing information is stored on external media. Since they are permanent (they are not 
erased when the equipment is turned off) one can store a long a long file on external media, and later on work on it in sections, 
keeping all the sections in storage except the one currently in use. The popular external storage media used with computers are: 
(A) Floppy Disks (B) Hard Disk (C) Magnetic Tapes (D) Optical Disk. 
 
(A)  Floppy Disks 

The most common storage medium used on small 
today is floppy disks. It is a flexible plastic disk 
coated with magnetic material and looks like a 
phonograph record. Information can be recorded 
or read by inserting it into a disk drive connected 
to the computer. The disks are permanently 
encased in stiff paper jackets for protection and 
easy handling. An opening is provided in the 
jacket to facilitate reading and writing of 
information. Floppy disks are available in two 
standard sizes. One is 8-inch size and    the other 

51/4 inch, which is frequently referred to as the mini floppy. An 8-inch floppy 
holds much more information than a 51/4inchminifloppy. The actual volume of 
information depends not only on size but also on the density with which 
information can be recorded. The 51/4 inch floppy has become a standard one 
in industry. Recently, 31/2- inch floppy 51/4- disks have been announced for use 
in portable computers. 
 
Storage Organization of Floppy Disk: 
 
Data is recorded on disks in circular bands referred to as tracks. The read/write heads are designed to move in smaller increments 
across the data access area of the disk to find the appropriate tracks. As the precision of positioning. The read/write head increases 
width of the tracks become thinner. As the precision of positioning. The two most common track densities in use today are 48 tracks 
per inch (tpi) and 96 tpi. The recording surface of a 5-1/4 inch disk is straightly less than 1 inch therefore the usable tracks per inch 
are 40 or 80 in most case. Typically a disk is divided up into eight or nine sectors are equal wedge shaped areas used for storage the 
point at which a sector intersects a track is used to reference the data location. The track number indicates where to position. The 
read/write head and the sector number indicate when to activate the read/write heads as the disk spins.  
Disks and drives are identifies as being either hard sectored or soft as below:- 
 
 Hard Sectored Disk: Hard sectored disks always have the same numbers and size of sectors. The presence of the hard sectored 

marks allows date to be retrieved from the disk with less effort then from of double-sided, double density soft sectored disk. Hard 
sectored disks have been used most often with dedicated computer system that Handel the manipulation and production of text. 

 Soft Sectored Disk: Today most microcomputer systems use soft sectored disk. Soft sectored disk are marked magnetically by the 
user's computer system during a process called formatting or initializing which determines the size and number of sectors on the 
disk. IBM PC can have following type of diskette drives: Single Side (160KB/ 180 KB) Double Sided (320KB/360KB), High 
Capacity (1.2MB)   

 
(B)    Hard Disks 
 
Another magnetic media suitable for storing large volumes of information is the hard disk, popularly known 
as the Winchester disk. A hard disk pack consists of two or more magnetic plates fixed to a spindle; one 
below the other with a set of read / write heads. The disk pack permanently sealed inside a casing to 
protect it from dust and other contaminations, thus increasing its operational reliability and date integrity. In 
some hard disk system date is stored in the some way as it is diskettes (floppy). Hard Disk has the 
following characteristics are: 

 They are rigid metal platters connected to a central spindle. 
 The entire disk unit is placed in a permanently sealed containers.  
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 Air flows through the container is filtered to prevent contamination and 
 The disks are rotated at very high speed (usually around 3600PRM) 

 
These Disks drives can have four or more disk platters in a sealed unit. In most of disk these disk units the read/write heads never 
touch the surfaces of the disks. A set of disk drives are connected to a disk controller. The Disk controller accepts commands from the 
computer and positions the read/write head of specified disk for reading and writing. In order to recorder write in a disk pack. The 
computer must specify the driver no., cylinder no., surface no. And sector no., drive no. Should be specified because controller. 
Normally controls more than one driver. 
 
(C)   Magnetic Tapes 
 

Relatively inexpensive storage media known as magnetic tapes are sometimes used a back-
up media. A standard 2,400 feet tape can store about 40 million characters and can be read 
at a speed of 1,60,000 characters per second. Remember that a tape, like music cassette, is 
a sequential device and therefore one has to read all previous records to reach a particular 
one. However, some computers support cassette tapes which are smaller and cheaper but 
slower. The storage capacity of a cassette is around 2, 50, 000 characters. 

 
(D)    Optical Disk 
 

The Optical disk is made by resin material and it is coated by optical material such as Aluminum. Internally, 
the disk divided into different concentric circle called tracks and tracks divided into different number of block 
called sector. In Optical disk, involves the use of a high power laser beam to bum microscopic spots in an 
aluminum surface coating. Data is represented by the presence (binary 1) and the absent (binary 0) of 
holes in the storage location. A much lower power laser beam is used to retrieve the data. The patterns 
spots detected by the leaser (during the read operation) are converted into electrical signals used by the 
computer. Following are the main kinds of optical disks: (i) CD-Rom (Compact Disk- read only memory) 
(ii) Write once, read many (WORM) (iii) Erasable Optical Disk 

 
(i) CD-Rom (Compact Disk-read only memory): In this disk the data is imprinted by the disk manufacturer. 
The user can not erase, change it, or write on the disk, the user can read only. The data thus type of optical 
disk is calling CD-Rom. 
(ii)  Write Once, Read Many (WORM): This optical disk is also imprinted by the manufacturer but the buyer 
can write once only. After that they can only be read from then on again, no changes can be made. 
(iii)   Erasable Optical Disk: In these disks the date can be read/write both operations can be performed. 
 
3.   Cache Memory 
 
The speed of CPU is extremely high compared to the access time of primary memory.  Therefore the 
working of CPU decreases due to the slow speed of primary memory. To decrease the mismatch in 
operating speed, a small memory chip is attached between CPU and primary (Main Memory) whose 
access time is very nearest to the processing speed of CPU. It is called Cache Memory. 
Cache (pronounced cash) memory is extremely fast in memory, built a computer’s central processing 
unit (CPU), or beside it away on a separate chip. The CPU cache memory used for instructions that 
are needed again to run programs that improve the overall system speed store. The advantage of the 
cache memory is that not using the CPU on the motherboard system bus for data transmission. If data 
needs to be slowed passed through the system bus, the speed of data transmission capacity of the main board. The CPU can 
process data much faster by avoiding the bottlenecks of the system bus created. 
Why is it when most programs are open and running, they use very little resources. If these resources are held in the cache, programs 
can work faster and more efficiently. All other things being equal, cache is so effective, the system performance for a computer with a 
fast processor cache can be a little lower, with benchmarks as a system with a slower CPU with more cache memory have. Cache in 
the CPU itself was built, referred to as Level 1 (L1) cache. Cache, which is on a separate chip in addition to the CPU, which is called 
Level 2 (L2) cache. Some CPUs have both L1 and L2 cache built-in and appoint each cache chip as a Level 3 (L3) cache. 

 
 COMPUTER SOFTWAREI 

 
Computer consists of four basic element hardware, software, firmware and human ware. The hardware of computer system alone is 
little different to any other complex piece of electronic machinery. The hardware would not work without programs (Set of instructions). 
The software directs and guides the operation of each device including CPU. The set of programs which control the activities of 
computer system or which may be processed on computer to do some useful work, are called software. As car needs fuel to run, 
similarly computer hardware needs software to do anything. Software may be put on disk, cassette, magnetic tape or Semi-conductor 
memory. 
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So we can say that software is a set of programs documents, procedure and routines associated with the operation of computer 
system. In other words, software means a collection of programs whose objective is to enhance the capabilities of the hardware. 
 
Classification of Software 
 
Software can be classified into two broad categories: 1. System Software 2. Application Software. System software performs 
computer- related tasks, such as managing input and output devices. Application software performs people-related tasks, such as 
human resources and marketing. 
 
1.   System Software:  
 

System software performs the basic functions necessary to start and operate a computer. It controls and monitors the various 
activities and resources of a computer and makes it easier and more efficient to use the computer.  System software is 
classified into three categories as follow:  

 
(A) System Control software: system control software includes programs that monitor, control, coordinate and manage the 

resources and functions of a computer system. The most important system software is the operating system and DBMS. 
(B)  System support software: System support software is software that supports, or, facilitates, the smooth and efficient operation 

of a computer. There are four major categories of systems support software: utility programs, language translators, database 
management systems, and performance statistics software. 

(C)  Systems Development Software: System development Software helps system developers design and build better system. An 
example is computer-aided software engineering or CASE, a collection of programs that assist developers in developing an 
information system.  

 
2. Application Software 

 
Application software can be divided into two categories: general purpose software and application dedicated software. 
Application software is designed to perform people-related tasks such as payroll, inventory, and sales analysis. There are two 
types of application software:  

 
 General Purpose Software: General Purpose software is used to perform common business applications such as word-

processing graphics, payroll, and accounting. 
 

 Special Application Based Software: The second type of applications software is Special application-Based software 
which includes specialized, applications designed for every specific purpose. Such a program cannot easily be modified and 
adopted for other applications because it is designed to perform a specific task. (Educational related application, Medical 
related application and scientific application) 

  
Firmware 
A programs by which perform predefined instruction in machine memory called firmware, examples ROM, PROM.EPROM etc. 
Humanware 
The Human beings who used the computer called human ware. 
Computer Language  
The functioning of a computer is controlled by a set of instructions (called a computer program). These instructions are written to tell 
the computer. What operation to perform? Where to locate data? How to present results? When to make certain decisions? and so 
on. The communication between two parties whether they are machines or human beings always needs a common language or 
terminology. The language used in the communication of computer instructions is known as the programming language into this 
language. The computer has its own language and any communication with the computer must be in its language or translated into 
this language. A language is a system of communication. We communicate to one another ideas and emotions by means of 
language. Similarly, a computer language is a mean of communication, which is used to communicate between people and the 
machine (Computer). Using some computer language a programmer can still the computer what he wants to do.  
Computer languages divide in three parts:- (a) Machine languages (low level languages) (b) Assembly (or symbolic) languages, 
and (C) High level language. 

 
 
 
 

_______________________________________ 
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Lesson: 5  
 

 Operating Systemi 
 
Introduction 

 
An operating system (OS) is software (programs and data) that runs on computers and manages the computer hardware and 
provides common services for efficient execution of various application software. 
For hardware functions such as input and output and memory allocation, the operating system acts as an intermediary between 
application programs and the computer hardware, although the application code is usually executed directly by the hardware. 
Operating systems are found on almost any device that contains a computer, from cellular phones and video game consoles to 
supercomputers and web servers. Operating systems are two-sided platforms, bringing consumers (the first side) and program 
developers (the second side) together in a single market. Some popular modern operating systems for personal computers include 
Microsoft Windows, Mac OS X, and Linux. Operating Systems is also a field of study within computer science Operating System is the 
medium of interaction (communication) between application program and computer hardware. 
 
In other words, An Operating System is System software which directs the computer in performing tasks that are basics to proper 
functioning of the system or commonly needed by system users. 
 
The Operating System serves as the "middleman" between the computer hardware and application software. The Operating System 
is the set of software routines that sits between the application program and the hardware. All systems have system software. 
 
Functions of Operating System: 

 
An operating system is an integrated set of system programs whose major functions are:—  

 
 Manage resources (CPU, disk, tape, printer, memory, etc.) 
 Schedule resources 
 Control Input and Output 
 Handle error recovery 
 Manage memory  
 Manage processor  
 Schedule tasks and jobs  
 Provides security  
 Supplies user commands 

 
Operating Systems have developed separately from each other over the last thirty years, occasionally borrowing ideas from each 
other and occasionally working in a similar manner to solve common problems of the computer and user. 
All computers must have an Operating System. The Operating System controls input and output; makes reasonable effort to control 
peripherals and in short acts as the interface between the user, the software, and the hardware. 
 

Operating Systems 
 
MS-DOS 
 
IBM compatible machines used an operating system called MS-DOS. MS stands for "Microsoft" (the trade name), while DOS stands 
for "Disk Operating System", which tells us that the original purpose of DOS was to provide an interface between a computer and its 
disk drives. Technically, DOS is a high-level interface between an application program and the computer. DOS has been extended 
further, allowing programs to handle the tasks of simple memory management, disk operations, and assorted system tasks (e.g. 
date/time), user input commands and managing input/output devices i.e. it provides operating instructions for the computer to manage 
both hardware and software. Versions 3.1 and up also provided basic networking functions. Beyond this, DOS also provides the user 
with the important facility of file and disk management (often referred to as disk-housekeeping). 
The development of MS-DOS/PC-DOS began in October 1980, when IBM began searching the market for a suitable operating 
system. Later, IBM approached a relatively small company called Microsoft, which specialized in language selling. 
Many people said that DOS has no future. It has seen it's heyday and now it's up to high-resolution GUI's (Graphic User-Interfaces - 
e.g. Windows 95) to lead the operating system pack. But let's not be too quick to dismiss it. There are many reasons why DOS is an 
essential part of many of today's finest systems. 

 
OS/2 
 
Having survived some dark ages since its invention in 1987. Operating System/7 (OS/2) was originally developed as a joint project 
between IBM and Microsoft. It's intention was to replace the Disk Operating System (DOS) as the operating system of choice. 
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OS/2 included several different applications and programs that you can use to perform a variety of tasks. It is a true multi-tasking 
operating system suitable for both desktop and server duties. The OS/2 version 2.1 delivers a robust platform that offers a user-
friendly desktop paradigm, flawless DOS and Microsoft Windows support connectivity to all classes of computers. 
 
Microsoft Windows 
 
Microsoft Windows is a family of proprietary operating systems most commonly used on personal computers. It is the most common 
family of operating systems for the personal computer, with about 90% of the market share. Currently, the most widely used version of 
the Windows family is Windows XP, released on October 25, 2001. The newest version is Windows 7 for personal computers and 
Windows Server 2008 R2 for servers. 
It originated in 1981 as an add-on to the older MS-DOS operating system for the IBM PC. Released in 1985, Microsoft came to 
dominate the business world of personal computers, and went on to set a number of industry standards and commonplace 
applications beginning with Windows XP, all modern versions are based on the Windows NT kernel. Current versions of Windows run 
on IA-32 and x86-64 processors, although older versions sometimes supported other architectures. 
Windows is also used on servers, supporting applications such as web servers and database servers. In recent years, Microsoft has 
spent significant marketing and research & development money to demonstrate that Windows is capable of running any enterprise 
application, which has resulted in consistent price/performance records (see the TPC) and significant acceptance in the enterprise 
market. However, its usage in servers is not as widespread as personal computers, and here Windows actively competes against 
Linux and BSD for market share, while still capturing a steady majority by some accounts 
 
UNIX and UNIX-like operating systems  
 
Ken Thompson wrote B, mainly based on BCPL, which he used to write UNIX, based on his experience in the MULTICS project. B 
was replaced by C, and UNIX developed into a large, complex family of inter-related operating systems which have been influential in 
every modern operating system (see History). The Unix-like family is a diverse group of operating systems, with several major sub-
categories including System V, BSD, and GNU/Linux. The name "UNIX" is a trademark of The Open Group which licenses it for use 
with any operating system that has been shown to conform to their definitions. "Unix-like" is commonly used to refer to the large set of 
operating systems which resemble the original UNIX. 
Unix-like systems run on a wide variety of machine architectures. They are used heavily for servers in business, as well as 
workstations in academic and engineering environments. Free UNIX variants, such as GNU/Linux and BSD, are popular in these 
areas. 
Some UNIX variants like HP's HP-UX and IBM's AIX are designed to run only on that vendor's hardware. Others, such as Solaris, can 
run on multiple types of hardware, including x86 servers and PCs. Apple's Mac OS X, a hybrid kernel-based BSD variant derived from 
NeXTSTEP, Mach, and FreeBSD, has replaced Apple's earlier (non-Unix) Mac OS. 
UNIX interoperability was sought by establishing the POSIX standard. The POSIX standard can be applied to any operating system, 
although it was originally created for various Unix variants. 
 
BSD and its descendants 
 
A subgroup of the UNIX family is the Berkeley Software Distribution family, which includes FreeBSD, NetBSD, and OpenBSD. These 
operating systems are most commonly found on web servers, although they can also function as a personal computer OS. The 
internet owes much of its existence to BSD, as many of the protocols now commonly used by computers to connect, send and receive 
data over a network were widely implemented and refined in BSD. The World Wide Web was also first demonstrated on a number of 
computers running an OS based on BSD called NextStep. 
BSD has its roots in UNIX. In 1974, University of California, Berkeley installed its first Unix system. Over time, students and staff in the 
computer science department there began adding new programs to make things easier, such as text editors. When Berkely received 
new VAX computers in 1978 with Unix installed, the school's undergraduates modified Unix even more in order to take advantage of 
the computer's hardware possibilities. The Defense Advanced Research Projects Agency of the US Department of Defense took 
interest, and decided to fund the project. Many schools, corporations, and government organizations took notice and started to use 
Berkeley's version of Unix instead of the official one distributed by AT&T. Steve Jobs, upon leaving Apple Inc. in 1985, formed NeXT 
Inc., a company that manufactured high-end computers running on a variation of BSD called NeXTSTEP. One of these computers 
was used by Tim Berners-Lee as the first web server to create the World Wide Web. 
Developers like Keith Bostic encouraged the project to replace any non-free code that originated with Bell Labs. Once this was done, 
however, AT&T sued. Eventually, after two years of legal disputes, the BSD project came out ahead and spawned a number of free 
derivatives, such as FreeBSD and NetBSD. However, the two year wait had set the stage for two projects that would ultimately 
eclipse both BSD and UNIX: GNU and Linux. 
 
Mac OS X 
 
Mac OS X is a line of partially proprietary graphical operating systems developed, marketed, and sold by Apple Inc., the latest of 
which is pre-loaded on all currently shipping Macintosh computers. Mac OS X is the successor to the original Mac OS, which had 
been Apple's primary operating system since 1984. Unlike its predecessor, Mac OS X is a UNIX operating system built on technology 
that had been developed at NeXT through the second half of the 1980s and up until Apple purchased the company in early 1997. 
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The operating system was first released in 1999 as Mac OS X Server 1.0, with a desktop-oriented version (Mac OS X v10.0) 
following in March 2001. Since then, six more distinct "client" and "server" editions of Mac OS X have been released, the most recent 
being Mac OS X v10.6, which was first made available on August 28, 2009. Releases of Mac OS X are named after big cats; the 
current version of Mac OS X is "Snow Leopard". 
 
The server edition, Mac OS X Server, is architecturally identical to its desktop counterpart but usually runs on Apple's line of 
Macintosh server hardware. Mac OS X Server includes work group management and administration software tools that provide 
simplified access to key network services, including a mail transfer agent, a Samba server, an LDAP server, a domain name server, 
and others. 
 
Plan 9 
 
Ken Thompson, Dennis Ritchie and Douglas McIlroy at Bell Labs designed and developed the C programming language to build 
the operating system UNIX. Programmers at Bell Labs went on to develop Plan 9 and Inferno, which were engineered for modern 
distributed environments. Plan 9 was designed from the start to be a networked operating system, and had graphics built-in, unlike 
UNIX, which added these features to the design later. It is currently released under the Lucent Public License. Inferno was sold to Vita 
Nuova Holdings and has been released under a GPL/MIT 
 
Linux and GNU 
 
Linux is the generic name for a UNIX like operating system that can be used on a wide range of devices from supercomputers to 
wristwatches. The Linux kernel is released under an open source license, so anyone can read and modify its code. It has been 
modified to run on a large variety of electronics. Although estimates suggest it is used on only 0.5-2% of all personal computers, it has 
been widely adopted for use in servers and embedded systems (such as cell phones). Linux has superseded UNIX in most places, 
and is used on the 10 most powerful supercomputers in the world. 
The GNU project is a mass collaboration of programmers who seek to create a completely free and open operating system that was 
similar to UNIX but with completely original code. It was started in 1983 by Richard Stallman, and is responsible for many of the parts 
of most Linux variants. For this reason, Linux is often called GNU/Linux. Thousands of pieces of software for virtually every operating 
system are licensed under the GNU General Public License. Meanwhile, the Linux kernel began as a side project of Linus Torvalds, a 
university student from Finland. In 1991, Torvalds began work on it, and posted information about his project on a newsgroup for 
computer students and programmers. He received a wave of support and volunteers who ended up creating a full-fledged kernel. 
Programmers from GNU took notice, and members of both projects worked to integrate the finished GNU parts into the linux kernel in 
order to create a full-fledged operating system. 
 
Google Chrome OS 
 
Chrome is an operating system based on the Linux kernel and designed by Google. Chrome targets computer users that spend most 
of their time on the internet—it is technically only a web browser with no other applications, and relies on internet applications used in 
the web browser to accomplish tasks such as word processing and media viewing. 
 
Other 
 
Older operating systems which are still used in niche markets include OS/2 from IBM and Microsoft; Mac OS, the non-Unix precursor 
to Apple's Mac OS X; BeOS; XTS-300. Some, most notably Haiku, RISC OS, MorphOS and AmigaOS 4 continue to be developed as 
minority platforms for enthusiast communities and specialist applications. OpenVMS formerly from DEC, is still under active 
development by Hewlett-Packard. Yet other operating systems are used almost exclusively in academia, for operating systems 
education or to do research on operating system concepts. A typical example of a system that fulfills both roles is MINIX, while for 
example Singularity is used purely for research. 

 
 
 
 

 
 
 
 
 
 

__________________________________ 
 

 
 



 
 
 

SARVA EDUCATION (SITED) (Running- An I.T & Skill Advancement Training Programme)                                                                                                                                                            - 24 -                                                                                                                 

                                                                       

 

Visit us at:  www.sarvaindia.com                                                                 Licensed by Govt. of India                                                                       ISO 9001:2015 Certified 

Lesson: 6  
 

 Windowsi 
 

Introduction 
 
Windows is a personal computer operating system from Microsoft that, together with some commonly used business applications 
such as Microsoft Word and Excel, has become a de facto "standard" for individual users in most corporations as well as in most 
homes.  
The original 1985 version of Windows introduced to home and business PC users many of the graphical user interface (GUI) ideas 
that were developed at an experimental lab at Xerox and introduced commercially by Apple's Lisa and Macintosh computers.  
 
In other words, Microsoft Windows is a series of software operating systems and graphical user interfaces produced by Microsoft.  
 
Microsoft first introduced an operating environment named Windows in November 1985 as an add-on to MS-DOS in response to the 
growing interest in graphical user interfaces (GUIs). Microsoft Windows came to dominate the world's personal computer market, 
overtaking Mac OS, which had been introduced previously.  
 
As of October 2009, Windows had approximately 91% of the market share of the client operating systems for usage on the Internet. 
The most recent client version of Windows is Windows 7, the most recent server version is Windows Server 2008 R2, the most recent 
mobile OS version is Windows Mobile 6.5.  
 
Current versions of windows 
 
 Windows 7:  for home and business desktops and portable computers. 
 Windows 7 Starter:  A variant for developing countries and netbooks, in which the Aero theme is not included, nor 64-bit 

compatibility. This edition will be available pre-installed on computers through system integrators or computer manufacturers. 
 Windows 7 Home Basic: Windows 7 Home Basic will be available in emerging markets such as Brazil, People's Republic of 

China, India, Indonesia, Mexico, Pakistan, the Philippines, and Thailand. It will not be available in countries such as Australia, 
Canada, France, Germany, The Netherlands, United Arab Emirates, Saudi Arabia, New Zealand, the United States, and the 
United Kingdom. Some Aero options are excluded along with several new features.  

 Windows 7 Home Premium: This edition contains features aimed at the home market segment, such as Windows Media 
Center, Windows Aero and touch-screen controls.  

 Windows 7 Professional:  This edition is targeted toward enthusiasts and small business users. It includes all the features of 
Windows 7 Home Premium, and adds the ability to participate in a Windows Server domain. Additional features include operating 
as a Remote Desktop server, location aware printing, Encrypting File System, Presentation Mode and Windows XP Mode.  

 Windows 7 Enterprise: (Microsoft Windows NT 6.1.7600) This edition targets the enterprise segment of the market and will be 
sold through volume licensing to companies which have Software Assurance contract with Microsoft. Additional features include 
support for Multilingual User Interface (MUI) packages, BitLocker Drive Encryption, and UNIX application-support. Not available 
through retail or OEM channels, this edition will be distributed through Microsoft Software Assurance (SA). As a result it includes 
several SA-only benefits, including a license allowing the running of multiple virtual machines, and activation via VLK.  

 Windows 7 Ultimate: Windows 7 Ultimate contains the same features as Windows 7 Enterprise, but unlike that edition it will be 
available to home users on an individual license basis. Windows 7 Home Premium and Windows 7 Professional users will be 
able to upgrade to Windows 7 Ultimate for a fee using Windows Anytime Upgrade if they wish to do so. Unlike Windows Vista 
Ultimate, the Windows 7 Ultimate edition will not include the Windows Ultimate Extras feature or any exclusive features. 
(6.1.7600)  

 Windows Server 2008 R2 for servers.  
 Windows Web Server 2008 R2.  
 Windows Server 2008 R2 Standard Edition.  
 Windows Server 2008 R2 Enterprise Edition.  
 Windows Server 2008 R2 Datacenter Edition. 
 Windows Server 2008 R2 for Itanium-based Systems. 
 Windows HPC Server 2008 R2 for high Performance supercomputers.  
 Windows Server 2008 R2 Foundation. 
 Windows Mobile 6.5:  for smartphones and PDAs  
 Windows Home Server: Announced at the 2007 Consumer Electronics Show (CES) in Las Vegas. Windows Home Server is 

intended to be a solution for homes with multiple connected PCs to offer file sharing, automated backups, and remote access.  
 Windows XP Embedded: for embedded systems requiring parts of the Windows XP infrastructure  
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 Windows Fundamentals for Legacy PCs: a low-end version of Windows XP that is intended to be a thin-client that works with 
older hardware.  

 Windows Embedded CE 6.0: for embedded systems (not based on the Windows NT kernel)  

Future versions 
 
Windows 8: Currently being developed as the successor to Windows 7. It will be released in 2011.  
Windows 9: A voice-activated operating system succeeded by Windows 8 scheduled to be released in Christmas 2013.  

 
Brief Explanation of popular window version. 

 
WINDOWS 95 
We have been using DOS and Windows version that ran on DOS. Now we have Windows version that itself is an operating system. 
The look and feel of Windows has been improved and make it easier and faster for us to get our work done. Windows 95 is an 
integrated and complete Windows Operating System that starts with the basic functionalities of DOS and Windows. 
Windows 95 added major enhancements when compared to Windows 3.11. Some of the new features that Windows 95 have 
which Windows 3.11 does not have are: 
 Plug and Play, which allowed hardware devices to be automatically installed into the computer with the proper software. 
 32 Bit, 32-Bit operating system allowing the computer to run faster and more efficiently. 
 Memory, Windows 95 has an improved memory handling processes compared to Windows 3.11. 
 Right mouse click, allows you new access and text manipulation by utilizing both buttons instead of one. 
 CD-Player enhanced CD-Player with improved usability and AutoPlay feature. 
 
WINDOWS NT 
Windows NT 4.0 is the look and feel of Windows 95 however is a completely different Operating System. Windows NT contains 
advanced security features, advanced network support, Full 32-bit operating system, advanced multitasking, user administration and 
much more. While NT is a very advanced Operating system it does lack the support of drivers, features, and gaming support when 
compared to Windows 95/Windows 98 and is why even today Windows NT is still used primarily by businesses and technical users. 
 
WINDOWS 98 
Microsoft Windows 98 is the upgrade to Microsoft Windows 95 Operating System. While this was not as big as release as Windows 
95, Windows 98 has significant updates, fixes and support for new peripherals. Today every machine is supporting Windows 98 
Operating System. You will also be using Windows 98 as your operating system. 
In Windows 98, you can move items that are already in the Start menu by dragging and dropping as well. Simply point to an item, click 
the left mouse button, it down as you drag. As with adding a shortcut, hovering over a submenu item opens at submenu, and 
Windows displays a divider to indicate where the item would appear if you dropped it. Features of Windows 98 Operating System: 
 Protection: Windows 98 includes additional protection for important files on your computer such as backing up. 
 Improved support: Improved support for new digital devices 
 FAT32: Windows 98 has the capability of converting your drive to FAT32 without loosing any information. 
 Interface: Users of Windows 95 and NT will enjoy the same easy interface. 
 Internet Explorer 4.0: Included Internet Explorer 4.0 web browser for net surfing. 
 Customizable Taskbar: It has added many nice new features to the taskbar which Windows 95 and WindowsNT do not have. 
 Active Desktop: Includes Active Desktop which allows the users to customize there desktop with the look of the Internet. 
 
WINDOWS 2000 
Windows 2000 was released on February 17, 2000. Some computer manufacturers were selling computers preinstalled with Win 
2000 in January. Windows 2000 is the new name for Windows NT 5.0, the replacement for the current Windows NT 4.0. It employs 
the same core technologies as NT, but adds many new ones that were not previously available in NT, such as Plug-and-Play, support 
for USB devices, power management, DirectX 7.x, etc.  There are different types of versions of Windows 2000: 
 WINDOWS 2000 PROFESSIONAL:  Windows 2000 Professional is the workstation edition of Windows 2000. 
 Windows 2000 Server/Advanced Server: Windows 2000 Server/Advanced Server is the server edition of Windows 2000, which 

is designed to serve small to mid-sized businesses and workgroups. Server supports up to 4GB of physical RAM and up to 4 
processors per computer. Advanced Server supports up to 8GB of RAM and 8 processors per computer. 

 Windows 2000 Datacenter Server: Windows 2000 Datacenter Server is designed for large businesses and computer clusters. 
Datacenter supports up to 32 processors per computer and up to 64GB of RAM, as well as built-in clustering and load-balancing 
features. 

 
WINDOWS XP  
It is produced by Microsoft for use on personal computers, including home and business desktops, laptops and media centers. First 
released to computer manufacturers on August 24, 2001, it is the second most popular version of Windows, based on installed user 
base. The name "XP" is short for "eXPerience. 
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WINDOWS 7  
is the current release of Microsoft Windows, a series of operating systems produced by Microsoft for use on personal computers, 
including home and business desktops, laptops, netbooks, tablet PCs, and media centerPCs. Windows 7 was released to 
manufacturing on July 22, 2009 and reached general retail availability worldwide on October 22, 2009, less than three years after the 
release of its predecessor, Windows Vista. Windows 7's server counterpart, Windows Server 2008 R2, was released at the same 
time. 
Unlike Windows Vista, which introduced a large number of new features, Windows 7 was intended to be a more focused, incremental 
upgrade to the Windows line, with the goal of being compatible with applications and hardware with which Windows Vista was already 
compatible. Presentations given by Microsoft in 2008 focused on multi-touch support, a redesigned Windows shell with a new taskbar, 
referred to as the Super bar, a home networking system called Home Group, and performance improvements. Some standard 
applications that have been included with prior releases of Microsoft Windows, including Windows Calendar, Windows Mail, Windows 
Movie Maker, and Windows Photo Gallery, are not included in Windows 7; most are instead offered separately at no charge as part of 
the Windows Live Essentials suite. 
 
WINDOWS 8  
is the official name for the next version of Microsoft Windows, a series of operating systems produced by Microsoft for use on personal 
computers, including home and business desktops, laptops, netbooks, tablet PCs, and media center PCs. According to unofficial 
sources, the release date for Windows 8 has been set for October 2012. 

 
How to start up windows. 

 
After a few seconds you'll see the Windows 
start-up logo. Now the Windows 'starting 
screen-the Desktop-appears as below: 
Depending on your computer and the options 
you have chosen, you may see different 
desktop on your computer.) 
 
Starting with the "Start" Menu 
 
When you click the Start button using Mouse, 
you see a menu that contains everything you 
need to begin using Windows. 
To select an item from the menu, move the 
mouse around the menu box and click on it. 
Also, there is a highlighted shaded color which 
moves along with mouse pointer inside the 
menu.  
 
An overview of each command is shown 
below:-  
 
 

Note:   Depending on your computer and the options you have chosen, you may see additional items on your menu. 
 
 

Selecting Menu Commands: 
 
Once a menu is open, you can select any of the 
highlighted commands in the menu. You can 
also select any of the menu commands in any 
of the following ways: 
•By typing the underlined letter in the command 
name. 
•By moving the mouse down and clicking on a 
command’s name. 
•By pressing the down-arrow or up-arrow keys 
on your  keyboard to highlight the desired 
command name and then pressing <Enter>.  
 
 

You can cancel a menu (that is, make the menu disappear without selecting any commands) by simply pressing Esc key or by 
clicking from the mouse anywhere outside the menu. 
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Special Indicators in Menus 
 
Menus often have special symbols that tell you a little more about the menu commands. For example, notice that many of these menu 
commands have additional words or symbols next to the command name. The following are the meanings of these words or symbols: 
  
A Grayed (Dimmed) Command 
 
When a command shown is not highlighted or dimmed or grayed, it means that this choice is not currently available to you. A 
command can be dimmed for a number of reasons. For example, if you want to paste the particular item or data you must select that 
item or data and then you can access the dimmed commands. 
 
Function of a triangle (>) 
 
A triangle to the right of a menu command means that the command has additional sub choices for you to make. This is called 
cascading menu. You can select from the submenu or cascaded menu the same way you select from a normal menu. 
 
Exiting From Windows  
 
After your work is finished, you must shut down the computer. You should not switch off the computer directly. By selecting the shut 
down option from start button you can shut down your computer. By clicking on the shut down button you can see your entire desktop 
colour changes and menu appears in the middle of your desktop as shown in figure. 
 
What does Accessories mean in window? 
 
Window has word has word processor, calculator, 
calendar, etc So to start Accessories click Start on the 
Desktop –Program- Accessories.  
 
Following are the accessories in Windows: 
 
1.   Calculator 
2.   Character Map 
3.   Note Pad 
4.   WordPad 
5.   Paint  
6.   Games 
7.   Media Player 
8.   Clock 
9.   Sound Recorder  

 
 

 
How to reinstall Windows XP? 
 
First, locate the Windows CD that shipped with your 
PC, along with the CDs for your application software. If 
you downloaded your antivirus, firewall, or other programs, copy those downloads to a CD or to some other type of removable media. 
(If your system didn't ship with a Windows CD, your reinstallation files are situated on your hard drive; I'll describe how to access them 
in just a minute.) Also, dig up the instructions that your ISP sent you for configuring your network settings, and keep them close at 
hand. 
 
Copy the contents of your 'C:\Documents and Settings' folder (or whichever folder you store your personal files on) to a CD or other 
removable medium. Then grab any other critical data and back it up. It helps to collect the installers for the latest drivers for your PC's 
graphics card and other hardware, too. 
 
Ready to Reinstall 
 
Now insert the Windows CD that came with your PC, and reboot your system. If you didn't receive a Windows disc with your machine, 
the files you need are sitting in a hidden partition on your hard drive. To access them, press the keys indicated on your screen when 
you reboot, but before Windows loads. The keys differ from vendor to vendor, so contact your PC's manufacturer if you don't see the 
prompt. In many instances, the only available option is 'Return the drive to its factory condition', which destroys all documents, photos, 
and other data files on your PC. That's why you made a copy of your data folders. 
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You get more options--including the ability to preserve your files and settings--when you use Microsoft's own Windows XP installation 
disc. Make your selection, and follow the on-screen prompts to complete the reinstallation. 
 
Starting Over 
 
Regardless of which option you choose, you'll have to reconfigure your network connections, reinstall some of your device drivers, 
and update XP and your applications manually. 
 
To configure your Internet connection, right-click My Network Places, click Create a new connection, and follow the prompts, entering 
the appropriate information you received from your ISP. 
 
Once you've re-established your Internet link, you must reinstall and update your firewall, antivirus, and antispyware programs. 
 
Next, check to see which of your device drivers need updates: Right-click My Computer and select Properties, Hardware, Device 
Manager. Look for entries with yellow question marks or red exclamation points. A question mark indicates that Windows is using a 
generic driver for that device instead of one specifically designed for it; an exclamation point means that the device is not working. 
 
The drivers for graphics boards, sound cards, and printers are most likely to need an update. If you haven't already done so, visit the 
vendors' Web sites to download updated drivers to your PC. Run the installer for each updated driver, allowing XP to reboot when 
needed, or right-click the entry in Device Manager, choose Update Driver, and step through the wizard, selecting No, not this time to 
the Windows Update question, and choosing the specified location option when it appears. When you can navigate to the driver file, 
select it and click OK to install it. When you finish updating your drivers, close all open windows. 
 
Updates Galore 
 
Your next stop is Microsoft's Windows Update site. Click Start, Windows Update, and follow the prompts. Since you'll probably be 
downloading many megabytes of updates, you might want to find yourself a good book or seek some other diversion while you wait. 
 
When the downloading is complete, you'll be ready to reinstall and update your applications. Don't forget to update your critical apps 
as well. Microsoft Office, in particular has some important updates. Download them at the Microsoft Office Online Downloads page. 
 
Once you've restored your applications, begin replacing your data. The first priorities are the My Documents and Application Data 
folders, which you'll find in the folder with your logon name inside 'C:\Documents and Settings'. To bring back your Internet Explorer 
favorites, restore the contents of the Favorites folder. Also restore the Shared Data and Application Data folders inside 'C:\Documents 
and Settings\Shared Documents'. Once you've reintroduced all of your data, your Windows refresh will be complete. 
 
 

 Basic of Window 7i 
 

Windows 7 is the latest in graphical operating systems from Microsoft. Its roots go 
back to early versions of Windows which acted as a shell on top of MS-DOS. 
Today’s operating system is a distant cousin to the early versions of Windows. You 
will find Windows 7 to be a very powerful, friendly, and easy to use operating 
system. In the past, Microsoft has been criticized relative to Apple for what was said 
to be gaps in power and usability between Windows and Mac OS. Many of these 
gaps have now disappeared and in some ways, Windows is easier to use and more 
powerful than its nemesis, Mac OS X. 
 
Windows 7 tries to hide a lot of back end processing and is noticeably faster than 
Windows Vista at many of the same tasks. You will like what you find in Windows 7. 
 
The first thing you will notice upon booting into Windows 7 for the first time is the 
more simplistic feel it provides. Your desktop is not inundated with icons (some with no perceived value to you) and instead a simple 
Recycle Bin sits on the desktop. Some PC manufacturers may helpfully provide a bunch of shortcut icons to their favorite applications, 
but a clean install of Windows would find a clean desktop. The traditional “Quick Launch” bar is missing and the status bar icons 
helpfully hide away so you do not need to see them when you don’t want to. They’ve added the date to the larger task bar, a great 
feature for those of us always running our mouse pointed to the bottom right to figure out what the date is. 
 
At this point, we recommend checking out the new interface. Click on the Start menu, open a few windows. Open an application. It’s 
going to be a different feel than previous Windows versions, but still feel familiar to you. The first thing we’re going to check out is 
the Task Bar. 
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The Taskbar 
 
The Windows 7 Taskbar is the starting point for almost everything you do in 
Windows 7. The first button on the far left is the Start Menu. You’ll notice the Quick 
Launch toolbar that a lot of us found handy in Windows XP is missing and instead 
is replaced with the ability to pin software icons to the bar so that you can quickly 
launch it at any time. 

On the bar above, the   icon has button outline around it with a second layer behind it. The outline indicates that Internet 

Explorer is open and the second layer indicates that two IE windows are open. Contrast this with the   icon which is not open. 
Without an outline, the application is simply pinned to the taskbar and not currently open. In the Taskbar image at the top, you can 
see Firefox as two layers behind the main one, this indicates Firefox has three or more windows open at a time. 
 
When you run your mouse over the icon on the Taskbar, you will get a preview of the windows currently 
open. When you run your mouse over one of the Windows show, it will appear on your screen for you to 
preview.  
 
In the taskbar Notification Area (formerly called the System Tray) you will see the first menu, allowing 
you access to all of the hidden notification area icons, and then the other options which have been 
pinned to the notification area such as the battery life, windows messages, networking, and audio 
settings. Additionally, you see the time & current date. 
At the far right you see a box with a slight shadow effect. This button is the Show Desktop button and 
will minimize your open windows to show you the Windows desktop. 
When you click on the show hidden notifications arrow, you will see a popup of all of the notification icons that are currently hidden. If 
you’d like to access one of them, simply click on it to open. You can also customize the notification area to include one of those icons 
by clicking Customize…. 
 
How to Customize the Notification Area 
1. Click on the Show hidden icons button in the Notification Area. 
2. Click Customize… 
3. This opens the Notification Area Icons control panel. To the right of each icon, you have a pull down menu listing Behaviors. 
4. The first option, Show icon and notifications, displays the icon in the notification area and alerts you if the program or utility needs 

attention. 
5. The second option, Hide icon and notifications, hides the notifications from view and does not alert you. 
6. The third option, Only show notifications, only displays the icon when the application or utility needs to alert you to something. 
7. Select the menu next to the item you want to customize and change the setting. 
8. When you’re finished, click OK to save your changes, or click Cancel to cancel out and keep everything the way it is. 
 
Just a note, in marketing materials, Microsoft has changed the name of the Taskbar to the Superbar. We’ve found the help 
documentation and options within Windows still refer to it as the Taskbar. If you see something on the web referring to the Superbar, 
they typically mean the Taskbar. 
 
The Start Menu 
 
 The Start Menu has not changed much from Windows Vista or Windows XP, but if you’re used to earlier versions of Windows, the 
Start Menu will be a big change for you. 

On the left hand side of the 
Start menu, you see the icons 
you have both pinned to the 
Start menu and the recently 
used applications. At the 
bottom of the left hand column 
is the Search programs and 
files text field. You can search 
for a file in this field, or launch 
a shortcut for any software you 
know the name of.  
In the right hand column of the 
Start menu, you see several 
shortcuts to libraries – folders 
of documents or files such 
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as Jeremy, my profile folder; Documents, the equivalent of My Documents in previous versions of Windows; Pictures, the equivalent 
of My Pictures in previous versions of Windows; and so on. 
The remaining items are shortcuts to the associate utility, such as Control Panel or Help and Support. At the bottom of the right hand 
column, you have a Shutdown button shortcut. If you click the arrow to the right of Shut down, you will see different options such as 
Restart, Shut Down, or Sleep. 
 
Accessing Help 
There are several methods to access Windows help. The most common method of accessing help is to press the F1 key to access 
context-sensitive help. This will open the help file to help information specific to the window you’re in. If you’re in a software 
application, most software developed for Windows supports the F1 key to find context sensitive help. 
  

Windows continues to improve its help system and Windows 7 probably has the best help 
and support knowledgebase versus any of the previous versions of Windows. When you 
select Help and Support from the Start Menu, you will start in a simple and clear help 
box. We will explore the help and support system in a whole section of this tutorial devoted 
entirely to help. The great thing is – since Windows is so common in home and business 
environments, no matter what your problem is, you can likely find someone experiencing 
the same thing and either find a resolution or a workaround. The trick is knowing how to 
ask the right questions! 
 
Online Help 
There are many sources of help available online and we explore those in the Getting Help 
section of this free tutorial. We’ve created a great resource in a Windows 7 reference guide 
section on Learnthat.com. You can find step by step instructions to do just about anything 
in Windows 7. 
Working with Windows 
Windows is a powerful operating system. It’s easy to use, but it’s not simple – there is a lot 
going on to run an efficient operating system across a variety of hardware platforms and 

manufacturers. After you take this tutorial, you will understand how to work with Windows 7 and make it work for you. 
If you’re new to Windows, let’s explore some of what’s going on: 
1. Turn on your computer. 
2. Login to Windows if you have a password and user account set. 

3. Click on the Start menu,    button. 
4. Click on the Computer link in the right hand column of   the Start  

Menu. 
5. In previous versions of Windows, this was called My Computer. 

Now, it’s just called Computer. This is the center of what’s 
happening on your computer system. Let’s break down this 
screen a little for you to understand how to navigate in Windows 
7. 

  
6. At the top of the Computer window is 

your address bar. At the left, you 
have a left and right arrow. Once you 
start navigating into your computer, 
you can go back or forward through 
the path of navigation. For example, 
if we double-click on our C: drive and 
go several folders deep, we can click 
the arrow to take use back to the 
previous level. 

7. In the middle of the address bar, you have location of where you are currently at, surrounded by little black arrows. This address 
portion of the address bar tells you both where you are at, and the previous and next levels. If you click on one of the arrows, it 
will show the path before, or other options you can pursue. 

8. At the far right of the address bar is your search field. 

  
9. The next bar is the toolbar. This replaces the old menu based structure (which is still just hiding under the surface). This toolbar 

lets you quickly select a destination to manage your computer. 
10. In the left hand side of your explorer window is the shortcut list of items you can quickly click to go to. 
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11. On the right hand side, you see the drives on your computer. Double-click to navigate into one. 

 
12.   Finally, at the bottom of the window is your information box. In previous versions of Windows, when you needed to find out your 

computer name, workgroup or domain, memory, and processor, there were several places you had to go. Help desks and 
support centers often need this information and you now have a quick and easy way to access it. 

 
Shutting Down the Computer 
 
As we learned earlier, there is a Shut down button/menu on the Start Menu. Click Start and select Shut down. This will quickly shut 
down your computer. 
If you click the arrow on the right of the Shut down button, you will be given a list of options for shutdown. Here’s a screenshot of my 

list of options (yours may be different): 
Switch user allows you to switch user accounts to someone else while remaining logged into the computer. You will 
use this option if someone else wants to use the computer but you do not want to exit out of your open software 
applications. Log off logs you off of your account, but does not shutdown the computer. This option takes you back to 
a login screen where you or another user could log in. This option leaves the computer turned on. 
Lock locks the screen requiring you to login to unlock the computer. The keyboard shortcut to lock your computer is 
Windows Key + L. Restart turns off your computer, then turns it back on and brings you back to the login screen for 

you or another user to enter your username and password. Sleep saves what you’re currently working on and sets your computer into 
a low power mode (not completely turned off). It is in a low power mode, versus completely turned off, so that you can more quickly 
start it back up when you want to use it. Hibernate saves what you’re currently working on as an “image” of your current system state 
to the hard drive. This allows the computer to completely power down. This is often used by laptops – if your battery runs low, the 
computer hibernates so that what you’re working on is saved until you can plug the computer in and get recharged. 

Customizing Windows 7 

Windows is infinitely customizable from the desktop image, colors on 
the screen, to the font size, screensaver, and security settings. You will 
find just about every kind of look and feel available to make Windows 
look and operate how you want it to. In this section of our free Windows 
7 tutorial, we’re going to look at how to customize the Windows 
desktop, change the video settings, customize the start menu, make 
the taskbar work for you, and set folder settings. Along the way, you will 
learn about power settings, screensavers, and a few tips on how to 
make Windows look like an older version – if you want to revert back to 
something old school. First, let’s explore the Windows desktop. 
 
Customizing the Desktop 
 
The Desktop is the background of what you see when Windows first 
starts up. It typically contains many icons, but by default only has the Recycle Bin icon. The other icons you see in my 
desktop above are Shortcuts to start a program. A shortcut is a link to start an application – it’s not the application 
itself. 
As you can see on the icon above, there is a shortcut arrow, , indicating this icon is a shortcut and not the actual 
application. Here’s the actual application icon, copied to my desktop: 
The icon on the left is the shortcut to the application, the one on the right is the actual application file. 
You can delete an icon on the desktop by clicking once on it and pressing the Delete key, by dragging it to the Recycle Bin, or by 
right-clicking on the icon and selecting Delete. 
As in any other folder on your computer, you can store any types of files you wish on the desktop, including folders. We don’t 
recommend using the desktop for file storage (that’s what your Documents folder is for), but many people find it easy to store files on 
the desktop to retrieve them quickly. 
 
Customizing the Windows 7 Desktop 
 
When you right-click in an open area on your desktop, you’re going to see a list of 
options to change settings on the desktop, like this one:  Changing the Desktop Views 
1. Right-click on the desktop and select the View menu. 
2. If you would like to change the size of the icons, select the size at the top. 
3. If you’d like Windows to Auto arrange the icons how it sees fit, select that option. 
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4. Align icons to grid keeps the icons well aligned where turning off this feature will allow you to place icons where ever you want. 
5. If you don’t like all those icons cluttering your desktop, you can turn them off using the Show desktop icons – they are still 

present, just hidden. 
6. Finally, if you’re using Desktop Gadgets, you can show or hide them with the final option. 
 
Personalizing Windows 
  
At the bottom of the desktop right-click menus is 
the Personalize option. This link opens the Personalization control 
panel allowing you to set the user interface to look and feel how 
you desire.  
 Change desktop icons: decide which desktop icons you 
want displayed on your Windows desktop. 
 Change mouse pointers: don’t like your current mouse 
pointers? Change the cursors and arrows to suit your desires. 
 Change your account picture: change the image shown at 
login and at the top of your Start menu. 
In the middle, you will see the different themes available with an 
option to obtain more themes online. As you see, several of the 
themes have multiple desktop images – these themes will rotate 
the desktop images so you see a different picture throughout the 
day. As you scroll down in the middle, you can select from many 
different themes to suit your personal style. You also will see a link 
near the top for Get more themes online which allows you to find 
many other unique themes to install for your computer. 
Across the bottom, you can see there are several different options for you to change if you’d like, including: 
 Change the desktop background image/colors 
 Change your window colors 
 Change the default Windows sounds 
 Change/enable/disable your screensaver 
 
Setting a New Windows Aero Theme 
 

If you would like to set a new theme, it’s pretty simple. In the Personalization control panel, click on the theme you’re interested in 
activating. 
  
Video Settings 
There are several things you can customize for the video 
settings on your computer. Windows tries to guess the 
appropriate screen resolution and settings for multiple 
monitors, but you may want to tweak this to meet your 
needs. 
  
1. Right-click anywhere on the desktop and Select  

Screen resolution. 
2. The Screen Resolution control panel opens. You have 

several options you can change on this screen. If you 
have several monitors, click on the monitor you’d like 
to customize. In the screenshot above, you can see I 
have two monitors – the internal laptop screen and a 
bigger external screen. 

3. To change the screen resolution, pull down 
the Resolution menu and select a resolution you 
would prefer. 

4. You can also decide how you would like to handle 
multiple monitors. Extend these displays treats the two 
monitors as one, allowing you to move windows 
between them. You can also Duplicate the displays, or have the same screen running on both monitors (for example, if you 
treat your laptop as docked, you may only want to work with your external screen). You can also decide if you simply want to 
have your desktop on monitor 1 or monitor 2. 

5. Once you’ve customized your display settings, click OK to save your settings. 
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Customizing the Start Menu 
 
The Start Menu is one of the most frequent places you will go when using Windows 7. As such, Microsoft wanted it to be highly 
customizable to work well for you. You can customize the Start Menu to make it work any way you want it to. 
1. Right-click on the Start menu and select Properties. 
2. Click on the Customize button. 
3. There are many options to customize in the Start menu. Scroll through the list to see all of the different features you can 

customize. 
4. Once you’ve made any changes, click OK to save your settings. 
 
Customizing the Taskbar 
 
The Taskbar, aka the Superbar, is where your running applications and any programs pinned are located. There are a few options 
you can customize on the taskbar, let’s explore them: 
To access the Taskbar properties, right-click anywhere in an empty area of the Taskbar and select Properties. The first option is 
to Lock the taskbar. This locks the current icons in place. Next, you have an option to Auto-hide the taskbar, selecting this option 
will hide the taskbar and start menu whenever your mouse is not at the bottom of the screen, when you move your mouse to the 
bottom of the screen, the task bar will show. The third option is to Use small icons, this changes the icon size from large to small. 
Next, you can move the taskbar to some other location on the screen (such as left, right, or top). 
You can change how Windows groups the icons by changing the Taskbar buttons option to always combine, combine when the 
taskbar is full, or never combine. 
We discussed changing the notification area icons in an earlier section of this tutorial. 
Finally, you can change the peek, if you run your mouse to the Show Desktop button at the bottom right of the taskbar; it will show 
you a peek at your desktop and temporarily make all of the windows transparent. You can turn this off. 
Once you have configured your taskbar, click OK to close the properties window. 
 
Folder Settings 
 
By default, Microsoft tries to protect you from yourself and hides operating 
system files to keep you from messing anything up! However, you may want 
to change folder settings to show hidden files, turn off simple file sharing, or 
show operating system files. 
 
How to Show Hidden Files in Windows 7 
 

1. Click on the Start menu. Click on Computer. 
2. Click on the Organize button.  
3. Click on Folder and Search Options. 
4. Click on the View tab. 
5. Click on the radio button next to Show hidden files, folder, and 

drives. 
6. Click OK to show hidden files. 
 

How to Show File Extensions of Known File Types 
 

Windows hides the extensions (such as .doc or .txt) of known file types. You 
can show these extensions in Explorer if you’d prefer. 
1. Click on the Start menu. Click on Computer. 
2. Click on the Organize button. Click on Folder and Search Options. 
3. Click on the View tab. 
4. Uncheck the checkbox next to Hide extensions for known file types. 
5. Click OK to show hidden files. 
 

How to Show Protected Operating System Files 
 

Windows hides protected operating system files. You can show these files in Explorer if you’d prefer. 
1. Click on the Start menu. Click on Computer. 
2. Click on the Organize button. Click on Folder and Search Options. 
3. Click on the View tab. 
4. Uncheck the checkbox next to Hide protected operating system files (Recommended). 
5. Click OK to show the protected operating system files. 
As you scroll through the Folder Options list, you will see many options you can use to customize how you interact with Windows 
Explorer. If you change some options and find out you made a mistake – don’t worry! – just click on the Restore Defaults button to 
get things back to normal. 
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Getting Help 
 
Windows 7 has the most robust help system of any version of Windows to date. Unfortunately, in the past, Windows has been lacking 
a great help system which forced hundreds of thousands of users to find help online or from a friend or relative. Now, the Windows 
help system has a much better search system, step by step instructions for many of your common problems, and an occasional video 
resource online to watch how to do it. 
 
Accessing Windows Help 
 
There are two ways to quickly access Windows Help, the first is to press the F1 key on your keyboard while the desktop or a Windows 
Explorer window is active. The second way is to click the Start menu, then select Help and Support. 
At the top of the window, you have several options: go to the 
help home page, print the current topic, browse help topics, 
learn about other support options, and the options menu for 
the help system. If you have an idea of what you’re looking for, type it into the Search Help text field and press Enter. We’re 
going to search for. When you press Enter, you will see a list of help topics.  
 
Working with Files and Folders 
 
Windows organizes your files into folders on your storage device, aka hard drive. Folders can contain both files and subfolders, 
allowing you to go as deep as you want in file structure and become as organized as you want. In this section of the Windows 7 
tutorial, we’re going to discuss the Windows 7 file structure, how to manage folders and files, creating zip archives, using the recycle 
bin, and creating shortcuts. First, let’s start with the Windows 7 folder structure: libraries. 
 
Windows 7 User Files 
 
Microsoft Windows creates a series of libraries to store your personal data in. You can find 
your libraries by clicking on the Start menu and then clicking Computer. Click on the Libraries link on 
the left: 
This will open the libraries on your computer. A Library is not a real folder; it’s really a collection of 
files or folders in different locations around your computer. This enables you to; for example, store 
all of the music on your computer in a single library but in different locations across your hard drive. 
If you click on the 2 Locations link at the top of the library window, you will see a list of all of the 
folders and folders in the library. You can Add a location to the library by clicking on the Add button. When you add other locations, 
you will start seeing those files in the library. 
 
Creating Folders 
 
A folder is a directory of files and folders on your computer. There are several ways to create a folder. Here’s the most common: 
1. Open up the folder or hard drive you want to create a folder in. We’re going to create a new folder in the Documents library. 
2. Click on the Start menu. Click on Documents. 

 
3. Click on the New folder button at the top of the Explorer window. 

 
4. A new folder is create in the current directory. You can start typing to rename the folder. 
 
Renaming Objects 
In an explorer window, click once on the file you want to rename, pause a couple of seconds, then click on the file name. It should 
highlight so you can rename it. 
Alternatively, right-click on the file or folder and select Rename to rename the object. 
 
Moving and Copying Files/Folders 
The most frequent way to move or copy files is to drag and drop them. When you drag and drop a file or older from one place on a 
hard drive to another place on the same hard drive, Windows moves the objects. If you drag and drop files 
from one hard drive to another, Windows copies the files. When you drag and drop, you can do so with your 
right mouse button and at the destination, a popup window will appear asking you which action you’d like to 
take. Select which you’d like to do, Copy the file, Move the file, or create a shortcut. 
You can also use your standard windows keyboard short cuts – copy a file using CTRL+C and paste it using 
CTRL+V. You can move a file by cutting it using CTRL+X and pasting it via CTRL+V. 
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Deleting and Undeleting Files/Folders 
When you delete a file or folder in Windows 7, it isn’t completely deleted. Instead, the record of the file locator is moved into a special 
storage area called the Recycle Bin. It is removed from display from where it is currently residing, but it can be brought back if you 
deleted it on accident. This is also important to remember if you’re deleting something confidential – make sure you read the section 
of this tutorial which discusses the Recycle Bin. If you delete a file or folder on a removable drive such as a thumb drive, it is likely 
deleted forever. Click on the file or folder you’d like to delete once and press the Delete key on your keyboard. You will be asked for 
confirmation. Alternatively, right-click on the file or folder and select Delete on the pop up menu. You can also drag and drop the 
object into the Recycle Bin and this will delete it as well. 
 
Creating Zip Archives 
A zip file is a compressed file containing one or more files or folders. Windows integrated in zipping and unzipping files into Windows 
Explorer in Windows XP. This feature allows you to combine several files into one, compress it, and then send it to someone or just 
use it to reduce space on your computer. 

If you are compressing several files, copy them into a single 
folder to make it easier to compress. Right-click on the 
folder and select Send to then click on Compressed 
(zipped) folder. This will compress the folder into a single 
zip file. 

The file icon of the zipped file 
appears to have a zipper on it. 
You can unzip a zipped file by 
right-clicking on it and 
selecting Extract All.  
The Extract Compressed 
(Zipped) Folders wizard appears 
allowing you unzip the contents of 
the file. 
Using the Recycle Bin 
When you delete a file in Windows 

7, the file isn’t deleted. Instead, Microsoft moves the record 
pointing to the file into the Recycle Bin and stores it there 

until the Recycle Bin is emptied. This allows you to easily recover files if you accidentally deleted them. Keep this in mind if you’re 
deleting sensitive files – they may still be around on your computer somewhere. (In fact, even once you remove them in the Recycle 
Bin, they aren’t really gone yet. A full deletion/cleaning utility will permanently remove the files). When you open the Recycle Bin on 
your desktop, you will see a list of files and folders you deleted. 
There are several options available to you: 
 Empty the Recycle Bin (remove all of the files from the list and delete them permanently) 
 Restore all items (return them to their original location) 
 Restore files one at a time 
 
Restoring an Item from the Recycle Bin 
1. Open up the Recycle Bin. 
2. Click on the item you would like to restore. 
3. Click on the Restore this item button at the top of the window. 
4. The item is restored to its original location. 

You can also empty the entire Recycle Bin by right-clicking on it and selecting the Empty Recycle Bin option. 
Note: when you are deleting a file, you can permanently delete it without sending it to the Recycle Bin by pressing Shift+Delete 
after selecting the file. 

 
Creating Shortcuts 
A shortcut is a link to a file somewhere else on the computer. A shortcut is commonly used to create icons which link to programs on 
the computer, but you could create a shortcut of any file or folder anywhere it is convenient for you on your computer. Right-click and 
drag and drop a folder or file into the location you want a shortcut. When you release the right-click button, a popup menu will appear. 
Select Create shortcut here to create a shortcut. If you’d like to create a shortcut of a file or folder on the desktop, there is a quick 
way to accomplish that. Right-click on the file or folder and select the Send to menu. Click on Desktop (create shortcut). 

 
Managing Users in Windows 7 
User accounts in Windows 7 allow you to setup different profiles for different people using your computer. This will keep your settings, 
documents, mail files, favorites, and so on separate so you can all lead your own lives on your computer! It’s easy to setup and use 
multiple accounts in Windows 7 and this section will show you how to create and manage users and setup parental controls so you 
know your children will be safer on the Internet. 



 
 
 

SARVA EDUCATION (SITED) (Running- An I.T & Skill Advancement Training Programme)                                                                                                                                                            - 36 -                                                                                                                 

                                                                       

 

Visit us at:  www.sarvaindia.com                                                                 Licensed by Govt. of India                                                                       ISO 9001:2015 Certified 

Creating Users 
 
You can setup as many user accounts as you wish on your computer, allowing each person in your household to have a Windows 
profile with their own documents, desktop images, mail files, Internet Explorer favorites, and so on, so you do not intrude on each 
other on one physical computer. You can share files among your different user accounts to make it easy if you want to write a 
Christmas letter with your wife, as an example. By default, you setup at least one account when you installed Windows, here’s how 
you create another user account: 
1. Click on the Start menu and select Control Panel. 

 
2. Click on Add or remove user accounts. 
3. Click on Create a new account. 
4. Enter the account name you want to use. Select whether or not the user will be a Standard user, one which will not be able to 

change some system settings or install some types of software, or an Administrator, a user with full control on the computer. 
A Standard user is recommended for most user accounts you will create so that the user does inadvertently cause major 
problems on your computer. 

5. Click Create Account. A new user account has been created! 
 
Resetting a User’s Password 
 
When you create a new account, by default, it does not have a password set. If you set a password or the user creates their own 
password and subsequently forgets it, you can reset the password with any administrator account. If you forget the password of an 
administrator account and have no other administrator accounts on the machine, you’re in some trouble! To reset the password of a 
user on the computer: 
1. Click on the Start menu and select Control Panel. 
2. Click on User Accounts and Family Safety. 
3. Click on User Accounts. 
4. Click on Manage another account. (You can change your own password on this screen if you’d like). 
5. Click on the account you want to reset the password for. 
6. Click Change the password. 
7. Enter a new password, confirm it, and then enter a password hint. 
8. Click Change password to change the user’s password. 
 
Deleting an Account 
 
If no longer need a user account, you can delete it to remove it from your computer. When you delete an account, you can choose 
whether or not save the person’s documents (not their email, however). Once you delete an account, the user’s profile – all of his or 
her settings and files – is deleted. 
1. Click on the Start menu and select Control Panel. 
2. Click on Add or remove user accounts under User Accounts and Family Safety. 
3. Click on the user account you would like to delete. 
4. Click on Delete the account. 
5. Select whether or not you want to Delete or Keep the user’s files. 
6. Confirm you would like to delete the account. 
7. The account is deleted and any of the user’s files are copied to your desktop. 
 
Configuring Parental Controls 
 
Windows 7 contains flexible parental controls you can use to help lock down your child’s account. They aren’t a good substitute for 
parental monitoring and involvement (in other words, an enterprising kid can bypass some of the controls if they’re smart enough and 
have the right access level), but it is a good option for young kids or as a baseline of control over what you’re children do. The first 
step to using parental controls is to setup a user account for your child. Next, let’s setup some parental controls: 
1. Click on the Start menu and select Control Panel. 
2. Click on Set up parental controls for any user under User Accounts and Family Safety. 
3. Click on the user account you would like to setup parental controls for. 
4. Turn parental controls on by clicking on the On, enforce current settings radio button. 
5. You have three ways you can control what the user does: time limits, games, and allow or block specific programs. Time limits 

allows you to select what hours of what days the user is permitted to logon to the computer and use it. Games allows you to 
block all games that use parental ratings or select specific game ratings permitted. You can also block or allow specific games. 
Finally, you can allow or block specific programs on the computer. This allows you to allow the user to only use programs you 
specify. Once you’ve set the parental controls you want to enable, click OK. 
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Adding and Removing Software in Windows 7 
 
Understanding User Account Control (UAC) 
In older versions of Windows (before Vista), Windows had set user 
levels and if a user was an Administrator on the machine, anything 
that user did was at the Administrator level. This could cause 
problems if a virus or trojan, or some other unwanted program, 
gained access to your system. You could become infected and not 
even know it! 
Microsoft borrowed from the security and stability of other 
operating systems such as Unix, Linux, or Mac OS, and introduced 
a feature called User Account Control (UAC). UAC limits 
privileges for software applications to those of a standard 
user (versus an administrator), and only elevates privileges after 
an administrator authorizes the elevation. This is designed to allow 
a user to decide if they trust an application before granting it 
administrative privileges to prevent malware from compromising the entire operating system. You will see a User Account 
Control window (and the dimming of everything else on your computer) whenever a software application performs a function requiring 
administrative privileges, such as when we attempt to change UAC settings. If the account you are logged in with does not have 
administrative privileges, you would be required to enter a username and password which does. 
 
Disable User Account Control 
You can disable UAC, but it is not something we recommend. UAC does give your computer some protection from rogue software 
applications (but as well know not total protection – malware still seems to find its way in). We recommend leaving it active – we don’t 
see it too often and when we do, it’s quick and easy to determine if it’s doing something I want my computer to be doing. However, if 
you still want to disable UAC, here’s how to do it: 
 
How to Disable User Account Control (UAC) 
1. Click on the Start menu. 
2. In the search field, type in UAC and click the Change User Account Control Settings link at the top. 
3. In the User Account Control Settings window, there is a slider with different level of notifications from Always notify to Never 

notify. If you’d like to disable UAC, drag the slider to the bottom and click OK. 
4. When you click OK, you will receive a UAC confirmation dialog box. Click Yes to save your change. 
5. In the future, you will not receive UAC popup once you disable them. 
 
Installing a Software Program 
Software programs for Microsoft Windows 7 typically come with their own setup program. This program installs the software and 
configures Windows to support the new software. There are thousands of applications you could install; we’ll review the installation 
process for Firefox, a web browser and common replacement for the built-in browser on Windows, Internet Explorer. 
 
How to Install Mozilla Firefox 
Mozilla Firefox is a free, open source web browser which replaces Microsoft Internet Explorer as the browser of choice for millions 
around the world. You can download Firefox at http://www.getfirefox.com. 
1. Open Internet Explorer to download Firefox. 

 
2. Type in http://www.getfirefox.com into the Internet Explorer address bar at the top. The address 

will redirect to the download page. 
3. Click on the Free Download button to 

download the latest version of Firefox. 
4. You will see a security warning from 

Internet Explorer. Click Save to save 
the installation program to your 
computer. This security warning is 
there to make sure a piece of bad 
software such as a malware does not 
download something without your 
permission. You want to download 
Firefox, so it’s ok to continue. 
Now, you will be presented with 
the Save As dialog box. By default, it 
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will open in your Downloads folder – it’s fine to save it there. If you don’t want to save it there, navigate to another folder. In the 
screenshot above, you will see I am downloading it to my desktop. 

5. The file will now download. Once it’s complete, navigate to the folder you saved the setup program in 
(most likely your download folder). To find the file, click the Start menu, select Computer. On the left, 
click on the Downloads link. This will open your downloads folder. 

6. Find the Firefox Setup 3.x icon and double-
click on it. 

7. You’ll see a security alert, click Run to 
continue. The setup files will extract. 

8. Click Yes on the User Account Control dialog 
box. 

9. Firefox setup will start. Click Next> to move 
forward with installation. 

10. Leave the Standard radio button selected and 
click Next >. 

11. Click Next or Install to continue. 
12. Click Finish. Firefox is now installed. 

 
Removing a Software Application 
 
There will come a time when you need to remove a software application on your computer. Perhaps it’s an old version, you need to 
free up space, or you just don’t want a software program installed. Here’s how to uninstall software in Windows 7: 
1. Click on the Start menu. Click Control Panel. 

 
2. Click Uninstall a program under the Programs section. 
3. The Programs and Features control panel opens. It contains a list of all of the programs installed on your computer. Scroll down 

until you find the program you want to uninstall. 
4. Click on the program you want to uninstall and then click on the Uninstall button at the top. 
5. Follow the application setup program to uninstall the software program. 
 
Setting Default Programs 
For many years, Microsoft has been fighting antitrust lawsuits from governments worldwide and as a part of the settlement with the 
US government; Microsoft has defined a “default program” setting for you to define what application opens up with something needs 
to start a Web browser or email. If you don’t desire to use Internet Explorer or Windows Mail, you could set a different default 
program. For example, I prefer to surf the web using Firefox and not Internet Explorer, so my default web browser is set to Firefox. In 
this section of the free Windows 7 tutorial, we’re going to explore how to manage the default programs and change them, if 
necessary. 
 
How to Set Default Programs in Windows 7 
1. Click on the Start menu. 
2. Click on the Default Programs link on the right-hand column of the Start menu. 
3. Click on the Set your default programs option. 
4. You will see a list of programs on the left. Click on one, such as Firefox or Internet Explorer to see the options available. 
5. You have two options available, Set this program as default, which will set the program to the default for all of the file types and 

protocols it can open, or Choose defaults for this program, which allows you to set which protocols and file types to open. 
6. Normally, I would like Firefox to handle all web browsing activities, but I will click on Choose defaults for this program for you 

to see the file types and protocols it will open. 
7. As you see in the list, Firefox handles web pages (such as .html) and web protocols (such as HTTP). If you double-click on a 

.html file in Windows Explorer, Firefox will open. If you select an HTTP link in an email, Firefox will load for that as well. We could 
selectively choose file types or protocols for Firefox to handle and for Internet Explorer to handle. 

8. If you make any changes, click Save, and then click OK to close the Set Default Programs window. 
 
Turning Windows Features On and Off 
By default, not every feature of Windows is installed nor enabled. This is because a majority of users do not need every possible 
feature and some, such as the IIS web server, could cause more harm than good. However, if you do need one of these other 
Windows features, you can easily turn them on in Windows 7. 
 

Installing Additional Windows Features 
1. Click on the Start menu. 
2. Select Control Panel. 
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3. Click on Programs in the control panel. 
4. Click on the Turn Windows features on or off at the top. 
5. Select the feature you would like to install in Windows 7. We’re going to install the Telnet Client. Telnet allows you to connect to 

servers via the command line interface and we occasionally need to do so for testing mail servers. Scroll down the list and 
select Telnet Client then click OK. 

6. Windows will make the necessary changes. During this time, User Account Control may popup. When the process is complete, 
the window will close and your feature will be installed. 

 
Windows 7 Networking 
 
Microsoft continues to improve the ease of use of networking and has improved file sharing and network access in Windows 7. In 
Windows 7, you can connect to a wired or wireless network, with all kinds of security options. Windows 7 introduces the HomeGroup 
feature to allow you to quickly share files among computers on your home network, while helping to keep out intruders from accessing 
your network. You can also easily share printers or other resources from one computer to another. 
 
Connecting to Your Network 
 
If you have a wired network, connecting to it is usually as easy as just plugging in a cable. A HomeGroup allows you to connect other 
computers on your network to share files, music, and printers. You can create a HomeGroup by: 
1. Click the Start menu and select Control Panel. 
2. Click on Choose homegroup and sharing options under Network and Internet. 
3. Click on Create a HomeGroup. You can determine what types of file and content you would like to share. 
4. Click Next to create the HomeGroup. You will receive a password for other users to join your HomeGroup. 
Note: HomeGroups are only available on Windows 7, Windows Vista and Windows XP users will not be able to join. 
 
Setting Up a Wireless Network 
 
Connecting to a wireless network in Windows 7 is a world’s difference from previous versions of Windows. In Windows XP, it was very 
painful to connect to a wireless network with any kind of security on it. In Windows 7, the process is much easier. 

1. In the notification area, you should have a wireless icon  if you have a wireless adapter and are not connected. 
 

 
 
2. Click on the icon to see the wireless networks available. 

 
Select the network you would like to connect to. If it requires a password, Windows will prompt you. Otherwise, Windows will 
attempt to connect. Once you’re connected to the wireless network, your icon will change. 

 
 

_________________________________________ 
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Lesson: 7  
 

 Basic of Multimediai 
 

 
Introduction 
 
Multimedia has become a popular technology in the ever- changing world of computers. Since a few years it seems to be much 
sought after and talked about not only in the world of Information Technology but also in the various functional fields like 
advertisement, corporate sectors, cinemas, fashion designing, education, art and craft etc. 
More and more research work on this technology and new technology of sounds, animation and text is making it better and better with 
every passing day. It is one of the most realistic ways of working even for the people who do not have any knowledge of computers. 
Multimedia software is used for electronic publishing and electronic games and in employee training programs. The term multimedia is 
also used to describe home entertainment systems and other electronic products and services, particularly interactive ones that 
combine text, sound, video, and the like. 
 
Concept of Multimedia 
 
The term multimedia is often associated with the information superhighway, or with the interactive TV that can produce videos, 
graphics, and animations or with hypermedia. Multimedia can be considered as text graphics, images, audio and video in the 
computer. One of the key features of multimedia is its interactivity i.e. it has the capability to convey enriched interactive information to 
its users. 
Multimedia is interactive, a non-linear media in comparison to a broadcast television. In addition it may provide user with as several 
meaningful paths. Thus, it is the interaction between the user 
and information that makes multimedia a very powerful media for activities that require the process of communicating information, 
such as education and training, reference material, business presentations, manuals, multimedia databases, geographic information 
system, advertising, documentaries and so on. 
Multimedia, in personal computing, is software and applications that combine text, high-quality sound producing high quality 
presentation to the user. 
 
The basic components of multimedia can be used as:— 
 

 The text provided can be used for adding emphasis 
 Graphics provides a visual impact. It is generally said that a picture is worth a thousands words. Thus graphics can be used 

for enhancing the presentations.  
 Voice tries to enhance the presentation to the extent that a presentation moves on to the form of persuasion. Many people 

want to listen about a particular topic rather then reading about it, here the voice enhancement makes the topic interesting 
also. 

 The animation can be used effectively for attracting attention. Animation also makes a presentation light, thus can be used 
for presentation of several complex subjects. It is also a tool that helps in focusing attention, for example, a chart if drawn 
through the help of animation effects may be focused by the user on to quickly.  

 The video part of multimedia can be used as a powerful communicator providing clear-cut Instructions. 
 
Use of multimedia in various applications can be justified by the levels of user friendliness, it provides to its users with its interactivity 
and customization. Multimedia is widely used now a day in various applications and business in one of them. As the market 
competition is increasing with the introduction of better products in the market everyday, it has become absolutely necessary to 
provide better service and timely information to your client in a brief, precise and more understandable manner in a short time. 
The interactive features of multimedia brings life to the presentations where one can present various aspects of information on a 
particular subject. The information which is digitized in multimedia makes it more assessable as compared to the conventional ways of 
presentation using video, chart etc. where you can not edit or modify whatever is already video taped. Even if you do it, the cost of the 
task involved will be high. But now days, organizations have already started creating powerful databases that can store and distribute 
digital media as easily as text. 
Another critical application of multimedia is in the educational sector. It enhances the quality of education. It provides a new way for 
teachers to encourage one of the most rare and important elements of learning i.e. curiosity to learn and explore. Topics can be linked 
with other related information. On the other hand students will also be able to further explore the topics using standard multimedia 
platform. In complete sense pictures, graphics, text and sound is the essence of multimedia and it provides the user-friendly 
environment with most flexible interactive facilities. 
 
Application Areas for Multimedia 
 
With the advancement of technology many applications are evident for the multimedia technology. The advancement of technology 
has opened up newer fields for the application development. 
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Multimedia in Entertainment 
The entertainment industry has used this technology the most to create real life like games. Several developers have used graphics, 
sound, animation of multimedia to create a variety of games. The special technology such as virtual reality have made this game just 
like experiences of real life. One such example is flight simulator that creates real life imaging. 
Multimedia in Edutainment 
Edutainment is nothing but educational entertainment. Many computer games with focus on education are also available now. For 
example is an educational game that plays various rhymes for little kids. Similarly many other edutainment packages which provide a 
lot of detailed information for students are also available popularly called "tutors". 
Microsoft has produced many such CD-based multimedia such as Sierra, knowledge Adventure etc. that in addition to play provide 
learning components also. 
Multimedia in Business Communication 
Multimedia is also a very powerful tool for enhancing the quality of business communications. The business communications such as 
employee related communications, product promotions, customer information and reports for investors can be presented in 
multimedia form. 
Multimedia and Publishing Industry 
The publishing industry can be classified according to the market it caters for. One of the classifications is based on the information, 
which is presented in published text, for example a publication may be for reference purposes or archival purposes or tutorials. The 
publishing meant for children has changed tremendously with the advent of multimedia. Today many encyclopedias and books 
providing a sort of edutainment are available. 
 
Hardware for Multimedia Computers 
In order to work with multimedia, a personal computer typically requires a powerful microprocessor, large memory and storage 
capabilities, a high-quality monitor and a video accelerator, external loudspeakers or headphones and a sound card (or sound board) 
for improved sound generation, and a CD-ROM or DVD-ROM (digital video disc) drive, as well as special software to utilize many of 
these devices. A multimedia computer may also use other devices, such as a microphone or keyboard for audio input and a 
videocassette recorder or camcorder for video input or output. 
 
Let us explore more about the hardware related to the multimedia technology. 
 
The CPU 
The CPU which is recommended as the microprocessor should be a Pentium Processor on the computer or any other advanced chip 
such as PowerPC etc. 
Apple Macintoshes and Silicon graphics computers have their own set of powerful processors to enable multimedia. However, the 
CPU of multimedia computer should be at least 486 with a math co-processor attached with it otherwise the response time of the 
multimedia will be poor. The co-processor chip greatly reduces the load of the CPU. The powerful co-processor chip added for 
supporting graphics is called graphics accelerator. 
 
The Monitor 
A typical representation, which may be used in multimedia, can be 720x640 or 1200x680 etc. The multimedia PC should be equipped 
with a monitor having a Super Video Graphics Arrays (SVGA) card. The basic advantage of having the SVGA card is that it has a 
better resolution, thus the graphics display will be of better quality. 
 
Input-Output Devices 
Keyboard and mouse are two important components for any multimedia PC. Since multimedia computers are accessed using a 
graphical user interface (GUI) the mouse is an essential part of this system. It is the most required input-output device for it. 
There should also be sound speakers, which produce sound output and microphones that are used for on-line recording of sound 
using various multimedia Softwares. 
 
CD-ROM 
CD-ROM (Compact Disc-Read Only Memory), a form of CD that can only be use for reading purpose, by a computer using a CD-
ROM drive and that can contain computer programs and digitized text, sound, photographs, and video. 
 
CD-R (Compact Disc-Recordable) and CD-RW (Compact Disc-Re Writable), which can be written to once and multiple times, 
respectively; interactive CDs, CD-I, CDTV, and other formats, which require special players with built-in microcomputers; and Photo 
CD, a format for storing photographs. 
 
DVD-ROM 
DVD-ROM (Digital Video Disk Read Only Memory) discs hold computer data and are read by a drive hooked up to a computer. These 
disks can only be read, not erased and written or recorded to. DVD-R (Recordable) discs can be written to sequentially only once. 
DVD-RAM (Random Access Memory), DVD-RW, and DVD+RW (Re-Writable) disks can be written or recorded to thousands of times; 
they differ in their technical standards and amount of data they can hold. 
Digital Versatile Disc (DVD) is an advanced optical technology used to create a disk that holds far more information than a CD can. 
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Sound Card 
The most important reason for adding a sound card to a computer is to able to use full multimedia recording and playing back the 
digital audio. While selecting an add on sound card quality of sound from the loudspeaker has to are taken into consideration and the 
software provided with a sound card should be adequate enough to suit your requirements for handling sound effects in multimedia. 
While installing a sound card one should keep in mind that it should not conflict with any other external devices installed in the 
computer system. Installation of sound card might require some default settings to be changed to make it compatible with the 
computer system. 
 
Different Types Software for Multimedia 
Among the Softwares used for multimedia presentations the most popular Softwares are Designer, Corel Draw, Picture Publisher, 
Photo Magic, Animator pro, Image Macromedia Director etc. 
 
Director 
Director is one of the professional rating drawing and graphics package made for windows. It is specially meant for graphic artists and 
technical illustrators. It has a wide range of drawing tools and powerful text handling features. 
 
Photo Publisher 
Similarly, Photo Publisher is a professional photo retouching or image-editing multimedia package designed to enable retouching and 
enhancing photos faster. It has powerful masking and retouching tools and more than 30 special effects and filters. It has an image 
browser, processor, scanner, printer calibration, a stitching tool and over 50 ready to use textures and images. 
Similarly other multimedia related software also wok on the same type of working environment along with their own features to 
experiment upon. 
 
ImageQ 
ImageQ is another multimedia authoring software package. Although it is a Windows 3.1 application but it can also play back on 
Windows 98. It lacks only the intuitive programming language and strong interface necessary for truly productive multimedia 
applications development. 
 
Macromedia Director 
Macromedia Director is better suited to multimedia presentations and kiosk application. This product offers a central scoring 
component that provides precise timing control, cross platform compatibility, strong animation features and extensive architecture to 
add functionality. 
Macromedia Director 8, the powerful, cross-platform application helps you create dynamic interactive movies for multimedia and 
Internet productions. 
 
Macromedia Flash Player 
Macromedia Flash Player is pre-installed in most Web browsers and on most computers. It is included in Windows 98 (including all 
new Windows 98 and Windows XP computers), Netscape Navigator, Apple Macintosh operating systems, America Online, and 
WebTV, among others. 
Macromedia Flash Player displays Web application front-ends, high-impact Web site user interfaces, interactive online advertising, 
and short-form to long-form animation. 
Macromedia Shockwave Player displays destination Web content such as high-performance multi-user games, interactive product 
simulations, online entertainment, and training applications 
 
Fixing photos using Photoshop 
We are taking the following picture for an example how you can fix photographs using the Adobe Photoshop multimedia software. 
The photo has been taken on a very short distance. That has resulted in a significant distortion in the left part of the image. But the 
photo is not to be wasted; it just has to be corrected. The great imaging editor Photoshop has the tools. 
You open the photo in Photoshop from the Start Menu and Programs option menu and choose Select all (Control+A). Then select 
Distort option from the Transformer option of Edit Menu. 
Now you see handles eight in the corners of the image. You may drag one of the handles, and the image is geometrically distorted. 
This is how this tool works. 
You can apply the transformation by hitting the Enter key. The image is OK from a geometrically point of view. 
You may need to do a little further editing. In the left corner there is a grey area which is an unwanted effect of the transformation. 
 
Finally  the image should be saved in a high quality JPEG file. 
 
 

______________________________________ 
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Lesson: 8  
 

 DOS (Disk Operating System)i 
 

Introduction to Dos Command 
Disk Operating System (DOS) is the first program which must be loaded in the memory of your PC before you can use it for any 
purpose (word processing or database management). A command, in simple term is the name of a program that you want the 
computer to carry out. All DOS commands one accepted either in upper or lower case letter and DOS treats them as the same. 
Various versions of DOS, such as 2.0, 3.0, 3.2,3, 4.0, 5.0, 6.0 and 6.2 are available. The higher versions have more features and 
commands but the basic commands and features are available in all versions. 
You can load DOS from the floppy drive or the hard disk, Loading DOS is also called booting up the PC. Complete the following steps 
to load DOS in your PC. 
 
If you PC has No Hard disk  
Put the DOS diskette in drive A and close the drive door.  
Then on the power on off switch, which is usually located on the right hand side of the main processing   units. If your monitor also 
has on/off switches, turn on that switch too. and wait for some time. Your PC performs the "self test" and the loads the DOS diskette in 
its memory. The monitor displays the DOS prompt A Self test means power on self test program (POST) that is designed for checking  
 (in first step) to confirmation of device attachment and device working position with system. Mainly these device are 
MONITOR.KEYBOARD, MOUSE, HARD DISK, RAM etc. and Second step, it locate and loading the operating system. 
 
If your PC has a hard disk PC 
If your PC has a hard disk, you can load DOS from a floppy disk or the hard disk. To load dos from the hard disk perform the following 
steps: 
Turn on the Power ON/OFF switch which is usually located on the right hand side of the main processing unit. 
If your   monitor has on/off switch, turn on that switch too. 
Do not put any diskette in drive A. 
Wait for some time. Your PC performs "self test" and loads DOS. Your monitor displays c:\>. 
 
Booting Process: 
You can load DOS from the floppy drive or the hard disk. Loading DOS is also called booting process of PC. In Booting process DOS 
execute mainly these files: COMMAND.COM, IO.SYS and MSDOS.SYS. In these the COMMAND.COM file gives the instruction to 
execute lO.sys and MSDOS.SYS files. IO.SYS file configure the input and output devices and then MSDOS.SYS file run the all DOS 
command. 
 
Basic For File Name 
In computer terminology a file is a collection of text of data stored on the storage device, such as a disk or magnetic tape. The 
information spread in various kinds of documents (invoice, letters. memo etc.). Usually one computer files is used to store only one 
kind of information. Different types of files are used to in a computer. The file that store database information, such as an address list 
of sales details, is called a database file and the file that store textual document is a document of text file. The file name can have up 
to eight alpha-numeric characters. Optionally, it can also have a period(.) and an extension name. The extension name can be upto 
three characters long. For instances, consider the following files names: 
 
MCS1, MSC2. & DOC 
Here, MSC1 and MSC2 are filenames. DOC is the extension name. Some file name, such as COM1 -communication port (used for 
serial communication), LPT1- first parallel printer port, CON- CON stands for console, For input, CON points to the keyboard; for 
output, CON points to the screen and PRN-The Parallel Printer port, are reserved by DOS for its own use. Therefore do not use them 
to name your files. 
 
Batch File 
A batch file is simply a text file that you can create by using unformatting text editor tools,  e.g. the EDIT command in MS-DOS. (some 
other methods will be discussed later) 
A batch file must be named with an extension BAT, e.g. autoexec.bat, menu. bat 
A batch file is a program which contains MS-DOS commands. Each command used in the batch file must be started from a new line 
and written in a correct syntax. The syntax of a command is just the same as that you use it at the DOS prompt. 
 
What is a Directory? 
As the storage capacity of the hard disk is usually quite large as compared to the capacity available on a floppy diskette, the hard disk 
is usually divided into various segments (sections) which are called directories. In other words, a directory is nothing but a named 
section of the storage area of the disk (hard or floppy diskette) which is used for storing fires. The directory serves the purpose or 
organizing the files in a better manner. For instance, word program files can be stored in a separate directory; the user Arjun may 
store his personal files in a directory-Arjun. 
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Like the filename, the directory name can have up to eight alpha- numeric characters and can also have up to 3 characters long 
extension name. However, normally the extension name is not used with the directory name. When you start your computer from the 
hard disk, it responds with C:\> and selects the main or root directory. Any file that you create or copy to drive C is added to this (root) 
directory. If you continue to add files in the root directory, after a few days, the root directory will have too many files. This will not only 
confuse you, but will also make the PC slow. Therefore you should try to use the directories (and sub-directories) in the hard disk. The 
root directory which contains files can also have one or more directories. Each directory in the root directory can have files as well as 
directories. Thus, the file and directory organization in DOS looks like the roots of tree, as shown in Fig. 
 

 
 
In these figure, the root directory in drive C contains a few files and two directory INDIA and ASTRAILIA. The India directory contains 
files & MP directory. The India directory contains files & MP-directory. The Australia directory contains files and two directories 
MARKET and PROGRAMS (called Sub-directory). 
 
Wild card 
Wild card use in DOS for specifying a file name and any match the specification a file name. Two wild card*, ? and one the asterisk (*) 
mean any file and the question mark (?) for any character. 
 
For example:- 
 
1.  Display all files stored in C drive then the command will be: 
 
 
2.  Display all the stored in C drive where extension is .txt then the command will be: 
 
 

3.   Display all files where extension that letter is E and first file name is A then the command must be: 
 

 
 
 
4.  Display all files name start with character A and extensions will be start with any character then the command will be: 
 
 
 
 
Elementary DOS Command 

DOS has internal and external commands there are program inherent in DOS with a number of service or commands available 
for us to use. The commands are in memory all the time once DOS has been read off the desk and start up. These are called the 
Internal /Resident commands since this are one internal to DOS. All other command programs one called External and they are kept 
in the disk (Secondary Memory) until they required. 
 

 

C:\>dir *.* 

 

C:\>dir *.txt 

 

C:\>dir A*.* or C:>dir A???????.* 

 

C:\>dir A???????.E?? 
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 Internal/Resident commandsI 
 
(A)  DATE & TIME  (B)  DIR/DIRECTORY  (C)  CLS  (D)  VOL/VOLUME  (E)  VER/VERSION  (F)  REN/RENAME  (G) TYPE  
(H)  COPY  (I)  DEL/DELETE/ERASE  (J)  MD  (K)  CD and CD\   (L)  RD  (M)  COPY CON   (N)  PATH  (O)  PROMPT  
 
(A)  DATE & TIME: DOS display the date and time of the day. Time we can create or change some internal a disk, the disk file is 
marked with the current date and time. 

 
                               SYNTAX:   
 

 
Example: C:\> Date  
Current Date is 03-16-2001: 
Enter new date (mm-dd-yy):  
 
(B)  DIR/DIRECTORY: Dir is a directory using command it is and to display the list of files on a disk. 
        
                                               SYNTAX: 
 
 
 
 
We can also use different switches to see information by directory command 
/P  -   this switch is used for pauses after each screen to information. 
/W -   this switch is used for apply screen in wide termite. 
/A  -   this switch is used to display file with specified attributes. 
 
Attributes 
         D -   Directory                       R -    Read-only Files 
         H -   Hidden Files                 S  -   System File 
         -       prefix meaning not      /O -    this command use to display the list by files in sorted order. 
 
Sort Order 
N    -   By name (Alphabetic)  
S    -   By size (smelliest first)  
E    -   By extension (Alphabetic) 
D    -   By date or time (finalist first)  
G    -   group directory first 
-     -    Prefix service order 
/s   -    It is used to display directory and all subdirectory. 
/b   -    It is used to display files with no heading information or summary.  
/V   -    verbose mode 
/4   -    It is used to display year with 4 digits. 
 
Example: 
C:\> DIR/P Directory Page wise  
C:\> DIR/W Directory width wise 
C:\> DIR/P/W Directory width & Page wise 
C:\> DIR/S Directory  
C:\> DIR/ON  (By Name, see in ascending order ) 
C:\> DIR/O-N (By Name, see in descending order) 
C\:> DIR/OD  (By date, see  in ascending order) 
C:\> DIR/O-D (By date, see in descending order) 
C:\> DIR/OE (By Name, see in ascending order) 
C:\> DIR/O-E (By Name, see in descending order) 
C:\> DIR/P Directory/Files, see in  Lower case  
C:\> DIR/G Group Directory, to see first 
 
(C)  CLS: These command used to Clears the screen. 
 
                                          SYNTAX:  
 

 

C:\>DATE 
C:\>TIME 

C:\>dir 
       [drive:] [path] [file name] [/p] [/w] [/A[[:] attributes]] 
       [/o[[:] sortrdr ]][/s][/b] [/I] [/v] [/4] 

C:\>CLS 
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(D)   VOL: These commands report to you the Volume cable on a disk. 
 
                                            SYNTAX: 
 
 
(E)  VER: These command report to you the Version number of MS-DOS (1.0,2.1,3.0,3.3 etc.) 
 
                                           SYNTAX: 
 
 
 

BASIC STRUCTURE FOR USING FOLLOWING COMMANDS 
 
 

 
 
 
(F)   RENAME: It is used to renames a files/ directories. 
 
 
        Example: C:\> RENAME C:\INDIA1\MP\INDORE.TXT C:\INDIA1\MP\XXY.TXT 
 
 
(G)  TYPE: It displays the information of file on monitor you can see only.   
 
       SYNTAX:                                                        Example -   C:\V> Type indore.txt 
 
(H) COPY: This is a command to make copies of disk files. It can also duplicate files from one disk to another we can copy several 

files by using with this command. 
 
       SYNTATX:                                                                                       Example: C:\>Copy C:\INDIA\MP\INDORE.TXT C:\INDIA\UP 
 
 
(I)   DEL/DELETE /ERASE: This is one command but with 2 different name, del and erase by which we can delete The file from  the 

disk directory. 
 
       SYNTAX:    
                
 
       [drive:][path]filename specifies the file(s) to delete. Specify multiple files by using wildcards. /P   Prompts for confirmation before 

deleting each file.  
       Example-            C:>CD INDIA 1 
                                   INDIA1 C:\INDIA1 > CD MP1  
                                   C:\INDIA1\MP> DEL INDORE.TXT 
 
(J)  MD: This command is used for Creates a directory.    
 
 
      SYNTAX:                                             Example-    C:\>MD INDIA1  
 
 

C:\>VOL 

C:\>VER 

REN [<old name of file/directory]       [file name of file directory]  
RENAME [old name of file/directory]  [new name of file directory] 

C:\>TYPE <filename> 

C:\> Copy <source path> <destination path> 

C:> DEL [drive:][path]filename [/P  
C:\>ERASE [drive:][path]filename [/P] 

MKDIR [drive:]path 
  MD [drive:]path 
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(K)  CD/CDX: This Command Displays the name of or changes the current directory.  
 
            SYNTAX:                                                       Specifies that you want to change to the parent directory.  
 
 
 
 
                                            Example-   C:>RD INDIA1 
 
(L)  RD: This is used for Removes (deletes) a directory.      SYNTAX:                                              Example- C:>RD MP  
 
 
(M)  COPY CON: This Command is used to make a file in DOS.  
 
             SYNTAX:                                               
 
 
 
 
                                     Example-   C:> Copy con Indore.Txt  
                                                        Indore is good city 
                                                        ^Z 
 
(N)  PATH: This Command Displays or sets a search path for executable files. 
 
             SYNTAX: 
 
 
                                     Example-   C:> Path C:\INDIA1\MP  
 
(O)  PROMPT COMMAND: Prompt command by using these command we can close the window command prompt. 
 
             SYNTAX:      
 
             "text" specifies a new command prompt.  
              prompt can be made up according to following special codes: 
 
             $Q     =       (equal sign)  
             $$      $       (dollar sign)     
             $T               current time     
             $D               current date  
             $P               current drive and path   
             $V               window version number   
             $N               current drive  
             $G     >        (Greater-than sing)       
             $L     <        (less-than sign)        
             $B     1        (pipe)                 
 
             Example-     Prompt $ Arjun $ 
                                  ARJUN>  
 

 External CommandsI 
 

 
(A) FORMAT (B)  DISK COPY  (C) CHKDSK  (D) TREE   (E)  UNDELETE  (F)  EDIT  (G)  XCOPY  (H)  SORT  (I)  MOVE (J)       
FIND (K)  MODE   (L)  DELTREE  (M)  SCANDISK  (N)  SYS  (O) PRINT  (P)  ATTRIB   (Q)  DOSKEY 
 
(A)   FORMAT: These command is used for create tracks and sector for storing information in file. 
 
                           SYNTAX:      
 

 

CHDIR [drive:][path] 
CHDIR[..] 
CD [drive:][path] 
CD[..] 

RMDIR [drive:]path  
RD [drive:]path 

C:\> Copy Con <File Name> 
------------------------ 
------------------------ 
^Z  or  F6 

PATH [[drive:]path[;...]]   
PATH ;                                  

Prompt [text] 

C:\>FORMAT<disk name> 
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There are following different switches is used in FORMAT Command. 
 
                                 /v             -      [:label]   Specifies the volume label. 
                                 /Q            -      Performs a quick format.  
                                 /F: size   -      specifies the size of the floppy disk to format (such as 160, 180,    320, 360, 720, 1.2, 1.44, 2.88).  
                                 /S            -      Copies system files to the formatted disk.  
                                 /1            -      Formats a single side of a floppy disk.  
                                 /8            -      Formats eight sectors per track. 
 
                                  Example-    C:\>Fcrmat D: 
 
(B)    DISKGOPY: This command is used to make duplicate copy of a disk of copies the content of source disk to target drive. 
                          
                                 SYNTAX: 
 
                                  /V     -     It ensures that the disk is copied currently. 
                                  /1     -     To make copy one side. 
                                  Example-      C\:>DISKCopy E:\ 
 
 
(C)   CHKDSK: It is used to report disk and memory status by checking the directory and file allocation table of the target of current 

disk. By using these command switches you can also repair errors in the directories. 
                               
                                 SYNTAX: 
                   

                                 Switches are: 
                                 /F      corrects the excess in FAT file allocation table. 
                                 /V-    Display the message of error and providing defaults about each error. 
 
(D)    TREE: This command is used to display all directory and subdirectory on tree format. 
                              
                                SYNTAX: 
 
                                 /F -   This switch is used to display file name with directory name.  
 
 
(E)    UNDELETE: This command is used to recover deleted file.     
                                
                                SYNTAX: 
 
 
                                /All  - This command automatically undelete all files.  
 
 
(F)    EDIT:  This command is used to write a text in dos editor 
       
                               SYNTAX: 
 
                               /B    -       Forces monochrome mode. 
                               /H    -       Displays the maximum number of lines possible for your hardware. 
                              /R     -       Load file(s) in read-only mode. 
                              /s      -       Forces the use of short filenames. 
                              /?      -       Displays this help screen. 
                              [file]  -      Specifies initial files(s) to load. Wildcards and multiple File spaces can be given. 
 
(G)   XCOPY: This command is used to copy file and directory. 
              
                              SYNTAX: 
                     

                              Source             -         Specifies the file(s) to copy. 
                              Destination     -          Specifies the location and/or name of new files. 

DISKCOPY [drive1: [drive2:]] [/I ] [/V] 

C:\>CHKDS

K 

C:\>TREE [/F] 

C:\>UNDELETE [/All] 

EDIT [/B] [/H] [/R] [/S] [/<nnn>] [/?] [File(s)] 

XCOPY Source [destination] [/A | [/M] 
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                              /A                   -       Copies fifes with the archive attribute set, doesn't change the attribute. 
                              /M                   -      Copies files with the archive attribute set, turns off the archive attribute. 
                              /S                   -       copy sub Directory & Files. 
                              Example:      -       C:\>XCopy  C:\India1\*.*   C:\xx/s 
 
(H)   SORT: It is used to display internals of the in sorted order. 
           
                               Syntax:       
 
                                       /R         -            Reverse the sort order  
                               /+N     -         Sorts the file according to character in columa N. 
                               Example-     C:\>TYPE INDORE.TXT:SORT 
                                                    C:\> TYPE INDORE.TXT: SORT/R  
                                                    INDORE.TXT  
 
(I)    MOVE: It is used to moves files and rename files and dir 
               
                               SYNTAX:      
 
                               Example-     C:\> MOVE C:\INDIA1\MP\INDORE.TXT C:\ INDIA1XUP *  
 
(j)    FIND:  It is use to search the text string is a files or file. 
         
                              SYNTAX: 
 
                              /V       -   displays all lines NOT containing the specified string. 
                              /C       -   displays only the count of lines containing the string. 
                              /N       -   displays line numbers with displayed lines. 
                               Example-   C:\>FIND "INDORE" C:\INDORE\MP\INDORETXT/V 
 
(K)   MODE: Configures system devices  
        
                             SYNTAX:  
 
(L)  DELTREE:  This Command deletes a directory and all the subdirectories and files in it. 
     
                             SYNTAX: 
 
 
                             /Y           -      Suppresses prompting to confirm you want to delete the subdirectory.  
                             [drive:]path       -       Specifies the name of the directory you want to delete. 
                             Example-  C:\>Deltree C:\lndia1 
 
(M)  SCANDISK: For information about the command-line parameters supported by ScanDisk for Windows, look up 'checking for   

errors, in disks' in the Windows Help index. Then view the topic 'Checking your disk for errors' every time your 
computer starts. 

                                   

                              SYNTAX:           
 
 
(N)  SYS:  Copies MS-DOS system files and command interpreter to a disk you specify. 
            
                              SYNTAX:   
 

                             [Drivel :][path] Specifies the location of the system files. 
                             [Drive2:][path] Specifies the drive the files are to be copied to. 
 
(O)  PRINT: Print command is used to print a file,  
                              
                              SYNTAX: 
  
     

SORT [/R] [/+N] [ [drives:][Path] file name] 

MOVE [Source Path Name ] [Destination Path Name] 

FIND [/V][/C][/N] "string" [[drive:][path] file name[...]] 

C:\>MODE 

DELTREE [/Y] [drive:]path [[drive:]path[...]] 

C:\>SCANDISK 

SYS [drivel:][path] drive2: 

C:\> Print 
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(P)   ATTRIB: This Displays or changes file attributes. 
                      
                                SYNTAX: 
 
 

/S     -   Sets an attribute. 
-       -   Clears an attribute.  
R     -    Read-only file attribute.  
A     -   Archive file attribute.  
S     -   System file attribute.  
H     -   Hidden file attribute. 

               S     -    Processes files in all directories in the specified path.  
                 
               Example-    C:\> ATTRIB + H  C:\lndia\MP1\lndore.Txt  
                                   C:\> ATTRIB – H  C:\lndia\MP1\lndore.Txt  
 
(Q):    DOSKEY: It is used to edit command lines, recalls command lines and macros. 
          Doskey             -        [SWITCH...]  
          Up, Down         -        Scroll commands. 
          ESC                  -        Clears Current Command. 
          F7                     -        Displays command   history. 
          ALT+F7     -         Clears command history  
          F8                    -         Searches for command beginning with characters. 
          F9                    -         Select   command number   with characters  
 
 
 
Comparison Between .COM,.EXE,.BAT . 
 
COM:      The extension meaning of these file is command file. The Internal command of dos written in command file. 
            
EXE:       The extension meaning of these file is executable file. The extension is used to execute any program or external command.   
          
.BAT:     The extension is represents batch file. There are many commands used many times then these file give the facility to   write 

them in-group and execute sequentially. 
 
 
 
 
 
 
 
 
 
 
 
 
 

____________________________________ 
 
 
 
 
 
 
 
  
 
 
 
 

ATTR1B [+R | -R] [+A | -A] [+S | -S] [+H | -H] [[drive:] 
[path]filename] [/S] 
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Unit-II MS-Word 2010i 
 

Lesson: 1  
 

 Introduction to M.S  Word 2010i 
 
What is M.S Office? 
 
Microsoft Office 2010 (also called Office 2010 and Office 14) is a productivity suite for Microsoft Windows, and the successor 
to Microsoft Office 2007. Office 2010 includes extended file format support, user interface updates,  and a changed user 
experience. A 64-bit version of Office 2010 is available, although not for Windows XP or Windows Server 2003. 
On April 15, 2010, Office 2010 was released to manufacturing. The suite became available for retail and online purchase on June 15, 
2010. Office 2010 is the first version to require product activation for volume license editions. 
M.S Office 2010 marks the debut of free online versions of Word, Excel, PowerPoint, and OneNote, which work in the web 
browsers Internet Explorer, Firefox, Chrome and Safari, but not Opera. Office Starter 2010, a new edition of Office, replaced the low-
end home productivity software, Microsoft Works. 
Microsoft's update to its mobile productivity suite, Office Mobile 2010, will also be released for Windows Phones running Windows 
Mobile6.5 and Windows Phone 7. In Office 2010, every application features the ribbon, Outlook, including, OneNote, Publisher 
InfoPath, SharePoint Workspace (previously known as Groove), and the new Office Web Apps. 
 
New Feature in M.S Office 2010 
 
Office 2010 is more "role-based" than previous versions. There are features tailored to employees in "roles such as research and 
development professionals, sales people, and human resources." In its Internet implementation, Office 2010 incorporates features 
of SharePoint Server and borrows from "Web 2.0" ideas.  
Microsoft Office 2010 includes updated support for ISO/IEC 29500:2008, the International Standard version of Office Open 
XML (OOXML) file format. Office 2010 provides read support for ECMA-376, read/write support for ISO/IEC 29500 Transitional, and 
read support for ISO/IEC 29500 Strict.  In its pre-release (beta) form, however, Office 2010 only supported the Transitional variant, 
and not the Strict. The intent of the ISO/IEC is to allow the removal of the Transitional variant from the ISO/IEC compliant version of 
the OOXML standard. Microsoft Office 2010 supports Open Document Format (ODF) 1.1, which is an OASIS standard. 
New features also include a built-in screen capture tool, a background removal tool, new SmartArt templates and author permissions. 
The 2007 "Office Button" was replaced with a menu button that leads to a full-window file menu, known as Backstage View, giving 
easy access to task-centered functions such as printing and sharing. A notable accessibility regression from 2007 is that the menu 
button scores worse with the Fitts's law accessibility calculation than previous versions. A modified Ribbon interface is present in all 
Office applications, including Office Outlook, Visio, OneNote, Project, and Publisher. Office applications also have 
functional jumplists in Windows 7, which would allow easy access to recent items and tasks relevant to the application.  
 
Features of Office 2010 include: Ribbon interface and Backstage View across all applications, Background Removal Tool, Letter 
Styling, The Word 2007 Equation editor is common to all applications, replacing Microsoft Equation Editor 3.0, New SmartArt 
templates, New text and image editing effects, Screen Capturing and Clipping tools, Live collaboration functions Jumplists in Windows 
7, New animations and transitions in PowerPoint 2010, View Side by Side/Synchronous Scrolling in Word 2010. 
A new feature in Microsoft Office 2010 is Outlook Social Connector, which allows users to connect to and receive updates from 
their social network inside Microsoft Outlook. When users view their emails a name, picture, and title is available for the person they 
are contacting. Upcoming appointments can also be viewed with this new feature and users can request friends. Outlook Social 
Connector currently supports Facebook, LinkedIn, MySpace and Windows Live Messenger. The Volume edition can be activated 
using a Multiple Activation Key (MAK) which is limited by the number of times a machine can activate when connected to Microsoft's 
servers, or using a Key Management Server (KMS) which requires activation every 180 days.  
 
What is M.S Word? 
 
Microsoft Word is a non-free commercial word processor designed by Microsoft. It is part of the Microsoft Office Suite. Microsoft Word 
is currently the most common word processor on the market. Because it is so common, the .doc/.docx format has become the de 
facto format for text documents. What is Microsoft Word used for: MS Word is a popular word-processing program used for 
creating documents such as letters, brochures, learning activities, tests, quizzes and students' homework assignments. There are 
many powerful features available in Microsoft Word to make it easier to learn for students with disabilities. 
Word 2010 is software for word processing. In the new Microsoft 2010 Office Suite. Word allows you to easily create professional-
looking documents using various themes, visual designs, formatting tools, sharing features and more. 
 

Microsoft Word is a word processor and was previously considered the main program in Office. Its proprietary DOC format is 
considered a de facto standard, although Word 2007 can also use a new XML-based, Microsoft Office-optimized format called 
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.DOCX, which has been controversially standardized by Ecma International as Office Open XML and its SP2 update 
supports PDF and a limited ODF. Word is also available in some editions of Microsoft Works. It is available for the Windows and Mac 
platforms. The first version of Word, released in the autumn of 1983, was for the MS-DOS operating system and had the distinction of 
introducing the mouse to a broad population. Word 1.0 could be purchased with a bundled mouse, though none was required. 
Following the precedents of LisaWrite and MacWrite, Word for Macintosh attempted to add closer WYSIWYG features into its 
package. Word for Mac was released in 1985. Word for Mac was the first graphical version of Microsoft Word. Despite its bugginess, 
it became one of the most popular Mac applications. 
 
New features in Word 2010 
 
Microsoft Word is a word processing software package. You can use it to type letters, reports, and other documents. It helps a lot in 
spelling-check and words-count. 
1.    Create visually compelling documents 

With Word 2010, you can create compelling documents while applying formatting effects such as shadow, bevel, glow, and 
reflection to your document text. You can spell-check text that uses visual effects, and add text effects to paragraph styles. Many 
of the same effects used for images are now available to both text and shapes, enabling you to seamlessly coordinate all of your 
content. 

 2.   Turn your text into compelling diagrams 
Word 2010 offers you more options to add visual impact to your documents. Choose from dozens of additional SmartArt® 
Graphics to build impressive diagrams just by typing a bulleted list. Use SmartArt to transform basic, bullet-point text into 
compelling visuals that better illustrate your ideas. 

 3.   Add visual impact to your document 
New picture-editing tools in Word 2010 enable you to add special picture effects without additional photo-editing software. You 
can easily adjust pictures with color saturation and temperature controls. You also get improved tools for easier and more precise 
cropping and image correction, to help you turn a simple document into a work of art. 

 
Getting to Know Word 2010 
 
Word 2010 is a bit different from earlier versions, so even if you've used Word before, you should take some time to familiarize 
yourself with the interface. The toolbars are similar to those in Word 2007, and they include the Ribbon and the Quick Access Toolbar. 
Unlike Word 2007, commands such as Open and Print are housed in Backstage view, which replaces the Microsoft Office Button. 
 
The Ribbon 
 
The new, tabbed Ribbon system was introduced in Word 2007 to replace traditional menus. The Ribbon contains all of the commands 
you'll need in order to do common tasks. It contains multiple tabs, each with several groups of commands, and you can add your own 
tabs that contain your favorite commands. Some groups have an arrow in the bottom-right corner that you can click to see even more 
commands. 
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To Minimize and Maximize the Ribbon: 
 
The Ribbon is designed to be responsive to your current task and easy to use; however, 
you can choose to minimize it if it's taking up too much screen space. 
 

1. Click the arrow in the upper-right corner of the Ribbon to minimize it. 
2. To maximize the Ribbon, click the arrow again. 

 
When the Ribbon is minimized, you can make it reappear by clicking on a tab. However, 
the Ribbon will disappear again when you're not using it. 
 

 

To Customize the Ribbon: 
  
You can customize the Ribbon by creating your own tabs with 
whichever commands you want. Commands are always housed 
within a group, and you can create as many groups as you want in 
order to keep your tab organized. If you want, you can even add 
commands to any of the default tabs, as long as you create a custom 
group in the tab. 
 

1. Right-click the Ribbon and select Customize the Ribbon. A 
dialog box will appear. 

2. Click New Tab. A new tab will be created with a new group 
inside it. 

3. Make sure the new group is 
selected. 

4. Select a command from the list 
on the left, then click Add. You 
can also drag commands 
directly into a group.   

5. When you are done adding 
commands, click OK. 

 
If you don't see the command you want, click on the Choose 
commands from: drop-down box and select All Commands. 
 
Backstage View 
 
Backstage view gives you 
various options for saving, 
opening a file, printing, or 
sharing your document. It is 
similar to the Office Button 
Menu from Word 2007 or 
the File Menu from earlier 
versions of Word. However, 
instead of just a menu, it is a 
full-page view which makes it 
easier to work with. 
 
To Get to Backstage View: 
1. Click the File tab. 
2. You can choose an 

option on the left side of 
the page. 

3. To get back to your 
document, just click any 
tab on the Ribbon. 

Click on the buttons to learn 
more about Backstage view 
as shown in following image. 
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The Quick Access Toolbar 
 
The Quick Access Toolbar is located above the ribbon, and it lets you access common 
commands no matter which tab you're on. By default, it shows the Save, Undo, 
and Repeat commands. You can add other commands to make it more convenient for you. 
 
To Add Commands to the Quick Access Toolbar: 
 

1. Click the drop-down arrow to the right of the Quick Access Toolbar. 
2. Select the command you wish to add from the drop-down menu. It will appear in the 

Quick Access toolbar. 
 

The Ruler 
  
The Ruler is located at the top and to the left of your document. It makes it easier to adjust your 
document with precision. If you want, you can hide the Ruler to free up more screen space. 
 
To Hide or View the Ruler: 

1. Click the View Ruler icon over the scrollbar to hide the ruler. 
2. To show the ruler, click the View Ruler icon again. 

 
Creating and Opening Documents 
 
To Create a New, Blank Document: 
 

1. Click the File tab. This takes you to Backstage view. 
2. Select New. 
3. Select Blank document under Available Templates. It will be highlighted by 

default. 
4. Click Create. A new, blank document appears in the Word window. 

 
To save time, you can create your document from a template, which you can select 
from the New Document pane. 
 
To Open an Existing Document: 

 
1. Click the File tab. This takes you to Backstage view. 
2. Select Open. The Open dialog box appears. 
3. Select your document and then click Open. 

 
 

 
If you've opened a file recently, you can also access it from the Recent 
Documents list. Just click on the File tab and select Recent. 
 
 
 

 
To Use the Save As Command: 
  
Save As allows you to choose a name and location for your document. It's 
useful if you've first created a document or if you want to save a different 
version of a document while keeping the original. 

1. Click the File tab. 
2. Select Save As. 
3. The Save As dialog box will appear. Select the location where 

you wish to save the document. 
4. Enter a name for the document and click Save. 

 
If you're using Windows 7, you'll usually want to save things to 
your Documents library, and in other versions of Windows you'll save them 
to the My Documents folder.  
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 To Use the Save Command: 
 

1. Click the Save command on the Quick Access Toolbar. 
2. The document will be saved in its current location with the same file name. 

 
If you are saving for the first time and select Save, the Save As dialog box will appear. 
  
 
 

 
AutoRecover: 
 
Word automatically saves your documents to a temporary folder while you're working on them. If you forget to save your changes, or if 
Word crashes, you can recover the auto saved file. 
 

1. Open a document that was previously closed without saving. 
2. In Backstage view, click Info. 
3. If there are auto saved versions of your file, they will appear under Versions. Click on the file to open it. 
4. To save changes, click Restore and then click OK. 

 
By default, Word autosaves every 10 minutes. If you are editing a document for less than 10 minutes, Word may not create an 
autosaved version.   
 
 
Other File Formats 
 
You can share your documents with anyone using Word 2010 or 2007, since they use the same file format. However, earlier versions 
of Word use a different file format, so if you want to share your document with someone using an earlier version of Word, you'll need 
to save it as a Word 97-2003 Document. 
 
To Save As Word 97 - 2003 Document: 
 

1. Click the File tab. 
2. Select Save As. 
3. In the Save as type drop-down menu, select Word 97-

2003 Document. 
4. Select the location you wish to save the document. 
5. Enter a name for the document and click Save. 

 
 
 
To Save As a PDF: 
 

1. Click the File tab. 
2. Select Save As. 
3. In the Save as type drop-down menu, select PDF. 
4. Select the location you wish to save the document. 
5. Enter a name for the document. 
6. Click the Save button. 

 
 
 
 
 
 
 

 
 

____________________________________ 
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Lesson: 2  
 

 Text Basici 
 
 
It is important to know how to perform basic tasks with text when working in a word processing application. In this lesson you will learn 
the basics of working with text including how to insert, delete, select, copy, cut, paste, and drag and drop text. 
 
To Insert Text: 
 

1. Move your mouse to the location you wish text to appear in the document. 
2. Click the mouse. The insertion point appears. 
3. Type the text you wish to appear. 

 
To Delete Text: 
 

1. Place the insertion point next to the text you wish to delete. 
2. Press the Backspace key on your keyboard to delete text to the left of the insertion point. 
3. Press the Delete key on your keyboard to delete text to the right of the insertion point. 

 
To Select Text: 
 

1. Place the insertion point next to the text 
you wish to select. 

2. Click the mouse, and while holding it down, 
drag your mouse over the text to select it. 

3. Release the mouse button. You have 
selected the text. A highlighted box will 
appear over the selected text. 

 
 

When you select text or images in Word, a hover toolbar with 
formatting options appears. This makes formatting commands 
easily accessible, which may save you time. If the toolbar does 
not appear at first, try moving the mouse over the selection. 

 
 
To Copy and Paste Text: 
 

1. Select the text you wish to copy. 
2. Click the Copy command on the Home tab. You can also right-click your 

document and select Copy. 
3. Place your insertion point where you wish the text to appear. 
4. Click the Paste command on the Home tab. The text will appear. 

 
 
To Cut and Paste Text: 
  

1. Select the text you wish to copy. 
2. Click the Cut command on the Home tab. You can also right-click 

your document and select Cut. 
3. Place your insertion point where you wish the text to appear. 
4. Click the Paste command on the Home tab. The text will appear. 

 
You can also cut, copy, and paste by right-clicking your document and 
choosing the desired action from the drop-down menu. When you use this 
method to paste, you can choose from three options that determine how the 
text will be formatted: Keep Source Formatting, Merge Formatting and Keep 
Text Only. You can hover the mouse over each icon to see what it will look 
like before you click on it. 
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To Drag and Drop Text: 
 

1. Select the text you wish to copy. 
2. Click and drag the text to the location you wish it to appear. The 

cursor will have a rectangle under it to indicate that you are moving 
text. 

3. Release the mouse button and the text will appear. 
 
If text does not appear in the exact location you wish, you can click 
the Enter key on your keyboard to move the text to a new line. 
 
To Find Text: 

 
1. From the Home tab, click 

the Find command. 
The Navigation pane will appear 
on the left side of the screen. 

2. Type the text you wish to find in 
the field at the top of the 
Navigation pane. 

3. If the text is found in the 
document, it will be highlighted in 
yellow, and a preview will appear 
in the Navigation pane. 

4. If the text appears more than once, you can click the arrows on the 
Navigation pane to step through the results. You can also click 
the result previews on the Navigation pane to jump to the location of a 
result in your document. 

5. When you close the Navigation pane, the highlighting will disappear. 
 
To Replace Text: 
 

1. From the Home tab, click the Replace command. 
The Find and Replace dialog box will appear. 

2. Type the text you wish to find in the Find what field. 
3. Type the text you wish to replace it with in 

the Replace with field. 
4. Click Find Next and then Replace to replace text. 

You can also click Replace All to replace all 
instances within the document. 

 
To Change the Font Size: 

 
1. Select the text you wish to modify. 
2. Click the drop-down arrow next to the Font Size box on the Home tab. A drop-

down menu appears. 
3. Move the mouse pointer over the 

various font sizes. A live preview of the 
font size will appear in the document. 

4. Select the font size you wish to use. 
5. You can also use the Grow 

Font and Shrink Font commands to 
change the size. 

 
 
To Change the Font: 
 

1. Select the text you wish to modify. 
2. Click the drop-down arrow next to the Font box on the Home tab. The Font drop-down menu appears. 
3. Move the mouse pointer over the various fonts. A live preview of the font will appear in the document. 
4. Select the font you wish to use. The font will change in the document. 
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To Change the Font Color: 
 

1. Select the text you wish to modify. 
2. Click the Font Color drop-down arrow on the Home tab. 

The Font Color menu appears. 
3. Move the mouse pointer over the various font colors. A 

live preview of the color will appear in the document. 
4. Select the font color you wish to use. The font color will 

change in the document. 
5. Your color choices aren't limited to the drop-down menu 

that appears. Select More Colors at the bottom of the list to 
access the Colors dialog box. Choose the color that you 
want and click OK. 

 
To Highlight Text: 
  

1. From the Home tab, click the Text Highlight Color drop-
down arrow. The Highlight Color menu appears. 

2. Select the desired highlight color. 
3. Select the text you wish to modify. It will then be 

highlighted. 
4. To switch back to the normal cursor, click the Text 

Highlight Color command. 

 
To Use the Bold, Italic, and Underline Commands: 
 

1. Select the text you wish to modify. 
2. Click the Bold (B), Italic (I), or Underline (U) command in the Font group on the 

Home tab. 
 
To Change the Text Case: 
 
1. Select the text you wish 

to modify. 
2. Click the Change 

Case command in 
the Font group on the 
Home tab. 

3. Select the desired case 
option from the list. 

 
 
To Change Text Alignment: 
 

1. Select the text you wish to modify. 
2. Select one of the four alignment options from the Paragraph group on 

the Home tab. 
 Align Text Left: Aligns all the selected text to the left margin. 
 Center: Aligns text an equal distance from the left and right margins. 
 Align Text Right: Aligns all the selected text to the right margin. 
 Justify: Justified text is equal on both sides and lines up equally to the 

right and left margins. Many newspapers and magazines use full-
justification. 

 
 

___________________________________ 
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Lesson: 3  
 

 Modifying Page Layout & Checking Spellingi 
 
 
You may find that the default page layout settings in Word are not sufficient for the document you wish to create, in which case you 
will want to modify those settings. For example, if you are printing on a different paper size, you'll want to change the document page 
size to match the paper. In addition, you may want to change the page formatting depending on the type of document you are 
creating. 
 
To Change Page Orientation: 
 

1. Select the Page Layout tab. 
2. Click the Orientation command in the Page Setup group. 
3. Click either Portrait or Landscape to change the page orientation. 

 
Landscape format means that the page is oriented horizontally, and portrait format is     
oriented vertically. 
 
 
 

 
To Change the Page Size: 
 

1. Select the Page Layout tab. 
2. Click the Size command and a drop-down menu will appear. The current page 

size is highlighted. 
3. Click the size option you desire. The page size of the document changes. 

 
To Format Page Margins: 
 

1. Select the Page Layout tab. 
2. Click the Margins command. A menu of options appears. Normal is selected by 

default. 
3. Click the predefined margin size you desire. 

 
To Use Custom Margins: 
 

1. From the Page Layout tab, click Margins. 
2. Select Custom Margins. This will take you to 

the Page Setup dialog box. 
3. Adjust the margin sizes for each side of the page 

and click OK. 
 
 

 

The Page Setup Dialog Box 
 
Previously, we showed how to open the Page Setup dialog box 
from the Margins drop-down menu. As you become more familiar 
with Word, you may find that you want to use the Page Setup 
dialog box more often to fine-tune the page margins and adjust 
other settings. To get there more quickly, you may want to use 
a shortcut that's conveniently located on the Page Layout tab. 
  
To Open the Page Setup Dialog Box: 
  

1. Click the Page Layout tab. 
2. Click the small arrow in the bottom-right corner of 

the Page Setup group. The Page Setup dialog box will 
appear. 



 
 
 

SARVA EDUCATION (SITED) (Running- An I.T & Skill Advancement Training Programme)                                                                                                                                                            - 60 -                                                                                                                 

                                                                       

 

Visit us at:  www.sarvaindia.com                                                                 Licensed by Govt. of India                                                                       ISO 9001:2015 Certified 

Checking Spelling & Grammar 
 
Worried about making mistakes when you type? Don't be. Word provides you with several proofing features that will help you produce 
professional, error-free documents. In this lesson you will learn about the various proofing features, including the Spelling and 
Grammar tool. 
 
To Run a Spelling & Grammar Check: 

 
1. Go to the Review tab. 
2. Click on the Spelling & Grammar command. 
3. The Spelling and Grammar dialog box will open. For each error in your document, Word 

will try to offer one or more suggestions. You can select a suggestion and then 
click Change to correct the error. 

4. If no suggestions are given, you can manually type in the correct spelling. 
 

 
Ignoring "Errors" 
 
The spelling and grammar check is not always correct. Particularly with grammar, there are many errors that Word will not notice. 
There are also times where the spelling and grammar check will say that something's an error when it's actually not. This often 
happens with people's names, which may not be in the dictionary. 
If Word says that something is an error, you can choose not to change it. Depending on whether it's a spelling or grammar error, you 
can choose from several options: 
 
For spelling "errors": 

 Ignore Once: This will skip the word without changing it. 
 Ignore All: This will skip the word without changing it, and it will also skip all other instances of this word in the document. 
 Add to Dictionary: This adds the word to the dictionary so that it will never come up as an error. Make sure that the word is 

spelled correctly before choosing this option. 
 
For grammar "errors": 

 Ignore Once: This will skip the "error" without changing it. 
 Ignore Rule: This will skip this "error" as well as all other instances that relate to this grammar rule. 
 Next Sentence: This skips the sentence without changing it, and leaves it marked as an error. That means it will still show 

up if you do another Spelling and Grammar check later on. 
If you're not sure about a grammar error, you can click Explain to see why Word thinks it's an error. This can help you 
determine whether you want to change it or not. 
 

Automatic Spelling and Grammar Checking 
 
By default, Word automatically checks your document 
for spelling and grammar errors, so you may not even need 
to run a separate Spelling and Grammar check. These errors 
are indicated by colored, wavy lines. 

 The red line indicates a misspelled word. 
 The green line indicates a grammar error. 
 The blue line indicates a contextual spelling error. 

This feature is turned off by default. 
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To Use the Spelling Check Feature: 
1. Right-click the underlined word. A menu will appear. 
2. Click on the correct spelling of the word from the listed suggestions. 
3. The corrected word will appear in the document. 

You can choose to ignore an underlined word, add it to the dictionary, or go to the Spelling dialog box for more options. 
 
To Use the Grammar Check Feature: 

1. Right-click the underlined word or phrase. A menu will appear. 
2. Click on the correct phrase from the listed suggestions. 
3. The corrected phrase will appear in the document. 

You can also choose to ignore an underlined phrase, go to the Grammar dialog box, or click About This Sentence for 
information about the grammar rule. 

 
To Change the Automatic Spelling and Grammar Check Settings: 

1. From Backstage view, click on Options. 
2. Select Proofing. The dialog box gives you several options to choose from: 

 If you don't want Word to automatically check spelling, uncheck Check spelling as you type. 
 If you don't want grammar errors to be marked, uncheck Mark grammar errors as you type. 
 To check for contextual spelling errors, check Use contextual spelling. 

 
If you've turned off the automatic spelling and/or grammar checks, you can still run a check by going to the Review tab and 
clicking the Spelling & Grammar button. 

 
To Hide Spelling and Grammar Errors in a Document: 
If you're sharing a document such as a resume with someone, you might not want them to see those annoying red, green, and blue 
lines. Turning off the automatic spelling and grammar checks only applies to your computer, so the lines may still show up when 
someone else views your document. Luckily, you can hide spelling and grammar errors in a document so that the lines will not show 
up on any computer. 

1. From Backstage view, click on Options. 
2. Select Proofing. 
3. In the drop-down box next to "Exceptions for:" select the correct document (if you have more than one document open). 
4. Put a checkmark next to Hide spelling errors in this document only and Hide grammar errors in this document only. 
5. Click OK. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

_______________________________ 
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Lesson: 4  
 

 Using Indents, Tab, Line & Paragraph Spacingi 
 
 
There are several ways in Word that you can indent text; however, it’s important to use these tools appropriately in order to indent 
correctly each time. This helps the editing process go smoothly, thus saving you time.  
 
In this lesson, you will learn how to use the tab selector and the horizontal ruler to set tabs and indents, and how to use 
the Increase and Decrease Indent commands. 
 
Indenting Text 
 
In many types of documents, you may wish to indent only the first line of each paragraph. This helps to visually 
separate paragraphs from one another. It's also possible to indent every line except the first line, which is known as a hanging 
indent. 

 
 

 
 
 
 
 
 
 
 
 

                                                         
 

                                          First Line Indent                                                                                                                       Hanging Indent 
  
To Indent Using the Tab Key: 
 
A quick way to indent is to use the Tab key. This will create a first line indent of 
1/2 inch. 
 

1. Place the insertion point at the very beginning of the paragraph you 
wish to indent. 

2.  Press the Tab key. You should see the First Line Indent 
marker move to the right by 1/2 inch. 

 
To Create or Adjust a First Line Indent or Hanging Indent: 
 

1. Place the insertion point anywhere in the paragraph you wish to indent, or 
select one or more paragraphs. 

2. To adjust the first line indent, drag the First Line Indent marker on the 
ruler. 

3. To adjust the hanging indent, drag the Hanging Indent marker. 
4. To move both markers at the same time, drag the Left Indent marker. This 

will indent all of the lines in the paragraph. 
 

To Use the Indent Commands: 
 

If you want to indent all of the lines in a paragraph, you can use the Indent 
commands on the Home tab. 

1. Select the text you wish to indent. 
2. Make sure you are on the Home tab. 
3. Click the Increase Indent command to increase the indent by increments 

of 1/4 inch. 
4. Click the Decrease Indent command to decrease the indent by increments 

of 1/2 inch. 
 

If you would prefer to type in your indent amounts, you can use the Indent fields on the Page Layout tab. 
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Tabs 
 
Using tabs is often the best way to control exactly 
where text is placed. By default, every time you press 
the tab key, the insertion point will move 1/2 inch to 
the right. By adding tab stops to the Ruler, you can 
change the size of the tabs, and you can even have 
more than one type of alignment in a single line. For 
example, you could Left Align the beginning of the 
line and Right Align the end of the line by simply 
adding a Right Tab. 
 
Pressing the tab key can either add a tab or create 
a first line indent depending on where the insertion 
point is. Generally, if the insertion point is at the 
beginning of an existing paragraph, it will create a first 
line indent; otherwise, it will create a tab. 
 
The Tab Selector 

 
The tab selector is above the vertical ruler on the left. Hover over the tab selector to see the 
name of the type of tab stop that is active. 
 
The types of tab stops include: 

 Left Tab : Left-aligns the text at the tab stop. 
 Center Tab : Centers the text around the tab stop. 
 Right Tab : Right-aligns the text at the tab stop. 
 Decimal Tab : Aligns decimal numbers using the decimal point. 
 Bar Tab : Draws a vertical line on the document. 
 First Line Indent : Inserts the indent marker on the ruler and indents the first line of 

text in a paragraph. 
 Hanging Indent : Inserts the hanging indent marker and indents all lines other than the 

first line. 
Although Bar Tab, First Line Indent, and Hanging Indent appear on the tab selector, they're not technically tabs. 
 
To Add Tab Stops: 
 

1. Select the paragraph or paragraphs that you want to add tab stops 
to. If you don't select any paragraphs, the tab stops will apply to 
the current paragraph and any new paragraphs that you type 
below it. 

2. Click the tab selector until the tab stop you wish to use appears. 
3. Click the location on the horizontal ruler where you want your 

text to appear (it helps to click on the bottom edge of the ruler). 
You can add as many tab stops as you want. 

4. Place the insertion point where you want to add the tab, and 
press the Tab key. The text will jump to the next tab stop. 

5. To remove a tab stop, just drag it off of the Ruler. 
  

 

 
Click the Show/Hide 

¶ command on the Home tab 
(in the Paragraph group). This 
will allow you to see the 
nonprinting characters such 
as: the spacebar, paragraph 
(¶), and Tab key markings. 
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Line Spacing 
 
Line spacing can either be measured in lines or points. For example, when text is double-spaced, the line spacing is two 
lines high. On the other hand, you might set 12-point text with something 
like 15-point spacing, which gives enough height for the text plus a little extra 
space. You can reduce the line spacing to fit more lines on the page, or you 
can increase it to improve readability. Line spacing is also known 
as leading (pronounced to rhyme with "wedding"). 
  
To Format Line Spacing: 

 
1. Select the text you want to 

format. 
2. Click the Line and Paragraph 

Spacing command in 
the Paragraph group on 
the Home tab. 

3. Select the desired spacing 
option from the drop-down 
menu. 

4. From the drop-down menu, you 
can also select Line Spacing 
Options to open 
the Paragraph dialog box. From 
here, you can adjust the line 
spacing with even more 
precision. 

 
If you select At least or Exactly in the Paragraph dialog box, the line spacing will be measured in points. Otherwise, it will be 
measured in lines. 
 
Paragraph Spacing 
 
Just as you can format spacing between lines in your document, you 
can also choose spacing options between each paragraph. Typically, 
extra spaces are added between paragraphs, headings, or 
subheadings. Extra spacing between paragraphs helps to make a 
document easier to read. 
 
To Format Paragraph Spacing: 
 

1. Click the Line and Paragraph Spacing command on the 
Home tab. 

2. Select Add Space Before Paragraph or Remove Space 
After Paragraph from the drop-down menu. 

3. From the drop-down menu, you can also select Line Spacing 
Options to open the Paragraph dialog box. From here, you 
can control exactly how much space there 
is before and after the paragraph. 

 
 
 
 
 
 
 
 
 

__________________________________ 
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Lesson: 5  
 

 Working with List, Adding Breaks, Column & Hyperlinksi 
 
 
Bulleted and numbered lists can be used in your documents to format, arrange and 
emphasize text. In this lesson, you will learn how to modify existing bullets, insert 
new bulleted and numbered lists, select symbols as bullets, and format multilevel lists. 
 
To Create a List: 
 

1. Select the text that you want to format as a list. 
2. Click the Bullets or Numbering drop-down arrow on the Home tab. 
3. Select the bullet or numbering style you would like to use, and it will appear 

in the document. 
4. To remove numbers or bullets from a list, select the list and click 

the Bullets or Numbering commands. 
 
When you're editing a list, you can press Enter to start a new line, and the new line 
will automatically have a bullet or number. When you've reached the end of your 
list, press Enter twice to return to "normal" formatting. 

 
Bullet Options 
 
To Use a Symbol as a Bullet: 

 
1. Select an existing list. 
2. Click the Bullets drop-down arrow. 
3. Select Define New Bullet from the drop-

down menu. The Define New Bullet dialog 
box appears. 

4. Click the Symbol button. The Symbol dialog 
box appears. 

5. Click the Font drop-down box and select a 
font. The Wingdings and Symbol fonts are 
good choices as they have a large number 
of useful symbols. 

6. Select the desired symbol. 
7. Click OK. The symbol will now appear in the Preview section 

of the Define New Bullet dialog box. 
8. Click OK to apply the symbol to the list in the document. 

 
 
You can use a picture as a bullet. Click the Picture button in the Define New Bullet dialog box, and 
then locate the image file on your computer. 

 
To Change the Bullet Color: 

 
1. Select an existing list. 
2. Click the Bullets drop-down arrow. 
3. Select Define New Bullet from the list. The Define New Bullet dialog box 

appears. 
4. Click the Font button. The Font dialog box appears. 
5. Click the Font Color drop-down box. 
6. Choosing a bullet color 
7. Click on the desired color to select it. 
8. Click OK. The bullet color will now appear in the Preview section of the 

Define New Bullet dialog box. 
9. Click OK to apply the bullet color to the list in the document. 
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Multilevel Lists 
 
Multilevel lists allow you to create an outline with multiple levels. In fact, you can turn any bulleted or numbered list into a multilevel list 
by simply placing the insertion point at the beginning of a line and pressing the Tab key to change 
the level for that line. You can then use the Multilevel List command to choose the types of bullets 
or numbering that are used.  
 
To Create a Multilevel List: 
 

1. Select the text that you want to format as a multilevel list. 
2. Click the Multilevel List command on the Home tab. 
3. Click the bullet or numbering style you would like to use. It will appear in the 

document.  
4. Position your cursor at the end of a list item and press the Enter key to add an item to 

the list. 
 
To remove numbers or bullets from a list, select the list and click 
the Bullets or Numbering commands 
 
To Change the Level of a Line: 
 

1. Place the insertion point at the beginning of the line. 
2. Press the Tab key to increase the level. 
3. Hold Shift and press Tab to decrease the level. 

 
Adding Breaks 
 
Word has several different types of breaks that you can add to your document to change the layout and pagination. Each type of 
break serves a different purpose and will affect the document in 
different ways. Page breaks move text to a new page before 
reaching the end of a page, while section breaks create a 
barrier between parts of the document for formatting 
purposes. Column breaks split text in columns at a specific 
point. In this lesson, you'll learn how to insert and delete breaks. 
 
Breaks allow you to have more control over the layout of your 
document. You might use a page break if you're writing a paper 
that has a bibliography to ensure that the bibliography starts on 
a new page. Or, you might use a column break if you are using 
columns and want them to be arranged in a particular way. 
 
To Insert a Break: 

1. Place the insertion point where you want 
the break to appear. 

2. Select the Page Layout tab. 
3. Click the Breaks command. A menu appears. 
4. Click the desired break option to create a break in 

the document. 
  
To Delete a Break: 
Breaks are hidden by default. If you want to delete a break, then 
you'll probably want Word to show the breaks so you can find them for editing. 
 

1. From the Home tab, click the Show/Hide ¶ command. 
2. Double-click the break to select it. 
3. Press the Backspace or Delete key to delete the break. 

 
Working with Columns 
 
Columns are used in many types of documents, but are most commonly used in newspapers, magazines, academic journals, and 
newsletters. In this lesson you will learn how to insert columns into a document and create column breaks. 
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To Add Columns to a Document: 
 

1. Select the text you want to format. 
2. Click the Page Layout tab. 
3. Click the Columns command. A drop-down menu will appear. 
4. Select the number of columns you would like to insert. 

 
If you want to get rid of the columns, just click the Columns command and select One for the 
number of columns. 
 
To Add Column Breaks: 
 

1. Place the insertion point where you would like to add the break. 
2. Click the Page Layout tab. 
3. Click the Breaks command in the Page Setup group. A drop-down menu will 

appear. 
4. Select Column from the list of break types. 
5. The text will shift to reflect the column break. 

 
Working with Hyperlinks 
 
Whenever you use the Web, you are using hyperlinks to navigate from one web page to another. Sometimes, a hyperlink will link to a 
different section of the same page. If you want to include a web address or email address in your Word document, you can format it 
as a hyperlink for a person to click on.  
 
Hyperlinks have two basic parts: the address of the web 
page, email address, or other location that they are linking to, 
and the display text (or image). For example, the address could 
be http://blog.gcflearnfree.org, and the display text could 
be "blog". In some cases, the display text might be the same as 
the address. When you're creating a hyperlink in Word, you'll be 
able to choose both the address and the display text or image. 
To follow a hyperlink in Word, hold down the Control key and 
click on the hyperlink. 
 
To Insert a Hyperlink: 
 

1. Select the text or image you would like to make a 
hyperlink. 

2. Right-click the selected text or image and 
click Hyperlink. Or, if you would prefer, you can right-
click in a blank area of the document and 
click Hyperlink. 
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3. The Insert Hyperlink dialog box will open. You can also get to this dialog box from 
the Insert tab by clicking Hyperlink. 

4. If you selected text, the words will appear in the Text to display: field at the top. You can 
change this text if you want. 

5. Type the address you would like to link to in the Address: field. 
6. Click OK. The text or image you selected will now be a hyperlink. 
 

You can also insert a hyperlink that links to another portion of the same document by selecting Place in This Document from the Insert 
Hyperlink dialog box. 
  
To Make an Email Address a Hyperlink: 
 

1. Right-click the selected text or image and click Hyperlink. 
2. The Insert Hyperlink dialog box will open. 
3. On the left side of the dialog box, click Email Address. 
4. Type the email address you want to connect to in the Email Address box and click OK. 

 
Word often recognizes email and web addresses as you type and will format them as hyperlinks automatically after you press 
the Enter key or spacebar. 
  
To Remove a Hyperlink: 
 

1. Right-click the hyperlink. 
2. Click Remove Hyperlink. 

 
After you create a hyperlink, you should test it. If you have linked to a web site, your web browser should automatically open and 
display the site. If it doesn't work, check the hyperlink address for misspellings. 
 
 
 
 

 
 
 
 
 

__________________________________________ 
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Lesson: 6  

 
 Working with Shapes, Text Boxes & Word Art i 

 
You can add a variety of shapes to your document including arrows, callouts, squares, stars, flowchart shapes and more. Want to set 
your name and address apart from the rest of your resume? Use a line. Need to create a diagram showing a timeline or process? Use 
the flowchart shapes. While you may not need shapes in every document you create, they can add visual appeal and clarity. In this 
lesson you will learn how to insert a shape and format it by changing its fill color, outline color, shape style, and shadow effects. 
Additionally, you will learn how to apply 3-D effects to shapes. 
 
To Insert a Shape: 

 
1. Select the Insert tab. 
2. Click the Shapes command. 
3. Select a shape from the drop-down menu. 
4. Click and drag the mouse until the shape is 

the desired size. 
5. Release the mouse button. 

 
To Resize a Shape: 
 

1. Click on the shape to select it. 
2. Click and drag one of the sizing handles on 

the corners and sides of the text box until it is 
the desired size. 

 
 

 
Resizing the shape 
 

1. To rotate the shape, drag the green handle. 
2. Some shapes also have one or more yellow handles that can be used to modify 

the shape. For example, with star shapes, you can adjust the length of the 
points. 

 
If you drag the sizing handles on any of the four corners, you will be able to change 
the height and width at the same time. The sizing handles on the top or bottom of the 
shape will only allow you to resize vertically, while the handles on the left and right sides 
will resize the shape horizontally. 

 
To Change the Order of Shapes: 
 
If one shape overlaps another, you may need to change the ordering so 
that the correct shape appears in front. You can bring a shape to 
the front or send it to the back. If you have multiple images, you can 
use Bring Forward or Send Backward to fine-tune the ordering. You 
can also move a shape in front of or behind text. 
 

1. Right-click the shape you wish to move. 
2. In the menu that appears, hover over Bring to Front or Send 

to Back. Several ordering options will appear. 
3. Select the desired ordering option. The shapes will reorder 

themselves. 
 

In some cases, the ordering option you select will not affect the ordering 
of the shapes. If that happens, select the same option again or try a 
different option. 
 
 
To Change to a Different Shape: 
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1. Select the shape. A new Format tab appears with Drawing Tools. 

 
2. Click on the Format tab. 
3. Click the Edit Shape command. 
4. Click Change Shape to display a drop-down list. 
5. Select the desired shape from the list. 

 

To Change Shape Style: 
 

1. Select the shape. The Format tab appears. 
2. Click the More drop-down arrow in the Shape Styles group to display more style 

options. 
3. Move your cursor over the styles to see a live preview of the style in your 

document. 

4. Select the desired style. 
 

To Change the Shape Fill Color: 
 

1. Select the shape. The Format tab appears. 
2. Select the Format tab. 
3. Click the Shape Fill command to display a drop-down list. 
 
Select the desired color from the list, choose No Fill, or choose More Fill Colors to 
choose a custom color. 

 
To Change the Shape Outline: 
 

1. Select the shape. The Format tab appears. 
2. Click the Format tab. 
3. Click the Shape Outline command to display a drop-down menu. 
4. From the drop-down menu, you can change the outline color, weight (thickness), 

and whether or not it is a dashed line. 
 
To Change Shadow Effects: 
 

1. Select the Format tab. 
2. Click the Shape Effects command. A drop-

down menu will appear. 
3. Hover the mouse over Shadow. You will 

see a list of shadow presets. 
4. Move your mouse over the menu options to 

see a live preview of the shadow effect in your document. 

5. Click the desired shadow effect to add it to your shape. 
 

You can select Shadow Options from the drop-down menu and click the Color button to 
select a different shadow color for your shape. 
 

 
3-D Effects 
 

There are two kinds of effects that you can apply to your shapes to give them a 3-D appearance: 3-D Rotation and Bevel. 3-D 
Rotation gives the appearance that you are viewing the object from a different angle, and it can be applied to any shape. Bevel adds 
thickness and a rounded edge to shapes, but it doesn't work with every type of shape. 
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To Use 3-D Rotation: 
 

1. Select the shape. 
2. Click on the Format tab. 
3. Click Shape Effects from the Shape Styles group. 
4. Hover the mouse over 3-D Rotation. A drop-down menu will 

appear. 
5. Select the desired rotation preset from the drop-down menu. 

You can also click 3-D Rotation Options if you would prefer 
to type in custom values. 

   
To Use Bevel: 
 

1. Select the shape. 
2. Click on the Format tab. 
3. Click Shape Effects from the Shape Styles group. 
4. Hover the mouse over Bevel. A drop-down menu will appear. 
5. Select the desired bevel preset from the drop-down menu. 

You can also click 3-D Options if you would prefer to type in 
custom values. 

 
If you click on 3-D Options, you'll also be able to change the shape's material to give it a metal, plastic, or translucent appearance, 
and you can choose the lighting type to change how the shape is illuminated. 

 
Text Boxes and WordArt 
 
You may want to insert a text box into your document to draw attention to specific text or to have the ability to easily move text around 
within a document. Text boxes are basically treated the same as shapes, so you can add the same types of effects to them, and you 
can even change their shape. If you want, you can format the text inside the text box as WordArt, allowing you to apply 3-D 
effects and transformations to the text itself. 
 
To Insert a Text box: 

 
1. Select the Insert tab on the Ribbon. 
2. Click the Text Box command in the Text group. A drop-down menu will 

appear. 
3. Select Draw Text Box. 

 
Creating a blank text box 
 

1. Click and drag on the document to create 
the text box. 

2. You can now start typing to create text 
inside the text box. 

From the drop-down menu, you can also select  
one of the built-in text boxes that have pre-defined 
colors, fonts, positions and sizes. If you choose this 
option, the text box will appear automatically, so you will not need to click and drag to 
draw it. 
 
 

 
 

 
To Move a Text Box: 
 

1. Click on the text box. 
2. Hover the mouse over one of the edges of the text box. The mouse pointer becomes a cross 

with arrows on each end and looks like this:  
3. Click and drag the text box to the desired location on the page. 
4. Moving a text box 
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To Resize a Text Box: 
 

1. Click the text box. 
2. Click and drag one of the sizing handles on the corners or sides of the text box until it is the 

desired size. 
 

If you drag the sizing handles on any of the four corners, you will be able to change 
the height and width at the same time. The sizing handles on the top or bottom of the text box will 
only allow you to resize vertically, while the handles on the left and right sides will resize the text 
box horizontally. 

 
To Change the Text Box Shape: 
 

 
1. Select the text box. A new Format tab appears with Drawing 

Tools. 
2. Go to the Format tab. 
3. Click the Edit Shape command 
4. Click Change Shape to display a drop-down list. 
5. Select the desired shape from the list. 

 
To Choose a Shape Style: 
 
Choosing a Shape Style allows you to apply a preset fill and outline color, 
and in some cases, other effects such as beveling and shadow. You don't 
have to pick a style for your text box, but it can help you save time or 
experiment with different appearances. 
 

1. Select the text box. The Format tab appears. 
2. Select the Format tab. 
3. Click the More drop-down arrow in the Shape Styles group to 

display more style options. 
4. Hover the mouse over the styles to see a live preview. 

5. Select the desired style. 

To Change Shape Fill: 
 

1. Select the text box. The Format tab appears. 
2. Click the Format tab. 
3. Click the Shape Fill command to display a drop-down menu. 
4. From the drop-down menu, you can select a color from the list, choose No Fill, or select More Fill Colors to use a color 

that's not on the list. 
 
To Change the Shape Outline: 
 

1. Select the text box. The Format tab appears. 
2. Click the Shape Outline command to display a drop-down list. 
3. Select a color from the list, choose No Outline, or select More Outline Colors to use a color that's not on the list. 
4. From the drop-down menu, you can change the outline color, weight (thickness), and whether or not it is a dashed line. 

 
To Change Shadow Effects: 
 

1. Select the text box. The Format tab appears. 
2. Select the Format tab. 
3. Click the Shape Effects command. 
4. Click Shadow. 
5. Move your mouse over the menu options to see a live preview in your document. 

6. Click the desired option to select the shadow effect. 

 
To choose a different shadow color for your shape, select Shadow Options from the drop-down menu and click 
the Color button. 
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3-D Effects 

Just like other types of shapes, text boxes can have 3-D Effects. There are two kinds of effects that you can apply to your shapes to 
give them a 3-D appearance: 3-D Rotation and Bevel. 3-D Rotation gives the appearance that you are viewing the object from a 
different angle, and it can be applied to any shape. Bevel adds thickness and a rounded edge to shapes; however it doesn't work with 
every type of shape. 

To Use 3-D Rotation: 
 

1. Select the text box. 

2. Click on the Format tab. 
3. Click Shape Effects from the Shape Styles group. 
4. Hover the mouse over 3-D Rotation. A drop-down menu will appear. 
5. Select the desired rotation preset from the drop-down menu. You 

can also click 3-D Rotation Options if you would prefer to type in 
custom values. 

 
To Use Bevel: 
 

1. Select the text box. 

2. Click on the Format tab. 
3. Click Shape Effects from the Shape Styles group. 
4. Hover the mouse over Bevel. A drop-down menu will appear. 
5. Select the desired bevel preset from the drop-down menu. You can 

also click 3-D Options if you would prefer to type in custom values. 
If you click on 3-D Options, you'll also be able to change the 
shape's Material to give it a metal, plastic, or translucent appearance, 
and you can choose the Lighting type to change how the shape is 
illuminated. 

Creating WordArt 
 
In addition to adding effects to a text box, you can also add effects 
to the text inside the text box, which is known as WordArt. For 
the most part, the types of effects you can add are the same as 
the ones you can add to shapes or text boxes (shadow, bevel, 
etc.). However, you can also Transform the text to give it a wavy, 
slanted, or inflated look. 
 
To Apply a Quick Style to Text: 
 
A Quick Style will automatically apply several effects to your text 
at once. You can then refine the look of your text by adding or 
modifying text effects. 
 

1. Select the text box, or select some text inside of the text 
box. The Format tab will appear. 

2. Click the Format tab. 
3. Click the Quick Styles command in the WordArt 

Styles group. A drop-down menu will appear. 
4. Select the desired style preset to apply the style to your 

text. 

After you have applied a Quick Style, you can still modify 
the font or font color from the Home tab if desired. 

To Convert Regular Text into WordArt: 
 
For text to be formatted as WordArt, it needs to be inside a text box. However, there is a shortcut that allows you to convert text into 
WordArt even if it's not in a text box. 
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1. Select the text you wish to convert. 
2. Click the Insert tab. 
3. Click the WordArt command. The Quick Styles drop-down menu 

will appear. 
4. Select the desired Quick Style. 
5. Word will automatically create a text box for your text and apply the 

style to the text. 

Some effects, such 
as shadows, can be 
added from the Text 
Effects menu in 
the Home tab. When you 
add effects in this way, it 
will not place the text in a 
text box. 

 
 

 
 
To Add or Modify Text Effects: 
 

1. Select the text box, or select some text inside of the text 
box. The Format tab will appear. 

2. Click the Format tab. 
3. Click the Text Effects command in the WordArt 

Styles group. A drop-down menu will appear showing 
the different effect categories. 

4. Hover over an effect category. A drop-down menu will 
appear. You can hover the mouse over the different 
presets to see a live preview. 

5. Select the desired effect preset. The effect will be 
applied to your text. If you want, you can combine 
several different effects. 

 
 

 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 

_______________________________ 
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Lesson: 7  
 

 Working with ClipArt & Picture i 
 

 
Images are a great way to liven up a document, and Word offers a couple of ways of inserting images. There are built-in Clip 
Art images for just about every topic, so you may be able to find a perfect Clip Art image for your document. If you have a more 
specific image in mind, you can insert a picture from a file. 
 
To Locate Clip Art: 
 

1. Select the Insert tab. 
2. Click the Clip Art command 

in the Illustrations group. 
 
3. The Clip Art options appear 

in the task pane to the right 
of the document. 

4. Enter keywords in 
the Search for: field that are 
related to the image you wish 
to insert. 

5. Click the drop-down arrow in the Results should be: field. 
6. Deselect any types of media you do not wish to see. 

7. If you would like to also search for Clip Art on Office.com, place a 
checkmark next to Include Office.com content. Otherwise, it will just 
search for Clip Art on your computer. 

8. Click Go. 
 
To Insert Clip Art: 
 

1. Review the results from a clip art search. 

2. Place your insertion point in the document where you wish to insert the clip art. 
3. Click an image in the Clip Art pane. It will appear in the document. 

You can also click the drop-down arrow next to the image in the Clip Art pane to view more 
options. 

 To Insert a Picture From a File: 
 

1. Place your insertion point where you want the image to appear. 
2. Select the Insert tab. 
3. Click the Picture command in the Illustrations group. The Insert Picture dialog 

box appears. 
4. Select the desired image file and click Insert to add it to your document. 

 
To resize an image, click and drag one of the corner sizing handles. The image will 
change size while keeping the same proportions. If you want to stretch it horizontally or 
vertically, you can use the side sizing handles. 
 

 
Changing the Text Wrapping Settings 
 
When you insert Clip Art or a picture from a file, you may notice that it's difficult to move it exactly where you want. That's because 
the text wrapping for that image is set to In Line with Text. You'll need to change the text wrapping setting if you want to move the 
image freely, or if you just want the text to wrap around the image in a more natural way. 
 
To Wrap Text Around an Image: 
 

1. Select the image. The Format tab will appear. 
2. Click the Format tab. 
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3. Click the Wrap Text command in the Arrange group. 
4. Select the desired menu option. The text will adjust based on the option you 

have selected. 

5. Move the image around to see how the text wraps for each setting. 

If you can’t get your text to wrap the way you wish, click the Wrap Text command and 
select More Layout Options from the menu. You can make more precise changes in 
the Advanced Layout dialog box that appears. 
 
To Use a Pre-Defined Text Wrapping 
Setting: 
 

1. Click the Position command, to 
the left of the Wrap 
Text command. A drop-down 
menu will appear. 

2. From the drop-down menu, select 
the desired image position. 

 The image will move to the position that you 
have selected, and it will automatically have 
text wrapping applied to it. 
 

 
To Format Pictures 
 
Once you've added pictures to your documents, you can format them in various ways. The picture tools in Word 2010 make it easy to 
incorporate images into your documents and modify those images in interesting ways.  
 
To Crop an Image: 
 

1. Select an image. The Format tab will appear. 
2. Select the Format tab. 
3. Click the Crop command. The black cropping handles 

appear. 
4. Click and drag a handle to crop an image. 
5. Click the Crop command to deselect the crop tool. 
 

Corner handles will allow you to simultaneously crop the image 
horizontally and vertically. 
 
To Crop an Image to a Shape: 
 

1. Select the image. The Format tab will appear. 
2. Select the Format tab. 
3. Click the Crop drop-down 

arrow (below the Crop 
command). A drop-down 
menu will appear. 

4. Select a shape from the 
drop-down menu. 

5. The image will take the 
shape that you have selected. 

You may want to crop the image to the desired size before cropping it to a shape. 
 
To Add a Border to a Picture: 
 

1. Select the picture. 
2. Select the Format tab. 
3. Click the Picture Border command. A drop-down menu will appear. 
4. From the drop-down menu, you can select a color, weight (thickness), and whether or not the line is dashed. 
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To Make Image Corrections: 
 

1. Select the image. The Format tab will appear. 
2. Click the Format tab. 
3. Click the Corrections command. A drop-down menu will appear. 
4. To sharpen or soften the image, hover over the Sharpen and Soften presets. You'll see a live preview of the preset in the 

document. 
5. When you've found a preset you like, click on it to select it. 

6. Click the Corrections command again. 
7. Hover over the Brightness and Contrast presets to see a live preview. 
8. When you've found one you like, click on it to select it. 

You can also select Picture Corrections Options from the drop-down menu to refine the settings. 
 
To Adjust the Color in an Image: 
 

1. Select the image. The Format tab will appear. 
2. Click the Format tab. 
3. Click the Color command. A drop-down menu will appear. 
4. From the drop-down menu, you can choose a preset from each of the three categories: 

 Color Saturation: Controls how vivid the colors are in the image. 
 Color Tone: Controls the "temperature" of the color, from cool to warm. 
 Recolor: Controls the overall color of the image. Use this option to make the image black and white, grayscale, or 

to colorize it with a different color. 
You can also select Picture Color Options from the drop-down menu to refine the settings. 

 
To Apply an Artistic Effect: 
 

1. Select the picture. The Format tab will appear. 
2. Click the Format tab. 
3. Click the Artistic Effects command. A drop-down menu will appear. 
4. Hover over the different presets to see a Live Preview of each one. 

5. When you've found a preset you like, click on it to select it. 

6. To adjust the settings for the effect, click Artistic Effects again and select Artistic Effect Options. 
Many Clip Art images do not allow you apply artistic effects. Generally speaking, the ones that look hand-drawn or painted 
do not work, while photographs do. 

  
To Apply a Picture Style: 

 
1. Select the picture. 

The Format tab will appear. 
2. Select the Format tab. 
3. Click the More drop-down arrow 

to display all the picture styles. 
4. Hover over a picture style to 

display a live preview of the style 
in the document. 

5. Select the desired style. 

6. To refine the picture style, click 
the Picture Effects command to 
see the Effects drop-down menu.  

 
 
Compressing Pictures 
 
You'll need to monitor the file size of your documents that include pictures, especially if you send them via email. Large, high-
resolution pictures can quickly cause your document to become too large, which may make it difficult or impossible to attach to an 
email. In addition, cropped areas of pictures are saved with the document by default, which can add to the file size. Word can reduce 
the file size by compressing pictures, lowering their resolution, and deleting cropped areas. 



 
 
 

SARVA EDUCATION (SITED) (Running- An I.T & Skill Advancement Training Programme)                                                                                                                                                            - 78 -                                                                                                                 

                                                                       

 

Visit us at:  www.sarvaindia.com                                                                 Licensed by Govt. of India                                                                       ISO 9001:2015 Certified 

To Compress a Picture: 
  

1. Select the picture. The Format tab will appear. 
2. Select the Format tab. 
3. Click the Compress Pictures command 

in the Adjust group. A dialog box appears. 
4. Place a checkmark next to Delete 

cropped areas of pictures. You can also 
choose whether to apply the settings 
to this picture only or to all pictures in 
the document. 

5. Choose a Target output. If you are 
emailing your document, you may want to 
select Email, which produces the smallest 
file size. 

6. Click OK. 
 

 

About Background Removal 
 
With Background Removal, Word uses special algorithms to determine which parts of the image 
are the background and then removes those areas from the image. This can give your images a 
cleaner appearance, and if you're printing your document, it can also save ink. 
 
To Remove the Background From an Image: 
 

1. Click on the image. The Format tab will appear. 
2. Click the Format tab. 
3. Click the Remove Background command. 
4. Word will try to guess which part of the image is the background, and it will mark that area 

with a magenta fill. It will also place a box around the image with selection handles. 
 

5. Drag the selection handles until all of the 
foreground is inside the box. After you 
do this, Word may re-adjust the 
background. 

6. At this point, you may need to help 
Word decide which parts of the image 
are foreground and which parts are 
backgrounds. You can do this by 
using the Mark Areas to 
Keep and Mark Areas to 
Remove commands: 
o If Word has marked part of the 

foreground magenta, click Mark 
Areas to Keep and draw a line in 
that region of the image. 

o If part of the background has not 
been marked with magenta, 
click Mark Areas to Remove and 
draw a line in that region of the image. 

 
7. After you add your marks, Word will readjust the image. 

8. When you're satisfied with the image, click Keep Changes. All of the magenta areas will 
be removed from the image. 

9. You can adjust the image at any time by clicking the Remove Background command 
again. 
As with artistic effects, Background Removal will not work with some Clip Art images. 

 
__________________________________________ 
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Lesson: 8  
 

 Working with Style, Themes, Header & Footer i 
 

 
Styles and themes are powerful tools in Word that can help you easily create professional looking documents. A style is a predefined 
combination of font style, color, and size of text that can be applied to selected text. A theme is a set of formatting choices that can be 
applied to an entire document and includes theme colors, fonts, and effects. 
 
To Select a Style: 
 

1. Select the text that you want to format. 

2. In the Style group on the Home tab, hover over each style 
to see a live preview in the document. Click the More drop-
down arrow to see additional styles. 

3. Select the style you desire. Now the selected text 
appears formatted in the style. 

 
Apply a Style Set: 

 
Style Sets include a combination of title, heading, and paragraph styles. Style sets 
allow you to format all the elements of 
your document at once, rather than 
formatting your title and headings 
separately. 
 

1. Click the Change 
Styles command on the Ribbon. A 
drop-down menu will appear. 

2. From the drop-down menu, 
select Style Set. 

3. Select the Style Set you desire and the change will be reflected in the 
entire document. 

 
To Modify a Style: 
 

1. Locate the style you wish to change in the Styles group. 
2. Right-click the style. A drop-down menu will appear. 

3. Click Modify and the Modify Style dialog box appears. 
4. Make the desired changes to the formatting. If you want, you can also 

change the name of the style.   

5. Click OK to apply the modifications to the style. 
 

To Create a New Style: 
 

1. Click the arrow in the bottom-right corner of the Styles group. This opens the Styles task 
pane.   

2. Select the New Style button at the bottom. A 
dialog box will appear. 

3. Enter a name for the style, and set the text 
formatting the way you want.   

4. Click OK, and the new style will appear in the 
task pane. 

 
Themes 
 
What is a Theme? 
 
A theme is a set of colors, fonts and effects that applies to the entire document to give it a consistent, professional look. 
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You've already been using a theme, even if you didn't know it: the default Office theme. Every 
theme, including the Office theme, has its own theme elements: 

 Theme Colors (available from every Color menu) 
 Theme Fonts (available from the Font menu) 
 Shape Styles (available in the Format tab when you click on a shape)   

 
Why Should You Use Theme Elements? 
 
If you're using theme elements, you'll probably find that your document looks pretty good and all 
of the colors work well together, which means you don't have to spend as much time tweaking the document. But there's another 
great reason to use theme elements: When you switch to a different theme, all of those elements will update to reflect the new 
theme. You can drastically change the look of the document in a couple of clicks, and it will usually still look good. 
Remember, the colors and fonts will only update if you're using Theme Fonts or Theme Colors. If you choose one of the Standard 
Colors or any of the Fonts that are not Theme Fonts, then your text will not change when you change the theme. That can be useful 
if you're creating a logo or title that always needs to look the same. 
If you're using built-in styles, you may notice that the fonts for those styles change when you select a different theme. That's because 
all of the built-in styles are based on the Theme Fonts. If you don't want the styles to change, you'll need to create custom styles. 
 
To Change the Theme: 
 

1. Select the Page Layout tab. 
2. Click the Themes command. A drop-down menu will appear. 
3. Hover the mouse over a theme to see a live preview of it. 

4. Select the desired theme.   
 

Customizing a Theme 
 
Suppose you really like the fonts from one theme, but you'd like to experiment with 
different color schemes. That's not a problem: you can mix and match 
the colors, fonts, and effects from different themes to create a unique look for 
your document. If it still doesn't look exactly right, you can customize the Theme 
Colors and Theme Fonts. 
 
To Change the Theme Colors: 
 

1. From the Page Layout tab, click the Theme Colors command. A drop-down menu will appear. 
2. Hover the mouse over the different sets of Theme Colors to see a live preview. 
3. Select the set of Theme Colors you desire, or select Create New Theme Colors to customize each color individually. 

When setting Theme Colors, try to find a part of your document that uses several colors, so that you get the best idea of what the 
color scheme looks like. 
 
To Change the Theme Fonts: 

1. From the Page Layout tab, click the Theme Fonts command. A drop-down menu will appear. 
2. Hover the mouse over the different sets of Theme Fonts to see a live preview. 
3. Select the set of Theme Fonts you desire, or select Create New Theme Fonts to customize each font individually. 

 
To Change the Theme Effects: 

1. From the Page Layout tab, click the Theme Effects command. A drop-down menu will appear. 
2. Hover the mouse over the different sets of Theme Effects to see a live preview. 
3. Select the set of Theme Effects you desire. 

Some themes can add a Picture Fill to shapes, depending on which Shape Styles are used. For example, the 
Paper theme can add a paper-like texture to shapes. Try exploring some of the different Shape Styles after changing the 
theme. 

 
To Save Your Theme: 
 
Once you've found settings that you like, you may want to save the theme so that you can use it in other documents. 

1. From the Page Layout tab, click the Themes command. A drop-down menu will appear. 
2. Select Save Current Theme. 
3. Type a file name for your theme and the click Save. 

Headers and Footers 
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You can make your document look professional and polished by utilizing the header 
and footer sections. The header is a section of the document that appears in the top 
margin, while the footer is a section of the document that appears in the bottom 
margin. Headers and footers generally contain information such as page number, 
date, document name, etc. 
 
To Insert a Header or Footer: 
 

1. Select the Insert tab. 
2. Click either the Header or Footer command. A drop-down menu will 

appear. 
3. From the drop-down menu, select Blank to insert a blank header or footer, 

or choose one of the built-in options. 
4. The Design tab will appear on the Ribbon, and the header or footer will 

appear in the document. 
5. Type the desired information into the header or footer. 

  

6. When you're finished, click Close Header and Footer in the Design tab, or hit the Esc key. 
After you close the header or footer, it will still be visible, but it will be locked. To edit it again, just double-click anywhere on 
the header or footer, and it will become unlocked 

  
To Insert the Date or Time into a Header or Footer: 

 
1. Double-click anywhere on the header or footer to unlock it. The Design tab will appear. 
2. From the Design tab, click the Date & Time command. 
3. Select a date format in the dialog box that appears. 
4. Place a checkmark in the Update Automatically box if you would like it to always reflect the 

current date. Otherwise, it will not change when the document is opened at a later date. 
5. Click OK. The date/time now appears in the document. 
 

 

To Remove Content Controls: 
 
By default, some of the built-in headers and footers have snippets of text that are called Content 
Controls. Content Controls can contain information such as the document title or company name, 
and they allow you to enter that information into a form field. 

 
However, you'll often just want to type a "normal" 
header, without any Content Controls. To do this, 
you'll need to remove any Content Control fields 
from the header or footer. 
1. With the header or footer section active, right-

click the Content Control field you wish to 
remove. A drop-down menu will appear. 

2. Click Remove Content Control. The Content Control field will disappear. 
 

 
Other Header and Footer Options 
 
There are many other header and footer options that you can use to design these sections of your document. You can review the 
Header and Footer Tools Design tab, to view and explore the design options. 
 
To Add Page Numbers to an Existing Header or Footer: 
 

1. Select the header or footer. The Design tab will appear. 
2. Place the insertion point where you want the page number to be. You can place it anywhere except inside a Content 

Control field. 
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3. From the Design tab, select the Page Number command. 
4. Click Current Position and select the desired style. The page number will appear in the document. 

 

 

 
If you've already typed information into your header or footer, it's important to place the page number at the Current 
Position to avoid losing anything. If you select a page number from Top of Page or Bottom of Page, it will delete anything 
that you have already added to the header or footer. 

 
To Insert Page Numbers into a New Header or Footer: 
 

1. From the Insert tab, click Page Number. A drop-down menu will appear. 
2. Select the desired page number style and it will appear in your document. 

 
To Hide the Page Number on the First Page: 
 

In some documents, you may not want the first page to show the page number. You can hide the first page number without 
affecting the rest of the pages. 

 
1. Select the header or footer that contains the page number. 
2. From the Design tab, place a checkmark next to Different First Page. The header and footer will disappear from the first 

page. If you want, you can type something new in the header or footer, and it will only affect the first page. 
 
If you're unable to select Different First Page, it may be because an object within the header or footer is selected. Click in 
an empty area within the header or footer to make sure nothing is selected. 

 
To Format the Page Numbers: 
 

1. Select the header or footer that contains the page number. 
2. From the Design tab, select the Page Number command. 
3. Click Format Page Numbers. 
4. From the dialog box, Select the desired Number format. 
5. Next to Start at, enter the number that you want the page numbers to start with. 

 
If you've created a page number in the side margin, it's still considered part of the header or footer. You won't be able to 
select the page number unless the header or footer is selected. 

 
 
 

 
 
 
 
 
 
 

__________________________________ 
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Lesson: 9  
 

 Working with Tables, SmartArt Graphics & Templatesi 
 

 
Working with Tables 
 
A table is a grid of cells arranged in rows and columns. Tables can be customized and 
are useful for various tasks such as presenting text information and numerical data.  
 
 To Insert a Blank Table: 
 

1. Place your insertion point in the document where you want the table to appear. 

2. Select the Insert tab. 

3. Click the Table command. 
4. Hover your mouse over the diagram squares to select the number 

of columns and rows in the table. 
5. Click your mouse, and the table appears in the document. 

6. You can now place the insertion point anywhere in the table to add text. 

 
To Convert Existing Text to a Table: 

 
1. Select the text you wish to convert. 

2. Select the Insert tab. 
3. Click the Table command. 
4. Select Convert Text to Table from the menu. A dialog 

box will appear. 
5. Choose one of the options in the Separate text 

at: section. This is how Word knows what text to put in 
each column. 

6. Click OK. The text appears in a table. 

 
 
To Add a Row Above an Existing Row: 

 
1. Place the insertion point in a 

row below the location where 
you wish to add a row. 

 

2. Right-click the mouse. A 
menu appears. 

3. Select Insert - Insert Rows 
Above. 

4. A new row appears above the insertion point. 
 
You can also add 
rows below the insertion point. Follow the same steps, but select 
Insert Rows Below from the menu. 
 

 
To Add a Column: 
 

1. Place the insertion point in a column adjacent to the location you wish the new column to appear. 
2. Right-click the mouse. A menu will appear. 

3. Select Insert - Insert Columns to the Left or Insert Columns to the Right. A new column appears. 
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To Delete a Row or Column: 
 

1. Select the row or column. 
2. Right-click your mouse. A menu will appear. 
3. Select Delete Cells. 
4. Select Delete entire row or Delete entire column and click OK. 

 
To Apply a Table Style: 
 

1. Click anywhere on the table. The Design tab 
will appear on the Ribbon. 

2. Select the Design tab and locate the Table 
Styles. 

3. Click the More drop-down arrow to see all of 
the table styles. 

4. Hover the mouse over the various styles to see 
a live preview. 

5. Select the desired style. The table style will appear in the 
document. 

To Change the Table Style Options: 
 
Once you've chosen a table style, you can turn various options on or off to change the appearance of the table. There are six 
options: Header Row, Total Row, Banded Rows, First Column, Last Column, and Banded Columns. 
 

1. Click anywhere on the table. The Design tab will appear. 
2. From the Design tab, check or uncheck the desired options in the Table Style Options group. 

 
Depending on which Table Style you're using, 
certain Table Style Options may have a somewhat 
different effect. You may need to experiment to get the 
exact look you want. 
 
 

 

To Add Borders to a Table: 
 

 
1. Highlight the cells you wish to add a 

border to. 

2. From the Design tab, select the 
desired Line Style, Line Weight, 
and Pen Color. 

 
3. Click the Borders drop-down arrow. 
4. From the drop-down menu, select the 

desired border type. 
5. The border will be added to the selected cells. 

 
Modifying a Table Using the Layout Tab 
 
When you select a table in Word 2010, Design and Layout tabs appear under Table Tools on the ribbon. Using commands on 
the Layout tab, you can make a variety of modifications to the table. 

 
 

 SmartArt Graphicsi 
 

SmartArt allows you to visually communicate information rather than simply using text. Illustrations can really enhance your document, 
and SmartArt makes using graphics especially easy. You will learn how to insert a SmartArt graphic, modify the color and effects, and 
change the organization of the graphic. 
 
To Insert a SmartArt Illustration: 
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1. Place the insertion point in the document where you want the graphic 
to appear. 

2. Select the Insert tab. 
3. Select the SmartArt command 

in the Illustrations group. A 
dialog box appears. 

4. Select a category on the left of 
the dialog box and review the 
SmartArt graphics that appear 
in the center. 

5. Select the desired SmartArt 
graphic and click OK. 

To see more details about a graphic, 
click on any image, and a larger 
preview of the graphic with additional 
text details will appear on the right side of the dialog box. 
  

 

To Add Text to a SmartArt Graphic: 
 

1. Select the graphic. A border will appear around it with an arrow on the left 
side. 

2. Click the arrow on the left side of the graphic to open the task pane. 
3. Enter text next to each bullet in the task pane. The information will appear in 

the graphic, and will resize to fit inside the shape. 

4. To add a new shape, press Enter. A new bullet will appear in the task pane, 
and a new shape will appear in the graphic. 

You can also add text by clicking on the desired shape and then typing your text. This 
works well if you only need to add text to a few shapes. However, for more complex 
SmartArt graphics, working in the task pane is often faster. 
You can change the layout of a SmartArt graphic even after you've added text. However, 

if the new layout is very different from the old one, some of your text may not show up. Experiment with different layouts to 
see how they display your text differently. 

 
To Add a Shape to a Graphic: 
 

1. Select the graphic. The Design and Format tabs appear on the 
Ribbon. 

2. Select the Design tab. 
3. Click the Add Shape command in the Graphics group. 
4. Decide where you want the new shape to appear and select 

one of the shapes nearby the desired location. 
5. Select Add Shape Before or Add Shape After. If we wanted to 

add a superior or a subordinate, we could select the Add 
Shape Above or Add Shape Below options. 

 
You can change the layout of a SmartArt graphic even after you've added 
text. However, if the new layout is very different from the old one, some of 
your text may not show up. Experiment with different layouts to see how 
they display your text differently. 
 
To Move Shapes Using the Promote or Demote Commands: 
 

1. Select the graphic. The Design and Format tabs appear on the Ribbon. 
2. Select the Design tab. 
3. Select the shape you would like to move. 
4. Click the Promote or Demote commands in the Create Graphic group. 
5. The shape will move up one level. 
 

You can also demote and promote shapes from within the task pane. With the insertion point in the task pane, press the Tab key to 
demote a shape. Press the Backspace key (or Shift-Tab) to promote a shape. It's a lot like creating an outline with a multilevel list.  
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To Change the SmartArt Style: 
 

1. Select the graphic. The Design and Format tabs appear on the 
Ribbon. 

2. Click the Design tab. 
3. In the SmartArt Styles group, click the More drop-down arrow to 

view all of the styles. 
4. Hover the mouse over each style to see a live preview. 

5. Select the desired style. 

 
To Change the Color Scheme: 
 

Word provides a variety of color schemes to use with SmartArt. The color schemes use Theme Colors, so they will vary 
depending on which Theme you are using. 

1. Select the graphic. The Design and Format tabs appear on the Ribbon. 
2. Select the Design tab. 
3. Click the Change Colors command. A drop-down menu appears showing various color schemes. 
4. Select the desired color scheme. 

If you want to change the appearance of a single shape within the SmartArt graphic, select the shape and click 
the Format tab. You can then modify the Shape Style, color, effects or other settings for that shape. 

 

 
 Using a Templatei 

 
A template is a pre-designed document that you can use to create documents quickly without having to think about formatting. With a 
template, many of the big document design decisions such as margin size, font style and size, and spacing are predetermined. You 
will learn how to create a new document with a template and insert text into it. 
 
To Insert a Template: 
 

1. Click the File tab to go to Backstage view. 
2. Select New. The New Document pane appears. 
3. Click Sample templates to choose a built-in template, or select an Office.com template category to download a template. 
4. Select the desired template and click Create. A new document will appear using the template you have selected. 
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To Insert Text into a Template: 
 
Templates include placeholder text that is surrounded by brackets. To personalize your document, you'll need to replace the 
placeholder text with your own text. 
Some templates simply use regular text as the placeholder text, rather than the "traditional" placeholder text with brackets. In those 
cases, just delete the text and type in your own text. 
 

1. Click on the text you want to replace. The text will appear highlighted and a template tag will appear. 
 

 
2. Enter some text. It will replace the placeholder text. 

For some fields, there is a drop-down arrow that you can use to select the information, rather than typing it. For example, 
a date field will show a calendar so that you can choose the date more easily. 

 
To Change Prefilled Information: 
 
In some templates, your name or initials will be automatically added. This is known as Prefilled information. If your name or initials 
are incorrect, you'll need to change them in Word Options. 
 

1. Click the File tab to go to Backstage view. 
2. Click the Options button. The Word Options dialog box appears. 
3. Enter the user name and/or initials in the General section, then click OK. 

 
If you are using a public computer, such as one at a library, you may not want to change these settings. 
 

 
_________________________________ 
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Lesson: 10  
 

 Mail Mergei 
 

 
Mail merge is a useful tool that will allow you to easily produce multiple letters, labels, envelopes, name tags and more using 
information stored in a list, database, or spreadsheet. You will learn how to use the mail merge wizard to create a data source and a 
form letter, and explore other wizard features. 

 
When you are performing a Mail Merge, you will need a Word document (you can start 
with an existing one or create a new one), and a recipient list, which is typically 
an Excel workbook.  
 
To Use Mail Merge: 
 

1. Open an existing Word document, or create a new one. 
2. Click the Mailings tab. 
3. Click the Start Mail Merge command. 
4. Select Step by Step Mail Merge Wizard. 
 

The Mail Merge task pane appears and will guide you through the six main steps to 
complete a mail merge. The following is an example of how to create a form letter and 
merge the letter with a recipient list. 
   
 

Step 1: 
 
1. Choose the type of document you wish to create. In this 

example, select Letters. 

 
2. Click Next: Starting document to move to Step 2. 
 

Step 2: 
 
1. Select Use the current document. 

 
2. Click Next: Select recipients to move to Step 3. 
 

Step 3: 
 
Now you'll need an address list so that Word can 
automatically place each address into the document. The list 
can be in an existing file, such as an Excel workbook, or you 
can type a new address list from within the Mail Merge 
Wizard. 
 
1. From the Mail Merge task pane, select Use an existing 

list and then click Browse. 
2. Locate your file in the dialog box (you may have to 

navigate to a different folder) and click Open.  
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3. If the address list is in an Excel workbook, select 
the worksheet that contains the list and click OK. 

 

 
 

4. In the Mail Merge Recipients dialog box, you 
can check or uncheck each recipient to control which 
ones are used in the mail merge. When you're done, 
click OK to close the dialog box. 

 

 
 

5. From the Mail Merge task pane, click Next: Select 
recipients to move to Step 4. 

 
Step 4: 
 
Now you're ready to write your letter. When it's printed, each copy of the letter will basically be the same, except the recipient 
data (such as the name and address) will be different on each one. You'll need to add placeholders for the recipient data, so 
that mail merge knows exactly where to add the data. If you're using mail merge with an existing letter, make sure that the file is 
open now. 
 
To Insert Recipient Data: 

1. Place the insertion point in the document where 
you wish the information to appear. 

2. Select Address block, Greeting line, Electronic 
postage, or More items from the task pane. 

 

 
3. Depending on your selection, a dialog box may 

appear with various options. Select the desired 
options and click OK. 

 
4. A placeholder appears in your document. For 

example: «Address Block». 
 

 
 

5. Repeat these steps each time you need to enter 
information from your data record. 

6. From the Mail Merge task pane, click Next: Preview 
your letters to move to Step 5 

 

For some letters, you'll only need to add an Address 
block and Greeting line. Sometimes, however, you 
may wish to place recipient data within the body of the 
letter to personalize it even further. 
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Step 5: 
 

1. Preview the letters to make sure the information 
from the recipient list appears correctly in the letter. 
You can use the left and right scroll arrows to view 
each document. 

 
 

2. Click Next: Complete the merge to move to Step 
6. 

Step 6: 
1. Click Print to print the letters. 

 
2. The Merge to Printer dialog box opens. Click All, 

and then click OK. 

 
3. The Print dialog box will appear. Adjust the print 

settings if needed, and then click OK. 

 
 
 
  
 
 
 
 
 

___________________________________________ 
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Lesson: 11  
 

 Reviewing & Printing of Documents i 
 

 
Suppose someone asks you to proofread a report for them. If you have a hard copy of the report, you might use a red pen to cross out 
sentences, mark misspellings, or add comments in the margins. However, you could also do all of these things in Word using 
the Track Changes and Comments features. 
When you've finished reviewing the document, the other person can choose to automatically Accept all of your changes, or decide 
whether to Accept or Reject each change one-by-one. 
 
About Track Changes 
 
When you turn on the Track Changes option, every 
change you make to the document shows up as 
colored markups. If you delete some text, it won't 
disappear, but instead will have a visible strike 
through it. If you add text, it will be underlined. This 
allows another person to see which changes have 
been made before making the changes permanent. 
The color of the markups will vary depending on 
who is reviewing the document, so if there are 
multiple reviewers, you'll be able to tell at a glance 
who made each change. 
 
To Turn on Track Changes: 

 
1. Click the Review tab. 
2. Click the Track Changes command. It should now be highlighted in gold to show that it is active. 
3. Any changes you make to 

the document will be 
shown as colored markups. 

4. Click the Track 
Changes command again to turn it off. 

 
 

 
 

Adding and Deleting Comments 
 
Sometimes, instead of changing something, you may want to make a comment about part of the document. Comments show up in 
"balloons" in the right margin and can be read by the original author or by any other reviewers. 
 
To Add a Comment: 

 
1. Highlight some text or place the insertion point where you want the comment to appear. 
2. From the Review tab, click the New Comment command. 
3. Type your comment. 

 
 

To Delete a Comment: 
 

1. Select the balloon containing the comment you wish to delete. 
2. From the Review tab, click the Delete command. 

 
To Delete All Comments: 
 

1. From the Review tab, click the Delete drop-down arrow. 
2. Click Delete All Comments in Document. 
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Accepting or Rejecting Changes 
 
Tracked changes are really just "suggested" changes. To become permanent, they have to be Accepted. On the other hand, the 
original author may disagree with some of the tracked changes and choose to Reject them. 
 
To Accept or Reject Changes: 
 

1. Select the change you want to accept or reject. 

2. From the Review tab, click the Accept or Reject command. 
3. If you accepted the change, the markup will disappear, and the text will look "normal." 

For some tracked changes, you can "reject" the changes by simply deleting them as if they were normal text. For example, if a 
reviewer adds a word to a sentence, you can just delete the word. 
 
To Accept All Changes: 
 

1. From the Review tab, click the Accept drop-down arrow. A drop-down menu will appear. 
2. Select Accept All Changes in Document. 

 
To Reject All Changes: 
 

1. From the Review tab, click the Reject drop-down arrow. A drop-down menu will appear. 
2. Select Reject All Changes in Document. 

 
Accepting or Rejecting all changes does not affect comments, so if you want to delete them, you'll have to do it separately. 
 
Changing How Markups Appear 
 
If there are a lot of tracked changes in a document, they may become distracting if you're trying to read through the document. There 
are a couple of settings that you can use to hide the markups or change how they appear. 
 
To Hide Tracked Changes: 
 

1. From the Review tab, click the Display for Review command. The Display for Review command is located to the right of 
the Track Changes command, and it may not be labeled. It will probably say Final: Show Markup. 

2. In the drop-down menu, there are four options: 

 Final: Show Markup: Shows the final version along with the markup. 
 Final: Shows the final version and hides all markups. 
 Original: Show Markup: Shows the original version along with the markup. 
 Original: Shows the original version and hides all markups. 

3. Choose Final or Original from the drop-down menu to hide the markups. 
 
Setting Display for Review to Final is not the same as accepting all changes. You will still need to Acceptor Reject the changes 
before sending out the final version of your document. 

 
To Show Revisions in Balloons: 
By default, most revisions show up inline, meaning the text itself is marked. You can choose to show the revisions in balloons, 
which moves many of the revisions (such as deletions) to balloons in the right margin. This may make the document easier to read, 
as there are fewer inline markups. The balloons also give you more detailed information about some markups. 
 

1. From the Review tab, click Show Markup - Balloons - Show Revisions in Balloons. 
2. Some of the revisions will move to the right margin. 

To go back to inline markups, you can select either Show All Revisions Inline or Show Only Comments and Formatting in 
Balloons. 
 
Comparing Two Documents 
 
If you edit a document without tracking changes, it's still possible to use reviewing features such as Accept andReject. You can do 
this by comparing two versions of the document. All you need is the original document and the revised document, and they need to 
have different file names. 
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To Compare Two Documents: 
 

1. From the Review tab, click the Compare command. A drop-down menu will appear. 
2. From the drop-down menu, click Compare. 
3. A dialog box will appear. Choose your Original document by clicking on the drop-down arrow and selecting the document 

from the list. If your document is not on the list, click the Browse button to browse for the file. 
4. Choose the Revised document the same way you chose the Original document and click OK. 

At this point, Word compares the two documents to determine which changes were made, and it creates a new document 
that you can save if you want. The changes show up as colored markups, just like the ones that appear when using Track 
Changes. You can then use the Accept and Reject commands to finalize the document. 
To the right of the new document, there is a pane that displays the Original and Revised documents that you can use for  
reference (although you can't edit them). If you don't see the pane on the right, click Compare  Show Source Documents 
 Show Both. 

 
Using the Reviewing Features Safely 
 
If there are any comments or tracked changes in your document, you should remove them before sending it out to anyone you're 
not collaborating with. Comments and tracked changes can reveal confidential information that could lead to embarrassment or make 
you or your company appear unprofessional (or worse). 
Once you've removed all of the comments and tracked changes, it's a good idea to double-check your document using the Document 
Inspector. The Document Inspector can tell you if there is any hidden data in your document that you may need to remove. It looks 
for data in many different places—not just comments and tracked changes. 
 
To Use the Document Inspector: 
 

1. Save your document. 
2. Click the File tab to go to Backstage view. 
3. Select Info on the left side of the page. 
4. Click the Check for Issues command. A drop-down menu will appear. 
5. Select Inspect Document. 
6. Click Inspect. 
7. The inspection results will show an exclamation mark for any categories where it found possibly sensitive data, and it will 

also have a Remove All button for each of those categories. Click Remove All to remove the data. 
8. Close the dialog box when you're done. 
9. From Backstage view, click Save to make the changes permanent. 

 
 

Printing a Documenti 
 

 
Once you’ve completed your document, you may want 
to print it. This lesson covers the tasks in the Print 
pane along with the Quick Print feature. 
In previous versions of Word, there was a Print 
Preview option that allowed you to see exactly what the 
document looked like before printing it. You may have 
noticed that this feature seems to be gone in Word 2010. It 
actually hasn’t disappeared; it’s just been combined with 
the Print window to create the Print pane, which is located 
in Backstage view. 
 
To View the Print Pane: 
 

1. Click the File tab to go to Backstage view. 
2. Select Print. The Print pane appears, with the 

print settings on the left and the Preview on the 
right. 

 

To Print: 
1. Go to the Print pane. 
2. If you only want to print certain pages, you can 

type a range of pages. Otherwise, select Print All 
Pages. 
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3. Select the number of copies. 
4. Check the Collate box if you are printing multiple copies of a multi-page document. 
5. Select a printer from the drop-down list. 
6. Click the Print button. 
 

Quick Print 
 
There may be times when you want to print something with a single click, using Quick Print. This feature prints the document using 
the default settings and the default printer. In Word 2010, you’ll need to add it to the Quick Access Toolbar in order to use it. 
Quick Print always prints the whole document, so if you only want to print part of your document you’ll have to use the Print pane. 
 
 
To Access the Quick Print Button: 
 

1. Click the drop-down arrow on the right side of the Quick Access Toolbar. 
2. Select Quick Print if it is not already checked. 
 

 
3. To print, just click the Quick Print command. 
 

 
 
 
 

__________________________________________ 
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 Unit-III    MS-Excel 2010i 
 

Lesson: 1  
 

 Introduction to M.S Excel 2010i 
 
 
Excel is a Microsoft office application. Excel is mainly used for making calculations and mathematical works. Microsoft excel is a 
spread sheet application in which number of sheets we can add as per our requirements. In a single sheet, it consists of rows and 
columns and cells. Every cell has different address. In excel sum, product, subtraction, division and many mathematical, logical 
functions are available with this application. Other features tables, charts, clip art etc. you can find with Excel. It basically used for 
payroll, accounts, mathematical and for other business purposes. 

Or 
Microsoft Excel is a commercial spreadsheet application written and distributed by Microsoft for Microsoft Windows and Mac OS X. It 
features calculation, graphing tools, pivot tables and a macro programming language called Visual Basic for Applications. 

Or 
Microsoft Excel is a spreadsheet application used to create and manage business transactions that deal with accounting. To make 
this possible, it can assist you with creating lists of transactions, then using those lists to create charts and other analysis tools. 

Or 
Excel is a spreadsheet program that allows you to store, organize, and analyze information.  
 
In this lesson, you will learn your way around the Excel 2010 environment, including the new Backstage view, which replaces the 
Microsoft Button menu from Excel 2007. We will show you how to use and modify the Ribbon and the Quick Access Toolbar, and how 
to create new workbooks and open existing ones.  
 
Basic Features of Excel:- 
 

1. Hyperlink: -We can link one file to another file or page with the use of Excel. 
2. Clip art: - In this we can add images and also audio, video clips can be added here.  
3. Charts: - With charts, we can clearly shown products evaluation to the clients. For example which product sale is more or 

less in this month. 
4. Tables: - Tables are created with different fields eg -name, age, address, roll no so we add a table to fill these values. 
5. Functions: - MATHEMATICAL: Add, subtract, div, multiply, LOGICAL: average, sum, mod, product. 
6. Images and Backgrounds:- In this we add images and backgrounds in sheet. 
7. Macros: - Macros are used for recording events for further use. 
8. Database: - We can add database from other sources with data feature. 
9. Sorting and Filter: - In sorting we can sort our data and also filter our data so that repetitions will be removed. 
10. Data Validations: - In data tools there are data validations consolidate etc are used. 
11. Grouping: - In this we can use group, ungroup subtotal etc. 
12. Page layout: - In this themes, colors, sheets, margins, size, backgrounds, breaks, print, titles, sheets height, width, scaling, 

gridness, headings, views, bring to front of font or back alignment etc will be used. 
 
Usages of M.S Excel 2010: 
  
1. Manage data records like name list 
The commonly usage of Excel is to manage data records and name lists. You don't have to plan in advance on how the table should 
look like, as the preset layout allows you to create the tables on the fly, just fill in the information; the table is developed on the go. 
Another more attractive point is that you have the ability to sort the list and filter the listing like a database tool. 
  
2. Used as an analytical tool 
Besides the good use on managing data, Excel is a great analytical tool for business. With the pivot table contained within Excel, you 
can easily analyses a large number of data, as the pivot table can automatically sort, count, and total the data stored in one table or 
spreadsheet and create a second table displaying the summarized data. It has gone through much revision. In each revision, we see 
its power being enhanced. In the latest version of Excel 2010, there are many new features added: It added almost six new 
calculations, a 'Show Value As' function and some great visual tools. 
  
3. Create forms and consolidate results 
You can use Excel to create not only a simple form that contains boxes, but also professional forms which include option buttons that 
allow you to select answers, dropdown list to select a particular answer from list of items. Together with charts, you can use Excel to 
compile answers to tests or quizzes and analyze the profile of the class (If you are a teacher) or your team (If you are a supervisor). 
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4. Corporate Budgeting 
A major business application of Excel is in corporate budgeting. Many companies, from big corporations to small companies use 
Excel for their budgeting. Despite numerous calls by suppliers of Business Performance Management Systems (BPM) to move away 
from Excel as a budgeting tool, 70% to 80% of all corporations still use Excel as their primary budgeting tool.  
 
5. Inventory Management 
Excel provides many functions and formulas that will not only help you manage your data records efficiently but will also allow you to 
analyze your data based on your constantly changing business environment. Through the use of Microsoft® Excel formulas, you can 
create comprehensive drop down boxes to facilitate data inputs and reduce erroneous entries. And through the use of pivot tables, 
you could get a good detailed analysis of your stock movement and also your inventory level at any point in time. 
  
6. Finding Profit Breakeven 
Finding breakeven is never easy without using Excel. To manually find out the breakeven for a project, you have to perform many 
calculations using different numbers as it's inputs. And the calculation becomes even more complex if the components include fixed 
cost and step up cost. But with the goal seek function in Excel, this task can be completed in a few seconds.  
 
The Ribbon 
 
The Ribbon contains multiple tabs, each 
with several groups of commands. You can 
add your own tabs that contain your favorite 
commands. 
Certain programs, such as Adobe Acrobat 
Reader, may install additional tabs to the 
ribbon. These tabs are called Add-ins. 
 
To Customize the Ribbon: 
 
You can customize the ribbon by creating 
your own tabs that house your desired 
commands. Commands are always housed 
within a group, and you can create as many groups as you need to keep your tabs organized. In addition, you can even add 
commands to any of the default tabs, as long as you create a custom group within the tab. 
 

1. Right-click the Ribbon and select customize the Ribbon. 
A dialog box will appear. 

2. Click New Tab. A new tab created with a new group inside it. 
3. Make sure the new group is selected. 

4. Select a command from the list on the left, then click Add. You 
can also drag commands directly into a group. 

5. When you are done adding commands, click OK. 
 
If you 
do not see the command you want, click on the Choose 
commands drop-down box and select All Commands. 
 
To Minimize and Maximize the Ribbon: 
  
The Ribbon is designed to be 
responsive to your current task 
and easy to use, but if you find it is 
taking up too much of your screen 
space, you can minimize it. 
 

1. Click the arrow in the 
upper-right corner of the 
Ribbon to minimize it. 

2. To maximize the Ribbon, 
click the arrow again. 

When the Ribbon is minimized, you can make it reappear by 
clicking on a tab. However, the Ribbon will disappear again 
when you are not using it. 
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The Quick Access Toolbar 
 
The Quick Access Toolbar is located above the Ribbon, and it lets you access common commands no matter which tab you are on. 
By default, it shows the Save, Undo, and Repeat commands. You can add other 
commands to make it more convenient for you. 
 
To Add Commands to the Quick Access Toolbar: 
 

1. Click the drop-down arrow to the right of the Quick Access Toolbar. 
2. Select the command you wish to add from the drop-down menu. To choose 

from more commands, select more commands. 
 
Backstage View 
 
Backstage view gives you various options for saving, opening a file, printing, or 
sharing your document. It is similar to the Office Button menu from Excel 2007 or 
the File menu from earlier versions of Excel. However, instead of just a menu, it is a 
full-page view which makes it easier to work with. 
 
To Get to Backstage View: 
 

1. On the Ribbon, click the File tab. 
2. Choose your desired option, or return to your workbook by clicking on any tab on the Ribbon. 

 

To Create a New, Blank Workbook: 
 

1. Click the File tab. This takes you to Backstage view. 
2. Select New. 
3. Select Blank workbook under Available Templates. It will be highlighted by default. 
4. Click Create. A new, blank workbook appears in the Excel window. 

 
 
To save time, you can create your document from 
a template, which you can select under Available 
Templates. We will talk more about this in a later lesson. 
 
To Open an Existing Workbook: 
 

1. Click the File tab. This takes you to Backstage 
view. 

2. Select Open. The Open dialog box appears. 
3. Select your desired workbook and then 

click Open. 
 
If you have opened the existing workbook recently, it 
may be easier to choose Recent from the File 
tab instead of Open to search for your workbook. 
 
 
 
 
 
 
 

 
 
 

___________________________________ 
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Lesson: 2  
 

 Cell Basici 
 
 

You will need to know the basic ways you can work with cells and cell content in Excel to be able to use it to calculate, analyze, and 
organize data. In this lesson, you will learn how to select cells; insert content; and delete cells and cell content. You will also learn how 
to cut, copy and paste cells; drag and drop cells; and fill cells using the fill handle. 
 
The Cell 
 

Each rectangle in a worksheet is called a cell. A cell 
is the intersection of a row and a column. 
Each cell has a name, or a cell address based on 
which column and row it intersects. The cell 
address of a selected cell appears in the Name box. 
Here you can see that C5 is selected. 
 
To Select a Cell: 
 

1. Click on a cell to select it. When a cell is 
selected you will notice that the borders of 
the cell appear bold  and 
the column heading and row heading of the cell are highlighted. 

2. Release your mouse. The cell will stay selected until you click on another cell 
in the worksheet. 

You can also navigate through your worksheet and select a cell by using the arrow 
keys on your keyboard. 
 

To Select Multiple Cells: 
 

1. Click and drag your mouse until all of the adjoining cells you want are highlighted. 
2. Release your mouse. The cells will stay selected until you click on another cell in the 

worksheet. 

 
 

 

Cell Content 
 

Each cell can contain its own text, formatting, comments, formulas, and 
functions. 
 

 Text 
Cells can contain letters, numbers, and dates. 

 Formatting attributes 
Cells can contain formatting attributes that change the way letters, 
numbers, and dates are displayed. For example, dates can be 
formatted as MM/DD/YYYY or Month/D/YYYY. 

 Comments 
Cells can contain comments from multiple reviewers. 

 Formulas and Functions 
Cells can contain formulas and functions that calculate cell values. 
For example, SUM(cell 1, cell 2...) is a formula that can add the 
values in multiple cells. 

 
To Insert Content: 
 

1. Click on a cell to select it. 
2. Enter content into the selected cell using your keyboard. The content appears in the cell and in the formula bar. You also 

can enter or edit cell content from the formula bar. 
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 To Delete Content Within Cells: 
 

1. Select the cells which contain content you want to delete. 

2. Click the Clear command on the ribbon. A dialog box will appear. 
3. Select Clear Contents. 

 
You can also use your keyboard's Backspace key to delete content from a single 
cell or Delete key to delete content from multiple cells.   
 
 

 

To Delete Cells: 
 

1. Select the cells that you want to delete. 
2. Choose the Delete command from the ribbon. 

 
To Copy and Paste Cell Content: 

1. Select the cells you wish to 
copy. 

2. Click the Copy command. 
The border of the selected 
cells will change appearance. 

3. Select the cell or cells where 
you want to paste the content. 

4. Click the Paste command. 
The copied content will be 
entered into the highlighted 
cells. 

 

 
To Cut and Paste Cell Content: 

1. Select the cells you wish to cut. 
2. Click the Cut command. The border of the selected cells will change appearance. 
3. Select the cells where you want to paste the content. 
4. Click the Paste command. The cut content will be removed from the original cells and entered into the highlighted cells. 

 

To Access More Paste Options: 
There are more Paste options that you can access from the drop-down menu on the Paste command.These options may be 
convenient to advanced users who are working with cells that contain formulas or formatting. 
 
To Access Formatting Commands by Right-Clicking: 

1. Select the cells you want to format. 
2. Right-click on the selected cells. A dialog box will appear where you can easily access many commands that are on the 

ribbon. 
 

To Drag and Drop Cells: 
1. Select the cells that you wish to move. 
2. Position your mouse on one of the outside edges of the selected cells. The mouse changes from a white cross  to a black 

cross with 4 arrows . 
3. Click and drag the cells to the new location. 
4. Release your mouse and the cells will be dropped there. 
5.  

 

To Use the Fill Handle to Fill Cells: 
1. Select the cell or cells containing the content you want to use. You can fill cell content either vertically or horizontally. 
2. Position your mouse over the fill handle so that the white cross   becomes a black cross  

 
3. Click and drag the fill handle until all the cells you want to fill are highlighted. 
4. Release the mouse and your cells will be filled. 
 

_____________________________ 
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Lesson: 3  
 

 Modifying Rows, Columns & Cellsi 
 
 
When you open a new, blank workbook, the cells are set to a default size. You do have the ability to modify cells, and to insert and 
delete columns, rows, and cells, as needed. In this lesson, you will learn how to change row height and column width; insert and 
delete rows and columns; wrap text in a cell; and merge cells. 
 
To Modify Column Width: 
 

1. Position your mouse over the column line in the column heading so that 
the white cross becomes a double arrow. 

2. Click and drag the column to the right to increase the column width or to the 
left to decrease the column width. 

3. Release the mouse. The column width will be changed in your spreadsheet. 

 
To Set Column Width with a Specific Measurement: 
 

1. Select the columns you want to modify. 

2. Click the Format command on the Home tab. The format drop-down menu appears. 
3. Select Column Width. 
4. The Column Width dialog box appears. Enter 

a specific measurement. 
5. Click OK. The width of each selected column 

will be changed in your worksheet. 
Select AutoFit Column Width from the format drop-
down menu and Excel will automatically adjust each 
selected column so that all the text will fit. 
 
 

 
To Modify the Row Height: 
 

1. Position the cursor over the row line so that the white cross becomes 
a double arrow. 

2. Click and drag the row downward to increase the row height or upward 
decrease the row height. 

3. Release the mouse. The height of each selected row will be changed in 
your worksheet. 

 
 
To Set Row Height with a Specific Measurement: 
 
 

1. Select the rows you want to modify. 

2. Click the Format command on the Home tab. The format drop-down menu 
appears. 

3. Select Row Height. 
4. The Row Height dialog box appears. 

Enter a specific measurement. 
5. Click OK. The selected rows heights will 

be changed in your spreadsheet 
 
   
Select AutoFit Row Height from the format drop-
down menu and Excel will automatically adjust each 
selected row so that all the text will fit. 
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To Insert Rows: 
 

1. Select the row below where you want the new row to appear. 
2. Click the Insert command on the Home tab. 
3. The new row 

appears in your 
worksheet. 

When inserting new rows, 
columns, or cells, you will 
see the Insert 

Options button   by the 
inserted cells. This button allows you to choose 
how Excel formats them. By default, Excel 
formats inserted rows with the same formatting 
as the cells in the row above them. To access 
more options, hover your mouse over the 
Insert Options button and click on the drop-
down arrow that appears. 

 
To Insert Columns: 
 

1. Select the column to the right of where you want the new column to appear. For example, if you want to insert a column 
between A and B, select column B. 

2. Click the Insert command on the Home tab. 
3. The new column appears in your worksheet. 

By default, Excel formats inserted columns with the same formatting as the column to the left of them. To access more 
options, hover your mouse over the Insert Options button and click on the drop-down arrow that appears. 
When inserting rows and columns, make sure you select the row or column by clicking on its heading so that all the cells in 
that row or column are selected. If you select just a cell in the row or column then only a new cell will be inserted. 

 
To Delete Rows: 
 

1. Select the rows you want to delete. 
2. Click the Delete command on the Home tab. 
3. The rows are deleted from your worksheet. 

 
Wrapping Text and Merging Cells 
 
If a cell contains more text than can be displayed, you can choose to wrap the text within the cell or merge the cell with empty, 
adjoining cells. Wrap text to make it display on multiple lines of the cell. Merge cells to combine adjoining cells into one larger cell. 
 
To Wrap Text: 
 

1. Select the cells with text you want to wrap. 

2. Select the Wrap Text command on the Home tab. 
3. The text in the selected cells will be wrapped in your 

worksheet. 

If you change your mind, re-click the Wrap Text command to unwrap 
the text. 
 
 
To Merge Cells Using the Merge & Center Command: 
 

1. Select the cells you want to merge together. 

To Delete Columns: 
 

1. Select the columns you want to delete. 
2. Click the Delete command on the Home tab. 
3. The columns are deleted from your worksheet. 
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(Selecting A1:D1 (A1, B1, C1, D1) 
 

2. Select the Merge & Center command on the Home tab. 

(Selecting the Merge & Center command) 
 
3. The selected cells will be merged and the text will be centered. 

(A1 after merging with B1:D1) 
 

If you change your mind, re-click the Merge & Center command to unmerge the cells. 
 
To Access More Merge Options: 

 
Click the drop-down arrow next to the Merge & Center command on the Home tab. The merge drop-
down menu appears. 

 Merge & Center: Merges selected cells into one cell and centers the text. 
 Merge Across: Merges each row of selected cells into larger cells. This command is useful if 

you are merging content across multiple rows of cells and do not want to create one large cell. 
 Merge Cells: Merges selected cells into one cell. 
 Unmerge Cells: Unmerges the selected cells. 

 
 

___________________________________ 
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Lesson: 4  
 

 Formatting Text & Cellsi 
 
Spreadsheets that have not been formatted can be difficult to read. Formatted text and cells can draw attention to specific parts of the 
spreadsheet and make the spreadsheet more visually appealing and easier to understand. 
In Excel, there are many tools you can use to format text and cells. In this lesson, you will learn how to change the color and style of 
text and cells; align text; and apply special formatting to numbers and dates. 
 
Formatting Text 
 
Many of the commands you will use to format text can be found in the Font, Alignment, and Number groups on the 
ribbon. Font commands let you change the style, size, and color of text. You can also use them to add borders and fill colors to 
cells. Alignment commands let you format how text is displayed across cells both horizontally and vertically. Number commands let 
you change how selected cells display numbers and dates. 
 
To Change the Font: 
 

 
1. Select the cells you want to modify. 

2. Click the drop-down arrow next to the font command on the Home 
tab. The font drop-down menu appears. 

3. Move your mouse over the various fonts. A live preview of the font 
will appear in the worksheet. 

4. Select the font you want to use. 
 

To Change the Font Size: 
 

1. Select the cells you want to modify. 

2. Click the drop-down arrow next to the font size command on the 
Home tab. The font size drop-down 
menu appears. 

3. Move your mouse over the various 
font sizes. A live preview of the font 
size will appear in the worksheet. 

4. Select the font size you want to use. 

You can also use the Grow Font and Shrink 
Font commands to change the size.   
 

 
To Use the Bold, Italic, and Underline Commands: 
 

1. Select the cells you want to modify. 

2. Click the Bold (B), Italic (I), or Underline (U) command on the Home tab. 
 
To Add a Border: 
 

1. Select the cells you want to modify. 

2. Click the drop-down arrow next to the Borders command on the Home tab. The 
border drop-down menu appears. 

3. Select the border style you want to use. 

You can draw borders and change the line style and color of borders with the Draw 
Borders tools at the bottom of the Borders drop-down menu. 
 
To Change the Font Color: 
 

1. Select the cells you want to modify. 

2. Click the drop-down arrow next to the font color command on the Home tab. The color menu appears. 
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3. Move your mouse over the various font colors. A live preview of the color will appear in the worksheet. 

4. Select the font color you want to use. 

Your color choices are not limited to the drop-down menu that appears. Select More Colors at the bottom of the menu to access 
additional color options. 
 
To Add a Fill Color: 
 

1. Select the cells you want to modify. 

2. Click the drop-down arrow next to the fill color command on the Home tab. The color menu appears. 
3. Move your cursor over the various fill colors. A live preview of the color will appear in the worksheet. 

4. Select the fill color you want to use. 
 

To Change Horizontal Text Alignment: 
 

 
1. Select the cells you want to modify. 

2. Select one of the three horizontal Alignment commands 
on the Home tab. 

 
o Align Text Left: Aligns text to the left of the cell. 
o Center: Aligns text to the center of the cell. 
o Align Text Right: Aligns text to the right of the cell. 

 
 
 

 

To Change Vertical Text Alignment: 
 

1. Select the cells you want to modify. 

2. Select one of the three vertical Alignment commands on the 
Home tab. 
o Top Align: Aligns text to the top of the cell. 
o Middle Align: Aligns text to the middle of the cell. 
o Bottom Align: Aligns text to the bottom of the cell. 

 
By default, numbers align to the bottom-right of cells and words or 
letters align to the bottom-left of cells. 
 
 
 

Formatting Numbers and Dates 
 
One of the most useful features of Excel is its ability to format numbers and dates in a variety of ways. For example, you might need 
to format numbers with decimal places, currency symbols ($), percent symbols (%), etc. 

 
To Format Numbers and Dates: 
 

1. Select the cells you want to modify. 

2. Click the drop-down arrow next to the Number Format command on the Home 
tab. 

3. Select the number format you want. 

 
 
 

 
______________________________________ 
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Lesson: 5  
 

 Workbook & Worksheeti 
 

 
A workbook is a file that stores the entered related data; a worksheet is a page of the workbook on which all the data is held. 
 
In Microsoft Excel, a workbook is simply an Excel file that stores entered related data. Workbooks are capable of holding an almost 
infinite number of worksheets, depending on the size and the relevance of the data. It is, essentially, a book filled with the data from 
multiple worksheets. Workbooks are usually labeled by the data which is on each worksheet – if all the pages of the workbook hold 
the same type of data, that workbook will be named for the relevant data that it holds. 
In Excel, a worksheet is an amalgamation of a number of cells that hold data pertaining to a certain piece of information. It is also 
known as a spreadsheet. A user is able to enter, modify, and manipulate the data that is entered in the spreadsheet. With a 
spreadsheet, a user is essentially entering information onto a page of a workbook. 
 
By default, each workbook automatically contains three worksheets. When a user opens Excel initially, the project on which they 
are going to begin work is entitled ‘Book 1′ until later renamed to fit the type of data being entered into each respective sheet. 
Essentially, when a user opens Excel, they are beginning creation on a workbook – a book that contains multiple pages of entered 
data. These pages fill the book and are, therefore, a part of the overall summation of information that the book is attempting to 
convey. 
 
A worksheet, then, is nothing more than a page in the workbook. Each page is filled with a specific amount of data. Within a 
worksheet, the data can be manipulated to create charts, graphs, or arrays that visually project the main purpose of the data that was 
initially entered. The worksheet is what defines what the workbook is – without the worksheets the workbook would be without form or 
purpose. The worksheets are what make the workbook what it is, and holds all the data for the workbook. 
 

Worksheet and workbook specifications 
 

FEATURE MAXIMUM LIMIT 

Open workbooks Limited by available memory and system resources 

Worksheet size 65,536 rows by 256 columns 

Column width 255 characters 

Row height 409 points 

Page breaks 1000 horizontal and vertical 

Length of cell contents (text) 32,767 characters. Only 1,024 display in a cell; all 32,767 display in the formula bar. 

Sheets in a workbook Limited by available memory (default is 3 sheets) 

Colors in a workbook 56 

Cell styles in a workbook 4,000 

Named views in a workbook Limited by available memory 

Custom number formats Between 200 and 250, depending on the language version of Excel you have installed. 

Names in a workbook Limited by available memory 

Windows in a workbook Limited by system resources 

Panes in a window 4 

Linked sheets Limited by available memory 

Scenarios Limited by available memory; a summary report shows only the first 251 scenarios 

Changing cells in a scenario 32 

Adjustable cells in Solver 200 

Custom functions Limited by available memory 

Zoom range 10 percent to 400 percent 

Reports Limited by available memory 

Sort references 3 in a single sort; unlimited when using sequential sorts 

Undo levels 16 

Fields in a data form 32 

Custom toolbars in a workbook Limited by available memory 

Custom toolbar buttons Limited by available memory 
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Opening a workbook when running Excel 2010 on Windows 7 or Vista 
 
Follow these steps to open a workbook when you're running 
Excel 2010 on Windows 7 or Vista: 
 
1. Click the File tab and choose Open. 
 

The Open dialog box appears. This dialog box is divided 
into panes: the Navigation pane on the left, where you 
can select a new folder to open, and the main pane on 
the right, showing the icons for all the subfolders in the 
current folder as well as the documents that Excel can 
open. 

 
2. If you want to open a workbook in another folder, 

select the folder in the Navigation pane. 
 

If you're running Excel 2010 on Windows Vista, the 
Navigation pane in the Open dialog box contains a 
Folders item instead of Libraries under your list of 
Favorites. Additionally, the Views button appears 
between the Organize and New Folder buttons and not 
to their right above the Navigation and main panes. 

 
3. Click the file you want to open and then click the 

Open button, or double-click the file's icon. 
 
To Rename Worksheets: 
 

1. Right-click the worksheet tab you want to 
rename. The worksheet menu appears. 

2. Select Rename. 
3. The text is now highlighted by a black box. 

Type the name of your worksheet. 

4. Click anywhere outside of the tab. The 
worksheet is renamed. 

 
 

To Insert New Worksheets: 
 

Click on the Insert Worksheet icon. A new worksheet will appear. 
You can change the setting for the default number of worksheets that appear in Excel 
workbooks. To access this setting, go into Backstage view and click on Options. 
 
 

 

To Delete Worksheets: 
 
Worksheets can be deleted from a workbook, including those that contain data. 
 

1. Select the worksheets you want to delete. 
2. Right-click one of the selected worksheets. The worksheet menu appears. 
3. Select Delete. The selected worksheets will be deleted from your workbook. 

 
To Copy a Worksheet: 
 

1. Right-click the worksheet you want to copy. The worksheet menu appears. 
2. Select Move or Copy. 
3. The Move or Copy dialog box appears. Check the Create a copy box. 
4. Click OK. Your worksheet is copied. It will have the same title as your original worksheet, but the title will include a version 

number, such as "January (2)". 



 
 
 

SARVA EDUCATION (SITED) (Running- An I.T & Skill Advancement Training Programme)                                                                                                                                                            - 107 -                                                                                                                 

                                                                       

 

Visit us at:  www.sarvaindia.com                                                                 Licensed by Govt. of India                                                                       ISO 9001:2015 Certified 

To Move a Worksheet: 
 

1. Click on the worksheet you want to move. The mouse will change to 
show a small worksheet icon. 

2. Drag the worksheet icon until a small black arrow appears where 
you want the worksheet to be moved. 

3. Release your mouse and the worksheet will be moved. 
 
To Color-Code Worksheet Tabs: 
 
You can color worksheet tabs to help organize your worksheets and make your workbook easier to navigate. 
 

1. Right-click the worksheet tab you want to color. The worksheet menu appears. 
2. Select Tab Color. The color menu appears. 
3. Select the color you want to change your tab. 
4. The tab color will change in the workbook. If your tab still appears white, that is because the worksheet is still selected. 

Select any other worksheet tab to see the color change. 
 
Grouping and Ungrouping Worksheets 
 
You can work with each worksheet in a workbook individually, or you can work with multiple worksheets at the same time. Worksheets 
can be combined together into a group. Any changes made to one worksheet in a group will be made to every worksheet in the group. 
 
To Group Worksheets: 
 

1. Select the first worksheet you want in the group. 
2. Press and hold the Ctrl key on your keyboard. 
3. Select the next worksheet you want in the group. Continue to select worksheets 

until all of the worksheets you want to group are selected. 
4. Release the Ctrl key. The worksheets are now grouped. The worksheet tabs 

appear white for the grouped worksheets. 
While worksheets are grouped, you can navigate to any worksheet in the group 
and make changes that will appear on every worksheet in the group. If you click 
on a worksheet tab that is not in the group, however, all of your worksheets will 
become ungrouped. You will have to regroup them. 

 
To Ungroup All Worksheets: 
 

1. Right-click one of the worksheets. The worksheet menu appears. 
2. Select Ungroup. The worksheets will be ungrouped. 

 
Freezing Worksheet Panes 
 
The ability to freeze specific rows or columns in your worksheet can be a very useful feature in Excel. It is called freezing panes. 
When you freeze panes, you select rows or columns that will remain visible all the time, even as you are scrolling. This is particularly 
helpful when working with large spreadsheets. 
 
To Freeze Rows: 

 
1. Select the 

row below the rows that 
you want frozen. For 
example, if you want 
rows 1 & 2 to always 
appear at the top of the 
worksheet even as you 
scroll, then select row 
3. 

 
2. Click the View tab. 
3. Click the Freeze Panes command. A drop-down menu 

appears. 
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4. Select Freeze Panes. 
5. A black line appears below the rows that are frozen in place. Scroll down in the worksheet to see the rows below the frozen 

rows. 
 

 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
To Freeze Columns: 
 

1. Select the column to the right of the columns you want frozen. For example, if you want columns A & B to always appear to 
the left of the worksheet even as you scroll, then select column C. 

2. Click the View tab. 
3. Click the Freeze Panes command. A drop-down menu appears. 
4. Select Freeze Panes. 
5. A black line appears to the right of the frozen area. Scroll across the worksheet to see the columns to the right of the frozen 

columns. 
 
To Unfreeze Panes: 
 

1. Click the View tab. 
2. Click the Freeze Panes command. A drop-down menu appears. 
3. Select Unfreeze Panes. The panes will be unfrozen and the black line will disappear. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

________________________________________ 
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Lesson: 6  
 

 Working with Formulasi 
 

 
Excel can be used to calculate numerical information. In this lesson you will learn how to create simple formulas in Excel to add, 
subtract, multiply, and divide values in a workbook. Also, you will learn the various ways you can use cell references to make working 
with formulas easier and more efficient. 
 

 Simple Formulasi 
 
A formula is an equation that performs a calculation. Like a calculator, Excel can execute formulas that add, subtract, multiply, and 
divide. One of the most useful features of Excel is its ability to calculate using a cell address to represent the value in a cell. This is 
called using a cell reference. In order to maximize the capabilities of Excel, it is important to understand how to create simple formulas 
and use cell references. 
 
Creating Simple Formulas 
 
Excel uses standard operators for equations, such as a plus sign for addition (+), a minus sign for 
subtraction (-), an asterisk for multiplication (*), a forward slash for division (/), and a carat (^) for 
exponents. 
The key thing to remember when writing formulas for Excel is that all formulas must begin with 
an equal sign (=). This is because the cell contains, or is equal to, the formula and its value. 
 
 To Create a Simple Formula in Excel: 

 
1. Select the cell where the answer will appear (B4, for example). 

2. Type the equal sign (=). 
3. Type in the formula you want Excel to calculate. For example, "75/250". 

4. Press Enter. The formula will be 
calculated and the value will be displayed 
in the cell. 

 
 
Creating Formulas with Cell References 
 
When a formula contains a cell address, it is called a cell reference. Creating a formula with cell references is useful because you 
can update data in your worksheet without having to rewrite the values in the formula. 
 

 
To Create a Formula Using Cell References: 
 

1. Select the cell where the answer will appear (B3, for example). 

2. Type the equal sign (=). 
3. Type the cell address that contains the first number in the equation (B1, for example). 

4. Type the operator you need for your formula. For example, type the addition sign 
(+). 

5. Type the cell address that contains the second number in the equation (B2, for 
example). 

6. Press Enter. The formula will be calculated and the value will be displayed in the cell. 
 
 

If you change a value in either B1 or B2, the total will automatically recalculate. 
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To Create a Formula using the Point and Click Method: 
 

1. Select the cell where the answer will appear (B4, for example). 

2. Type the equal sign (=). 
3. Click on the first cell to be included in the formula (A3, for example). 
4. Type the operator you need for your formula. For example, type the multiplication sign (*). 
5. Click on the next cell in the formula (B3, for example). 
6. Press Enter. The formula will be calculated and the value will be displayed in the cell. 

 
To Edit a Formula: 
 

1. Click on the cell you want to edit. 

2. Insert the cursor in the formula bar and edit the formula as desired. You can also double-click the cell to view and edit 
the formula directly from the cell. 

3. When finished, press Enter or select the Enter command   . 
4. The new value will be displayed in the cell. 

 
If you change your mind, use 
the Cancel command  in the 
formula bar to avoid accidentally 
making changes to your formula. 

 
 
 
 
 
 

 
 
 

 Creating Complex Formulasi 
 

Excel is a spreadsheet application that can help you calculate and analyze numerical information for household budgets, company 
finances, inventory, and more. To do this, you need to understand complex formulas. 
 
Simple formulas have one mathematical operation, such as 5+5.Complex formulas have more than one mathematical operation, such 
as 5+5-2. When there is more than one operation in a formula, the order of operations tells us which operation to calculate first. In 
order to use Excel to calculate complex formulas, you will need to understand the order of operations. 
 
Order of Operations 
 
Excel calculates formulas based on the following order of operations: 
 

1. Operations enclosed in parentheses 
2. Exponential calculations (to the power of) 
3. Multiplication and division, whichever comes first 
4. Addition and subtraction, whichever comes first 
 

A mnemonic that can help you remember the order is Please Excuse My Dear Aunt Sally. 
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Example 2 
In this example, we will review how Excel will calculate a complex formula 
using the order of operations. The selected cell will display the percent of 
total Pete Lily seeds sold that were white. 

 
 

 
Order of Operations Excel example 
 

1. First, Excel will calculate the amount sold in parentheses: (19*1.99)=37.81 White Lily seeds and (33*1.99)=65.67 Total Lily 
seeds. 

2. Second, it will divide the White Lily seeds amount by the Total Lily seeds amount: 37.81/65.67=.5758. 
3. Last, it will multiply the result by 100 to obtain the value as a percent: .5758*100=57.58. 

Based on this complex formula, the result will show that 57.58% of the total Pete Lily seeds sold were white. You can see 
from this example, that it is important to enter complex formulas with the correct order of operations. Otherwise, Excel will 
not calculate the results accurately. 

 
To Create a Complex Formula Using the Order of Operations: 
 
In this example, we will use cell references in 
addition to actual values, to create a complex 
formula that will add tax to the nursery order. 

1. Click the cell where you want the 
formula result to appear (for example, 
F11). 

2. Type the equal sign (=). 
3. Type an open parenthesis, then click 

on the cell that contains the 
first value you want in the formula (for 
example, F4). 

4. Type the first mathematical 
operator (for example, the addition 
sign). 

5. Click on the cell that contains the 
second value you want in the formula 
(for example, F5), and then type a 
closed parenthesis. 

6. Type the next mathematical 
operator (for example, the multiplication sign). 

7. Type the next value in the formula (for example, 0.055 for 5.5% tax). 
8. Click Enter to calculate your formula. The results show that $2.12 is the tax for the nursery order. 

 
Working with Cell References 
 
In order to maintain accurate formulas, it is necessary to understand how cell references respond when you copy or fill them to new 
cells in the worksheet. Excel will interpret cell references as either relative or absolute. By default, cell references are relative 
references. When copied or filled, they change based on the relative position of rows and columns. If you copy formula (=A1+B1) into 
row 2, the formula will change to become (=A2+B2). 

Example 1 
The following example demonstrates how to use the 
order of operations to calculate a formula: 
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Absolute references, on the other hand, do not change when they are copied or filled and are used when you want the values to 
stay the same. 
Relative References 
 
Relative references can save you time when you are repeating the same kind of calculation across multiple rows or columns. 
In the following example, we are creating a formula with cell references in row 4 to calculate the total cost of the electric bill and water 
bill for each month (B4=B2+B3). For the upcoming months we want to use the same formula with relative references (C2+C3, D2+D3, 
E2+E3, etc.) For convenience, we can copy the formula in B4 into the rest of row 4 and Excel will calculate the value of the bills for 
those months using relative references. 
 
To Create and Copy a Formula Using Relative References: 
 

1. Select the first cell where you want to enter the formula (for example, B4). 

  

2. Enter the formula to calculate the value you want (for example, add B2+B3). 

 
3. Press Enter. The formula will be calculated. 
4. Select the cell you want to copy (for example, B4) and click on the Copy command from 

the Home tab. 
5. Select the cells where you want to paste the formula and click on the Paste command 

from the Home tab. (You may also drag the fill handle to fill cells.) 

  
6. Your formula is copied to the selected cells as a relative reference (C4=C2+C3, D4=D2+D3, E4=E2+E3, etc.) and the values 

are calculated. 
 

Absolute References 
 
There may be times when you do not want a cell reference to change when copying or filling cells. You can use an absolute 
reference to keep a row and/or column constant in the formula. 
An absolute reference is designated in the formula by the addition of a dollar sign ($). It 
can precede the column reference, the row reference, or both. 
In the below example, we want to calculate the sales tax for a list of products with varying 
prices. We will use an absolute reference for the sales tax ($B$1) because we do not 
want it to change as we are copying the formula down the column of varying prices.  
 
To Create and Copy a Formula Using an Absolute Reference: 
 

1. Select the first cell where you want to enter the formula (for 
example, C4) 

2. Click on the cell that contains the first value you want in the 
formula (for example, B4). 

3. Type the first mathematical operator (for example, the 
multiplication sign). 

4. Type the dollar sign ($) and enter the column letter of the 
cell you are making an absolute reference to (for example, B). 



 
 
 

SARVA EDUCATION (SITED) (Running- An I.T & Skill Advancement Training Programme)                                                                                                                                                            - 113 -                                                                                                                 

                                                                       

 

Visit us at:  www.sarvaindia.com                                                                 Licensed by Govt. of India                                                                       ISO 9001:2015 Certified 

 
   

5. Type the dollar sign ($) and enter the row number of the same 
cell you are making an absolute reference to (for example, 1). 

 

6. Press Enter to calculate the formula. 
 
 
7. Select the cell you want to copy (for example, C4) and click on the Copy command from the Home tab. 
8. Select the cells where you want to paste the formula and click on 

the Paste command from the Home tab. (You may also drag the 
fill handle to fill cells.) 

9. Your formula is copied to the selected cells using the absolute 
reference (C5=B5*$B$1, C6=B6*$B$1, etc.) and your values are 
calculated. 

 
 
 

 Working with Basic Functionsi 
 

Figuring out formulas for calculations you want to make in Excel can be tedious and complicated. Fortunately, Excel has an entire 
library of functions or predefined formulas that you can take advantage of. You may be familiar with common functions 
like sum, average, product or count, but there are hundreds of functions in Excel, even for things like formatting text, referencing 
cells, calculating financial rates, analyzing statistics, and more. 
A function is a predefined formula that performs calculations using specific values in a particular order. One of the key benefits of 
functions is that they can save you time since you do not have to write the formula yourself. Excel has hundreds of different functions 
to assist with your calculations. In order to use these functions correctly, you need to understand the different parts of a function and 
how to create arguments in functions to calculate values and cell references. 
 
The Parts of a Function 
 
The order in which you insert a function is important. Each function has a specific 
order, called syntax, which must be followed for the function to work correctly. The 
basic syntax to create a formula with a function is to insert an equal sign (=), 
a function name (SUM, for example, is the function name for addition), and 
an argument. Arguments contain the information you want the formula to calculate, 
such as a range of cell references. Types of Functions:- 
 
  
 
 
 
 
 
 
 
 
 
 
 

Financial functions 
 

FUNCTION DESCRIPTION 

ACCRINT Returns the accrued interest for a security that pays periodic interest 

ACCRINTM Returns the accrued interest for a security that pays interest at maturity 

AMORDEGRC Returns the depreciation for each accounting period by using a 
depreciation coefficient 

AMORLINC Returns the depreciation for each accounting period 

COUPDAYBS Returns the number of days from the beginning of the coupon period to the 
settlement date 

COUPDAYS Returns the number of days in the coupon period that contains the 
settlement date 

COUPDAYSNC Returns the number of days from the settlement date to the next coupon 
date 

COUPNCD Returns the next coupon date after the settlement date 

COUPPCD Returns the previous coupon date before the settlement date 

FV Returns the future value of an investment 

 

Engineering functions 
 

IMLOG2 Returns the base-2 logarithm of a complex number 

IMPOWER Returns a complex number raised to an integer power 

IMPRODUCT Returns the product of from 2 to 29 complex numbers 

IMREAL Returns the real coefficient of a complex number 

IMSIN Returns the sine of a complex number 

IMSQRT Returns the square root of a complex number 

IMSUB Returns the difference between two complex numbers 

IMSUM Returns the sum of complex numbers 

OCT2BIN Converts an octal number to binary 

OCT2DEC Converts an octal number to decimal 

OCT2HEX Converts an octal number to hexadecimal 
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If you want detailed Explanation on Various Function used in Excel, 2010 then please Visit following website: 

Math and trigonometry functions 
 

FUNCTION DESCRIPTION 

ABS Returns the absolute value of a number 

ACOS Returns the arccosine of a number 

ACOSH Returns the inverse hyperbolic cosine of a number 

ASIN Returns the arcsine of a number 

ASINH Returns the inverse hyperbolic sine of a number 

ATAN Returns the arctangent of a number 

ATAN2 Returns the arctangent from x- and y-coordinates 

ATANH Returns the inverse hyperbolic tangent of a number 

CEILING Rounds a number to the nearest integer or to the nearest multiple of 
significance 

COMBIN Returns the number of combinations for a given number of objects 

COS Returns the cosine of a number 

COSH Returns the hyperbolic cosine of a number 

DEGREES Converts radians to degrees 

EVEN Rounds a number up to the nearest even integer 

EXP Returns e raised to the power of a given number 

FACT Returns the factorial of a number 

FACTDOUBLE Returns the double factorial of a number 

FLOOR Rounds a number down, toward zero 

GCD Returns the greatest common divisor 

INT Rounds a number down to the nearest integer 

LCM Returns the least common multiple 

LN Returns the natural logarithm of a number 

LOG Returns the logarithm of a number to a specified base 

LOG10 Returns the base-10 logarithm of a number 
 

Statistical functions 
 

FUNCTION DESCRIPTION 

AVEDEV Returns the average of the absolute deviations of data 
points from their mean 

AVERAGE Returns the average of its arguments 

AVERAGEA Returns the average of its arguments, including numbers, 
text, and logical values 

BETADIST Returns the beta cumulative distribution function 

BETAINV Returns the inverse of the cumulative distribution function 
for a specified beta distribution 

BINOMDIST Returns the individual term binomial distribution probability 

CHIDIST Returns the one-tailed probability of the chi-squared 
distribution 

CHIINV Returns the inverse of the one-tailed probability of the chi-
squared distribution 

CHITEST Returns the test for independence 

CONFIDENCE Returns the confidence interval for a population mean 

CORREL Returns the correlation coefficient between two data sets 

COUNT Counts how many numbers are in the list of arguments 

COUNTA Counts how many values are in the list of arguments 

COUNTBLANK Counts the number of blank cells within a range 

COUNTIF Counts the number of nonblank cells within a range that 
meet the given criteria 

 

Logical functions 
 

FUNCTION DESCRIPTION 

AND Returns TRUE if all of its arguments are TRUE 

FALSE Returns the logical value FALSE 

IF Specifies a logical test to perform 

NOT Reverses the logic of its argument 

OR Returns TRUE if any argument is TRUE 

TRUE Returns the logical value TRUE 

 
Lookup and reference functions 

 
FUNCTION DESCRIPTION 

ADDRESS Returns a reference as text to a single cell in a worksheet 

AREAS Returns the number of areas in a reference 

CHOOSE Chooses a value from a list of values 

COLUMN Returns the column number of a reference 

COLUMNS Returns the number of columns in a reference 

GETPIVOTDATA Returns data stored in a PivotTable 

HLOOKUP Looks in the top row of an array and returns the value of 
the indicated cell 

HYPERLINK Creates a shortcut or jump that opens a document stored 
on a network server, an intranet, or the Internet 

INDEX Uses an index to choose a value from a reference or array 

INDIRECT Returns a reference indicated by a text value 

LOOKUP Looks up values in a vector or array 

MATCH Looks up values in a reference or array 

OFFSET Returns a reference offset from a given reference 

ROW Returns the row number of a reference 

ROWS Returns the number of rows in a reference 

RTD Retrieves real-time data from a program that 
supports COM automation 

TRANSPOSE Returns the transpose of an array 

VLOOKUP Looks in the first column of an array and moves across the 
row to return the value of a cell 

 
Text functions 

 
FUNCTION DESCRIPTION 

ASC Changes full-width (double-byte) English letters or katakana within a 
character string to half-width (single-byte) characters 

BAHTTEXT Converts a number to text, using the ß (baht) currency format 

CHAR Returns the character specified by the code number 

CLEAN Removes all nonprintable characters from text 

CODE Returns a numeric code for the first character in a text string 

CONCATENATE Joins several text items into one text item 

DOLLAR Converts a number to text, using the $ (dollar) currency format 

EXACT Checks to see if two text values are identical 
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http://office.microsoft.com/en-us/excel-help/excel-functions-by-category-HP005204211.aspx 

 
Working with Basic Arguments 
 
Arguments must be enclosed in parentheses. Individual values or cell references inside the parentheses are separated by 
either colons or commas. 
 

 Colons create a reference to a range of cells.  
For example, =AVG(E19:E23) would calculate the average of the cell range E19 through E23. 

 Commas separate individual values, cell references, and cell ranges in the parentheses. If there is more than one 
argument, you must separate each argument by a comma.  
For example, =COUNT(C6:C14,C19:C23,C28) will count all the cells in the three arguments that are included in 
parentheses. 

 
To Create a Basic Function in Excel: 

 
 
Using AutoSum to select Common Functions: 
 
The AutoSum command allows you to automatically return the results for a range of cells for common functions like SUM and AVG. 

 

 
 
 

Function Library 

1. Select the cell where the answer will appear (F15, for 
example)  

2. Type the equal sign (=) and enter the function 
name (SUM, for example). 

 

3. Enter the cells for the argument inside the 
parenthesis. 

 
4. Press Enter and the result will appear. 

 

1. Select the cell where the answer will 
appear (E24, for example). 

2. Click on the Home tab. 

3. In the Editing group, click on 
the AutoSum drop-down arrow and 
select the function you desire (Average, 
for example). 

 

4. A formula will appear in the selected cell E24. If logically 
placed, AutoSum will select your cells for you. Otherwise, 
you will need to click on the cells to choose the argument 
you desire. 

 
5. Press Enter and the result will appear. 

 
The AutoSum command can also be accessed from 
the Formulas tab. 
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There are hundreds of functions in Excel, but only some will be useful for the kind of data you are working with. There is no need to 
learn every single function, but you may want to explore some of the different kinds to get ideas about which ones might be helpful to 
you as you create new spreadsheets. 

To Insert a Function from the Function Library: 

 
Insert Function Command 
 
The Insert Function command is convenient because it allows 
you to search for a function by typing a description of what you are 
looking for or by selecting a category to peruse. The Insert Function command can also be used to easily enter or select more than 
one argument for a function. 
 
Using the Insert Function command: 
 
In this example, we want to find a function that will count the total number 
of supplies listed in the Office Supply Order Log. The basic COUNT 
function only counts cells with numbers; we want to count the cells in the 
Office Supply column, which uses text. Therefore, we will need to find a 
formula that counts cells with text. 
 

1. Select the cell where the answer will appear (A27, for example) 

2. Click on the Formulas tab and select the Insert 

1. Select the cell where the answer will appear (I6, for 
example) 

2. Click on the Formulas tab. 

3. From the Function Library group, select 
the function category you desire. In this example, 
we will choose Date & Time. 

4. Select the desired function from the Date & Time 
drop-down menu. We will choose the 
NETWORKDAYS function to count the days between 
the order date and receive date in our worksheet. 

 

 

5. The Function Arguments dialog box will appear. 
Insert the cursor in the first field and then enter or 
select the cell(s) you desire (G6, for example). 

 
 

6. Insert the cursor in the next field and then enter or 
select the cell(s) you desire (H6, for example). 

 
 

7. Click OK and the result will appear. Our results 
show that it took 5 days to receive the order. 
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Function command. 
3. The Insert Function dialog box will appear. 
4. Type a description of the function you are searching for and click Go. For our example, we will type: Count cells with text. 

(You may also search by selecting a category.) 

 
5. Review the results to find the function you desire. We will use COUNTA. Then click OK. 

 
6. The Function Arguments dialog box will appear. Insert the cursor in the first field and then enter or select the cell(s) you desire 

(A6:A14, for example). 

 
7. Insert the cursor in the next field and then enter or select the cell(s) you desire (A19:A23, for example). (You may continue to add 

additional arguments if needed.) 
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8. Click OK and the result will appear. Our results show that 14 Total Supplies were ordered from our log. 
 

VLOOKUP Function 
 
Excel VLOOKUP function can be used when you need to look up the values in the specific table and check it against the other data 
fields for comparison purpose. VLOOKUP stands for Vertical lookup, used to find specific data from the datasheet. By creating a 
sample table generally referred as lookup table you can extract info from it and compare it with the desired field to yield required 
results. This post elaborates where you can use VLOOKUP function. Launch Excel 2010, and open a datasheet on which you want to 
apply VLOOKUP function. For instance, we have included a student grading datasheet, containing fields; Name, Course, and 
Marks. 

 

 

Now in the Grade first row, we will write VLOOKUP function. The syntax of this function is 
VLOOKUP(lookup_value, table_array, col_index_num, [range_lookup] ) 
The first parameter of the formula lookup_value defines the value of the number which we will be looking in the newly created table. 
We need to lookup the value 80 (Marks field) in the newly created table. The next parameter, table_array defines the table we will be 
referring to in our case it will be newly created table, containing ranges of marks and grades. col_index_num defines data from which 
column we want to extract values to show, in our case it is the second column that contain grades range. [range_lookup] lets you to 
choose an option either TRUE (approximately matching of values) or FALSE (Exact matching of values). 
We will write this function in Grade first row, it will go like this; 
=VLOOKUP(C2,$F$3:$G$8,2,TRUE) 
In the formula parameters, C2 is cell of column Marks which contain marks secured by students, F3:G8 is the location of the newly 
created table, containing ranges of marks and grades (use absolute referencing with $ sign), 2 in the formula means that values from 
second column will appear, and TRUE defines that we need approximately match as we have included ranges not exact values. 
After evaluating formula, it will show grade A in Grade column as shown in the screen shot below. 

 

Now we will add new column Grade, which will contain 
grades secured by the students. Now for this, we will be 
using VLOOKUP function for looking up values from 
other table that contains sample data for grades. 
Create two new columns containing marks range 
(sorted in any order) and corresponding grades. you 
don’t need to create them in a new worksheet, you can 
place anywhere in the existing datasheet as we just 
want to get values from it. 
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Now apply this function over the whole Grade column, drag the plus sign towards the end of Grade column to apply it over, as 
show in the screen shot below. 
 

Now we also want to calculate the prize money for each student. for 
instance, we assume the following criteria. 

For grade A  $1000 

For grade B+ $700 

For grade B   &600 

For grade C+ $250 

For grade D   N/A 

The criteria defined contains the exact value, so we will be making a 
small change in the parameters of the function. we will be choosing 
FALSE from [range_lookup] instead of TRUE as we want to show the 
exact match. 

D2 contains the grade secured by students, so it will check the value 
in Grade column against the newly created columns, containing prize money criteria, as shown in the screenshot below. 
 

 
 

Now apply the function in Prize Money column to view the prize money won by each student. Now as you can see in the 
screenshot below that by using VLOOKUP function it is easier to look up specific values for populating new fields by 
connecting different columns. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

___________________________________ 
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Lesson: 7  
 

 Data Sorting, Outlining & Filteringi 
 
 
Sorting Data 
 
With over 17 billion cells in a single worksheet, Excel 2010 gives you the ability to work with an enormous amount of data. Arranging 
your data alphabetically, from smallest to largest, or other criteria, can help you find the information you're looking for more quickly. 
Sorting is a common task that allows you to change or customize the order of your spreadsheet data. For example, you could 
organize an office birthday list by employee, birthdates, or department, making it easier to find what you're looking for. Custom sorting 
takes it a step further, giving you the ability to sort multiple levels (such as department first, then birthdate, to group birthdates by 
department), and more. 

 
 

To Sort in Alphabetical Order: 
 

1. Select a cell in the column you want to sort by. In 
this example, we will sort by Last Name. 

 
2. Select the Data tab, and locate the Sort and 

Filter group. 

3. Click the ascending command  to Sort A to Z, 

or the descending command  to  Sort Z to A. 

 
 

4. The data in the spreadsheet will be organized 
alphabetically. 

 
 
Sorting options can also be found on the Home tab, 
condensed into the Sort & Filter command 

To Sort in Numerical Order: 
 

1. Select a cell in the column you want to sort by. 

 
 

2. From the Data tab, click the ascending 
command  to Sort Smallest to Largest, or the 
descending command to Sort Largest to Smallest. 

3. The data in the spreadsheet will be organized 
numerically. 

 
 
To Sort by Date or Time: 
 

1. Select a cell in the column you want to sort by. 

 
 

2. From the Data tab, click the ascending 
command  to Sort Oldest to Newest, or the 
descending command  to Sort Newest to Oldest. 

3. The data in the spreadsheet will be organized by 
date or time. 
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Custom Sorting 
 
To Sort in the Order of Your Choosing: 

 
You can use a Custom List to identify your own sorting order, such as days of the week, or, in this 
example, t-shirt sizes from smallest to largest (Small, Medium, Large, and X-Large). 

1. From the Data tab, click the Sort command to open the Sort dialog box. 
2. Identify the column you want to Sort by by clicking the drop-down arrow in 

the Column field.  
3. Make sure Values is selected in the Sort On field. 
4. Click the drop-down arrow in the Order field, and choose Custom List... 
5. Select NEW LIST, and enter how you want your data sorted in the List entries box. We 

will sort t-shirt sizes from smallest to largest. 
6. Click Add to save the list, then click OK. 
7. Click OK to close the Sort dialog box and sort your data. 
8. The spreadsheet will be sorted in order of Small, Medium, Large, and X-Large. 

 

To Sort by Cell Color, Font Color, or Cell Icon: 
 

1. From the Data tab, click the Sort command to open the Sort dialog box. 
2. Identify the column you want to Sort by by clicking the drop-down arrow in the Column field. 
3. Choose whether you want to sort by Cell Color, Font Color, or Cell Icon in the Sort On field. In this example, will sort 

on Font Color. 
4. In the Order field, click the drop-down arrow to choose a color, then decide whether you want it ordered On Top or On 

Bottom. 
5. Click OK. The data is now sorted by attribute rather than text. 

 
Sorting Multiple Levels 
 
Another feature of custom sorting, sorting multiple levels allows you to identify which columns to sort by and when, giving you more 
control over the organization of your data. For example, you could sort by more than one cell color (such as red, then yellow, then 
green, to indicate different levels of priority); or, as seen here, sort students by homeroom number, then by last name. 
 
To Add a Level: 
 

1. From the Data tab, click the Sort command to open the Sort dialog box. 
2. Identify the first item you want to Sort by. 
3. Click Add Level to add another item. 
4. Identify the item you want to sort by next. We will sort Last Name from A to Z. 

5. Click OK. 
6. The spreadsheet will be sorted so that homeroom numbers are in order, and within each homeroom, students are listed 

alphabetically by last name.  

Copy Level will add a level by duplicating the one you have selected, and allowing you to modify the sorting criteria. This is 
useful if you need to sort multiple levels that share some criteria, such as the same Column, Sort On, or Order. 

 
To Change the Sorting Priority: 
 

1. From the Data tab, click the Sort command to open the Custom Sort dialog box. 
2. Select the level you want to re-order. 
3. Use the Move Up or Move Down arrows. The higher the level is on the list, the higher its priority. 
4. Click OK. 

 
 

 Outlining Datai 
 
If the amount of data in your worksheet becomes overwhelming, creating an outline can help. Not only does this allow you to organize 
your data into groups, and then show or hide them from view; you can also summarize data for quick analysis using the Subtotal 
command (for example, subtotaling the cost of office supplies depending on the type of product). 
 
Outlines give you the ability to group data that you may want to show or hide from view, and create a quick summary using the 
Subtotal command. Because outlines rely on grouping data that is related, you must sort before you can outline. 
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To Outline Data Using Subtotal: 
 
The Subtotal command can be used to outline your worksheet in many different ways. It uses common functions like SUM, COUNT, 
AVG, and more, to summarize your data, and place it in a group. 
In this example, we will use the Subtotal command to count the number of t-shirt sizes that were ordered at a local high school. This 
will also place each t-shirt size in a group, making it possible to show the count, but hide the details that are not crucial to the placing 
of the order (such as the student's homeroom number and payment date). 
 

1. Sort according to the data you want to outline. 
Outlines rely on grouping data that is related. In 
this example, we will outline the worksheet by T-
Shirt Size, which has been sorted from smallest 
to largest. 

 
2. Select the Data tab, and locate 

the Outline group. 
3. Click the Subtotal command to open the 

Subtotal dialog box. 

 
4. In the At each change in field, select the 

column you want to use to outline your 
worksheet. In this example, we will choose T-
Shirt Size. 

5. In the Use function field, choose from the list of 
functions that are available for subtotaling. We 
will use the COUNT function to tally the number 
of each size. 

       6.     Select the column you want the subtotal to appear 
in. We will choose the T-Shirt Size column. 

7. Click OK. 

 
8. The contents of your worksheet will be outlined. 

Each t-shirt size will be placed in its own group, 
and the subtotal (in this case, count) will be listed 
below each group. 
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To Ungroup Data: 
 

1. Select the rows or columns that you want to 
ungroup.. 

2. From the Data tab, click the Ungroup command. 
The range of cells will be ungrouped. 

3. To ungroup all the groups in your outline, open the 
drop-down menu under the Ungroup command, 
and choose Clear Outline. 

Ungroup and Clear Outline will not remove subtotaling from 
your worksheet. Summary or subtotal data will stay in place 
and continue to function until you remove it. 
  
To Ungroup Data and Remove Subtotaling: 

1. From the Data tab, click the Subtotal command to 
open the Subtotal dialog box. 

2. Click Remove All. 
3. All data will be ungrouped, and subtotals will be 

removed. 
 

Creating Your Own Groups 
 

The Group command allows you to group any 
range of cells - either columns or rows. It does not 
calculate a subtotal, or rely on your data being 
sorted. This gives you the ability to show or hide any 
part of your worksheet, and display only the 
information you need. 

 
To Create and Control Your Own Group: 

In this example, we will prepare a list of t-shirt colors 
and sizes that need to be distributed to each 
homeroom. Some of the data in the worksheet is not 
relevant to the distribution of the t-shirts; however, 
instead of deleting it, we will group it, then 
temporarily hide it from view. 
 

1. Select the range of cells that you want to group. In 
this example, we will group the First Name, Last 
Name, and Payment columns. 

 
2. From the Data tab, click the Group command. 
3. Excel will group the selected columns or rows. 

4. Click the minus sign, also known as the Hide 
Detail symbol, to hide the group. 

5. The group will be hidden from view. 

Click the plus sign, also known as the Show Detail symbol, to 
show the group again. 

To Show or Hide a Group: 
 

1. Click the minus sign, also known as the Hide 
Detail symbol, to collapse the group. 

 
2. Click the plus sign, also known as the Show 

Detail symbol, to expand the group again. 

 
You can also use the  or  commands on the Data tab in the 
Outline group. First select a cell in the group you want to show 
or hide, then click the appropriate command. 
 
To View Groups by Level: 
 
The groups in your outline, based on their hierarchy, are 
placed on different levels. You can quickly display as little or 
as much information as you want by clicking the level 
symbols  to the left of your worksheet. In this example, we will 
view levels in descending order, starting with the entire 
worksheet on display, then finishing with the grand total. While 
this example contains only 3 levels, Excel can accommodate 
up to 8. 

1. Click the highest level (in this example, level 3) to view 
and expand all of your groups. Viewing groups at the 
highest level will display the entirety of your worksheet. 

2. Click the next level (in this example, level 2) to hide the 
detail of the previous level. In this example, level 2 
contains each subtotal. 

3. Click the lowest level (level 1) to display the lowest 
level of detail. In this example, level 1 contains only the 
grand total. 
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 Filtering Datai 
 
 

 
 

6. The Filter menu appears. 
7. Uncheck the boxes next to the data you don't want to 

view. (You can uncheck the box next to Select All to 
quickly uncheck all.) 

8. Check the boxes next to the data you do want to view. In 
this example, we will check Laptop and Projector to view 
only those types of equipment. 

 
9. Click OK. All other data will be filtered, or temporarily 

hidden. Only laptops and projectors will be visible. 

 
Filtering options can also be found on the Home tab, condensed 
into the Sort & Filter command. 
  

Filters can be used to narrow down the data in your 
worksheet and hide parts of it from view. While it may sound 
a little like grouping, filtering is different in the way that it 
allows you to qualify and display only the data that interests 
you. For example, you could filter a list of survey participants 
to view only those who are between the ages of 25-34. You 
could also filter an inventory of paint colors to view anything 
that contains the word "blue," such as "bluebell" or "robin's 
egg blue." 
Filters can be applied in many different ways to improve the 
performance of your worksheet. You can filter text, dates, 
and numbers. You can even use more than one filter to 
further narrow down your results. 
 
To Filter Data: 
 
In this example, we will filter the contents of an equipment 
log at a technology company. We will display only the 
laptops and projectors that are available for check-out. 
 

1. Begin with a worksheet that identifies each column 
using a header row. 

 
2. Select the Data tab, and locate the Sort & 

Filter group. 
3. Click the Filter command. 

 
 

4. Drop-down arrows will appear in the header of 
each column. 

5. Click the drop-down arrow for the column you 
would like to filter. In this example, we will filter the 
Type column to view only certain types equipment. 
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To Add Another Filter: 
 
Filters are additive, meaning you can use as many as you need to narrow down your results. In this example, we will work with a 
spreadsheet that has already been filtered to display only laptops and projectors. Now we will display only laptops and projectors that 
were checked out during the month of August. 
 

1. Click the drop-down arrow where you would like to add a filter.  
2. Uncheck the boxes next to the data you don't want to view. Check the boxes next to the data you do want to view. 
3. Click OK. In addition to the original filter, the new filter will be applied. The worksheet will be narrowed down even further. 

 
To Clear a Filter: 
 

1. Click the drop-down arrow in the column from which you want to clear the filter. 
2. Choose Clear Filter From... 
3. The filter will be cleared from the column. The data that was previously hidden will be on display once again. 

To instantly clear all filters from your worksheet, click the Filter command on the Data tab. 
 
Advanced Filtering 
 
To Filter Using Search: 

 
Searching for data is a convenient alternative to checking or unchecking data from 
the list. You can search for data that contains an exact phrase, number, or date, or 
a simple fragment. For example, searching for the exact phrase "Saris X-10 
Laptop" will display only Saris X-10 Laptops. Searching for the word "Saris," 
however, will display Saris X-10 Laptops, and any other Saris equipment, including 
projectors, digital cameras, and more. 

1. From the Data tab, click the Filter command. 
2. Click the drop-down arrow in the column you would like to filter. In this 

example, we will filter the Equipment Detail column to view only a specific 
brand. 

3. Enter the data you would like to view in the Search box. We will enter the 
word "Saris" to find all Saris brand equipment. The search results will 
appear automatically. 

4. Check the boxes next to the data you want to display. We will display all 
the data that includes the brand name Saris. 

5. Click OK. The worksheet will be filtered according to your search term.   
 
 

To Use Advanced Text Filters: 
 
Advanced text filters can be used to display more specific information, such as cells that 
contain a certain number of characters, or data that does not contain a word you 
specify. In this example, we will use advanced text filters to hide any equipment that is 
related to cameras, including digital cameras, camcorders, and more. 

1. From the Data tab, click the Filter command. 
2. Click the drop-down arrow in the column of text that you would like to filter. In this 

example, we will filter the Equipment Detail 
column to view only certain kinds of equipment. 

3. Choose Text Filters to open the advanced filtering 
menu. 

4. Choose a filter. In this example, we will 
choose Does Not Contain to view data that does 
not contain the text we specify. 

5. The Custom AutoFilter dialog appears. 
6. Enter your text to the right of your filter. In this 

example, we will enter "cam" to view data that 
does not contain those letters. That will exclude 
any equipment related to cameras, such as digital cameras, camcorders,camera 
bags, and the digicam printer. 

7. Click OK. The data will be filtered according to the filter you chose and the text you 
specified. 
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To Use Advanced Date Filters: 
 
Advanced date filters can be used to view information from a certain time period, such as last year, next quarter, between two dates, 
and more. Excel automatically knows your current date and time, making this tool very easy to use. In this example, we will use 
advanced date filters to view only the equipment that has been checked out this week. 
 

1. From the Data tab, click the Filter command. 
2. Click the drop-down arrow in the column of dates that you would like to filter. In this example, we will filter the Checked Out 

column to view only a certain range of dates. 
3. Choose Date Filters to open the advanced filtering menu. 
4. Click a filter. We will choose This Week to view equipment that has been checked out this week. 
5. The worksheet will be filtered according to the date filter you chose. 

                                                                                                 

 
 
 
 

 
To Use Advanced Number Filters: 
 
Advanced number filters allow you to manipulate numbered data in many different ways. For example, in a worksheet of exam 
grades, you could display the top and bottom numbers to view the highest and lowest scores. In this example, we will display only 
certain kinds of equipment based on the range of ID #s that have been assigned to them.  

1. From the Data tab, click the Filter command. 
2. Click the drop-down arrow in the column of numbers that you would like to filter. In this example, we will filter the ID # 

column to view only a certain range of ID #s. 
3. Choose Number Filters to open the advanced filtering menu. 
4. Choose a filter. In this example, we will choose Between to view ID #s between the numbers we specify. 
5. Enter a number to the right of each filter. In this example, we will view ID #s greater than or equal to 3000, but less than or 

equal to 4000. That will display ID #s in the 3000-4000 range. 
6. Click OK. The data will be filtered according to the filter you chose and the numbers you specified. 
 

            
 
 
 
 
 
 
 
 
 

 
________________________________ 
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Lesson: 8  
 

 Table, Chart, Sparklines & Templatesi 
 
Once you have entered information into a spreadsheet, you may want to format it. Formatting your spreadsheet can not only improve 
the look and feel, but also make it easier to use. 

 
4. A dialog box will appear, confirming the range of cells 

you have selected for your table. The cells will appear 
selected in the spreadsheet, and the range will appear in 
the dialog box. 

5. If necessary, change the range by selecting a new range 
of cells directly on your spreadsheet. 

 
6. If your table has headers, check the box next to My table 

has headers.  
7. Click OK. The data will be formatted as a table in the 

style that you chose. 
 

 
 
Tables include filtering by default. You can filter your data at any 
time using the drop-down arrows in the header. To convert a 
table back into "normal" cells, click the Convert to 
Range command in the Tools group. The filters and the Design 
tab will then disappear, but the cells will retain their data and 
formatting. 
 

To Format Information as a Table: 
 

1. Select the cells you want to format as a table. In 
this example, an invoice, we will format the cells 
that contain the column headers and the order 
details. 

 
2. Click the Format as Table command in 

the Styles group on the Home tab.  
 

 
 

3. A list of predefined table styles will appear. Click 
a table style to select it.  
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Modifying Tables 
 
To Add Rows or Columns: 

1. Select any cell in your table. The Design tab will appear on the Ribbon. 
2. From the Design tab, click the Resize Table command. 
3. Directly on your spreadsheet, select the new range of cells that you want your table to cover. You must select your original 

table cells as well. 
4. Click OK. The new rows and/or columns will be added to your table. 

 
To Change the Table Style: 

1. Select any cell in your table. The Design tab will appear. 
2. Locate the Table Styles group. Click the More drop-down arrow to see all of the table styles. 
3. Hover the mouse over the various styles to see a live preview. 

4. Select the desired style. The table style will appear in your worksheet. 

To Change the Table Style Options: 
When using an Excel table, you can turn various options on or off to change its appearance. There are six options: Header 
Row, Total Row, Banded Rows, First Column, Last Column, and Banded Columns. 

1. Select any cell in your table. The Design tab will appear. 
2. From the Design tab, check or uncheck the desired options in the Table Style Options group. 

Depending on the Table Style you're using, certain Table Style Options may have a different effect. You may need 
to experiment to get the exact look you want. 

 
 Working with Chartsi 

 
A chart is a tool you can use in Excel to communicate your data graphically. Charts allow your audience to see the meaning behind 
the numbers, and they make showing comparisons and trends a lot easier. In this lesson, you will learn how to insert charts 
and modify them so that they communicate information effectively. 
Excel workbooks can contain a lot of data, and that data can often be difficult to interpret. For example, where are the highest and 
lowest values? Are the numbers increasing or decreasing? The answers to questions like these can become much clearer when the 
data is represented as a chart. Excel has many different types of charts, so you can choose one that most effectively represents the 
data. 

 

 
 

5. The chart will appear in the worksheet. 

 

To Create a Chart: 
 

1. Select the cells that you want to chart, including the column 
titles and the row labels. These cells will be the source 
data for the chart. 

 
2. Click the Insert tab. 
3. In the Charts group, select the desired chart 

category (Column, for example). 

 
4. Select the desired chart type from the drop-down menu 

(Clustered Column, for example). 
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Chart Tools 
 
Once you insert a chart, a set of Chart Tools, arranged into three tabs, will appear on the Ribbon. 
These are only visible when the chart is selected. You can use these three tabs to modify your 
chart. 
 

 

To Change the Chart Type: 
1. From the Design tab, click the Change Chart Type command. A dialog box appears. 
2. Select the desired chart type and click OK. 

 
To Switch Row and Column Data: 
Sometimes when you create a chart, the data may not be grouped the way you want it to be. In the clustered column chart below, 
the Book Sales statistics are grouped by Fiction/Non-Fiction, with a column for each year. However, you can also switch the row 
and column data so that the chart will group the statistics by year, with columns for Fiction and Non-Fiction. In both cases, the chart 
contains the same data; it's just organized differently. 

1. Select the chart. 
2. From the Design tab, select the Switch Row/Column command. 
3. The chart will then readjust. 

To Change the Chart Layout: 
1. Select the Design tab. 
2. Click the More drop-down arrow in the Chart Layouts group to see all of the available layouts. 
3. Select the desired layout. 
4. The chart will update to reflect the new layout. 

Some layouts include chart titles, axes, or legend labels. To change them, just place the insertion point in the text and 
begin typing. 

 
To Change the Chart Style: 

1. Select the Design tab. 
2. Click the More drop-down arrow in the Chart Styles group to see all of the available styles. 
3. Select the desired style. 
4. The chart will update to reflect the new style. 

 
To Move the Chart to a Different Worksheet: 

1. Select the Design tab. 
2. Click the Move Chart command. A dialog box appears. The current location of the chart is selected. 
3. Select the desired location for the chart (i.e., choose an existing worksheet, or select New Sheet and name it). 
4. Click OK. The chart will appear in the new location. 

 
 Working with Sparklinesi 

 
 

Sparklines are miniature charts that fit into a single cell. Since they're so compact, you can place a large number of them in your 
worksheets. For example, you could place one sparkline on each row to show trends within that row. In this lesson, you will learn how 
to insert sparklines and change their type and appearance. 
Sparklines were introduced in Excel 2010 to be a convenient alternative to charts. Unlike a traditional chart, a sparkline is placed 
inside a cell, allowing you to easily create a large number of sparklines (for example, one on each row). 
 
Types of Sparklines 
 
There are three different types of sparklines: Line, Column, 
and Win/Loss. Line and Column work the same as line and 
column charts. Win/Loss is similar to Column, except it only shows whether each 
value is positive or negative, instead of how high or low the values are. All three 
types can display markers at important points, such as 
the highest and lowest points, to make them easier to read. 
 
Why Use Sparklines? 
 
Sparklines are basically charts, so why would you want to use sparklines instead of charts? Sparklines have certain advantages that 
make them more convenient in many cases. Imagine you have 1000 rows of data. If you place a sparkline on each row, it will be right 
next to its source data, making it easy to see the relationships between the numbers and the sparkline. If you used a traditional chart, 

 
Line 

 
Column 

 
Win/Loss 
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it would need to have 1000 data series in order to represent all of the rows, and you would probably need to do a lot of scrolling to find 
the relevant data in the worksheet. 
Sparklines are ideal for situations where you just want to make the data clearer and more eye-catching, and where you don't need all 
of the features of a full chart. On the other hand, charts are ideal for situations where you want to represent the data in greater detail, 
and they are often better for comparing different data series. 
 

6.   Click OK. The sparkline will appear in the document. 
7.   Click and drag the fill handle downward. 

 
8. Sparklines will be created for the remaining rows. 

 
To Show Points on the Sparkline: 
Certain points on the sparkline can be emphasized 
with markers, or dots, making the sparkline more readable. 
For example, in a line with a lot of ups and downs, it may be 
difficult to tell which ones are the highest and lowest points, 
but if you show the High Point and Low Point, it will be easy to 
identify them. 

1. Select the sparklines that you want to change. If 
they are grouped, you only need to select one of 
them. 

2. Locate the Show group in the Design tab. 
3. Hover over the different checkboxes to see a 

description of each one. 

 
4. Check each option that you want to show. The 

sparklines will update to show the selected options. 

To Change the Style: 
1. Select the sparklines that you want to change. 
2. Locate the Style group in the Design tab. 
3. Click the More drop-down 

arrow to show all of the 
available styles. 

4. Select the desired style. 
5. The sparklines will update 

to show the selected style. 
 

To Change the Sparkline Type: 
1. Select the sparklines that you want to change. 
2. Locate the Type group in the Design tab. 
3. Select the desired type (Column, for example). 
4. The sparkline will update to reflect the new type. 

Some sparkline types will be better or worse for certain types 
of data. For example, Win/Loss is best suited for data where 
there may be positive and negative values (such as net 
earnings). 

To Create Sparklines: 
 
Generally, you will have one sparkline for each row, but you can 
create as many as you want in any location you want. Just like 
with formulas it's usually easiest to create a single sparkline and 
then use the fill handle to automatically create the sparklines for 
the remaining rows. 

1. Select the cells that you will need for the first 
sparkline. In this example, we are creating a sparkline 
for Kathy Albertson, so we will select her sales data. 

 

 
 
2. Click the Insert tab. 
3. In the Sparklines group, select Line. A dialog box will 

appear. 
 

 
 
4. Make sure the insertion point is next to Location 

Range. 
5. Click the cell where you want the sparkline to be. In 

this example, we'll select the cell to the right of the 
selected cells. 
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Changing the Display Range 
By default, each sparkline is scaled to fit the maximum and minimum values of its own data. This allows it to fill the entire 
cell no matter how high or low the values are. However, it has a downside: if you are trying to compare several sparklines, 
you won't be able to tell at a glance which ones have higher or lower values. The solution is to make the display range the 
same for all of the sparklines. 
 

 To Change the Display Range: 
1. Select the sparklines that you want to change. 
2. In the Design tab, click the Axis command. A drop-down menu will appear. 
3. Under Vertical Axis Minimum Value Options and Vertical Axis Maximum Value Options, select Same for All 

Sparklines. 
4. The sparklines will update to reflect the new range. 

 

 Using Templatesi 
 
In Excel 2010, you have many templates that can save you a lot of time. A template is a pre-designed spreadsheet that you can use 
to create new spreadsheets with the same formatting and predefined formulas. With templates, you don't need to know how to do the 
math, or even how to write formulas - these are already integrated into the spreadsheet. 
In this lesson, you will learn how to create a new workbook with a template, as well as basic information about how templates work in 
Excel 2010. Excel allows you to create new workbooks using templates, or a predefined pattern. Several templates are preloaded in 
Excel and others are located on Microsoft Office Online. 

 
6.  A new workbook will appear using the template you   
chose. 
 

 
 

________________________________ 
 

To Create a New Workbook Using a Template: 
 

1. Click the File tab to go to Backstage view. 
2. Select New. The Available Templates pane appears. 
3. Click Sample templates to choose a built-in template, or 

select an Office.com template category to download a 
template. In this example, we will download a template from 
Office.com. 

 

 
 
4. Thumbnail images of the templates you have to choose from 

appear in the center. A larger preview appears on the right. 

5. Select the desired template, then click Download to open it. (If 
using a Sample template, Download will be replaced 
by Create.) 
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Lesson: 9  
 

 Conditional Formatting, Pivot Table & What-if Analysisi 
 
 
Using Conditional Formatting 

 
Imagine you have a spreadsheet with thousands of rows of data. It would be extremely difficult to see patterns and trends just from 
examining the raw data. Excel gives us several tools that will make this task easier. One of these tools is called conditional formatting. 
With conditional formatting, you can apply formatting to one or more cells based on the value of the cell. You can highlight 
interesting or unusual cell values, and visualize the data using formatting such as colors, icons, and data bars. 
Conditional formatting applies one or more rules to any cells that you want. An example of a rule might be "If the value is greater 
than 5,000, color the cell yellow." By applying this rule to the cells in a worksheet, you'll be able to see at a glance which cells are over 
5,000. There are also rules that can mark the top 10 items, all cells that are below the average, cells that are within a certain date 
range, and many more. 

 

Conditional Formatting Presets 
 
Excel has a number of presets that you can use to quickly apply 
conditional formatting to your cells. They are grouped into three 
categories: 
 Data Bars are horizontal bars added to each cell, much like a bar 

graph. 

 
 Color Scales change the color of each cell based on its value. 

Each color scale uses a two or three color gradient. For 
example, in the Green - Yellow - Red color scale, 
the highest values are green, average values are yellow, and 
the lowest values are red. 

 
 Icon Sets add a specific icon to each cell based on its value. 

 
 

To Use Preset Conditional Formatting: 
 

1. Select the cells you want to add the formatting to. 
2. In the Home tab, click the Conditional 

Formatting command. A drop-down menu will appear. 
3. Select Data Bars, Color Scales or Icon Sets (Data Bars, 

for example). Then, select the desired preset. 
4. The conditional formatting will be applied to the selected 

cells. 

     

To Create a Conditional Formatting Rule: 
 
1. Select the cells that you want to add the formatting to. 
2. In the Home tab, click the Conditional 

Formatting command. A drop-down menu will appear. 
3. Select Highlight Cells Rules or Top/Bottom Rules. We 

will choose Highlight Cells Rules for this example. A menu 
will appear with several rules. 

4. Select the desired rule (Greater Than, for example). 

 
5. From the dialog box, enter a value in the space provided, if 

applicable. In this example, we want to format cells that are 
greater than $5,000, so we'll enter 5000 as our value. If 
you want, you can enter a cell reference instead of a 
number. 

6. Select a formatting style from the drop-down menu. 

 
7. The formatting will be applied to the selected cells. 

 
 
If you want, you can apply more than one rule to your cells. 
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To Remove Conditional Formatting Rules: 
1. Select the cells that have conditional formatting. 
2. In the Home tab, click the Conditional Formatting command. A drop-down menu will appear. 
3. Select Clear Rules. 
4. A menu will appear. You can choose to clear rules from the Selected Cells, Entire Sheet, This Table, or This PivotTable. 

In this example, we will clear rules from the entire sheet. 
You can edit or delete individual rules by clicking on the Conditional Formatting command and selecting Manage Rules. 
This is especially useful if you have applied multiple rules to the cells. 

 

 
 Creating PivotTablesi 

 
PivotTable reports (or, simply PivotTables) make the data in your worksheets much more manageable by summarizing the data 
and allowing you to manipulate it in different ways. PivotTables can be an indispensable tool when used with large, complex 
spreadsheets, but they can be used with smaller spreadsheets as well. 
When you have a lot of data, it can sometimes be difficult to analyze all of it. A PivotTable summarizes the data, making it easier to 
manage. Best of all, you can quickly and easily change the PivotTable to see the data in a different way, making this an extremely 
powerful tool. 
 
Using PivotTables to Answer Questions 
 
The example below contains sales statistics for a fictional company. There is a row for each order, and it includes the order amount, 
the name of the salesperson who made the sale, the month, the sales region, and the customer's account number. 
  

Suppose we wanted to answer the question, "What is the amount sold by each 
salesperson?" This could be time-consuming, as each salesperson appears on multiple 
rows, and we would need to add up all of the order amounts for each salesperson. Of 
course, we could use the Subtotal feature to add 
them, but we would still have a lot of data to sift 
through. 
Luckily, a PivotTable can instantly do all of the 
math for us and summarize the data in a way that's 
not only easy to read, but easy to manipulate. 
When we're done, the PivotTable will look 
something like this:- 
As you can see, the PivotTable is much easier to 
read. It only takes a couple of steps to create one, 
and once you create it you'll be able to take 
advantage of the PivotTable's powerful features. 

 
 
5.   A blank PivotTable will appear on the left, and the Field List will       
appear on the right 
 

 

To Create a PivotTable: 
 

1. Select the table or cells (including column 
headers) containing the data you want to 
use. 

2. From the Insert tab, click 
the PivotTable command. 

 
3. The Create PivotTable dialog box will 

appear. Make sure the settings are correct, 
and then click OK. 
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To Add Fields to the PivotTable: 
 

       To Change the Row Labels: 
 

1. Drag any existing fields out of the Row 
Labels area, and they will disappear. 

 

 
 

2. Drag a new field from the Field List into the Row 
Labels area. In this example, we're using 
the Month field. 

 

 
 

3. The PivotTable will adjust to show the new data. 
In this example, it now shows us the total Order 
Amount for each month. 

 

 
 

Now, you'll need to decide which fields to add to the PivotTable. 
Each field is simply a column header from the source data. It 
may be helpful to recall the question that you are trying to 
answer. In this example, we want to know the total amount sold 
by each salesperson, so we'll just need the Order 
Amount and Salesperson fields. 
 

1. In the Field List, place a check mark next to each field 
you want to add. 

2. The selected fields will be added to one of the 
four Areas below the Field List. In this example, the 
Salesperson field is added to the Row Labels area, 
and the Order Amount is added to the Values area. If 
a field is not in the desired area, you can drag it to a 
different one. 

3. The PivotTable now shows the amount sold by 
each salesperson. 

 

 
 

Just like with normal spreadsheet data, you can sort the data in a 
PivotTable using the Sort & Filter command in the Home tab. 
You can also apply any type of formatting that you want. For 
example, you may want to change the Number 
Format to Currency. However, be aware that some types of 
formatting may disappear when you modify the PivotTable. 
 
Pivoting Data 
 
One of the best things about PivotTables is that they let you 
"pivot" the data in order to look at it in a different way. This allows 
you to answer multiple questions and even experiment with the 
data to learn new things about it. 
In our example, we used the PivotTable to answer the question 
"What is the total amount sold by each salesperson?" But now 
we'd like to answer a new question, such as "What is the total 
amount sold in each month?" We can do this by simply changing 
the Row Labels 
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To Add Column Labels: 
 

 

 
     
4.     Click OK. The PivotTable will adjust to reflect the changes. 

 
  
Slicers 
 
Slicers were introduced in Excel 2010 to make filtering 
data easier and more interactive. They're basically just report filters, 
but they're more interactive and faster to use, as they let you quickly 
select items and instantly see the result. If you filter your PivotTables 
a lot, you might want to use slicers instead of report filters. 
 
To Add a Slicer: 

1. Select any cell in your PivotTable. The Options tab will 
appear on the Ribbon. 

2. From the Options tab, click the Insert Slicer command. A 
dialog box will appear. 

 
3. Select the desired field. In this example, we will 

select Salesperson. Then click OK. 

 
4. The Slicer will appear next to the PivotTable. Each item 

that is selected will be highlighted in blue. In the example 
below, the Slicer contains a list of all of the different 
salespeople, and four of them are currently selected. 

So far, our PivotTable has only shown one column of data 
at a time. In order to show multiple columns, you'll need to 
add Column Labels. 

1. Drag a field from the Field List into the Column 
Labels area. In this example, we're using 
the Region field. 

 
2. The PivotTable will now have multiple columns. 

In this example, there is a column for 
each region. 

 
 
Report Filters 
 
Sometimes you may want focus on just a portion of the 
data and filter out everything else. In our example, we're 
going to focus on certain salespeople, to see how they 
affect the total sales. 
 
To Add a Report Filter: 
 

1. Drag a field from the Field List into the Report 
Filter area. In this example, we're using 
the Salesperson field. 

 
2. The report filter appears above the PivotTable. 

Click the drop-down arrow on the right side of 
the filter to view the list of items. 

3. Select the item that you wish to view. If you want 
to select more than one item, place a checkmark 
next to Select Multiple Items. Then click OK. In 
the example below, we are selecting five 
salespeople. 
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(A slicer with four selected items) 

Pivot Charts 
 

Using What-If Analysis 
 
The real power in Excel comes in its ability to perform multiple 
mathematical calculations for you. One of the tools in Excel that 
you can use to perform these calculations is a Data 
tool called What-If Analysis. What-If analysis allows you to see the 
effect that different values have in formulas. Have you ever 
thought, "What interest rate do I need to qualify for to have a car 
payment of $400 on the car I want?" This question can be 
answered using What-If Analysis.  
 
What-If Analysis 
 
In many worksheets, there may be some cells whose values are 
unknown, or you may just want to change certain cells to see what 
the outcome is. What-if analysis is perfect for these situations. It 
allows you to experiment and answer questions with your data, 
even when the data is incomplete. 
 
Goal Seek 
 
Goal Seek is a type of what-if analysis that is useful if you know 
the desired result, but need to find the input value that will give you 
that result. For example, suppose you need a loan to buy a new 
car. You already know that you want a loan amount of $20,000, a 
60-month term (the length of time it takes to pay off the loan), and 
a payment of no more than $400 a month. However, you're not 
sure yet what the interest rate is going to be. 
In the image below, you can see that Interest Rate is left blank, 
and Payment is $333.33. That's because the payment is being 
calculated by a specialized function called the PMT (Payment) 
function, and $333.33 is what the monthly payment would be if 
there were no interest ($20,000 divided by 60 monthly payments). 
  
If we typed 
different values 
into the 

empty Interest 
Rate cell, we 
could eventually 
find the value that 

causes 
Payment to be 
$400, and that 
would be the 
highest interest 
rate that we could 

afford. 
However, Goal Seek can do this automatically by starting with 
the result and working backward. 

Pivot Charts are like regular charts, except they display data 
from a PivotTable. As with a regular chart, you'll be able to 
select a chart type, layout and style to best represent the 
data. In this example, we'll use a PivotChart so we can 
visualize the trends in each sales region. 

 
To Create a PivotChart: 

1. Select any cell in your PivotTable. The Options tab 
will appear in the Ribbon. 

2. From the Options tab, click 
the PivotChart command. 

 
3. From the dialog box, select the desired chart 

type (3-D Clustered Column, for example) and 
click OK. 

 
4. The PivotChart will appear in the worksheet. If you 

want, you can move it by clicking and dragging. 

 
If you make any changes to the PivotTable, the 
PivotChart will adjust automatically. 
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To Use Goal Seek to Find the Interest Rate: 
 

Other Types of What-If Analysis 
 
For more advanced projects, you may want to look at the other two 
types of what-if analysis: scenarios and data tables. Rather than 
starting from the desired result and working backward, like Goal 
Seek, these options allow you to test multiple values and see how 
the result changes. 
Below is an introduction to some of the things you can do 
with scenarios and data tables. 

 Scenarios let you substitute values for multiple 
cells (up to 32) at the same time. It is especially well-
suited to showing best-case and worst-case scenarios. 
You can create as many scenarios as you want, and 
then compare them without having to manually change 
all of the values. In the example below, each scenario 
contains a term and an interest rate. When each 
scenario is selected, it will replace the values in the 
spreadsheet with its own values, and the result will be 
recalculated. 

 
 Data Tables allow you to take one or two variables in a 

formula and replace them with as many different values 
as you want, and then view the results in a table. This 
option is especially powerful because it shows multiple 
results at the same time, unlike Scenarios or Goal Seek. 
In the example below, 24 possible results are shown in 
the table; doing the same task with Scenarios would 
take much longer. 

 
 

 
__________________________________ 

 
 

1. From the Data tab, click the What-If 
Analysis command. 

2. Select Goal Seek. 
 

 
 
3. A dialog box will appear containing three fields: 

o Set cell: This is the cell that will contain 
the desired result (in this case, the monthly 
payment). In this example, we will set it 
to B5 (it doesn't matter whether it's 
an absolute or relative reference). 

o To value: This is the desired result. We'll set 
it to -400. Since we're making a payment that 
will be subtracted from our loan amount, we 
have to enter the payment as a negative 
number. 

o By changing cell: This is the cell where Goal 
Seek will place its answer (in this case, the 
interest rate). We'll set it to B4. 
 

 
 
4. When you're done, click OK. The dialog box will 

tell you whether or not Goal Seek was able to find 
a solution. In this example, the solution is 7.42%, 
and it has been placed in cell B4. This tells us that 
a 7.42% interest rate will give us a $400-a-month 
payment on a $20,000 loan that is paid off over 5 
years, or 60 months. 
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Lesson: 10  
 

 Reviewing, Sharing, Saving & Printingi 
 

 
   Reviewing and Sharing Workbooks 

 
To Turn off Track Changes: 
 

1. From the Review tab, click Track Changes. Then 
select Highlight Changes from the drop-down menu. 

2. Uncheck the box next to Track changes while 
editing. 

3. Click Yes to confirm that you want to turn off Track 
Changes and stop sharing your workbook. 

Turning off Track Changes will delete any tracking that has 
taken place in your workbook. You will not be able to view, 
accept, or reject changes; instead, they will all be applied to 
your workbook automatically. Always review the changes in your 
worksheet before turning Track Changes off. 
 
Adding and Deleting Comments 
 
Sometimes, you may want to add a comment to a worksheet, to 
provide feedback for the author instead of changing the 
contents. Comments are highlighted by a unique indicator and 
can be read by the original author or by any other reviewers. 
 
To Add a Comment: 

1. Select the cell where you want the comment to 
appear. 

2. From the Review tab, click the New 
Comment command. 

 
3. Type your comment. 

 
4. The red indicator in the upper right corner shows that 

there is a comment in that cell. 
5. Hover your mouse over the cell to view the comment. 

 
To Edit a Comment: 

1. Select the cell containing the comment you wish to 
edit. 

2. From the Review tab, click the Edit 
Comment command (where the New Comment 
command used to be). 

3. Edit your comment. 

Suppose someone asked you to proofread or collaborate on a 
worksheet they put together. If you had a hard copy, you might 
use a red pen to cross out cell data, mark misspellings, or add 
comments in the margins. However, you could also do all of 
these things in Excel using the Track Changes and Comments 
features. 
When you've finished reviewing the worksheet, the other 
person can choose to automatically Accept all of your 
changes, or decide whether to Accept or Reject each change 
one-by-one. 
 
About Track Changes 
 
When you turn on the Track Changes option, every change 
you make to the worksheet will be highlighted with a unique 
border and indicator. Hovering your mouse over a highlighted 
cell will display the details of the change. This allows the other 
person to see what changes have been made before making 
the changes permanent. 

 
The color of the highlights will vary depending on who is reviewing 
the document, so if there are multiple reviewers, you'll be able to 
tell at a glance who made each change. 
There are some changes that Excel cannot track. Familiarize 
yourself at changes that Excel does not track or highlight. 
 
To Turn on Track Changes: 
1. Go to the Review tab. 
2. Click Track Changes, then select Highlight Changes from 

the drop-down menu. 
3. The Highlight Changes dialog box will appear. 
4. Check the box next to Track changes while editing. 
5. Verify the box is checked for Highlight changes on screen. 

This will highlight your changes while you work. 
6. Click OK. 
7. If prompted, click OK to allow Excel to save your workbook 
8. Change tracking is now active. Any changes you make to the 

worksheet will be highlighted with a unique border and 
indicator. 

Your workbook will be "shared" automatically when you 
turn Track Changes on. Shared workbooks are designed to 
be stored where other users (such as users on the same 
network) can access and edit the workbook at the same 
time.  
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Finalizing and Protecting Your Workbook 
 

Protecting Your Workbook 
 
By default, anyone with access to your workbook will be able 
to open, copy, and change any part of it unless you protect it. 
There are many ways you can protect your workbook 
depending on your needs. For example, you can mark your 
workbook as final, set it up with a password, put restrictions 
on who can make changes, or make it so that only certain 
cells or features of the workbook are changeable. 
 
To Protect Your Workbook: 
 

1. Click the File tab to access the Backstage view . 
2. From the Info pane, click the Protect 

Workbook command. 
3. Choose the option that best suits your needs. In 

this example, we will select Mark as Final. Marking 
your workbook as final is a way to discourage others 
from making any changes to the workbook. It will 
alert whoever opens it that typing, editing, and 
proofreading commands are unavailable. 

4. Click OK. 
5. Another dialog box will appear. Click OK to confirm. 

 
 Saving Workbooki 

 
Are you saving a workbook for the first time? Saving it as 
another name? Sharing it with someone that does not have 
Excel 2010? There are many ways you share and receive 
workbooks, which will affect how you need to save the file. 
In this lesson you will learn how to use the Save and Save 
As commands, how to save as an Excel 97-2003 compatible 
workbook, and how to save as a PDF. 
 
To Use the Save As Command: 
 
Save As allows you to choose a name and location for your 
workbook. Use it if you are saving a workbook for the first 
time or if you want to save a different version of a workbook 
while keeping the original. 
 

1. Click the File tab. 
2. Select Save As. 
3. The Save As dialog box will appear. Select the 

location where you wish to save the workbook. 
4. Enter a name for the workbook and click Save. 

 
If you are using Windows 7, you will most likely want to save 
files to your Documents library. For other versions of 
Windows, you will most likely want to save files to the My 
Documents folder 
 
To Use the Save Command: 
 

1. Click the Save command on the Quick Access 
Toolbar. 

2. The workbook will be saved in its current location 
with the same file name. 
If you are saving for the first time and select Save, 

the Save As dialog box will appear. 

Before you send your workbook out, take a minute to prepare a 
final copy. Excel has tools that might save you from sharing a 
workbook that contains spelling errors, or information about the 
workbook itself that you do not want the recipient to see. Use 
the Spelling command to find and edit any misspelled words; use 
the Document Inspector to find and delete any hidden data or 
personal information that is stored in the workbook, such as 
hidden comments, invisible objects, and file paths; and consider 
your Protect Workbook options, designed to keep other users 
from making unwanted changes to your workbook. 
 
To Check Spelling: 
 

1. Select the cells you want to spell check. 
2. Click on the Spelling command from the Review tab. 
3. The Spelling dialog box will open. From the Spelling 

dialog box, you can review and edit any misspelled 
words. 
You can also check the spelling of every cell in an 
active worksheet by selecting any empty cell in the 
worksheet and then clicking on the Spelling command. 

 
Ignoring Spelling "Errors" 
 
There are times when Excel will say something is an error when 
it is not. This often happens with people's names, which may not 
be in the dictionary. Even if Excel says that something is an 
error, you can choose not to change it. There are three options 
you can choose from: 

 Ignore Once: This will skip the word without changing 
it. 

 Ignore All: This will skip the word without changing it, 
and it will also skip all other instances of this word in 
the worksheet. 

 Add to Dictionary: This adds the word to the 
dictionary so that it will never come up as an error 
again. Make sure that the word is spelled correctly 
before choosing this option. 

 
To Use the Document Inspector: 
 

1. In Backstage view, click Info. 
2. Click on the Check for Issues button. A drop-down 

menu will appear. 
3. Select Inspect Document. A dialog box will appear. 
4. Check the boxes beside the content you want to 

inspect. To unselect a box, simply click it again and the 
check mark will disappear. 

5. Click Inspect. 
6. After the Document Inspector finishes, a new dialog 

box will appear where you can review the inspection 
results. Click the Remove All command beside any 
information you want to remove. 
It is a good idea to save an additional copy of your 
workbook before you use the Document Inspector to 
remove information, because some changes cannot be 
undone. 
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To Use AutoRecover: 
 

 Printingi 
 
There are many choices you can make when printing an Excel 
workbook. You can choose what parts of a workbook to print and how 
the data fits on the page. 
In previous versions of Excel, there was a Print Preview option that 
allowed you to preview and modify the workbook before printing. You 
may have noticed that this feature seems to be gone in Excel 2010. It 
actually has not disappeared; it has just been combined with the Print 
window to create the Print pane, which is located in Backstage view. 
 
To View the Print Pane: 

1. Click the File tab. This takes you to Backstage view. 
2. Select Print. The Print pane appears, with the print 

settings on the left and the Print Preview on the right. 
 
To Print Active Sheets: 
 
If you have multiple worksheets in your workbook, you will need to 
decide if you want to print the whole workbook or specific worksheets. 
Excel gives you the option to Print Active Sheets. A worksheet is 
considered active if it is selected. 

1. Select the worksheets you want to print. To print multiple 
worksheets, click on the first worksheet, hold down the Ctrl 
key, then click on the other worksheets you want to select. 

 
2. Click the File tab. 
3. Select Print to access the Print 

pane. 
4. Select Print Active Sheets from 

the print range drop-down menu. 
5. Click the Print button. 

 
To Print the Entire Workbook: 

1. Click the File tab. 
2. Select Print to access the Print pane. 
3. Select Print Entire Workbook from the print range drop-

down menu. 
4. Click the Print button. 

 
To Print a Selection, or Set the Print Area: 
 

Printing a selection (sometimes called setting the print area) lets you 
choose which cells to print, as opposed to the entire worksheet. 

1. Select the cells that you want to print. 

 
2. Click the File tab. 
3. Select Print to access the Print pane. 
4. Select Print Selection from the print range drop-down 

menu. 
5. You can see what your selection will look like on the page 

in Print Preview. 
6. Click the Print button. 

Excel automatically saves your workbooks to a 
temporary folder while you are working on them. If you 
forget to save your changes, or if Excel crashes, you 
can recover the autosaved file. 

1. Open a workbook that was previously closed 
without saving. 

2. In Backstage view, click Info. 
3. If there are autosaved versions of your 

workbook, they will appear under Versions. 
Click on the file to open it. 

4. A yellow caution note will appear on the 
ribbon of the workbook. To restore this 
version of the workbook click Restore and 
then click OK. 

By default, Excel autosaves every 10 minutes. If you 
are editing a workbook for less than 10 minutes, Excel 
may not create an autosaved version. 
If you do not see the file you are looking for, or if you 
are looking for an autosaved version of a file that has 
no previously saved versions, you can browse all 
autosaved files by clicking on the Manage 
Versions button and selecting Recover Unsaved 
Workbooks from the drop-down menu. 
 
To Save As an Excel 97-2003 Workbook: 
 
You can share your workbooks with anyone 
using Excel 2010 or 2007, since they use the same file 
format. However, earlier versions of Excel use a 
different file format, so if you want to share your 
workbook with someone using an earlier version of 
Excel, you will need to save it as an Excel 97-2003 
Workbook. 

1. Click the File tab. 
2. Select Save As. 
3. In the Save as type drop-down menu, 

select Excel 97-2003 Workbook. 
4. Select the location you wish to save the file. 
5. Enter a name for the file and click Save. 

 
To Save As a PDF: 
 
Saving your workbook as an Adobe Acrobat Document, 
which is called a PDF file, can be especially useful 
when your recipients do not have Excel. A PDF file will 
make it possible for recipients to view the content from 
your workbook, but they will not be able to edit 
anything. Click the File tab. 
 

1. Select Save As. 
2. In the Save as type drop-down menu, 

select PDF. 
3. Select the location you wish to save the file. 
4. Enter a name for the file and click Save. 

 
Excel defaults to saving the active worksheet only. If 
you have multiple worksheets and want to save all of 
them in the same PDF file, click on Options. The 
Options dialog box will appear. Select Entire 
workbook from the Options dialog box and click OK. 
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You don't have to wait until you're ready to print to set the print area. You can also set it from the Page Layout tab in advance. This 
will place a dotted line around your selection, so you can see which cells are going to print while you work. To do this, just select the 
cells you want to print, go to the Page Layout tab, and choose Print Area. 
 
To Change Page Orientation: 
 

Change the page orientation to Portrait to orient the page vertically or Landscape to orient the page 
horizontally. Portrait is useful for worksheets needing to fit more rows on one page, and Landscape is 
useful for worksheets needing to fit more columns on one page. 

1. Click the File tab. 
2. Select Print to access the Print pane. 
3. Select either Portrait Orientation or Landscape Orientation from the orientation drop-down 

menu. 
4. Your page orientation is changed. 

 
To Fit a Worksheet on One Page: 

1. Click the File tab. 
2. Select Print to access the Print pane. 
3. Select Fit Sheet on One Page from the scaling drop-down menu. 
4. Your worksheet is reduced in size until it fits on one page. Remember that if it is 

scaled too small it might be difficult to read. 

To Modify Margins While in Print Preview: 
The margins of your worksheet may need to be adjusted to make data fit more 
comfortably on the printed page. You can adjust the margins in Print Preview. 

1. Click the File tab. 
2. Select Print to access the Print pane. 
3. Click on the Show Margins button. Your margins will appear. 
4. Hover your mouse over one of the margin markers  until the double 

arrow  appears. 
5. Click and drag the margin to your desired location. 
6. Release the mouse. The margin is modified. 

 

To Use Print Titles: 
Imagine how difficult it would be to read a worksheet if the column and row headings only appeared on the first page. The Print 
Titles command allows you to select specific rows and columns to appear on each page. 

1. Click the Page Layout tab. 
2. Select the Print Titles command. 
3. The Page Setup dialog box appears. Click the icon at the end of the Rows to repeat at top field. 
4. Your mouse becomes the small selection arrow . Click on the rows you want to appear on each printed page. The Rows to 

repeat at top dialog box will record your selection. 
5. Click the icon at the end of the Rows to repeat at top field. 
6. Repeat for Columns to repeat at left, if necessary. 
7. Click OK. You can go to Print Preview to see how each page will look when printed. 

 
 To Insert a Break:   

1. Click the Page Layout tab. 
2. Determine the placement of the break 

by clicking on the row below, cell 
below, or column to the right of 
where you want the break to appear. 
For example, select column C and a 
break will appear after column B. 

3. Select the Insert Page 
Break command from 
the Breaks drop-down menu. 

4. The break is inserted. You can go 
to Print Preview to confirm it appears 
in the correct place on the page. 

 
                     

_________________________________________________ 
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Unit-IV- MS-PowerPoint 2010i 
 

Lesson: 1  
 

 Getting Started with PowerPointi 
 
 
PowerPoint 2010 is presentation software that allows you to create dynamic slide presentations that may include animation, narration, 
images, videos and more. Microsoft PowerPoint, usually just called PowerPoint, is a commercial presentation program developed by 
Microsoft. It is part of the Microsoft Office suite which also includes another two office tools - Microsoft Excel and Microsoft Word. 
PowerPoint uses a graphical approach to presentations in the form of slide shows that accompany the oral delivery of the topic. The 
current versions are Microsoft PowerPoint 2010 for Windows and 2011 for Mac. 
  
What is Microsoft PowerPoint used for? 
 
The main purpose of MS PowerPoint is to enable the user to create dynamic, informational slide shows through the use of text, 
graphics, and animation. Slide shows created with the software are often displayed on projection screens for business, training, or 
educational presentations, although they can be distributed as stand-alone files. Additionally, the slides can be arranged and printed 
as handouts for reference. 
  
New features in PowerPoint 2010 
 
With Microsoft PowerPoint, you can make charts, tables, and macros, and insert images, audio, video, and other multimedia files. 
With the new release of Microsoft Office 2010, many advanced features were added in PowerPoint 2010. 
  
 Embed and edit video from within PowerPoint. Now you can add fades, formatting effects, bookmark scenes, and trim videos to 

give your presentations a professional multimedia experience. And since the embedded videos become part of your PowerPoint 
presentation, you don’t have to manage additional files when sharing with others. 

 Use new and improved picture editing tools. You can use picture editing tools including versatile artistic effects and advanced 
correction, color, and cropping tools, to fine-tune every picture in your presentation to look its absolute best. Even, dynamic 3-D 
slide transitions and more realistic animation effects can be added to grab your audience’s attention. 

 Work together more successfully. If you are one of the many people who work with others on presentations and projects, 
PowerPoint 2010 is the perfect tool for you. The new added co-authoring capabilities to edit the same presentation allows you to 
work with people in different locations at the same time. You can even communicate as you work, directly from PowerPoint. 

 Access and share your content from more places. Your ideas, deadlines, projects, and work emergencies don’t always occur 
conveniently when you are at your desk. Fortunately, you now have the power to get things done when and where you need to, 
from the Web with Microsoft PowerPoint Web App or even from your smartphone with Microsoft PowerPoint Mobile. 

  
Create a slide show 
 
When beginning a new slide show, PowerPoint provides an array of templates to choose from. Experienced users with a specific look 
in mind can start with a blank presentation for setting attributes, such as colors and fonts, to their own specifications. After creating the 
initial file, the next step is to create a slide, which can be done by using an auto layout, or a blank screen in order to add components 
manually. You can then choose to add a combination of text and graphics to suit the needs of the presentation, and apply animation 
to either of these elements to create a dynamic effect. You can add as many slides and make them as content-rich as your system 
can handle; there are no limits imposed in the software itself. 
The Ribbon and the Quick Access Toolbar are where you will find the commands you need to do common tasks in PowerPoint. If you 
are familiar with PowerPoint 2007, you will find that the main difference in the PowerPoint 2010 Ribbon is that commands such as 
Open and Print are now housed in Backstage view. 
 
The Ribbon 
 
The Ribbon contains multiple tabs, each with 
several groups of commands. Some tabs, like "Drawing 
Tools" or "Table Tools," may appear only when you are 
working with certain items like images or tables. In addition, 
you can add your own customized tabs that contain your 
favorite commands. 
Certain programs, such as Adobe Acrobat Reader, may 
install additional tabs to the Ribbon. These tabs are 
called Add-ins. 
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To Customize the Ribbon: 
  
You can customize the Ribbon by creating your own tabs that house your 
desired commands. Commands are always housed within a group, and you 
can create as many 
groups as you need to 
keep your tabs 
organized. In addition, 
you can even add 
commands to any of 
the default tabs, as 

long as you create a custom group within the tab. 
1. Right-click the Ribbon and select Customize the Ribbon. A dialog 

box will appear. 
2. Click New Tab. A new tab will be created with a new group inside it. 
3. Make sure the new group is selected. 

4. Select a command from the list on the left, then click Add. You can 
also drag commands directly into a group. 

5. When you are done adding commands, click OK. 
If you do not see the command you want, click on the Choose 
commands drop-down box and select All Commands. 

 
To Minimize and Maximize the Ribbon: 
 

To Get to Backstage View: 
 

1. Click the File tab. 
2. You can choose an option on the left side of the page. 

3. To get back to your document, just click any tab on the Ribbon. 

To Create a New, Blank Presentation: 
1. Click the File tab. This takes you to Backstage view. 
2. Select New. 
3. Select Blank presentation under Available Templates and 

Themes. It will be highlighted by default. 
4. Click Create. A new, blank presentation appears in the 

PowerPoint window. 

 
To save time, you can create your presentation from 
an Office.com template, which you can also select under Available 
Templates and Themes. 
 
To Open an Existing Presentation: 

1. Click the File tab. This takes you to Backstage view. 
2. Select Open. The Open dialog box appears. 
3. Select your desired presentation and then click Open. 

If you have opened the existing presentation recently, it may be easier to 
choose Recent from the File tab instead of Open to search for your presentation. 
 

 

__________________________________ 
 

The Ribbon is designed to be responsive to your 
current task and easy to use, but if you find it is 
taking up too much of your screen space, you 
can minimize it. 

1. Click the arrow in the upper-right corner of 
the Ribbon to minimize it. 

2. To maximize the Ribbon, click the arrow 
again. 

When the Ribbon is minimized, you can make it 
reappear by clicking on a tab. However, the Ribbon 
will disappear again when you are not using it. 
 
The Quick Access Toolbar 
 

The Quick Access Toolbar is located above the 
Ribbon, and it lets you access common commands 
no matter which tab you are on. By default, it shows 
the Save, Undo, and Repeat commands. You can 
add other commands to make it more convenient for 
you. 
 
To Add Commands to the Quick Access Toolbar: 

1. Click the drop-down arrow to the right of the Quick 
Access Toolbar. 

2. Select the command you wish to add from the drop-
down menu. To choose from more commands, 
select More Commands. 
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Lesson: 2  
 

 Slide Basici 
 
 
PowerPoint includes all the features you need to produce professional-looking presentations. When you create a PowerPoint 
presentation, it is made up of a series of slides. The slides contain the information you want to communicate with your audience. This 
information can include text, pictures, charts, video, sound, and more. Before you begin adding information to slides, you need to 
know the basics of working with slides.  
 
About Slides 

 
Slides contain placeholders, which are areas on the 
slide that are enclosed by dotted borders. 
Placeholders can contain many different items, 
including text, pictures, charts, and more. Some 
placeholders have placeholder text, or text that you 
can replace. They also have thumbnail-sized 
icons that represent specific commands such as 
Insert Picture, Insert Chart, and Insert Clip Art. In 
PowerPoint, hover over each icon to see the type of 
content you can insert in a placeholder. 
 

About Slide Layouts 
 
The placeholders are arranged in different layouts that can be applied to existing slides, or 
chosen when you insert a new slide. A slide layout arranges your content using different 
types of placeholders, depending on what kind of information you might want to include in 
your presentation. In the example above, the layout is called Title and Content and 
includes title and content placeholders. While each layout has a descriptive name, you can 
also tell from the image of the layout how the placeholders will be arranged. 
 
To Change the Layout of an Existing Slide: 
 

1. Select the slide you wish to change. 
2. Click the Layout command in the Slides group on the Home tab. A menu will appear with your options. 
3. Choose a layout from the menu. The slide will change in the presentation. 

 
To Delete a Placeholder: 
 
You can easily customize your layout by deleting unwanted or "extra" placeholders from any slide. 

1. Position your mouse on the dotted border of the placeholder so it changes to a cross 

with arrows  . 
2. Click the border to select it. 
3. Press Backspace or Delete on your keyboard. The placeholder will be 

removed from the slide. 
 
To Add a Text Box: 
Text boxes allow you to add to your current layout, so you can place text wherever 
you want on your slide. 

1. From the Insert tab, click the Text Box command.  
2. Your cursor will turn into an upside-down cross  . 
3. Click, hold, and drag your mouse to draw a text box. A text box will 

appear. 
 
To Use a Blank Slide: 
For more control over your content, you may prefer a blank slide (a slide without 
placeholders) over one of the existing layouts. Blank slides can be customized by 
adding your own text boxes, pictures, charts, and more. 

 Select Blank from the menu of layout options. 
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To Insert a New Slide: 
1. From the Home tab, click the bottom half of the New Slide command to open 

the menu of slide layout options. 
2. Select the slide you want to insert. 

3. A new slide will be added your presentation. 

To instantly add a slide that uses the same layout as the one you have 
selected, simply click the top half of the New Slide command. 

 
To Copy and Paste a Slide: 

1. On the Slides tab in the left pane, select the slide you wish to copy. 
2. Click the Copy command on the Home tab. You can also right-click your selection and choose Copy. 
3. In the left pane, click just below a slide (or between two slides) to choose the location where you want the copy to appear. 

A horizontal insertion point will mark the location. 
4. Click the Paste command on the Home tab. You can also right-click and choose Paste. The copied slide will appear. 

To select multiple slides, press and hold Ctrl on your keyboard, and click the slides you wish to select. 
 
To Duplicate a Slide: 
An alternative to Copy and Paste, Duplicate copies the selected slide and, in one step, pastes it directly underneath. This feature does 
not allow you to choose the location of the copied slide (nor does it offer Paste Options for advanced users), so it is more convenient 
for quickly inserting similar slides. 

1. Select the slide you wish to duplicate. 
2. Click the New Slide command. 
3. Choose Duplicate Selected Slides from drop-down menu. 
4. A copy of the selected slide appears underneath the original. 

 
To Delete a Slide: 

1. Select the slide you wish to delete. 
2. Press the Delete or Backspace key on your keyboard. 

 
To Move a Slide: 

1. Select the slide you wish to move. 
2. Click, hold, and drag your mouse to a new location. A horizontal insertion point will mark the location. 
3. Release the mouse button. The slide will appear in the new location. 

 
About Slide Views 
 
It is important that you be able to access the different slide views and use 
them for various tasks. The slide view commands are located on the bottom 
right of the PowerPoint window in Normal View. 
 
Normal View: This is the default view where you create and edit your slides. 
You can also move slides in the Slides tab in the pane on the left. 
Slide Sorter View: In this view, miniature slides are arranged on the screen. 
You can drag and drop slides to easily reorder them, and see more slides at 
one time. This is a good view to use to confirm that you have all the needed 
slides and that none have been deleted. 
Reading View: This view fills most of the computer screen with a preview of your presentation. Unlike Slide Show View, it includes 
easily accessible buttons for navigation, located at the bottom right. 
Slide Show View: This view completely fills the computer screen, and is what the audience will see when they view the presentation. 
Slide Show View has an additional menu that appears when you hover over it, allowing you to navigate through the slides, and access 
other features you can use during a presentation. 
Use the keys on your keyboard (including the arrow keys, Page Up and Page Down, space bar, and Enter) to move through the 
slides in Slide Show view. Press the Esc key to end the slide show. 
 
To View an Outline of Your Presentation: 
 
The Outline tab shows your slide text in outline form. This allows you to quickly edit your slide text, and view the contents of multiple 
slides at once. 

1. Click the Outline tab in the left pane. 
2. An outline of your slide text appears 
3. Type directly in the pane to make changes to your text. 
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To Organize Slides into Sections: 
 
You can organize your slides into sections to make your presentation easier to navigate. Sections can be collapsed or expanded in 
the left pane, and named for easy reference. In this example, we will add two sections: one for dogs that are available for adoption, 
and another for cats and other pets. 
 

1. Select the slide that you want to begin your first section. 
2. From the Home tab, click the Section command. 
3. Choose Add Section from the drop-down menu.  
4. An Untitled Section appears in the left pane. 
5. To rename the section while it is still selected, click the Section command, and choose Rename Section from the drop-

down menu.  
6. Enter your new section name in the dialog box. Then click Rename. 
7. Repeat to add as many sections as you need. 
8. In the left pane, click the arrow next to a section name to collapse or expand it. 

 
Adding Notes to Slides 
 
PowerPoint gives you the ability to add notes to your slides, often called speaker notes, 
to help you deliver or prepare for your presentation. You can enter and view your 
speaker notes using the Notes pane or the Notes Page View. 
 
To Use the Notes Pane: 
 

1. Locate the Notes pane at the bottom of the screen, directly below 
the Slide pane. 

2. Click and drag the edge of the pane to make it bigger or smaller, if desired. 
3. Type your notes in the Notes pane. 
 

To Use the Notes Page View: 
 

1. Go to the View tab. 
2. Click the Notes Page command in the Presentation Views group. 
3. Type your notes in the text box, or use the scroll bar to review your slides. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
_____________________________________ 
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Lesson: 3  
 

 Inserting Text, Themes & Imagesi 
 
Inserting Text 

 

To Cut and Paste Text: 
1. Select the text you wish to cut. 
2. Click the Cut command on the Home tab. You 

can also right-click your selection and 
choose Cut. 

3. Place your insertion point where you wish the text 
to appear. 

4. Click the Paste command on the Home tab. The 
text will reappear. 

You can also cut, copy, and paste by right-clicking your 
slide and choosing the desired action from the drop-down 
menu. When you use this method to paste, you can choose 
from four options that determine how the text will be 
formatted: Use Destination Theme, Keep Source 
Formatting, Picture and Keep Text Only. You can hover 
the mouse over each icon to see what it will look like before 
you click it. 
 
To Drag and Drop Text: 

1. Select the text you wish to copy. 
2. Click, hold, and drag your mouse to the location 

where you want the text to appear. The cursor will 
have a rectangle under it to indicate that you are 
moving text. 

 
3. Release the mouse button, and the text will 

appear. 
If text does not appear in the exact location you wish, you 
can press the Enter key on your keyboard to move the text 
to a new line. 
 
Find and Replace 
 
Find and Replace is another technique that can be used to 
edit text. Find and Replace allows you to search all of your 
slides for a specific word or phrase (for example, "English"), 
then replace it with another word or phrase (for example, 
"British"). 
 
To Add a Text Box: 
Text can be inserted into both placeholders and text 
boxes. A placeholder is a kind of text box, but is unique 
because it is part of the slide layout, and often contains 

It is important to know how to perform basic tasks with text, Theme 
& Images, when working in PowerPoint; you will learn the basics of 
working with text, Themes & Images including how to insert, delete, 
and move text, Images & Themes. 
 
To Insert Text: 

1. Click the placeholder or text box where you want to 
insert text. 

2. The insertion point appears. 

 
3. Type directly into the placeholder or text box. 

Some placeholders automatically format your text in 
a bulleted list. This is because bulleted lists are so 
frequently used in PowerPoint. To remove the bullets, 
deselect the Bullets command in the Paragraph group 
on the Home tab. 

 
To Delete Text: 

1. Place the insertion point next to the text you wish to 
delete. 

2. Press the Backspace key on your keyboard to delete text 
to the left of the insertion point. 

3. Press the Delete key on your keyboard to delete text to 
the right of the insertion point. 

 
To Select Text: 

1. Place the insertion point next to the text you wish to 
select. 

2. Click the mouse button, and, while holding it down, drag 
the mouse over the text. 

3. Release the mouse. The text will be selected. 
A highlighted box will appear over the selected text. 
When you select text in PowerPoint, a hover toolbar with 
formatting options appears. This makes formatting 
commands easily accessible, which may save you time. If 
the toolbar does not appear at first, try moving the mouse 
over the selection. 

 
To Copy and Paste Text: 

1. Select the text you wish to copy. 
2. Click the Copy command on the Home tab. You can also 

right-click your selection and choose Copy. 
3. Place your insertion point where you wish the text to 

appear. 
4. Click the Paste command on the Home tab. The text will 

appear. 
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formatting specific to the slide (for example, a larger font size for the title of your 
presentation). Inserting an extra text box allows you to add to the slide layout, so you 
can include as much text as you want. 

1. From the Insert tab, click the Text Box command.  
2. Your cursor will turn into an upside-down cross . 
3. Click the area on your slide where you want to add a text box. A text box will 

appear with an insertion point inside. 
 
To Change Text Direction: 

1. Select the text your wish to modify. 
2. Click the Text Direction command in 

the Paragraph group. A menu will appear. 
3. Choose for the direction of the text to 

be Horizontal, Rotated, or Stacked. 
 

 Applying a Themei 
 

A theme is a predefined combination of colors, fonts, and 
effects that can be applied to your presentation. PowerPoint 
includes built-in themes that allow you to easily create 
professional-looking presentations without spending a lot of 
time formatting.  
A theme is a set of colors, fonts, effects, and more that can be 
applied to your entire presentation to give it a consistent, 
professional look. You've already been using a theme, even if 
you didn't know it: the default Office theme, which consists of 
a white background, the Calibri font, and primarily black text. 
Themes can be applied or changed at any time. 
 
Theme Elements 
 
Every PowerPoint theme, including the default Office theme, 
has its own theme elements. Those elements are: 

 Theme Colors (available from every Color menu) 
 Theme Fonts (available from the Font menu) 
 Shape Styles (available in the Format tab when 

you click on a shape) 
 
Why Use Theme Elements? 
 
If you're using theme elements, you'll probably find that your 
presentation looks pretty good. All of the colors will work well 
together, which means you won't have to spend as much time 
formatting your presentation. But there's another great reason 
to use theme elements: when you switch to a different 
theme, all of those elements will update to reflect the new 
theme. You can drastically change the look of your 
presentation in just a couple clicks. 
Remember, the colors and fonts will only update if you're 
using Theme Fonts or Theme Colors. If you choose one of 
the Standard Colors or any of the Fonts that are not Theme 
Fonts, then your text will not change when you change the 
theme. That can be useful if you're creating a logo or title that 
always needs to look the same. 
 
Themes and Slide Layouts 
 

As you can see from the two different Title Slides above, 
themes also affect the various slide layouts. 
If you apply a theme before you start building your 
presentation, you will be able to arrange your content to fit 

To Move a Placeholder or Text Box: 
 

1. Click the box you would like to move. 

2. Position your mouse on the border of the box so it 

changes to a cross with arrows  . 
3. Click and hold the mouse button as you drag the box to 

the desired location. 
4. Release the mouse button. The box will be moved. 

To rotate the box, click and drag on the green circle at 
the top of the box. 

 
To Resize a Placeholder or Text Box: 

1. Click the box you wish to resize. 
2. Position your mouse over any one of the sizing 

handles that appear on the corners and sides of the 
box. The cursor will become a pair of arrows . 

3. Click, hold, and drag your mouse until the text box is 
the desired size. 

4. Release the mouse button. The box will be resized. 
 
To Insert a Bulleted List: 

1. Select the text box (or specific text) that you want to 
format as a bulleted list. 

2. Click the Bullets command in the Paragraph group on 
the Home tab. 

3. A bulleted list will appear. 

To Change Horizontal Text Alignment: 
1. Select the text you wish to modify. 
2. Select one of the four alignment options in 

the Paragraph group. 
 Align Text Left: Aligns all the selected text to the left 

margin. 
 Center: Aligns text an equal distance from the left and 

right margins. 
 Align Text Right: Aligns all the selected text to the 

right margin. 
 Justify: Justified text is equal on both sides and lines 

up equally to the right and left margins. Many 
newspapers and magazines use full-justification. 

The alignment commands align the text within the placeholder or 
text box it is in, not across the slide. 
 
To Change Vertical Text Alignment: 

1. Select the text your wish to modify. 
2. Click the Align Text command in the Paragraph group. 

A menu will appear. 
3. Choose to align the text at the Top, Middle, 

or Bottom of the text box. 
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the layouts you have to choose from. If you apply the theme after, the text boxes and placeholders may move depending on the 
theme you choose. 

 
Applying Themes 
To Insert an Image From a File: 

1. Select the Insert tab. 
2. Click the Picture command in the Images group. The 

Insert Picture dialog box appears. 

 
3. Select the desired image file and click Insert. 
4. The picture will appear in your slide. 

You can also select the Insert Picture from File command in 
a placeholder to insert images. 

 
  
To Locate Clip Art: 

1. Select the Insert tab. 
2. Click the Clip Art command in the Images group. 
3. The clip art options appear in the task pane to the 

right of the document. 
4. Enter keywords in the Search for: field that are related 

to the image you wish to insert. 
5. Click the drop-down arrow in the Results should 

be: field. 
6. Deselect any types of media you do not wish to see. 

7. If you would like to also search for clip art on 
Office.com, place a checkmark next to Include 
Office.com content. Otherwise, it will just search for 
clip art on your computer. 

8. Click Go. 
 
To Insert Clip Art: 
 

1. Review the results from a clip art search in the Clip 
Art pane. 

2. Select the desired image. 

3. The clip art will appear in your slide. 

 
You can also select the Insert Clip Art from File command in 
a placeholder to insert clip art. 

You will need to know how to apply a theme and how to 
switch to a different theme if you want to use this feature to 
create presentations. All of the themes that are included in 
PowerPoint are located in the Themes group on the 
Design tab. Themes can be applied or changed at any time. 
 
To Apply a Theme: 

1. Go to the Design tab. 
2. Locate the Themes group. Each image represents a 

theme. 

 
3. Click the drop-down arrow to access more themes. 

4. Hover over a theme to see a live preview of it in the 
presentation. The name of the theme will appear as 
you hover over it. 

5. Click a theme to apply it to the slides. 

 
 

 Inserting Imagesi 
 

Adding images to your presentations makes them more 
interesting and engaging. Pictures, clip art and screenshots 
can be inserted into PowerPoint to help you effectively 
communicate your ideas to your audience.  
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Inserting Screenshots 
 
Screenshots are pictures that capture the visible windows and items displayed on your computer screen. They may include an open 
window of a website, items on your desktop or an open program, like the PowerPoint images displayed in this tutorial. These images 
can be useful for explaining or displaying computer programs, functions and websites. PowerPoint allows you to capture an image of 
an entire window or a screen clipping of part of a window. 
 
To Insert Screenshots of a Window: 
 

1. Select the Insert tab. 
2. Click the Screenshot command in the Images group. 
3. The Available Windows from your desktop will appear. Select the 

window you would like to capture as a screenshot. 
4. The screenshot will appear in your slide. 

 

Inserting a Screen Clipping from a Window: 
 

1. Select the Insert tab. 
2. Click the Screenshot command and select Screen Clipping. 
3. A faded view of your current desktop will appear and your cursor will 

turn into a cross shape . 

4. Click, hold and drag on the area of the window that you want to 
capture. 

5. The screen clipping will appear in your slide. 

 
 
To Resize an Image:  

1. Click on the image. 

2. Position your mouse over any one of the corner sizing 
handles. The cursor will become a pair of directional 
arrows  . 

3. Click, hold, and drag your mouse until the image is the 
desired size. 

4. Release the mouse. The image will be resized.  

The side sizing handles change the image's size, but do not keep 
the same proportions. If you want to keep the image's 
proportions, always use the corner handles. 
 
To Move an Image: 

1. Click on the image. The cursor will turn into a cross with 

arrows.  
2. While holding down the mouse button, drag the 

image to the desired location. 
3. Release the mouse button. The box will be moved. 

To rotate the image, click and drag on the green circle located at 
the of the image. 
 

 
 
 

 
 

 
__________________________________________ 
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Lesson: 4  
 

 Inserting WordArt, Shapes, Tables & Chartsi 
 

 
Inserting a Shape 
 

1. Select the Insert tab. 
2. Click the Shapes command. 

 
3. Select a shape from the drop-down menu. 

4. Click and drag the mouse until the shape is the desired 
size. 

5. Release the mouse button. 

 
3-D Effects to Shapes 
 
There are two kinds of effects that you can apply to your shapes and 
text boxes to give them a 3-D appearance: 3-D 
Rotation and Bevel. 3-D Rotation gives the appearance that you 
are viewing the object from a different angle, and it can be applied to 
any shape. Bevel adds thickness and a rounded edge to shapes, but 
it doesn't work with every type of shape. 
 
To Use 3-D Rotation: 

1. Select the shape or text box. 
2. Click on the Format tab. 
3. Click Shape Effects from the Shape Styles group. 
4. Hover the mouse over 3-D Rotation. A drop-down menu 

will appear. 
5. Select the desired rotation preset from the drop-down 

menu. You can also click 3-D Rotation Options if you 
would prefer to type in custom values. 

 
 

Inserting Word Arts 
 
PowerPoint allows you to add effects to the text inside of 
a text box, which is known as WordArt. For the most part, 
the types of effects you can add are the same as the ones 
you can add to shapes and text boxes (shadow, bevel, 
etc.). However, with WordArt, you can also Transform the 
text to give it a wavy, slanted, or inflated look. 

 
To Apply a WordArt Style to Text: 
A WordArt Style will automatically apply several effects 
to your text at once. You can then refine the look of your 
text by adding or modifying text effects. 

1. Select the text box, or select some text inside of 
the text box. The Format tab will appear. 

2. Click the Format tab. 
3. In the WordArt Styles group, click 

the More drop-down arrow to view all of the 
available styles. 

4. Select the desired style preset to apply the style 
to your text. 

 
 
To Add or Modify Text Effects: 

1. Select the text box, or select some text inside of the 
text box. The Format tab will appear. 

2. Click the Format tab. 
3. Click the Text Effects command in the WordArt 

Styles group. A drop-down menu will appear showing 
the different effect categories. 

4. Hover over an effect category. A drop-down menu will 
appear. You can hover the mouse over the different 
presets to see a live preview. 

5. Select the desired effect preset. The effect will be 
applied to your text. If you want, you can combine 
several different effects. 

 

 
In the WordArt Styles group, you can also use the Text 
Fill and Text Outline drop-down boxes to modify 
the filland outline color. 
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Inserting Table 
 

1. On the Insert tab, click the Table command. 
2. Hover your mouse over the diagram 

squares to select the number 
of columns and rows in the table. 

 
3. Click your mouse. The table will appear on 

the slide. 

4. You can now place the insertion point 
anywhere in the table to add text. 

To make sure your table looks good with the slide layout, you can also insert a table using 
the placeholder. Click the Insert Table icon in the placeholder, then enter the desired 
number of rows and columns.  
  

 
Inserting Charts 
 
PowerPoint uses an Excel worksheet as a placeholder for entering chart data. Therefore, when you insert or edit a chart in 
PowerPoint, an Excel window will automatically open.  
 
To Insert a Chart: 

1. Select the Insert tab. 
2. Click the Insert Chart command in the Illustrations Group. The Insert 

Chart dialog box will appear. 
 

3. Select a category from the left pane of the dialog box and review 
the charts that appear in the center.  

4. Select the desired chart. 

5. Click OK. An Excel window will open with a placeholder for your data. 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

___________________________________ 
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Lesson: 4  
 

 Transition & Slide Showi 
 
 
Transitions are motion effects that, when in Slide Show View, add movement to your slides as you advance from one slide to 
another. There are many transitions to choose from; each one allows you to control the speed, and even add sound. 

 
About Transitions 
 

To Preview a Transition: 
You can preview the transition for a selected slide at any time, 
using either of these two methods: 

 Click the Preview command on the Transitions tab. 
 Click the star Play Animations icon. The icon appears on 

the Slides tab in the left pane beside any slide that 
includes a transition. 

  
 
To Modify the Duration: 

1. Select the slide that includes the transition you wish to 
modify. 

2. In the Duration field in the Timing group, enter the 
amount of time you want the transition to take. In this 
example, we will specify the length as 2 seconds, or 
02.00. 

 
 
To Add Sound: 

1. Select the slide that 
includes 
the transition you wish 
to modify. 

2. Click the Sound drop-
down menu in 
the Timing group. 

3. You will hear the sound 
and see a live preview of 
the transition as you 
hover over each sound. 

4. Click a sound to apply it 
to the selected slide. 

 
To Remove a Transition: 

1. Select the slide you wish to modify. 
2. Choose None from the gallery in the Transition to This 

Slide group. 
3. Repeat this process for each slide you want to modify. 

To remove transitions from all slides, select a slide that uses None, 
and click the Apply to All command. 
 

You can apply different transitions to some or all of your slides 
to give your presentation a polished, professional look. There 
are three categories of unique transitions to choose from, all of 
which can be found on the Transitions tab: 
 

 Subtle (slight transitions) 

 
 Exciting (strong transitions) 

 
 Dynamic Content (strong transitions that affect only 

the content, such as text or images) 

 
 
To Apply a Transition: 
 

1. Select the slide you wish to modify. 
2. Click the Transitions tab. 
3. Locate the Transition to This Slide group. By 

default, None is applied to each slide. 
 

 
 
4. Click the More drop-down arrow to display all the 

transitions. 
5. Click a transition to apply it to the selected slide. 

This will automatically preview the transition as well. 
 

When working with transitions, the Apply To All command in 
the Timing group can be used at any time to make your 
presentation uniform. Use this command with caution. Not only 
does it apply the same transition to every slide; it also applies the 
settings in the Timing group, which you may not want to be the 
same throughout your presentation. 
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To Advance Slides Automatically: 
 

 To Stop or End Slide Show: 
To end slide show, hover and select the menu box 
options command and click End Show. You can also press 
the "Esc" key at the top left of your keyboard to end show.  
 

To Access the Pen or Highlighter: 
1. Hover and click on the pen menu option in the bottom 

left of your screen. 
2. Select Pen or Highlighter based on your preference. 

 

 
3. Use the pointer to draw on or mark your slides.  

 
From the same menu, you can also change the color of the pen or 
highlighter. Keep in mind that light color choices are best for the 
highlighter. 
To Erase Ink Markings: 

1. Hover and click on the pen menu option in the bottom 
left of your screen. 

2. Select Eraser to erase individual ink markings or 
select Erase All Ink on Slide to erase all markings. 

When you end your slide show, you also have the option 
to Keep or Discard (erase) any ink markings you made during your 
presentation. 
To Jump to a Non-Adjacent Slide: 

1. Hover and click on the menu box option in the bottom 
left of your screen. 

2. Select Go to Slide and choose the slide you would like to 
jump to in your presentation. 

To Access the Desktop: 
Sometimes you may need to access the Internet or other files and 
programs on your computer during your presentation. PowerPoint 
allows you to access your desktop task bar without ending your 
presentation. 

1. Hover and click on the menu box option in the bottom 
left of your screen. 

2. Select Screen and then click on Switch Programs. 
3. Your computer's task bar will appear. Choose a program 

you would like to switch to. 
Menu Access Options: 
You can also access any of the above menu items by right-
clicking anywhere on the screen during your slide show. 

 Switch between the pen pointer and mouse pointer by 
pressing "Ctrl + P" (pen) or "Ctrl + M" (mouse) on the 
keyboard. 

 Press "E" on the keyboard to erase any ink markings 
while using the pen or highlighter. 

To Access Slide Show Set Up Options: 
1. Select the Slide Show tab. 
2. Click the Set Up Show command. 
3. The Set Up Show dialog box will appear.  
4. Click OK to apply the settings to the slide show. 

 

_____________________________________________ 
 

Normally, in Slide Show View, you would advance to the next 
slide by clicking your mouse (or pressing Enter on your 
keyboard). Using the Advance Slides settings in 
the Timing group, you can set your presentation to advance 
on its own instead, and display each slide for a specific 
amount of time. This is useful for unattended presentations, 
such as at a trade show booth. 

1. Select the slide you wish to modify. 

2. Locate the Timing group on the Transitions tab. 
3. Under Advance Slide, uncheck the box next to On 

Mouse Click. 
4. In the After field, enter the amount of time you want to 

display the slide. In this example, we will advance the 
slide automatically after 1 minute 30 seconds, or 
01:30:00. 

5. Select another slide and repeat the process until all the 
desired slides have the appropriate timing. 

 
 Presenting Slide Showi 

 
Once your slide show is completed, you will need to learn 
how to present it to an audience. PowerPoint offers several 
tools and features that can assist you in making your 
presentation smooth, engaging and professional. 

 
To Start Slide Show: 

1. Select the Slide Show tab. 
2. Click the From Beginning command in the Start Slide 

Show group to start the slide show with the first slide. 

   
You can also start the slide show from the slide you prefer by 
selecting the slide and clicking on From Current Slide from the 
Start Slide Show group. This option is convenient if you only want 
to view or present certain slides. 
Another option for starting the slide show is to select Slide 
Show view at the bottom of the window. 
 
Starting Slide Show view option 
 
To Advance and Reverse Slides: 

1. Hover your mouse over the bottom right of the 
screen. A menu will appear. 

2. Click on the right arrow to advance slides or click on 
the left arrow to reverse slides. 

 

Advance or reverse slides  
 
You may also use the arrow keys on your keyboard to 
advance and reverse slides. 
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Lesson: 5  
 

 Aligning & Animating Objectsi 
 

 
In PowerPoint, each slide may have multiple items, such as pictures, shapes and text boxes. PowerPoint lets you arrange the objects 
the way you want by aligning, grouping, rotating, and ordering them in various ways. 
 
Aligning Objects 
 

You can click and drag objects to align them manually, but guesswork will 
never give you the best result. Additionally, aligning objects in this way can 
take a great deal of time. Luckily, PowerPoint provides you with several 
commands that allow you to easily arrange and position objects 
 
To Align Two or More Objects: 
  
1. Click and drag your mouse to form a selection box around the objects 

you want to align. All of the objects will now have sizing handles to show 
that they are selected. 

2. From the Format tab, click the Align command and select Align Selected 
Objects. 

3. Click the Align command again and select one of the six alignment 
options. 

4. The objects will align to each other based on the option that you have 
selected. 

  
To Align Objects to the Slide: 
Sometimes, you may wish to align one or more objects to a specific location within the slide, such as 
the top or bottom. You can do this by simply selecting the Align to Slide option before you align the 
objects. 

1. Click and drag your mouse to form a selection box around the objects you want to align. All 
of   the objects will now have sizing handles to show that they are selected. 

2. From the Format tab, click the Align command and select Align to Slide. 
3. Click the Align command again and select one of the six alignment options. 
4. The objects will align to the slide based on the option that you have selected. 

To Distribute Objects Evenly: 
If you have arranged objects in a row or column, you may want them to be an equal distance from one another for a neater 
appearance. You can do this by distributing the objects horizontally or vertically. 

1. Click and drag your mouse to form a selection box around the objects you want to   align. All of the objects will now 
have sizing handles to show that they are selected. 

2. From the Format tab, click the Align command. 
3. From the menu, select Distribute Horizontally or Distribute Vertically. 

 
To Change the Ordering by One Level: 

1. Select an object. The Format tab will appear. 
2. From the Format tab, click the Bring Forward or Send Backward command to change the object's ordering by one level. 

If the object overlaps with more than one other object, you may need to click the command several times to achieve the 
desired ordering. 

3. The objects will reorder themselves. 
 
To Bring an Object to the Front or Back: 
If you want to move an object behind or in front of several objects, it's usually faster to bring 
it to front or send it to back rather than clicking the ordering commands multiple times. 

1. Select an object. The Format tab will appear. 
2. From the Format tab, click the Bring Forward or Send Backward drop-down box. 
3. From the drop-down menu, select Bring to Front or Send to Back. 
4. The objects will reorder themselves. 

To Rotate an Object: 
1. Select an object. The Format tab will appear. 
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2. From the Format tab, click the Rotate command. A drop-down menu will appear. 
3. Select the desired rotation option. 
4. The object in the slide will rotate. 

To Group Objects: 
 
1. Click and drag your mouse to 

form a selection box around the 
objects you want to align. All of 
the objects will now have sizing 
handles to show that they are 
selected. 

2. From the Format tab, click 
the Group command and 
select Group. 

3. The selected objects will now be grouped. There will be a single box with sizing handles around the entire group to show 
that they are one object. 

If you select the objects and the Group command is disabled, it may be because one of the objects is inside a place holder. If this 
happens, try reinserting the images or cutting and pasting them into the same slide outside of any placeholders. 
 
To Ungroup Objects: 

1. Select the grouped object that you wish to ungroup. 
2. From the Format tab, click the Group command and select Ungroup. 
3. The objects will be ungrouped. 
 

 Animating Text and Objectsi 
 
In PowerPoint you can animate text and objects such as clip art, shapes, and pictures. Animation, or movement, on the slide can be 
used to draw the audience's attention to specific content or to make the slide easier to read.  
 
The Four Types of Animations 
 
There are many different animation effects that you can choose from, and they are organized into four types: 

 Entrance: These control how the object enters the slide. For 
example, with the Bounce animation, the object will "fall" onto 
the slide and then bounce several times. 

 
 Emphasis: These animations occur while the object is on the 

slide, often triggered by a mouse click. For example, you can 
set an object to Spin when you click the mouse. 

  
 Exit: These control how the object exits the slide. For 

example, with the Fade animation, the object will simply fade 
away. 

  

 Motion Paths: These are similar to Emphasis effects, except 
the object moves within the slide along a pre-determined 
path, for example a circle. 

  
To Apply an Animation to an Object: 
 

1. Select an object. 
2. Click the Animations tab. 
3. In the Animation group, click the More drop-

down arrow to view the available animations. 
4. Select the desired animation effect. 
5. The object will now have a small number next 

to it to show that it has an animation. Also, in 
the Slide pane, the slide will now have 
a star symbol next to it. 
At the bottom of the menu, you can access 
even more effects. 
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Effect Options 
 
Some effects will have options that you can change. For example, with the Fly In effect, you can control which direction the object 
comes from. These options can be accessed from the Effect Options command in the Animation group. 
 
To Add Multiple Animations to an Object: 

If you select a new animation from the menu in the 
Animation group, it will replace the object's current 
animation. However, you'll sometimes want to 
place more than one animation on an object, for 
example an Entrance and an Exit effect. To do this, 
you'll need to use the Add Animation command, 
which will allow you to keep your current animations 
while adding new ones. 
 

1. Select the object. 
2. Click the Animations tab. 
3. In the Advanced Animation group, click the Add Animation command to 

view the available animations. 
4. Select the desired animation effect. 
5. If the object has more than one effect, it will have a different number for 

each effect. The numbers indicate the order in which the effects will occur. 
           

To Copy Animations with the Animation Painter: 
  

In some cases, you may want to apply the same 
effects to more than one object. You can do that 
by copying the effects from one object to another 
using the Animation Painter. 
 

1. Click on the object that has the effects 
that you want to copy. 

2. From the Animations tab, click the Animation Painter command. 
3. Click on the object that you want to copy the effects to. The effects will be applied 

to the object. 
   

To Reorder the Animations: 
 

1. Select the number of the effect that you want to change. 
2. From the Animations tab, click the Move Earlier or Move Later commands to change the ordering. 

 
To Preview Animations: 
 
Any animation effects that you have applied will show up when you play the slide show. However, you can also quickly preview the 
animations for the current slide without viewing the slide show. 

1. Navigate to the slide that you want to preview. 
2. From the Animations tab, click the Preview command. The animations for the current slide will play. 
 

The Animation Pane 
 
The Animation Pane allows you to view and manage all of the effects that are on the current slide. You can modify and reorder effects 
directly from the Animation Pane, which is especially useful when you have a large number of effects. 
 
To Open the Animation Pane: 
 

1. From the Animations tab, click the Animation Pane command. 
2. The Animation Pane will open on the right side of the window. It will show all of the effects for the current slide in the order 

that they will appear. 

To Reorder Effects from the Animation Pane: 
 

1. On the Animation Pane, click and drag an effect up or down. 
2. The effects will reorder themselves. 
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To Preview Effects from the Animation Pane: 
 

1. From the Animation Pane, click the Play button. 
2. The effects for the current slide will play. On the right side of the Animation Pane, you will be able to see a timeline that 

shows the progress through each effect. 
If the timeline is not visible, click the drop-down arrow for an effect and select Show Advanced Timeline. 

To Change an Effect's Start Option: 
 
By default, an effect starts playing when you click the mouse during a slide show. If you have multiple effects, you will need to click 
multiple times to start each effect individually. However, by changing the start option for each effect, you can have effects that 
automatically play at the same time or one after the other. 

1. From the Animation Pane, select an effect. A drop-down arrow will appear next to the effect. 
2. Click the drop-down arrow. You will see three start options: 

o Start on Click: This will start the effect when the mouse is clicked. 
o Start With Previous: This will start the effect at the same time as the previous effect. 
o Start After Previous: This will start the effect when the previous effect ends. 

 
To Open the Effect Options Dialog Box: 
 

1. From the Animation Pane, select an effect. A drop-down arrow will appear next to 
the effect. 

2. Click the drop-down arrow and select Effect Options. The Effect Options dialog 
box will appear. 

3. From here, you can add various enhancements to the effect: 
o Sound: Adds a sound effect to the animation. 
o After animation: Changes the color or hides the object after the 

animation is over. 
o Animate text: If you are animating text, you can choose to animate it all 

at once, one word at a time, or one letter at a time. 
Some effects have additional options that you can change. These will vary depending on which effect you have selected. 

 
To Change the Effect Timing: 
 

1. From the Effect Options dialog box, select the Timing tab. 
2. From here, you can add a delay before the effect starts, change the duration of the effect, and control whether or not the 

effect repeats. 
3. Select the desired start option. 

When you preview the animations, all of the effects will play through automatically. To test effects that are set toStart on 
Click, you will need to play the slide show. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

___________________________________________ 
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Lesson: 6  
 

 Inserting Video & Audioi 
 
 
Inserting Video 
 
Videos are a great way to make your presentations more engaging for your audience. PowerPoint allows you to insert a video from a 
file on your computer or from a web site such as YouTube. You can even edit the video within PowerPoint and customize its 
appearance with a Video Style. 
 
To Insert a Video from a File on Your Computer: 
 

1. From the Insert tab, click the Video drop-down arrow and select Video from File. 
2. Locate and select the desired video file and then click Insert. 
3. The video will be added to the slide. 

To Insert a Video from a Web Site: 
 

Some web sites, like YouTube or Hulu, allow you to embed videos in a 
blog, Facebook profile, or other web page. In PowerPoint, you 
can embed videos in your slides in the same way. This feature only works 
with web sites that provide embed code, and the embed code from some 
sites may not work with PowerPoint. 

1. On the web site that contains the video (YouTube, for example), locate and copy 
the embed code. 

2. In PowerPoint, click the Insert tab. 
3. Click the Video drop-down arrow, and select Video from Web Site. 
4. In the space provided, right-click and select Paste. The embed code will appear. 
5. Click Insert. The video will be added to the slide. 
 

To Preview the Video: 
 

1. Make sure the video is selected. 
2. Click the Play/Pause button below the video. The video will start playing, 

and the timeline next to the Play/Pause button will begin to advance. 
3. To jump to a different part of the video, click anywhere on the timeline. 

 
If you are using an embedded video from a web site, you may need to click 
the Play button in the Playback tab in order to view the video's playback controls (the 
Play button is also located on the Format tab). 
 

To Resize the Video: 
1. Select the video. A box with resizing handles will appear around the video. 
2. Click and drag any of the handles to resize the movie. 

Edit and Format Video 
The Playback tab has several options that you can use to edit your video. For example, you can trim your video so that it will only 
play an excerpt, add a fade in and fade out, and add bookmarks that allow you to jump to specific points in the video. 
Most of the features on the Playback tab can only be used with videos that are inserted from a file. They will not work with embedded 
videos. 
 
To Trim the Video: 

1. From the Playback tab, click the Trim Video command. The Trim Video dialog box will appear. 
2. Use the green and red handles to set the start time and end time. 
3. To preview the video file, click the Play button. 
4. Adjust the green and red handles again if necessary, and then click OK. 

 
To Add a Fade In and Fade Out: 
 

1. On the Playback tab, locate the Fade In and Fade Out fields. 
2. Type in the desired values, or use the up and down arrows to adjust the times. 
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To Add a Bookmark: 
 

To Insert Clip Art Audio: 
 
1. From the Insert tab, click the Audio drop-down 

arrow and select Clip Art Audio. The Clip Art pane 
will appear on the right. 

2. Enter keywords in the Search for: field and click Go. 
3. The results will appear in the Clip Art pane. To 

preview an audio file, right-click the file and select 
Preview/Properties. 

4. A dialog box will appear, and the audio file will start 
playing automatically (it may take a few seconds to 
load). To play it again, press the Play button. 

5. When you're finished previewing the file, click Close. 
6. Once you have found the audio file that you want to 

use, click it to insert it into the slide. 

To Trim the Audio: 
1. From the Playback tab, click the Trim 

Audio command. The Trim Audio dialog box will 
appear. 

2. se the green and red handles to set the start time 
and end time. 

3. To preview the audio file, click the Play button. 
4. Adjust the green and red handles again if necessary, 

and then click OK. 
 
To Add a Fade In and Fade Out: 
1. On the Playback tab, locate the Fade In and Fade 

Out fields. 
2. Type in the desired values, or use 

the up and down arrows to adjust the times. 
 
To Add a Bookmark: 
1. Click the Play/Pause button to play the audio file, 

and when you have located the part that you want to 
bookmark, pause it. You can also click 
the timeline to locate the desired part of the audio 
file. 

2. From the Playback tab, click Add Bookmark. 
3. A small circle will appear on the timeline to indicate 

the bookmark. 
4. You can now click the bookmark to jump to that 

location. 
 
Audio Options 
 
There are other options that you can set to control how 
your audio file plays, and these are found in the Audio 
Options group on the Playback tab. 

 Volume: Changes the audio volume. 
 Start: Controls whether the audio file 

starts automatically or when the mouse 
is clicked. 

 Hide During Show: Hides the audio icon while 
the slide show is playing. 

 Loop until Stopped: Causes the audio file to 
repeat until it is stopped. 

 Rewind after Playing: Causes the audio file to 
return to the beginning when it is finished 
playing. 

 
 

 

________________________________________ 
 

1. Click the Play/Pause button to play the video, and when you have 
located the part that you want to bookmark, pause it. You can also click 
the timeline to locate the desired part of the video. 

2. From the Playback tab, click Add Bookmark. 
3. A small circle will appear on the timeline to indicate the bookmark. 
4. You can now click the bookmark to jump to that location. 
 
To Remove a Bookmark: 
1. Select the bookmark. 
2. From the Playback tab, click Remove Bookmark. The bookmark will 

disappear. 
 
Video Options 
 
There are other options that you can set to control how your video plays, and 
these are found in the Video Options group on the Playback tab:- 
 Volume: Changes the audio volume in the video. 
 Start: Controls whether the video file starts automatically or when the 

mouse is clicked. 
 Play Full Screen: Lets the video fill the entire screen while it is playing. 
 Hide While Not Playing: Hides the video when it is not playing. 
 Loop until Stopped: Causes the video to repeat until it is stopped. 
 Rewind after Playing: Causes the video to return to the beginning 

when it is finished playing. 
 
To Create a Poster Frame: 
1. Select the video. 
2. Start playing the video. When you see the frame that you want to use, 

click the Play/Pause button to pause it. 
3. From the Format tab, click the Poster Frame command. A drop-down 

menu will appear. 
4. Select Current Frame. 
5. The current frame will become the poster frame. 

If you would prefer to use a picture from your computer, you can 
select Image from file from the menu. 

 
To Apply a Video Style: 
1. Select the video. The Format tab will appear. 
2. Select the Format tab. 
3. In the Video Styles group, click the More drop-down arrow to display 

all the video styles. 
4. Select the desired style. 
5. The new style will be applied to the video. 
 
To Insert Audio from a File on Your Computer: 
1. From the Insert tab, click the Audio drop-down arrow and select Audio 

from File. 
2. Locate and select the desired audio file and then click Insert. 
3. The audio file will be added to the slide. 

To Record Audio: 
1. From the Insert tab, click the Audio drop-down arrow and 

select Record Audio. 
2. Type a name for the audio recording, if desired. 
3. Click the red Record button to start recording. 
4. When you're finished recording, click the Stop button. 
5. To preview your recording, click the Play button. 
6. When you're done, click OK. The audio file will be inserted into the 

slide. 
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Lesson: 7  
 

 Advance Presentation Optionsi 
 
 
Broadcasting Your Slide Show to Remote Audiences 
 
Broadcasting a presentation remotely is surprisingly easy. All you and your viewers need is an internet connection-- they don't even 
need PowerPoint. Once your viewers are connected, you can start the presentation as you normally would. 
Please note that you cannot edit your presentation or mark it with a highlighter or pen while you are broadcasting a slide show. You 
also cannot use PowerPoint to speak to your audience. Plan to communicate with your viewers through teleconferencing, or pre-
record your narration. 

 
4.   A link will appear. Select the link, and click Copy Link to 
make a copy of the link, or Send in Email to send an email with 
the link to your viewers. 

 
 

5. Click Start Slide Show. 
6. Present your slide show. 
7. When you are finished, click End Broadcast in the 

yellow bar at the top of the screen. 

 
  
 
Customizing Your Slide Show 
 
Sometimes you might want to hide a slide while still keeping it in 
your presentation. For instance, if you are presenting a slide 
show to more than one group of people, hiding or even 
rearranging certain slides could help you tailor your slide show 
to each group you present it to. You could also choose to create 
a shortened version of your slide show to present when you're 
short on time. The Custom Slide Show feature allows you to 
create and name different versions of your slide show with 
hidden or rearranged slides. 

To Broadcast a Slide Show: 
1. Select the Slide Show tab and locate the Start Slide 

Show group. 
2. Click the Broadcast Slide Show command. 

The Broadcast Slide Show dialog box will open. 
 

 
 
3. Click Start Broadcast. A status bar will appear as 

PowerPoint prepares your broadcast. 
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To Create a Custom Show: 
 

 

7.  Click OK. 
8.   Select Close to exit or Show to view your custom show. 
 

 
 

You can also hide slides by selecting the Hide 
Slide command, which can be found on the Slide Show tab. 
To unhide a slide, simply click the Hide Slide command 
again. 
 
Creating Handouts of a Presentation 
 
Printing handouts with images of your slides can be helpful 
to your audience, as it gives them a hard copy of the 
information you're presenting. Plus, they can take notes on 
the handouts as you present your slide show. 
 
To Create Handouts of a Presentation: 
 

1. Click the File tab. This takes you to the Backstage 
view. 

2. Click Print. 
3. Click the drop-down arrow in the box that says Full 

Page Slides, and locate the Handouts group. 
4. Select a page layout for your handouts. Up to nine 

slides can be displayed per page. Note that the 3 
slides layout offers lined space for your viewers to 
take notes. 

5. Click the Print command. 
 
If you would like to add a header or footer to your handouts, 
click the View tab on the Ribbon, then select Handout 
Master. Just type your header or footer information into the 
boxes provided. To return to the normal view, click Exit 
Master View. 

 
 
 
 
 
 
 
 
 

 
 

______________________________________ 
 

1. Select the Slide Show tab and locate the Start Slide 
Show group. 

2. Click the Custom Slide Show command. 

 
3. Select Custom Shows.... The Custom Shows dialog box 

will appear. 
4. Click New. The Define Custom Show dialog box will 

appear. 

 
5. Locate the Slide show name box and type in a name for 

your custom show. 
6. Select the slides in the Slides in presentation: box that 

you would like to include in your custom show, then 
click Add>> to add them to the Slides in custom 
show: box. If necessary, use the up and down arrows to 
reorder the added slides. 
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Lesson: 8  
 

 Saving & Printingi 
 

 
Are you saving for the first time? Do you need to share your presentation with someone who does not have PowerPoint 2010? Would 
you like to print handouts of your presentation? Perhaps you need a printout that shows your notes with your slides? All of these 
things will affect how you save and print your PowerPoint presentations. 

 
To Save As PowerPoint 97 - 2003 Presentation: 
You can share your presentation with anyone using 
PowerPoint 2010 or 2007, since they use the same file 
format. However, earlier versions of PowerPoint use a 
different file format, so if you want to share your presentation 
with someone using an earlier version of PowerPoint, you'll 
need to save it as a PowerPoint 97-2003 presentation. 

1. Click the File tab. 
2. Select Save As. 
3. In the Save as type drop-down menu, 

select PowerPoint 97-2003 Presentation. 
4. Select the location you wish to save the 

presentation. 
5. Enter a name for the presentation and click Save. 

 
To Save as a Different File Type: 
If you would like to share your presentation with someone 
who does not have PowerPoint, you have several different file 
types to choose from. 

1. Click the File tab. 
2. Select Save & Send. 
3. Choose from three special File Types. 
 Create PDF/XPS Document: Saves the contents of 

your slide show as a document instead of a 
PowerPoint file. 

 Create a Video: Saves your presentation as a video 
that can be shared online, in an email, or on a disc. 

 Package Presentation for CD: Saves your 
presentation in a folder along with the Microsoft 
PowerPoint Viewer, a special slide show player that 
anyone can download and use. 

 
To View the Print Pane: 

1. Click the File tab to go to Backstage view. 
2. Select Print. The Print pane appears, with the print 

settings on the left and the Preview on the right. 
 
To Print: 

1. Go to the Print pane. 
2. Determine and choose how you want the slides to 

appear on the page. 
3. If you only want to print certain pages, you can type 

a range of pages. Otherwise, select Print All Pages. 
4. Select the number of copies. 
5. Check the Collate box if you are printing multiple 

copies of a multi-page document. 
6. Select a printer from the drop-down list. 
7. Click the Print button. 

 
 

 
___________________________________________ 

 

To Use the Save As Command: 
 
Save As allows you to choose a name and location for your 
presentation. It's useful if you've first created a presentation or if 
you want to save a different version of a presentation while 
keeping the original. 
1. Click the File tab. 
2. Select Save As. 
3. The Save As dialog box will appear. Select the location where 

you wish to save the presentation. 
4. Enter a name for the presentation and click Save. 

 
If you're using Windows 7, you'll usually want to save things to 
your Documents library, and in other versions of Windows you'll 
save them to the My Documents folder.. 
 
To Use the Save Command: 
1. Click the Save command on the Quick Access Toolbar. 
2. The presentation will be saved in its current location with the 

same file name. 
If you are saving for the first time and select Save, the Save 
As dialog box will appear. 
 
AutoRecover 
PowerPoint automatically saves your presentation to a temporary 
folder while you're working on them. If you forget to save your 
changes, or if PowerPoint crashes, you can recover the autosaved 
file. 
1. Open a presentation that was previously closed without saving. 
2. In Backstage view, click Info. 
3. If there are autosaved versions of your file, they will appear 

under Versions. Click on the file to open it. 
4. To save changes, click Restore and then click OK. 
By default, PowerPoint autosaves every 10 minutes. If you are 
editing a presentation for less than 10 minutes, PowerPoint may not 
create an autosaved version. 
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Unit-V- MS-Access 2010i 
 

Lesson: 1  
 

 Getting Started with M.S Access 2010i 
 

 
Access 2010 is relational database software in the Microsoft 2010 Office Suite that allows users to enter, manage and run reports on 
large amounts of data. Whenever you're learning a new program, it's important to familiarize yourself with the program window and 
the tools within it. Working with Access is no different. Knowing your way around the Access environment will make learning and 
using Access much easier. You will familiarize yourself with the Access environment, including the Ribbon, the Backstage view, 
the Navigation Pane, the Document Tabs bar, and the Record Navigation bar. You will also learn how to navigate with navigation 
form, if your database includes one. 
 
Working with Your Access Environment 
 
The Ribbon and the Quick Access Toolbar are where you will find the commands you will use to do common tasks in Access. If you 
are familiar with Access 2007, you will find that the main difference in the Access 2010 Ribbon is that commands such 
as Open and Print are now housed in Backstage view. 
 
The Ribbon 
 
The Ribbon contains 
multiple tabs, each with 
several groups of commands. 
Some tabs, like Form Layout 
Tools or Table Tools, may 
appear only when you are 
working with certain objects like 
forms or tables. These tabs are 
called contextual tabs, and are 
highlighted in a contrasting color 
to distinguish them from normal 
tabs. 

  
 
To Minimize and Maximize the Ribbon: 
 

The Quick Access Toolbar 
 

  
The Quick Access Toolbar is located above the Ribbon, 
and it lets you access common commands no matter which 
tab you are on. By default, it shows the Save, Undo, 
and Repeat commands. If you'd like, you can customize it 
by adding additional commands. 
Note that the Save command only saves the current open 
object. In addition, the Undo command will not undo certain 
actions, like adding a record. Pay close attention to your 
information when using the Undo command to make sure it 
has the desired effect. 
 

The Ribbon is designed to be easy to use and responsive to your 
current task, but if you feel that it's taking up too much of your 
screen space, you can minimize it. 

1. Click the arrow in the upper-right corner of the Ribbon to 
minimize it. 

2. To maximize the Ribbon, click the arrow again. 

When the Ribbon is minimized, you can make it reappear by 
clicking on a tab. However, the Ribbon will disappear again when 
you are not using it. 
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Backstage View 
   

To Minimize and Maximize the Navigation Pane: 
The Navigation Pane is designed to help you manage all your 
objects, but if you feel that it takes up too much of your screen 
space, you can minimize it. 

1. Click the double arrow  in the upper-right corner 
of the Navigation Pane to minimize it. 

2. To make the Navigation Pane visible again, click 
the double arrow   to maximize it. 

If you would like to make the Navigation Pane smaller without 
fully minimizing it, you can resize it. Simply click and drag the 
right border of the Navigation Pane. When it is the desired size, 
release your mouse. 

 
 
To Sort the Objects in the Navigation Pane: 
By default, your objects are sorted by type, with the tables in 
one group, the forms in another, and so on. However, if you 
wish, you can sort the objects in the Navigation Pane into 
groups of your choosing. 
1. Click the drop-down arrow to the right of the words All 

Access Objects. 

 
2. In the drop-down menu, select the desired sort. 

o Select Custom to create a custom group for sorting the 
objects. After applying the sort, simply drag the desired 
objects to the new group. 

o Select Object Type to group the objects by type. This is 
the default setting. 

o Select Tables and Related Views to group forms, queries, 
and reports together with the tables 
they refer to. 

o Select Created Date or Modified 
Date to sort the objects from most 
to least recently created or 
modified.      

3. The objects in the Navigation Pane 
will now be sorted to reflect your 
choice. 

To further customize the appearance of 
the Navigation Pane, you can 
also minimize groups of objects you 
don't want to see. Simply click the 
upward double arrow next to the 
name of the group. To restore the group 
to its full size, click the downward 
double arrow . 
 

Backstage view gives you various options for opening, 
saving, printing, and viewing more information about your 
database. It is similar to the Office Button Menu from 
Access 2007 or the File Menu from earlier versions of 
Access. However, unlike those menus, it is a full-page 
view, which makes it easier to work with. 
 
To Get to Backstage View: 

1. Click the File tab. 
2. You can choose an option on the left side of the 

page. 

3. To get back to your database objects, just click any 
tab on the Ribbon. 

 
 
The Navigation Pane 
 

The Navigation Pane is a list containing every object in your 
database. For easier viewing, the objects are organized into 
groups by type. You can open, rename, and delete objects 
using the Navigation Pane. 
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Databases with Navigation Forms 
 
Some databases include a navigation form that opens automatically when the database is opened.  Navigation forms are designed 
as a user-friendly replacement for the Navigation Pane. They contain tabs that allow you to view and work with common forms, 
queries, and reports. Having your frequently-used objects available to you in one place lets you access them quickly and easily. 
To open an object from a navigation form, simply click on its tab. The object will be displayed within the navigation form. Once an 
object is open, you can work with it as you normally would. 

 
 

(Viewing the Orders form using a navigation form) 
 

Generally, navigation forms include only the objects a typical user will need to work with fairly regularly, which is why your navigation 
form may not include every single form, query, or report. This makes it easier to navigate around the database. By hiding tables and 
rarely used forms, queries, and reports, it also reduces the chance of the database being damaged by users accidentally editing or 
deleting necessary data. 
For this reason, it's important to ask your database designer or administrator before you work with objects that are not available in 
your navigation form. Once you have the go-ahead, you can simply maximize the Navigation Pane and open the objects from there. 

 

 
 
 

_______________________________________________ 
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Lesson: 2 
 

 Introduction to Database & Objectsi 
 

 

  

In Access, lists are a little more complex than the ones you write on 
paper. Access stores its lists of data in tables, which allow you to 
store even more detailed information. In the table below, the 
“People” list in the amateur baker’s database has been expanded to 
include other relevant information about the baker’s friends. 

 

(A table in Access) 
If you are familiar with other programs in the Microsoft Office suite, 
this might remind you a lot of Excel, which allows you to organize 
data in a similar way. And in fact, you could build a very similar table 
in Excel. 
 
Why Use a Database? 
 
If a database is essentially a collection of lists stored in tables, and 
you can build tables in Excel, why do you need a real database in the 
first place? While Excel is great at storing and organizing numbers, 
Access is far stronger at handling non-numerical data like names and 
descriptions. Non-numerical data plays a big role in almost any 
database, and it's important to be able to sort and analyze it. 
However, the thing that really sets databases apart from any other 
way of storing data is connectivity. We call a database like the ones 
you’ll work with in Access a relational database. A relational 
database is able to understand how lists and the objects within 
them relate to one another. To explore this idea, let's go back to 
the simple database with two lists: names of your friends, and the 
types of cookies you know how to make. You decide to create a third 
list to keep track of the batches of cookies you make and who they’re 
for. Since you're only making cookies you know the recipe for, and 
you're only going to give them to your friends, this new list will get all 
its information from the lists you made earlier. 
See how the third list uses words that appeared in the first two lists? 
A database is capable of understanding that the "Dad" and 
"Oatmeal" cookies in the "Batches" list are the same things as the 
"Dad" and "Oatmeal" in the first two lists. This relationship seems 
obvious, and a person would understand it right away. However, an 
Excel workbook wouldn’t. 
Excel would treat all of those things as distinct and unrelated pieces 

Databases  
 
Access 2010 is a database creation and 
management program. To understand Access, you must 
first understand databases. You will familiarize yourself 
with the differences between data management 
in Access and Microsoft Excel.  
 
What is a Database? 
 
A database is a collection of data that is stored in a 
computer system. Databases allow their users to enter, 
access, and analyze their data quickly and easily. 
They’re such a useful tool that you see them all the time. 
Ever waited while a doctor’s receptionist entered your 
personal information into a computer, or watched a store 
employee use a computer to see whether an item was in 
stock? Then you’ve seen a database in action. 
The easiest way to understand a database is to think of it 
as a collection of lists. Think about one of the databases 
we mentioned above-- the database of patient information 
at a doctor’s office. What lists are contained in a database 
like that? Well, to start with, there’s a list of the customer 
names. Then, there’s a list of past appointments, a list 
with medical history for each patient, a list of contact 
information... and so on, and so on. 
This is true of all databases, from the simplest to the most 
complex. For instance, if you like to bake, you might 
decide to keep a database containing the types of cookies 
you know how to make and the friends you give those 
cookies to. This is one of the simplest databases 
imaginable. It contains two lists: a list of your friends, and 
a list of cookies. 

 
However, if you were a professional baker, you would 
have many more lists to keep track of: a list of customers, 
a list of products sold, a list of prices, a list of orders... it 
goes on and on. The more lists you add, the 
more complex the database will be. 



 
 
 

SARVA EDUCATION (SITED) (Running- An I.T & Skill Advancement Training Programme)                                                                                                                                                            - 168 -                                                                                                                 

                                                                       

 

Visit us at:  www.sarvaindia.com                                                                 Licensed by Govt. of India                                                                       ISO 9001:2015 Certified 

of information. In Excel, you'd have to enter every single piece of information about a person or type of 
cookie all over again each time you mentioned it, because that database wouldn't be relational like an 
Access database is. Simply put, relational databases can recognize what a human can: that if the 
same words appear in multiple lists, they refer to the same thing. 
The fact that relational databases can handle information this way allows you to enter, search, 
and analyze data in more than one table at a time. All of these things would be very difficult to do in 
Excel, but in Access, even complicated tasks can be simplified and made fairly user-friendly. 
 

 Introduction to Objectsi 
 

Databases in Access 2010 are composed of four objects: tables, queries, forms, and reports. Together, these objects allow you to 
enter, store, analyze, and compile your data as you wish. 

 
Likewise, a record is more than just a row-- it’s a unit of 
information. Every cell in a given row is part of that row’s 
record.   

(A record) 
 

Notice how each record spans several fields. Even though 
the information in each record is organized into fields, it 
belongs with the other information in that record. See 
the number at the left of each row? That’s the ID number 
that identifies each record. The ID number for a record 
refers to every piece of information contained on that row. 
 

(Record ID numbers) 
 

 

Tables are good for storing closely related information. 
Say that you own a bakery and have a database that 
includes a table with your customers' names and 
information like their phone numbers, home addresses, and 
email addresses. Since these pieces of information are all 
details about your customers, you’d include them all in the 
same table. Each customer would be represented by a 
unique record, and each type of information about those 
customers would be stored in its own field. If you decided to 
add any more information-- say, the customer's birthday-- 
you would simply create a new field within the same table. 
 

Tables 
 
By this point, you should already understand that a database is a 
collection of data organized into many connected lists. In Access, 
all data is stored in tables, which put tables at the heart of any 
database. You might already know that tables are organized into 
vertical columns and horizontal rows. 

 
In Access, rows and columns are referred to 
as Records and Fields. A field is more than just a column: it’s a 
way of organizing information by the type of data it is. Every piece 
of information within a field is of the same type. For example, 
every entry in a field called “First Name” would be a name, and 
every entry in field called “Street Address” would be an address. 
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   Forms 
Reports 
 
Reports offer you the ability to present your data in print. If 
you've ever received a computer printout of a class schedule or 
a printed invoice of a purchase, you've seen a database report. 
Reports are useful, because they allow you to present 
components of your database in an easy-to-read format. You 
can even customize a report's appearance to make it visually 
appealing. Access offers you the ability to create a report from 
any table or query. 

 
(A report) 

 

Putting it All Together 
 
Even if you have a good idea of how each object can be used, it 
can initially be hard to understand how they all work together. It 
helps to remember that they all work with the same data. Every 
piece of data a query, form, or report uses is stored in one of 
your database tables. 

 
(The four Access 2010 objects) 

Forms allow you to both add data to tables and view data that 
already exists.  Reports present data from tables and also from 
queries which, in turn, search for and analyze data within those 
same tables. 
These relationships sound complicated, but in fact, they work 
together so well and naturally that we often don't even notice 
when we're using connected database objects.  
Managing Databases and Objects 
 

Forms are used for: entering, modifying, 
and viewing records. You have probably had to fill out forms 
on many occasions, like when visiting a doctor's office, 
applying for a job, or registering for school. The reason forms 
are used so often is that they're an easy way to guide people 
into entering data correctly. When you enter information into a 
form in Access, that data goes exactly where the database 
designer wants it to go-- in one or more related tables. 

 
(A form) 

Forms make entering data easier. Working with extensive 
tables can be confusing, and when you have connected tables, 
you might need to work with more than one at once to enter a 
set of data. However, with forms, it's possible to enter data into 
multiple tables at once, all in one place. Database designers 
can even set restrictions on individual form components to 
ensure that all of the needed data is entered in the correct 
format. All in all, forms help keep data consistent and well-
organized, which is essential for an accurate and powerful 
database. 
 
Queries 
 
Queries are a way of searching for and compiling data from 
one or more tables. Running a query is like asking a 
detailed question of your database. When you build a query in 
Access, you are defining specific search conditions to find 
exactly the data you want. Queries are far more powerful than 
the simple searches you might carry out within a table. While 
a search would be able to help you find the name of one 
customer at your business, you could run a query to find the 
name and phone number of every customer who's made a 
purchase within the past week. A well-designed query can give 
information that you might not be able to find out just by 
looking through the data in your tables. 

 
(A query design) 
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Each Access database consists of multiple objects that let you interact with data. Databases can include forms for entering 
data, queries for searching within it, reports for analyzing it, and of course, tables for storing it. Whenever you work with your 
database, you are working with many of these objects at once. Fortunately, Access makes managing these objects pretty easy. 
 
To Open an Existing Database: 

1. Click the File tab. This takes you to Backstage view. 
2. Select Open. A dialog box will appear. 
3. Locate and select the desired database, then click Open. 
4. One or more warning messages may appear when you open your database. 

o If the database contains customized functions, a yellow bar with a security warning may appear below the Ribbon. 
If you trust the source of your database, click Enable Content for your database to display correctly. 

o After enabling all content in the database, you may see a message asking if you want to make the database 
a Trusted Document. Click yes if you would like all content to be automatically enabled each time you open the 
database. 

o You may be prompted to Log In to the database. Select your name from the log in list. If your name does not 
appear, click Add User to enter your information. 

If you have opened the existing database recently, it may be easier to look for your database in the short list that appears in the 
sidebar or to select Recent and choose a database from the list that appears. 
 
To Close a Database: 

1. Click the File tab to go to Backstage View. 
2. Select Close Database. 
3. If you have any unsaved objects, a dialog box will pop up for each one asking if you would like to save it. Select Yes to save 

the object, No to close it without saving, or Cancel to leave your database open. 
 
To Open an Object: 

1. In the Navigation Pane, locate the object you would like to open. 
2. Double-click the desired object. It will open and appear as a tab in the Document Tabs bar. 

By default, the most recently opened object will display in the main window as the current object. To view another open object, 
simply click its tab in the Document Tabs bar. 
 
Saving Objects 
 
As in other Microsoft Office programs, you will be prompted to save any unsaved work when you attempt to close your database. 
However, it is a good idea to save your work as you go along. Saving your work often is the best way to ensure that you don't lose any 
information if your computer crashes. 
 
To Save a New Object: 

1. Select the object you wish to save by clicking its tab in the Document Tabs bar. 
2. Select the File tab to navigate to Backstage View. 
3. Click Save. 
4. The first time you save an object, you will be prompted to name it. Enter the desired object name, and click OK. 

To save an existing object, select save in Backstage View, or simply click the Save command in the Quick Access Toolbar. 
 
To Close an Object: 

1. Select the object you wish to close on the Document Tabs bar. 
2. Click the  on the far right of the Document Tabs bar. 
3. If there are any unsaved changes to the object, you will be prompted to save it. Select Yes to save, No to close it without 

saving your changes, or Cancel to leave the object open. 
You can also close an object by right-clicking its tab on the Document Tabs bar. A drop-down menu will appear. Select Close to close 
that object, or Close All to close all open objects. 
 
To Rename an Object: 

1. If the object you wish to rename is open, close it. 
2. In the Navigation Pane, right-click the object you would like to rename. 
3. Select Rename. 
4. Type the new name, then press the Enter key. 
 

______________________________ 
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Lesson: 3 
 

 Working with Tablesi 
 
While there are four types of database objects in Access 2010, tables are arguably the most important. Even when you're using 
forms, queries, and reports, you're still working with tables, since that's where all your data is stored. Tables are at the heart of any 
database, so it's important to understand how to use them. 
 
To Open an Existing Table: 

 
A record is one unit of information. Every cell on a 
given row is part of that row's record. Each record 
has its own ID number. Within a table, each ID 
number is unique to its record, and refers to all the 
information within that record. The ID number for a 
record cannot be changed. 

 
Each cell of data in your table is part of both 
a field and a record. For instance, if you had a 
table of names and contact information, each 
person would be represented by a record, and each 
piece of information about them-- their name, phone 
number, address, and so on-- would be contained 
within a distinct field on that record's row. 
 
Navigating Within Tables 
 
To navigate through records in a table, you can 
use the up and down arrow keys, scroll up and 
down, or use the arrows in the record navigation 
bar located at the bottom of your table. You can 
also find any record in the currently open table 
by searching for it using the record search box. 
Simply place your cursor in the search box, type any 
word that appears in the record you would like to 
find, and press the enter key. To view additional 
records that match your search, press enter again. 

 
To navigate between fields, you can use the left 
and right arrow keys or scroll left and right. 

 

1. Open your database and locate the Navigation Pane. 
2. In the Navigation Pane, locate the table you would like to open. 

Tables are marked with the  icon. 
3. Double-click the name of the table. It will open and appear as 

a tab in the Document Tabs bar. 

 
 
Understanding Tables 
 
All tables are composed of horizontal rows and vertical columns, with 
small rectangles called cells in the places where rows and columns 
intersect. In Access, rows and columns are referred to 
as records and fields. 

 
A field is a way of organizing information by type. Think of the field name as a 
question, and every cell within that field as a response to that question. 
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To Add a New Record: 
 

 

To Save a Record: 
1. Select the Home tab, and locate 

the Records group. 
2. Click the Save command. 

 
Be sure to save any unsaved records before closing a 
table. Access will not prompt you to save them when you 
close the table. 
 
Editing Records 
 

To quickly edit any record within a table, you can just click 
on it and type in your changes. However, Access also 
offers you the ability to find and replace a word within 
multiple records and to delete records entirely. 
 
To Replace a Word within a Record: 
You can edit multiple occurrences of the same word by 
using Find and Replace, which searches for a term and 
replaces it with another term. 

1. Select the Home tab and locate the Find group. 
2. Select the Replace command. The Find and 

Replace dialog box will appear. 

      
3. Click the Find What: box and type the word you 

would like to find. 
4. Click the Replace With: box and type the word 

you would like to replace the original word. 
5. Click the Look In: drop-down arrow to select the 

area you would like to search. 
o Select Current Field to limit your 

search to the currently selected field. 
o Select Current Document to search 

within the entire table. 
6. Click the Match: drop-down arrow to select how 

closely you'd like results to match your search. 
o Select Any Part of Field to search for 

your search term in any part of a cell. 
o Select Whole Field to search only for 

cells that match your search term 
exactly. 

o Select Beginning of Field to search 
only for cells that start with your search 
term. 

7. Click Find Next to find the next occurrence of 
your search term. 

8. Click Replace to replace the original word with 
the new one. 

While you can use Replace All to replace every instance of 
a term, replacing them one at a time allows you to be 
absolutely certain that you edit only the data you want. 
Replacing data unintentionally can have a negative impact 
on your database. 

There are three ways to add a new record to a table: 
 In the Records group on the Home tab, click 

the New command. 

 
 On the Record Navigation bar at the bottom of the 

window, click the New Record button. 

 
 Simply begin typing in the row below your last added 

record. 

 
Occasionally when you enter information into a record, a window 
will pop up to tell you that the information you've entered is invalid. 
That means the field you're working with has a validation rule, 
which is a rule about the type of data that can appear in that field. 
Click OK, then follow the instructions in the pop-up window to re-
enter your data. 
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To Delete a Record: 
1. Select the entire record by clicking the gray border at the left side of the record. 
2. Select the Home tab and locate the Records group. 
3. Click the Delete command. The record will be permanently deleted. 

The ID numbers assigned to records stay the same even after you delete a record. For example, if you delete the 34th record in a 
table, the sequence of record ID numbers will read "...32, 33, 35, 36...", rather than "...32, 33, 34, 35, 36...". 

       

Resizing Fields and Rows 
Alternate Row Color 
 
By default, the background of every other row in an Access 
table is a few shades darker than the background of the rest of 
the table. This darker alternate row color makes your table 
easier to read by offering a visual distinction between each 
record and the records directly above and below it. 
 
To Change the Alternate Row Color: 

1. Select the Home tab and locate the Text 
Formatting group. 

2. Click the Alternate Row Color drop-down arrow. 
3. Select a color from the drop-down menu, or select No 

Color to remove the alternate row color. 
4. Your alternate row color will be updated. 

 
 
Modifying Gridlines 
 
Another way Access makes your tables easier to read is by 
adding gridlines that mark the borders of each cell. Gridlines 
are the thin lines that appear between each cell, row, and 
column of your table. By default, gridlines are dark gray and 
appear on every side of a cell, but you can change their color, 
or hide undesired gridlines. 
 

 

If your fields and rows are too small or large for the data contained 
with them, you can always resize them so that all the text is 
displayed. 
 
To Resize a Field: 
1. Place your cursor over the right gridline in the field title. 

Your mouse will become a double arrow  . 

 
2. Click and drag the gridline to the right to increase the 

field width or to the left to decrease the field width. 
3. Release the mouse. The field width will be changed. 
 
To Resize a Row: 
1. Place your cursor over the bottom gridline in the gray 

area to the left of the row. Your mouse will become a 
double arrow . 

2. Click and drag the gridline downward to increase the row 
height or upward to decrease the row height. 

3. Release the mouse. The row height will be changed. 
 
Hiding Fields 
 
If you have a field that you don't plan on editing or don't want other 
people to edit, you can hide it. A hidden field is invisible but is still 
part of your database. Data within a hidden field can still be 
accessed from forms, queries, reports, and any related tables. 
 
To Hide a Field: 
1. Right-click the field title. 
2. From the drop-down menu, select Hide Fields. 
3. The field will be hidden. 

If you decide you would like the field to be visible again, you 
can unhide it. Simply right-click any field title, then select Unhide 
Fields. In the dialog box, click the checkboxes of any fields you 
would like to be visible again, then click OK. 
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To Customize Which Gridlines Appear: 
Adding and Rearranging Fields 
 
Access makes it easy to rearrange existing fields and 
add new ones. When you add a new field, you can 
even set the data type, which dictates which type of 
data can be entered into that field. 
 
To Add a New Field to an Existing Table: 

1. Open the table, then click the header with 
the text Click to Add. If you already have 
many fields, you may have to scroll all the 
way to the right to see this. 

 
2. A drop-down menu will appear. Select 

the data type you'd like for the new field. 
 

o Text: The default option, and best for text. 
You should also choose it for numbers you 
don't plan to do math with, like postal codes 
and phone numbers. 

o Number: Best for numbers you might want 
to do calculations with, like quantities of an 
item ordered 
or sold. 

o Currency: 
Automatically 

formats 
numbers in 
the currency 
used in your 
region. 

o     Date & Time: 
Allows you to 
choose a 
date from a 

pop-out 
calendar. 

o Yes/No: Inserts a checkbox into your field. 
o Memo: Ideal for large amounts of text, like 

product descriptions. You can format text 
entered in Memo fields. 

o Attachment: Allows you to attach files, like 
images. 

o Hyperlink: Creates a link out of web or email 
addresses. 

3. Type a name for your field, then press 
the Enter key. 

 
To Move a Field: 

 

1. Select the Home tab and locate the Text Formatting group. 
2. Click the Gridlines drop-down arrow. 

 
3. Select the gridlines you would like to appear. You can choose 

to have horizontal gridlines between the rows, 
vertical gridlines between the columns, both types of 
gridlines, or none at all. 

 
4. The gridlines on your table will be updated. 

Additional Formatting Options 
 

To view additional formatting options, click the Datasheet Formatting 
arrow located in the bottom right corner of the Text Formatting group. 

 
The Datasheet Formatting dialog box offers many advanced formatting 
options, including the ability to modify background color, gridline color, 
and border and line style. It even includes the ability to view 
a sample table with your formatting choices, so play around with the 
various formatting options until you get your table looking the way you 
want it. 
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To Set a Character Limit for a Field: 
1. Select the desired field. 

2. Click the Fields tab in the Table Tools tab group, 
then locate the Properties group. 

3. In the box next to Field Size, type the maximum 
number of characters you would like to allow in your 
field. 

 
4. Save your table. 

  
Validation Rules 
 
A validation rule is a rule that dictates what information can 
be entered into a field. When a validation rule is in place, it is 
impossible for a user to enter data that violates that rule. For 
example, if we were asking the user to input a state name into 
a table with contact information, we might create a rule which 
limits the valid responses to U.S. state postal codes. This 
would prevent users from typing something that wasn't 
actually a real state postal code. 
In the example below, we will apply that rule to 
our Customers table. It's a fairly simple validation rule-- we'll 
just name all of the valid responses a user could enter, which 
will mean the user can't type anything else into the record. 
However, it's possible to create validation rules that are much 
more complex.  
 
To Create a Validation Rule: 

1. Select the field you wish to add a validation rule to. 
For our example, we'll set a rule for the State field. 

2. On the Ribbon, select the Fields tab and locate 
the Field Validation group. Click 
the Validation  drop-down command and 
select Field Validation Rule. 

 
3. The Expression Builder dialog box will appear. Click 

1. Locate the field you wish to move, then hover your mouse 
over the bottom border of the field header. Your cursor 

will become a four-sided arrow  . 

 
2. Click and drag the field to its new location. 

 
3. Release your cursor. The field will appear in the new 

location. 

 
  
Field Character Limits 
 
Setting the character limit for a field sets a rule about how 
many characters-- letters, numbers, punctuation, even spaces-
- can be entered in that field.  This can be useful to keep the 
data in your records concise, or even to force the user to enter 
the data a certain way. 
For instance, in the example below, the user is entering 
records which include addresses. If you set the character limit 
in the "state" field as "2," the user can only enter 2 characters 
of information. This means that he must enter postal 
abbreviations for the states instead of the full name-- here, NC 
instead of North Carolina. Note that you can only set a 
character limit for fields defined as text. 



 
 
 

SARVA EDUCATION (SITED) (Running- An I.T & Skill Advancement Training Programme)                                                                                                                                                            - 176 -                                                                                                                 

                                                                       

 

Visit us at:  www.sarvaindia.com                                                                 Licensed by Govt. of India                                                                       ISO 9001:2015 Certified 

the text box and type in your validation rule.  
In our example, we want to limit data in the State field to actual state postal codes. We'll type each of the valid responses in 
quotation marks, and separate them with the word Or, which lets Access know that this field can accept the response 

"AL" or "AK" or "AZ" or any of the other terms we've entered. 
  
4. Once you're 

satisfied with the 
validation rule, 
click OK. The 
dialog box will 
close. 

5. Click 
the Validation dro
p-down command 
again. This time, 
select Field Valid
ation Message.  

6. The Enter 
Validation 
Message dialog 
box will appear. 

Type the phrase you would like to appear in an error 
message when a user tries to enter data that violates the 
validation rule. Your message should let the user know what data is 
permitted. 

7. When you're satisfied with the error message, click OK. 
8. The validation rule is now included in the field. Users will be unable to enter 

data that violates 
the rule. 

 
Simple validation rules 
can be written exactly like query criteria. The only difference is that query 
criteria search for data, while an identical validation rule 
either permits or rejects data.  
 

 Calculated Fields and Totals Rows 
 
Adding calculated fields and totals rows to your table lets you perform calculations using your table data. A calculated field 
calculates data within one record, while a totals row performs a calculation on an entire field of data. Whenever you see a subtotal for 
one record, you are looking at a calculated field. Likewise, a grand total at the bottom of a table is really a totals row. 
 

 
 

________________________________________ 
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Lesson: 4 
 

 Working with Formsi 
 
While you can always enter data directly into database tables, you might find it easier to use forms. Using a form to enter data lets you 
be certain that you're entering the right data in the right location and format. This can help keep your database accurate and 
consistent.  
  
Why Use Forms? 
Many of us fill out forms so often that we hardly even notice when we're asked to use them. Forms are so popular because they're 
useful for both the person asking for the information and the person providing it. They are a way of requiring information in a specific 

format, which means the person filling out the form knows exactly which information to 
include and where to put it. 
 
Filling out a paper form 
This is just as true of forms in Access.  When you enter information into a form in Access, 
that data goes exactly where it's supposed to go-- into one or more related tables.  While 
entering data into simple tables is fairly straightforward, data entry becomes more 
complicated as you start populating tables with records from elsewhere in the database. 
For instance, the orders table in a bakery's database might link to information about 
customers, products, and prices drawn from related tables. A record with information 
about a single order might look like this: 

 
In fact, in order to see the entire order, you would also have to look at the order items table, where the menu items that make up each 
order are recorded. 

The records in these tables include ID numbers of records from other 
tables. You can't learn much just by glancing at these records, as the 
ID numbers don't tell you much about the data they relate to. Plus, 
since you have to look at two tables just to view one order, you might 
have a hard time even finding the right data. It's easy to see how 
viewing or entering many records this way could become a difficult 

and tedious task. 
 
A form containing the same data might look like this: 
 
As you can see, this record is much easier to 
understand when viewed in a form. Modifying 
the record would be easier, too, since you 
wouldn't have to know any ID numbers to enter 
new data. When you're using a form, you don't 
have to worry about entering data into the right 
tables or in the right format-- the form can 
handle those things itself. There's no need to 
go back and forth between tables or search 
carefully within a table for a certain record, 
since forms let you see entire records one at a 
time. 
Not only do forms make  the data entry process 
easier for the user, they keep the database 
itself working smoothly. With forms, database 
designers can control exactly how users are 
able to interact with the database. They can 
even set restrictions on individual form 
components to ensure that all of the needed 
data is entered, and that it's all entered in a 
valid format. This is useful, as keeping the data 
consistent and well-organized is essential for 
an accurate and powerful database. 
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To Open an Existing Form: 
 

To Save the Current Record: 
1. Select the Home tab and locate 

the Records group. 
2. Click the Save command. The current record 

will be saved. 
 
To Delete the Current Record: 

1. Select the Home tab and locate 
the Records group. 

2. Click the Delete command. The record will be 
permanently deleted. 

 
Creating Forms 
 
Access makes it easy to create a form from any table in 
your database. Any form you create from a table will let 
you view the data that's already in that table and add 
new data. Once you've created a form, you can also 
modify it by adding additional fields and design 
controls such as combo boxes. 
 
To Create a Form: 

1. In the Navigation Pane, select the table you 
would like to use to create a form. You do not 
need to open the table. 

2. Select the Create tab on the Ribbon and locate 
the Forms group. Click the Form command. 

 
3. Your form will be created and opened 

in Layout View. 

 
4. To save the form, click the Save command on 

the Quick Access Toolbar. When prompted, 
type a name for the form and then click OK. 

1. Open your database and locate the Navigation Pane. 
2. In the Navigation Pane, locate the form you would like to 

open. Forms are marked with the  icon. 
3. Double-click the name of the form. It will open and appear 

as a tab in the Document Tabs bar. 

 
 
Entering and Modifying Data 
 
Depending on the database you're using, the forms you work with 
may include special tools and features that let you do common tasks 
with one click of a button. You'll see examples of these tools in the 
interactive on the next page. However, no matter what type of form 
you're working with, you can follow the same procedures for carrying 
out certain basic tasks. 
 
To Add a New Record: 
There are two ways to add a new record to a form: 

 In the Records group on the Home tab of the Ribbon, click 
the New command. 

 On the Record Navigation bar at the bottom of the window, 
click the New Record button. 

 
To Find an Existing Record to View or Edit: 
There are two ways to find and view an existing record using a form, 
and they both use the Navigation Bar at the bottom of the screen: 

 To look through records one at a time, click the navigation 
arrows. The right arrow will take you to the next record, and 
the left arrow will take you to the previous one. 

 
 To search for a record, type a word that you know is 

contained in that record in the navigation search box. 
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About Subforms 
To Add a Field to a Form: 
1. Select the Form Layout Tools Design tab, then locate 

the Tools group on the right side of the Ribbon. 
2. Click the Add Existing Fields command. 

 
3. The Field List pane will appear. Select the field or fields to 

add to your form. 
o If you want to add a field from the same table you used to 

build the form, simply double-click the name of the desired 
field. 

 
To add a field from a different table: 
1. Click Show All Tables. 
2. Click the plus sign + next to the table that contains the field 

you wish to add. 
3. Double-click the desired field. 

 
4. The new field will be added. 

 
You can also use the above procedure to add fields to a totally blank 
form. Simply create a form by clicking the Blank Form command 
on the Create tab, then follow the above steps to add the desired 
fields. 

If you created a form from a table whose records are linked to 
another table, your form probably includes a subform. A 
subform is a datasheet form that displays linked records in a 
table-like format. For instance, the subform included in 
the Customers form we just created displays linked 
customer orders. We probably don't need to include this 
subform, since we really just want to use the Customers form 
to enter and review contact information. If you find that you 
don't need a subform, you can easily delete it. Simply click it 
and press the delete key. 

 
However, subforms aren't always useless. Depending on the 
content and source of your form, you might find that the 
subform contains useful information, as in the example below. 
In our Orders form, the subform contains the name, quantity, 
and price of each item contained in that order, which is all very 
useful information. 

 
 

Adding Additional Fields to a Form 
When you use the Form command on an existing table, all of 
the fields from that table are included in that form. However, if 
you later add additional fields to that table, those fields 
will not automatically show up in existing forms. In situations 
like this, you can add additional fields to a form. 
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Adding Design Controls 
Design Controls set restrictions on the fields in your forms. This helps you better control how the data is entered into your forms, 
which in turn helps keep the database consistent. 
 
Combo Boxes 
A combo box is a drop-down list that you can use in your form in place of a field. Combo boxes limit the information that a user can 
enter by forcing them to select only the options that you have specified. 
Combo boxes are useful for fields that have a limited number of possible valid responses. For instance, you might use a combo box to 
make sure that people only enter a valid U.S. state while entering an address, or that they only choose products that already exist in 
your database while placing an order. 

   

5. Type in the choices you would like to appear in your 
drop-down list. Each choice should be on its own row. In 
our example, we are creating a combo box for the Add 
to Mailing List? field in our form, so we will enter all of 
the possible valid responses for that field. Users will be 
able to select one of three choices from our finished 
combo box: "No,"  "Yes- Weekly," and "Special Offers 
Only." 

 
6. If necessary, resize the column so that all your text is 
visible. Once you are satisfied with your list, click Next. 

 
7. Select Store that value in this field, then click the 
drop-down arrow and select the field where you would 
like selections from your combo box to be recorded. After 
making your selection, click Next. 

 

To Create a Combo Box: 
1. In Form Layout view, select the Form Layout Tools Design tab 

and locate the Controls group. 
2. Select the Combo Box command, which looks like a drop-down 

list. 

 
3. Your cursor will turn into a tiny crosshairs and drop-down 

list icon . Move the cursor to the place where you would like to 
insert the combo box, and click. A yellow line will appear to 
indicate the location where your combo box will be created.  
In our example, the combo box will be 
located between the City field and the Add to Mailing 
List? field. 

 
4. The Combo Box Wizard dialog box will appear. Select the 

second option, I will type in the values I want, then click Next. 
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Some users report that Access malfunctions while working 
with forms. If you have a problem performing any of these 
tasks in Layout view, try switching to Design View. 
 
Customizing Form Settings with the Property Sheet 
 
The Property Sheet is a pane containing detailed 
information about your form and each of its components. 
From the Property Sheet, you can make changes to every 
part of your form, both in terms of function and appearance. 
The best way to familiarize yourself with the property sheet 
is to open it and select various options. When you select 
an option, Access will display a brief description of that 
option on the bottom left border of the program window. 
 

 

8.     Enter the label, or name that will appear next to your combo 
box. Generally, it's a good idea to use the name of the field 
that you chose in the previous step. 

 
9.  Click Finish. Your combo box will appear on the form. If you 

created your combo box to replace an existing field, you 
should delete the first field. 
In our example, you might notice that we now have two fields 
with the same name. These two fields send information to the 
same place, so we don't need them both. We'll delete the one 
without the combo box. 

 
10.   Switch to Form view to test your combo box. Simply click the 

drop-down arrow and verify that the list contains the correct 
choices. The combo box can now be used to enter data. 

 
If you want to include a drop-down list with a long list of options and 
don't want to type them all out, create a combo box and choose the 
first option in the combo box wizard, I want to get the values from 
another table or query. This will allow you to create a drop-down 
list from a table field. 
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Modifying Form Settings 
 

To Set a Field to Auto-fill with the Current Date 
 
1. In either Layout or Design view, select 

the Design tab and locate the Tools group. Click 
the Property Sheet command. 

2. The Property Sheet will appear in a pane on the right. 
On the form, select the field you would like to 
automatically fill in the current date. This must be a 
field with the date data type. For our example, we'll 
select the Pickup Date field on our Orders form. 

3. In the Property Sheet, click the Data tab and select 
the Default Value field in the fourth row. Click the 
Expression Builder button  that appears in the 
column to the right. 

4. The Expression Builder dialog box will open. In 
the Expression Elements list, click the 
words Common Expressions. 

5. In the Expression Categories list, double-
click Current Date. 

6. The expression for Current Date will be added. 
Click OK. 

7. Switch to Form view to verify that the expression 
works. When you create a new record with that form, 
the date field that you modified will automatically fill in 
the current date. 

 
Formatting Forms 
 
Access offers many options that let you make your forms 
look exactly the way you want. While some of these 
options, like command buttons, are unique to forms, others 
may be familiar to you. 
 
Command Buttons 
 
If you want to create a way for users of your form to quickly 
perform specific actions and tasks, consider adding 
command buttons. When you create a command button, 
you specify an action for it to carry out when clicked. By 
including commands for common tasks right in your form, 
you're making the form easier to use. 
Access offers many different types of command buttons, 
but they can be divided into a few main categories, 
including: 
 

 Record Navigation command buttons, which 
easily allow your user to move among the records 
in your database. 

 
 Record Operation command buttons, which let 

your user do things like save or print a record. 
 

 Form Operation command buttons, which give 
your user the ability to quickly open or close a 
form, print the current form, and other actions. 

 
 

 Report Operation command buttons, which offer 
the user a quick way to do things such as preview 
or mail a report from the current record. 

There are far too many options in the Property Sheet to discuss 
them all in detail. We'll review two useful ones here: hiding fields, 
and setting fields with dates to automatically fill in the current 
date. Practicing these procedures should give you a sense of how 
to work with other Property Sheet settings, as well. 
 
To Hide a Field: 
1. In either Layout or Design view, select the Design tab and 

locate the Tools group. Click the Property Sheet command. 

 
2. The Property Sheet will appear in a pane on the right. On the 

form, select the field you wish to hide. In our example, we'll 
hide the Customer ID field, since we don't want any of our 
users to try to edit it. 

 
 

3. In the Property Sheet, click the Format tab and locate 
the Visible option on the third row. 

4. Click the drop-down arrow in the column to the right, and 
select No. 
 

 
 

5. Switch to Form view to verify that the field is hidden. 
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To Add a Command Button to a Form: 
o To include a picture, select the Picture option. You can 

decide to keep the default picture for that command 
button, or select another picture. Click Show All 
Pictures to choose from another command button icon, 
or Browse... to choose a picture from your computer. 

 
2. When you are satisfied with the appearance of your 

command button, click Next. 
3. Type a name for the button. This name won't appear on 

the button, but knowing the name will help you quickly 
identify the button if you ever want to modify it with 
the Property Sheet. After typing the button name, click 
Finish. 

 
4. Switch to Form view to test the new button. Our Find 

Record button opens the Find and Replace dialog box.               

 
Some users report that Access malfunctions while formatting 
forms. If you have a problem performing any of these tasks in 
Layout view, try switching to Design View. 
 
Modifying Form Layout 
 
When you create a form, Access arranges the form 
components in a default layout where the fields are neatly 
stacked up on top of each other, all exactly the same width. 

1. In Form Layout view, select the Form Layout Tools 
Design tab and locate the Controls group. 

2. Select the Button command. 

 
3. Your cursor will turn into a tiny crosshairs with a 

button icon  . Place it in the spot where you would like 
your command button to be, and click. 

 
4. The Command Button Wizard will appear. In 

the Categories pane, select the category of button you want 
to add. We want to find a way to move more quickly to 
specific records, so we'll choose the Record Navigation 
category. 

5. The list in the Actions pane will update to reflect your 
chosen category. Select the action you would like the button 
to perform, then click Next. For our example, we'll 
choose Find Record. 

 
6. You can now decide whether you want your button to 

include text or a picture. A live preview of your button 
appears on the left. 

o To include text, select the Text option and type the desired 
word or phrase into the text box. 

 



 
 
 

SARVA EDUCATION (SITED) (Running- An I.T & Skill Advancement Training Programme)                                                                                                                                                            - 184 -                                                                                                                 

                                                                       

 

Visit us at:  www.sarvaindia.com                                                                 Licensed by Govt. of India                                                                       ISO 9001:2015 Certified 

While this layout is functional, you might find that it doesn't best fit your information. For instance, in the form below, most of the fields 
are almost completely empty, since the data stored there doesn't take up much room. 
The form would fit the data a little better if we made the fields and command buttons smaller, and even put some of them side by side. 
However, with the default layout, you won't be able to put two fields next to each other or resize one field or button without resizing 
them all. This is because Access lines up form components in rows and columns. When you resize a field, you're really resizing the 
column that contains it. 
We can do this using the command on the Arrange tab, which contains all the tools you need to customize your form's layout.  

 
 
2. Click and drag the field or button to its new location. If you're moving a 
field, make sure to move the field label, as well. 

 
 3. Repeat steps 1-2 with any other fields or buttons you wish to   move. 

 
If you would like to make a field take up more or less space than one 
column, you can use the Merge and Split commands. The Merge 
command combines two or more cells, while 
the Split command divides a cell. 
    

 
 

_____________________________________ 

To Resize Form Components: 
1. Switch to Layout view. 

 
2. Select the field or button you would like to resize, 

and hover your mouse over the edge. Your cursor will 
become a double-sided arrow. 

3. Click and drag the edge to resize, and release when 
the field or button is the desired size. 

4. The field or button, as well as every other item in line 
with it, will be resized. 

To Move Form Components: 
 
1. If necessary, add columns or rows to make room for 

the field or button you wish to move, by using the Insert 
commands in the Rows & Columns group. 
In our example, we want to move the Last Name field to 
the right of to the First Name field, so we'll have to 
create two new columns to the right: one for the field 
label, and one for the field itself. To do this, we'll click 
the Insert Right command twice. 

 



 
 
 

SARVA EDUCATION (SITED) (Running- An I.T & Skill Advancement Training Programme)                                                                                                                                                            - 185 -                                                                                                                 

                                                                       

 

Visit us at:  www.sarvaindia.com                                                                 Licensed by Govt. of India                                                                       ISO 9001:2015 Certified 

Lesson: 5 
 

 Sorting & Filtering Recordsi 
 
 
Access 2010 gives you the ability to work with enormous amounts of data, which means it can be hard to learn anything about your 
database just by glancing at it. Sorting and filtering are two tools that let you customize how you organize and view your data making 
it more convenient to work with. Essentially, sorting and filtering are tools that let you organize your data. When you sort data, you 
are putting it in order. Filtering data lets you hide unimportant data and focus only on the data you're interested in. 
 
Sorting Records 
 

 
4. The table will now be sorted by the selected field. 

 
5. To save the new sort, click the Save command on the Quick 
Access toolbar. 
After you save the sort, the records will stay sorted that way until 
you perform another sort or remove the current one. To remove a 
sort, simply click the Remove Sort command. 
 
Filtering Records 
 
Filters allow you to view only the data you want to see. When 
you create a filter, you set criteria for the data you want to display. 
The filter then searches all of the records in the table, finds the 
ones that meet your search criteria, and temporarily hides the 
ones that don't. 
Filters are useful, as they allow you to focus in on specific records 
without being distracted by the data you're uninterested in. For 
instance, if you had a database that included customer and order 
information, you could create a filter to display only customers 
living within a certain city, or only orders that contain a certain 
product. Viewing this data with a filter would be far more 
convenient than searching for it in a large table.   
In our examples and explanations, we will be applying filters to 
tables. However, you can apply filters to any Access object. The 
procedure is largely the same. 

When you sort records, you are putting them into a logical 
order, with like data grouped together. As a result, sorted 
data is often simpler to read and understand than unsorted data. 
By default, Access sorts records by their ID numbers. However, 
there are many other ways records can be sorted. For example, 
the information in a database belonging to a bakery could be 
sorted in a number of ways: 

 Orders could be sorted by order date or by the last 
name of the customers who placed the orders. 

 Customers could be sorted by name or by 
the city or zip code where they live. 

 Products could be sorted by name, category (e.g., 
pies, cakes, cupcakes, etc.), or price. 

 You can sort both text and numbers in two ways: 
in ascending order or descending order. "Ascending" means 
"going up," so an ascending sort will arrange numbers 
from smallest to largest and text from A to Z. "Descending" 
means "going down," or largest to smallest for numbers and Z 
to A for text. The default ID number sort that appears in your 
tables is an ascending sort, which is why the lowest ID numbers 
appear first. In our example, we will be performing a sort on a 
table. However, you can sort records in any Access object. The 
procedure is largely the same. 
 
To Sort Records: 

1. Select a field in the cell you wish to sort by. In this 
example, we will sort by customers' last names. 

 
2. Click the Home tab on the Ribbon and locate the Sort 

& Filter group. 
3. Sort the field by selecting 

the Ascending or Descending command. 
o Select Ascending to sort text A to Z or to 

sort numbers from smallest to largest. We 
will select this in our example, since we 
want the last names to be in A to Z order. 

o Select Descending to sort text Z to A or to 
sort numbers from largest to smallest. 
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To Create a Simple Filter: 
   

Filtering Text by a Search Term 
 
When filtering text by entering a search term, you can use 
some of the same options you use when filtering by a 
selection, like Equals, Does not Equal, Contains, and Does 
Not Contain. You can also choose from the following options: 
 Begins With, which includes only records whose data 

for the selected field begins with the search term 
 Does Not Begin With, which includes all 

records except those whose data for the selected field 
begins with the search term 

 Ends With, which includes only records whose data for 
the selected field ends with the search term 

 Does Not End With, which includes all 
records except those whose data for the selected field 
ends with the search term 

 
To Filter Text by a Search Term: 

1. Click the drop-down arrow next to the field you 
would like to filter by. If We want to filter the records 
in our orders table to display only those that contain 
notes with certain information, so we'll click the 
arrow in the Notes field. 

2. In the drop-down menu, hover your mouse over the 
words Text Filters. From the list that appears, 
select the way you would like the filter to match the 
term you enter. In this example, we want to view 
only records whose notes indicate the order was 
placed for a party. We'll select Contains, so that we 
can search for records that contain the word "party." 

3. The Custom Filter dialog box will appear. Type in 
the word you would like to use in your filter. 

4. Click OK. The filter will be applied. 
 
Filtering Numbers with a Search Term 
 
The process for filtering numbers with a search term is very 
similar to the process for filtering text. However, different 
filtering options are available to you when working with 
numbers. In addition to the Equals and Does not Equal, you 
can also choose: 

 Greater Than to include only records with numbers 
in that field greater than or equal to the number 
you enter 

 Less Than to include only records with numbers in 
that field less than or equal to the number you 
enter 

 Between to include records with numbers that fall 
within a certain range 

 
 
 
 
 
 

____________________________________________ 
 

1. Click the drop-down arrow next to the field you would like 
to filter by.  

2. A drop-down menu with a checklist will appear. Only 
checked items will be included in the filtered results. Use 
the following options to determine which items will be 
included in your filter: 

o Select and deselect items one at a time by 
clicking their checkboxes.  

o Click Select All to include every item in the filter. 
Clicking Select All a second time will deselect 
all items. 

o Click Blank to set the filter to find only the 
records with no data in the selected field. 

3. Click OK. The filter will be applied.  
Toggling your filter allows you to turn it on and off. To view the 
records without the filter, simply click the Toggle Filter command. To 
restore the filter, simply click it again. 
 
Creating a Filter from a Selection 
 
Filtering by selection allows you to select specific data from your 
table and find data that is similar or dissimilar to it. For instance, if 
you were working with a bakery's database and wanted to search for 
all products whose names contained the word "chocolate," you could 
select that word in one product name and create a filter with that 
selection. Creating a filter with a selection can be more convenient 
than setting up a simple filter if the field you're working with contains 
many items. 
 
To Create a Filter from a Selection: 

1. Select the cell or data you would like to create a filter with. 
If We want to see a list of all of our products that contain 
the word "chocolate" in their names, so we'll select the 
word "chocolate"  in the Product Name field. 

2. Select the Home tab on the Ribbon and locate the Sort & 
Filter group. 

3. Click the Selection drop-down arrow. 
4. Select the type of filter you would like to set up: 

o Selecting Equals will include only records with 
data that is identical to the selected data. 

o Selecting Does Not Equal will include all 
records except the data that is identical to the 
selection.. 

o Selecting Contains will include only records with 
cells that contain the selected data. We'll select 
this, since we want to see records that contain 
the word "chocolate" anywhere in the title. 

o Selecting Does Not Contain will include all 
records except those with cells that contain the 
selected data. 

5. The filter will be applied. Our table now displays only 
products with the word "chocolate" in their names. 

Creating a Filter from a Search Term 
 
You can also create a filter by entering a search term and specifying 
the way Access should match data to that term. Creating a filter from 
a search term is similar to creating a filter from a selection. 
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Lesson: 6 
 

 Designing A Queryi 
 

 
The real power of a relational database is in the ability to quickly retrieve and analyze your data by running a query. Queries allow you 
to pull information from one or more tables based on a set of search conditions you define. 
Running a query is like asking a detailed question of your database. When you build a query in Access, you are defining specific 
search conditions to find exactly the data you want. 
 
How are Queries Used? 
Queries are far more powerful than the simple searches or filters you might use to find data within a table. This is because queries 
can draw their information from multiple tables. For example, while you could use a search in the customers table to find the name of 
one customer at your business or a filter on the orders table to view only orders placed within the past week, neither of those would let 
you view both customers and orders at once. However, you could easily run a query to find the name and phone number of every 
customer who's made a purchase within the past week. A well-designed query can give information that you might not be able to find 
out just by examining the data in your tables. 
When you run a query, the results are presented to you in a table, but when you design one, you use a very different view. This is 
called Query Design view, and it lets you see how your query is put together. 
 
One-Table Queries 
Let's familiarize ourselves with the query-building process by building the simplest query possible: a one-table query. 
We will run a query on the Customers table of our bakery database. Imagine that our bakery is having a special event, and we want to 
invite our customers who live nearby, since they are the most likely to come. This means we need to see a list of all the customers 
who live close by, and only those customers. 
If you think this sound a little like applying a filter, you're right. A one-table query is actually just an advanced filter applied to a table. 

 
4. The selected table will appear as a small window in 
the Object Relationship Pane. In the table window, 
double-click the field names you would like to include in 
your query. They will be added to the Design Grid in the 
bottom part of the screen.  
In our example, we want to mail invitations to customers 
who live in a certain area, so we'll include the first and last 
name, street address, city, state, and zip code fields. We 
aren't planning on calling or emailing our customers, so we 
don't have to include the telephone or email fields. 
 

 
 
5. Set the search criteria by clicking on the cell in 
the Criteria: row of each field you would like to filter.   

To Apply a Simple One-Table Query: 
1. Select the Create tab on the Ribbon and locate 

the Queries group. 
2. Select the Query Design command. 

 
3. Access will switch to Query Design view. In the Show 

Table dialog box that appears, select the table you would 
like to run a query on. Click Add, then click Close. We 
are running a query about our customers, so we will add 
the Customers table. 
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                                                                                              To Design a Multi-Table Query 
 

Queries can be hard to understand and build if you 
don't have a good idea of what you're trying to find 
and how to find it. A one-table query can be simple 
enough to make up as you go along, but to build 
anything more powerful, you'll need to plan the 
query in advance. 
 
Planning a Query 
 
When planning a query that uses more than one 
table, you should go through these four steps: 
1. Pinpoint exactly what you want to know. If you 

could ask your database any question, what 
would it be? Building a query is more 
complicated than just asking a question, but 
knowing precisely what question you want to 
answer is essential to building a useful query. 

2. Identify every type of information you want 
included in your query results. Which fields 
contain this information? 

3. Locate the fields you want to include in your 
query. Which tables are they contained in? 

4. Determine the criteria the information in each 
field needs to meet. Think about the question 
you asked in the first step. Which fields do you 
need to search for specific information? What 
information are you looking for? How will you 
search for it? 

  
This process might seem abstract at first, but as we 
go through the process of planning our own multi-
table query, you should start to understand how 
planning your queries can make building them a lot 
easier. 
 
Joining Tables in Queries 
 
The final thing you need to consider when designing 
a query is the way you link, or join, the tables you're 
working with. When you add two tables to an 
Access query, this is what you'll see in the Object 
Relationship Pane: 

 
The line connecting the two tables is called the join 
line. See how the join line is actually an arrow? This 
is because it indicates the order in which the query 
looks at data from the two tables.  In the image 
above, the arrow is pointing from left to right, which 
means that the query will look at data in 
the left table first, then look at only the data in the 

Typing criteria into more than one field in the Criteria: row will set your 
query to include only results that meet all the  
criteria. If you want to set multiple criteria, but don't need the records 
shown in your results to meet them all, type the first criteria in the Criteria: 
row and additional criteria in the Or: row and the rows beneath it. 
For this one-table query, we'll use very simple search criteria. 
o We want to find our customers who live in a city called Raleigh, so 

in our City field; we'll type"Raleigh." Typing "Raleigh" in quotation 
marks will retrieve all records with an exact match for "Raleigh" in 
the City field. 

o Some customers who live in the suburbs live fairly close by, and 
we'd like to invite them as well. We'll add their zip code, 27513 as 
another criterion. Since we want to find customers who either live in 
Raleigh or the 27513 zip code, we'll type "27513" in the or: row of 
the Zip Code field. 

. 
6.     After you have set your criteria, run the query by clicking 

the Run command on the Query Tools Design tab. 
7.     The query results will be displayed in the query's Datasheet View, 

which looks like a table. If desired, save your query by clicking 
the Save command in the Quick Access Toolbar. When prompted to 
name it, type in the desired name and click OK. 
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right table that relates to the records it's already seen in the left table. 
Your tables won't always be joined this way-- sometimes Access will join them right to left. In either case, you might need to change 
the direction of the join to make sure your query includes the correct information. The join direction can affect which 
information your query retrieves. 
 
Creating a Multi-Table Query 
 
Now that we've planned our query, we're ready to design and run it. If you have created written plans for your query, be sure to 
reference them often throughout the query design process. 

 
4.  The Join Properties dialog box will appear. Select an option to 
choose the direction of your join. 
o Choose option 2: for a Left to Right join. In our query, 

the left  table is the Customers table, so choosing this would 
mean that all of the customers who met our location criteria, 
whether or not they had placed an order, would be included in 
our results. We don't want to choose this option for our query. 

o Choose option 3: for a Right to Left query.  Since 
our right table is our Orders table, selecting this option will let 
us work with records for all of the orders and only the 
customers who've placed orders. We'll choose this option for 
our query, since this is exactly the data we want to see. 

 
5. In the table windows, double-click the field names you would 

like to include in your query. They will be added to the Design 
Grid in the bottom part of the screen. 
In our example, we'll include most of the fields from 
the Customers table: First Name, Last Name, Address, 
City, State, Zip Code, and Phone Number. We'll also include 
the ID number from the Orders table. 

 
6. Set field criteria by entering the desired criteria in the 

criteria row of each field. We want to set two criteria: 

To Create a Multi-Table Query: 
1. Select the Query Design Command from 

the Create tab on the Ribbon. 

 
2. In the Show Table dialog box that appears, select 

each table you would like to include in your query 
and click Add. After you have added all of the tables 
you wish, click Close. When we planned our query, 
we decided we needed information from 
the Customers and Orders table, so we'll add those. 

 
3. The tables will appear in the Object Relationship 

Pane, linked by a join line. Double-click the thin 
section of the join line between two tables to edit 
its join direction. 
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 First, to find customers who do not live in Raleigh, we'll type Not like ("Raleigh") in the City field. 
 Second, to find customers who have a phone number beginning with the area code 919, we'll type Like ("919*") in the Phone 

Number field. 

   
7. After you have set 

your criteria, run the 
query by clicking 
the Run command 
on the Query Tools 
Design tab. 

8. The query results will 
be displayed in the 
query's Datasheet 
View, which looks like a table. If desired, save your 
query by clicking the Save command in the Quick 
Access Toolbar. When prompted to name it, type in 
the desired name and click OK. 

  
To Sort Queries 
 

Access allows you to apply multiple sorts at once while you're designing your 
query.  This allows you to view your data exactly the way you want; every single 
time you view it. A sort that includes more than one sorted field is called a multi-
level sort. A multi-level sort allows you to apply an initial sort, then further 
organize that data with additional sorts.  For instance, if you had a table full of 
customers and their addresses, you might choose to first sort the records by city, 
then further sort them alphabetically by last name. 
When more than one sort is included in a query, Access reads the sorts from left 
to right. This means that the leftmost sort will be applied first. So for instance, in 
the below example, the customers will be sorted first by the City they live in and 
then by the Zip Code within that city. 

 

To Apply a Multi-Level Sort: 
1. Open the query, and switch to Design View. 
2. Locate the field you would like to sort first. In the Sort: row, click the drop-down arrow to select either an 

ascending or descending sort. 
3. Repeat the process in the other fields to add additional sorts. Remember, the sorts are applied from left to right, so any 

additional sorts must be applied to fields located to the right of your primary sort. If necessary, you can rearrange the fields 
by clicking a field and dragging it to a new location. 

4. To apply the sort, click the Run command. 
5. Your query results will appear with the desired sort. 

You can also apply multi-level sorts to tables that don't have queries applied to them. On the Home tab on the Ribbon, select 
the Advanced drop-down command in the Sort & Filter group. Select Advanced Filter/Sort, and create the multi-level sort as you 
normally would. When you're finished, click the Toggle Filter command to apply your sort. 
 

Hiding Fields within Queries 
 
Sometimes you might have fields that contain important criteria, but you might not need to actually see the information from that field 
in the final results. For example, take one of the queries we built in our last lesson-- a query to find the names and contact information 
of customers who had placed orders. We included Order ID numbers in our query, since we wanted to make sure that we only pulled 
customers who had placed orders. However, we really didn't need to see that information in our final query results. In fact, if we were 
just looking for customer names and addresses, seeing the order number mixed in there too might have even been distracting. 
Fortunately, Access makes it very easy to hide fields while still including any criteria they contain. 
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3. A row will be added to the table in the Design Grid, with all 
values in that row set to Group By. Select the cell in 
the Total: row of the field you would like to perform a 
calculation on, and click the drop-down arrow that appears. 

 
4. Select the calculation that you would like to be performed in 
that field. In our example, we want to add the quantities of 
products we've sold, so we'll select the Sum option. 

 
5. When you are satisfied with your query design, select 
the Run command on the Query Tools Design tab to run the 
query. 
6. The query results will be displayed in the 
query's Datasheet View, which looks like a table. If 
desired, save your query by clicking the Save command in 
the Quick Access Toolbar. When prompted to name it, type in 
the desired name and click OK. 
 
Other Types of Query 
 

 Parameter Query 
A parameter query allows you to create a query that can be 
updated easily to reflect a new criterion, or search term. 
When you open a parameter query, Access will prompt you 
for a search term, and show you query results that reflect that 
search. 
 Find Duplicates Query 
A find duplicates query lets you find all duplicate 
records in your database, so that you can delete them.  
Duplicate records can negatively affect the integrity of your 
database. 

 
__________________________________________ 

 

To Hide a Field within a Query:  
1. Open the query, and switch to Design View. 
2. Locate the field you would like to hide. 
3. Click the checkbox in the Show: row to uncheck it. 
4. To see the updated query, select the Run command. 

The field will be hidden. 
To unhide a hidden field, simply return to Design View and click 
the checkbox in the field's Show: row again. 

     
More Types of Queries 
 
By this point, you should understand how to create a simple one- 
or multi-table query using multiple criteria. Additional queries 
offer you the ability to perform even more complex actions with 
your database. One of these is the totals query, which lets you 
perform calculations with your data. 
 
Totals Queries 
 
Sometimes, setting simple criteria won't give you the results you 
need, especially when you're working with numbers. You may 
want to see your query results grouped or counted in some way. 
Access 2010 offers several options that make these functions 
possible. Perhaps the easiest of these is the Totals command. 
When you use the Totals function in your query, the data in your 
fields will be grouped by value, meaning that all items of one type 
are listed together. For instance, in a totals query about the items 
sold at our bakery, each type of item sold would be listed on a 
single row, no matter how many times that item had been sold. 
Once your records are grouped, you can perform calculations 
with them. These calculations include: 
 
 Count, which counts the number of the same items in a field 
 Sum, which adds the numbers in that field 
 Average, which finds the average of the numbers that occur in 

that field 
 Maximum, which returns the highest value that has been 

entered in that field 
 Minimum, which returns the lowest value that has been 

entered in that field 
 First, which returns the first, or earliest, value that has been 

entered in that field 
 Last, which returns the last, or most recent, value that has 

been entered in that field 
   

To Create a Totals Query: 
 
1. Create or open a query you would like to use as a totals 

query. For our example, we want to find the total number 
we've sold of each of our menu items, so we'll use a query 
showing us all of the menu items we've sold. If you want to 
follow along in our database, open the Menu Items 
Ordered query. 

2. In the Query Design tab, locate the Show/Hide group and 
select the Totals command. 
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Lesson: 7 
 

 Creating A Reporti 
 

Creating Reports 
If you need to share information from your database with someone, but don't want them actually working with your database, you 
should consider creating aReport. Reports allow you to organize and present your data in a reader-friendly, visually appealing format. 
Access 2010 makes it easy to create and customize a report using data from any query or table in your database. 
Reports give you the ability to present components of your database in an easy-to-read, printable format. Access 2010 lets you 
create reports from both tables and queries. 
 
To Create a Report: 

1. Open the table or query you would like to use in your report. We want to print out a list of last month's orders, so we'll open up 
our Orders Query. 

 
2. Select the Create tab on the Ribbon and locate the Reports group. Click the Report command. 

 
3. Access will create a new report based on your object. 

4. It's likely that some of your data will be located on the other side of the page break. To fix this, resize your fields. Simply select 
a field, then click and drag its edge until the field is the desired size. Repeat with additional fields until all of your fields fit. 
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5. To save your report, click the Save command on the Quick Access Toolbar. When prompted, type a name for your report 
and then click OK. 

Just like tables and queries, reports can be sorted and filtered. Simply right-click the field you wish to sort or filter. Then, select the 
desired sorting or filtering option. 
 
Deleting Fields 
You might find that your report contains some fields you don't really need to view. For instance, our report contains the Zip Code field, 
which isn't really necessary in a list of orders. Fortunately, you can delete fields in reports without affecting the table or query you got 
your data from. 
To Delete a Field in a Report: 

1. Click any cell in the field you would like to delete. 
2. Press the delete key. 

When you delete a field, be sure to delete its header as well. Simply select the header and press the delete key. 
  

Printing and Saving Reports in Print Preview 
 
While you can print reports using commands in the Backstage view, you can also use Print Preview. Print Preview shows you how 
your report will appear on the printed page. It also allows you to modify the way your report is displayed, print it, and even save it as 
a different file type. 
 
To Print a Report: 

1. On the Home tab of the Ribbon, click the View command and select Print Preview from the drop-down list. Your report will 
be shown as it will appear on the printed page. 

2. If necessary, modify the page size, margin width, and page orientation using the related commands on the Ribbon. 
3. Click the Print command. 
4. The Print dialog box will appear. Set any desired print options, then click OK. 

 
Saving Reports 
 
You can save reports in other formats so that they'll be viewable outside of Access. This is called exporting a file, and it allows you to 
view and even modify reports in other formats and programs. 
Access offers options to save your report as an Excel file, a Text file, a PDF, an XPS file, an email attachment, a Rich Text file, or 
an HTML document. Experiment with the different export options to find the one that best suits your needs. 
 
To Export a Report: 

1. On the Home tab of the Ribbon, click the View command and select Print Preview from the drop-down list. 
2. Locate the Data group on the Ribbon. 
3. Select one of the file type options on the Ribbon, or click More to see options to save your report as a Word or HTML file.  
4. Save your file. 

o If you're saving the report as a PDF or XPS file: 
1. Select the location where you wish to save the report. 

2. Place your cursor in the file name text box and type a name for your report if you wish to name it something other 
than the report title. 

3. In the Save as Type drop-down menu, select either PDF or XPS. 
4. Select the file quality by clicking either Standard for reports you plan on printing or Optimized for reports you plan 

to share primarily online. 
5. Once you are satisfied with your settings, click Publish to save your report. 

o If you're saving the report as any other type of file: 

1. Click Browse to specify your file location and name, then click Save. 
2. In the Export dialog box, click the checkboxes to select desired saving options where applicable, 
3. Click OK to export your report. 

5. A dialog box will appear to notify you that your file has been successfully saved. Click Close to return to your report. 
 

 
 
 
 

_______________________________ 
 
 



 
 
 

SARVA EDUCATION (SITED) (Running- An I.T & Skill Advancement Training Programme)                                                                                                                                                            - 194 -                                                                                                                 

                                                                       

 

Visit us at:  www.sarvaindia.com                                                                 Licensed by Govt. of India                                                                       ISO 9001:2015 Certified 

Lesson: 8 
 

 Designing Your Own Databasei 
 

 
Designing Your Own Database 
 
Now that you know how to use and modify existing databases, you might be interested in designing your own. Database design can 
be very complicated-- so complicated, in fact, that people take extensive courses just to learn how to plan databases. For that reason, 
we haven't focused on creating a database from scratch in this course. However, we can help you get started. 
In this lesson, you will learn how to create a database from an existing template. You will also learn about other resources you can 
use to learn database design. 
 
Creating a Database from a Template 
 
Before deciding to build your own database, you may want to look at the templates included in Access to see if any of them match 
your needs. When you select a template, Access creates a new database based on that template. Once it's created, you can fill the 
database with your own information, or modify it to suit your needs. 

 
4. Access will display all of the available templates of that 
type. Select a template to see more information about it, 
including a visual preview, on the right. 

 
5. When you have found the template you'd like to use,  
click Download. The template will open automatically once 
it's finished downloading. 

 
 

 
 

____________________________________ 
 

To Create a Database from a Template: 
1. Select the File tab. This will take you to Backstage View. 

 
2. On the sidebar, click New. 
3. Template options will appear. Under the Office.com 

Templates heading, you can see a list of templates 
grouped by type. Select the template type that best fits 
your needs. 
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Unit-VI- Interneti 
 

Lesson: 1  
 

 Introduction to Interneti 
 

 
Introduction to Internet 
 
In 1970 the Defence Department of USA, set up a network called ARPANET (Advanced Research Projects Agency Network). The 
main objective was to provide aid to military research and to test and develop network technologies. In order to share information and 
research results, scientific teams at Defence Ministry of US and a few selected universities and research laboratories collaborated. 
Slowly word spread about the advantages of collaborative work and more research teams and equipment manufacturers started 
forming network teams. As the network started growing, newer protocols like TCP/IP protocol (a set of protocols that help in 
communication over the Internet) evolved in which communication could take place between machines of different configurations and 
types.  In 1983, APRAnet disintegrated into:  
 

1.   MILnet (Military Network which integrated with Defence Data Network) 
2.   APRAnet (Network for research and educative purposes). 
 

Organizations in this period generally had Local Area Networks and were UNIX based systems, which could communicate very well 
with the APRAnet as they supported IP protocol. In late 1980s, the NSF (National Science Foundation) created five regional super 
computer centers to share resources for research. Now these centers were not only connected to each other but also had to provide 
support to all the clients. Slowly this system started suffering from bureaucratic problems, and finally, in 1990, this system was aban-
doned. 
NSF constructed its own network, namely, NSFnet based on ARPAnet's IP technology. In the new network, the centers were 
connected and each of the sites were connected to their nearest neighbor. This chain continued up till on of the regional super 
computers. As the success of communication and sharing of network resources spread, more and more users joined it and soon the 
network became overloaded. 
In 1987, NSF signed a cooperative agreement with Merit Network Inc. to maintain and upgrade the system. IBM, MCI and Merit 
together later founded the ANS (American National Standards). The original network lines were now replaced by faster telephone 
lines. In 1988, on 1st November, the Internet worm destroyed about 6,000 of the 60,000 hosts on the Internet, thus causing major 
damage. Since more and more countries were getting hooked onto the NSFnet, the NSFnet backbone was replaced by Tl NSFnet in 
1988 and later on by T3 NSFnet backbone in 1991, and finally even that was retired in April 1995 and was replaced by Network 
Access Points. In 1992, Internet Society (ISOC) was founded. It is a non-profit professional organization that facilitates and supports 
the technical evolution of the Internet. 
 
Meaning of Internet 
 
The term Internet has been coined by the combination of two words namely "interconnectivity" and "networks". Therefore, it is 
called the network of networks. It is a vast pool of resources that offers different opportunities to different people. In fact so much is its 
vastness that is cannot be explained by one single definition. A few common concepts about the Internet are: 

 
 It is an ocean of information waiting to be dived into. 
 It is a place where you can show your company's presence all over the world. 
 It provides an opportunity to communicate with near and dear ones all over the world at the least cost. 
 If offers employment opportunities all over the world.      
 It is a source of entertainment to the young and old in all walks of life. 

 
Internet Disadvantage- 
 

 However, not everything said about the Internet is positive. There are some taboos about it, namely: 
 Hackers and miscreants may create havoc by destroying system securities and injecting viruses. 
 Children may be exposed to topics censored at their ages.  
  It can be a time waster if not properly utilized. 
 There may be loss of privacy. 
 Addiction to Internet surfing is leading not only to social problems but medical ailments like weak eyes, backaches etc. 

 
Administration and Ownership of Internet 
 

One thing is certain that nobody owns the Internet, nobody funds it. In fact, every person who get connected to the Internet 
becomes a part of the family. The Internet is not administered by any central body. Many committees are working in teams to 
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constantly maintain the integrity of the Internet. ISOC consists of a group of people who maintain the Internet and promote 
communication on the Internet. It appoints the Internet Architecture Board, which authorizes standards and allocates and keeps a 
record of Internet resources (like IP addresses). Internet Engineering is another voluntary group, which handles technical problems. 
Coordination functions are performed by Internet NIC which charges a fee for registration of domain names to help cover 
administrative costs. Computer Emergency Response Team (CERT) looks after security matters. There are many n*ore voluntary 
bodies and the objective of all is to preserve the Internet and prevent it from crashing. 

 
8.  Direct Contacts between Customers and Organizations: 
The role of intermediaries had declined with the arrival of 
Internet, especially in the service industry. Direct reservation, 
sale/purchase of shares, downloading of software information 
regarding particular topics, are all easily available. Popularity of 
direct shopping by giving the product code is gaining importance 
these days. 
 
9.  Reduction of Uncertainty: 
Faster access to information brings the latest techniques and 
technologies at your doorstep thus increasing productivity. 
Uncertainty in mailing addresses etc., have diminished as an 
organizational or a residential address may change but the 
person can still be contacted, as e-mail identity remains the 
same. Of course, if the e-mail address is abandoned, then 
tracing a person would be next to impossible. 

 
10.  Curtailment of Unnecessary Expenditure: 
       In an organization, unnecessary expenditure can be   
reduced in the following ways: 

 No stationary or printing charges as orders and 
messages travel electronically. 

 Mailing is done at the cost of a telephone call. 
 No deliver charges. 
 Cost of filing is reduced. 
 Reduction of clerical costs like that of peons. 

 
11.   Internet supports different Machine Configurations: 
Different people are connected to different configuration 
machines and use different operating systems. The Internet 
provides connectivity to heterogeneous machines, therefore not 
only communication is possible between these machines but 
documents and files can also be shared. 

 
12.  Source of Entertainment: 
The Internet provides a wide range of entertainment like movies, 
music and games. Infact, there are certain screen savers that 
provide good quality music so mush so that you feel like dancing 
to their tunes. For a few such screen savers, try going to the 
website wwww.screensavers.com and website 
www.teenstation.com provides you a list of latest music 
albums. 
 
13.  Internet Resources: 
The power and potential of the Internet is unlimited. During the 
past few years the Internet has grown at an exponential rate, 
thus providing many services. A few of them are: 
 

  

7.   Internet Relay Chat 
8.   Finger Service 
9   Electronic Magazine/Journal 
10. Directories 
11. Bulletin Board System  
12. Mailing List of Listsery  
 
 

Internet Advantages- 
 
1. Employment Opportunities: 
The Internet opens up a Web of employment opportunities. As 
e- commerce is making rapid strides in India, and more and 
more companies are logging on to the Internet, many career 
opportunities have been created like that of web administrator, 
web designer, web developer, web page hosting, e-commerce 
and consultation groups 
 
2. High Speed and Accurate Information and Data Flow: 
An MBA graduate was looking for job opportunities in 
marketing. By 11 am., she had identified five interested jobs to 
which she e-mailed her resume and faxed some additional 
material the companies required. Within two hours, she 
received from two companies information regarding personal 
interview. Had conventional methods been used, the entire 
process would have taken a few days to a few weeks. 
 
3.  Round the Clock Availability: 
Though during office hours, employees cannot search for 
information of personal interest, e.g., search for jobs or do 
personal correspondence, during leisure time, the Internet can 
be well utilized for pleasure, work or for chat and mail. 
 
4.  Ocean of Knowledge: 
Information about a vast variety of subjects is available on the 
Internet all under one roof. The Internet could be considered 
as a vast encyclopedia containing the latest information of the 
old as well as latest products. All sorts of queries from gold 
rates to travel reservations to medical services to share prices 
etc., can be obtained on the Net. 
 
5.  Interactive Communication: 
Communication is the keyword today. Infact, due to this 
capability the world seems to get smaller all the time. Letters, 
telegrams, faxes are all one way communication but the 
Internet offers a huge variety in the types of information 
exchange, namely interactive, offline, one-to-one 
communication, one to many communication, and so on. 
 
 6.  Business on the Internet: 
E-commerce is the killing application of the Internet, where all 
sorts of business functions like ordering of items, making 
quotations, payment of bills, exchange of business documents 
take place. The only thing that is not possible on the Internet is 
the actual supply of goods apart from documents and 
software.  
 
7.  No Biased ness of the Internet: 
The Internet treats all people connected to it equally. No 
access permission is required apart from valid passwords and 
identity on the Internet. As a result of this feature, communi-
cation takes place all over the world without preference being 
given to a specific person, organization, or country 

1.  E-mail 
2.  Telnet or Remote Login 
3.   Usenet or Newsgroups  
4.   World Wide Web 
5.   File Transfer Protocol 
6.   Wide Area Information Server 
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Types of Connections: 
   

Internet Service Providers (ISP) 
 
An ISP sells monthly/hourly connections to the Internet, 
Initially, VSNL was the only ISP in India but as surfing 
the Internet became popular, many Indian companies 
have come forward. Some popular Indian ISPs are: 

 
The registration forms are available on the Internet itself 
on the web sites of the ISPs. 
 
Internet Application 
 
Browser 
 
A web browser is computer program/software that has to 
be loaded in the memory. A browser is an interface 
between the user and the internal working of the Internet. 
Browsers are referred as web clients or universal clients 
as they follow the principle of client server technology 
where the browser is the client. On typing in a URL in the 
address window or by following hyperlinks, the browser 
contacts the server by sending a request for the required 
information. After receiving this information the browser 
displays sit on the web page in the user's window. 
Browsers have different type- we can get its 
information from website (www.browers.com). Here we 
discussed features of browsers mainly about Microsoft 
Explorer:  
 
Features of a Good Browser- 
 
 The most important feature of a web browser is the 

presentation of web pages without distortion. 
 The browser should support multimedia features like 

sound, video etc. 
 It should also support forms and frames, divide web 

pages into sections, thus improving readability. 
 A good browser should have the ability to open 

multiple windows. 
 Latest browser support Active X technology, Java, 

VRML and other plug- in-supports. 
 E-mail, News, and FTP support should also be 

extended.  

No matter what type of connection you go in for, it should be reliable, 
fast, easily available, and economical. There are no such thing as a 
free connection to the Internet. Someone somewhere has to pay for 
the equipment, software, telephone lines, and electricity. 
 
Basically there are four types of connections to the Internet: 
 
1.      Dial-up Connection 
2.      ISDN Connection  
3.      Leased Line Connection 
4.      Cable Modem 
The most popular type of connection for an individual is the dial-up 
connection as it is easily available and economical. 
 
1.     Dial- Up Connection 

   
As the name suggests, dial-up link means you have to dial into a 
modem over a telephone line before you can get connected to the 
Internet. A modem (modulator demodulator) is a device, which 
converts digital signals emitting from the computer into analog signals 
so that the data is easily transmitted over analog telephone lines. At 
he receiving end, there is another modem, which converts these 
transmitted analog signals back to the digital form, which are received 
by the target computer. 
 
2.    Integrated Services Digital Network Connection (ISDN) 
This is a very high-speed connection to the Internet over normal 
telephone lines. It combines both voice and digital information in a 
single medium, making it possible to provide the Customers with 
digital as well as voice connections. In ISDN connection, the 
information which is sent from your computer to the Internet is digital. 
Here we do not use a normal modem. As no conversion from analog 
to digital or vice versa is required, so we use an ISDN modem which 
is merely a terminal adapter. Another difference lies in the fact that 
the ISDN lines, in order to work, require power from outside. When 
there is a power shutdown, ISDN lines will not work. ISDN service has 
many variations but we follow Basic Rate Interface (BRI) service. 
Here ISDN line is divided into two logical channels, namely. (a) Two 
64Kbps B (bearer) channels. (b) One 16Kbps D (data) channels. 
Thus ISDN is commonly referred to as 2B+D3. 
 
3.    Leased Line Connection (Dedicated Connection) 
As the name suggests, a leased line connection is permanent 
connection laid down between you and a modem. As it is permanently 
linked, you have a 24-hour access to the Internet, seven days in a 
week. A leased line connection is very useful especially when 
frequent information has to be accessed from the Internet and also 
when the volume of data transfer is high. It is also useful if the Internet 
is to be used for more than 12 hours a day. 
 
4.   Cable Modem 
In case of cable modem the Internet can be accessed through the 
normal coaxial television cables with the help of cable modems. 
Speed of cable modems is 10 to 100 times faster than normal dial-up 
connection modems. The only catch is that the local operator should 
have the capability to access the internet over cable TV wires and that 
cable modems are slightly more expensive than normal modems. One 
advantage of cable modem connection is that you need not have a 
telephone line if you want this type of connection to the Internet. 
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Microsoft Internet Explorer (MIE) 
 

Microsoft Internet Explore is a user friendly browser for the Internet. In other words, all multimedia resources (i.e. text, images sound 
and video) can be successes by must pointing and then clicking the mouse on full down menus, toolbar buttons and hyperlinks. 
Internet explorer is the primary internet browser for American Online. 

 

 
Internet Explorer-8 

 
 Beginning exploring the Internet by clicking an item icon the Internet Explorer main window. The following features are available in 

Internet Explorer 6.0. 
    For more convenient Web browsing, you can now download files from the Internet in a separate window while you continue 

browsing other Web pages. 
 The new resizable toolbar provides you with Links, which give you fast and easy access to great Internet pages with content that is 

update regularly. 
 With the industry standard Internet ratings support, parents can filter our Web sites that could be inappropriate for their children. 
 Internet Explorer provides support for all of the latest HTML (Hypertext Markup Language) authoring features, including some 

features that are unique to Internet Explorer, such as borderless frames, floating frames, and HTML style sheets. 
 Internet Explorer also provides support for ActiveX documents. This means that you can view documents such as Microsoft Office 

files right in Internet Explorer, without starting another program, such as Microsoft Word. 
 SSL 2.0, SSL 3.0, and PCT security provide ultra-secure transactions over the Internet, For example, now you can make secure 

credit card purchases from a catalog on a Web page. 
 

To view a page on the Internet, click any hyperlink on your start page. A hyperlink can be a picture, a 3D image, or colored text 
(usually underlined). If you want to go to the next page, click the forward button on the toolbar, if you want to return to the previous 
page, click the back button on the toolbar. 
To go to a specific place or page in the address bar, type the address of the page you want to open, or click the down arrow to 
select it from the list, and then press ENTER. 
To search the Internet, click the button on the toolbar. The search programs that are available vary depending on your Internet 
service provider. 
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To return to a page you have already seen on the File menu, click the page in the list that you want to go to. This list is emptied 
when you quit Internet Explorer. For a complete list of all the pages you have viewed in all sessions, click the View menu, click Option, 
click the Navigation tab, and then click View History. Then double click the page you want to open. 
To return to the start page, click the home button on the toolbar. To use the Link bar to visit preselected Web pages, click the word 
Links on the toolbar and then click one of the links on it. 
To send a shortcut to a Web page in e-mail, on the File menu, point to Send Link To. Click the destination you want. To include this 
shortcut in an e-mail message, you must have an e-mail program installed. 
Viewing and organizing pages 

 
You can speed up the time it takes to display a page by not displaying pictures, sounds, or video. You can cancel a page that is taking 
too long to display by clicking the stop button on the toolbar. Internet Explorer keeps track of the last five pages you viewed. They are 
added to the Go menu so that you can easily return to them. If you plan to view a page often, you might want to add it to your 
collection of favorite pages, or create a shortcut to it on your desktop. You can save the current page to a file on your computer by 
clicking the file menu and then clicking Save As. 
 
 Netscape Navigator 
 
The Netscape Navigator is an example of a full 
feature World Wide Web browser. Developed 
by Netscape Communications Corporation, it 
offers an intuitive graphical interface; you must 
have domain access to the Internet. Once you 
establish your connection to the Internet, 
launch the Netscape Navigator by double 
clicking its icon. 
 
The first time you use the Netscape Navigator, 
you will see the Netscape Home page. Like 
most browsers, the Netscape Navigator allows 
you to specify any Web page to load when you 
start the browser. Access the Preferences 
dialog box under the Options menu to set a 
preference for a different Home Page. 
 
Netscape's browser offers many custom 
features under Preferences. You can select 
fonts, colors, and image display options. The 
middle section of the Options pull down menu 
allows you to control the appearance of the 
screen. Click on the selections in the pull down 
menu for additional information. After hyper 
linking to a new page, you can continue 
navigating the Web by a activating additional 
links you can also press the back button to 
return to the last Web page that was displayed 
 
Links that you have already activated appear in 
a different color. Unless you change the setting 
in the preference dialog box, Netscape retains 
your link history for thirty days. After that time, 
a link to a site you have already visited reverts 
to the color of unflawed links. 
 
The Netscape Navigator has many features that make browsing the Web simple and quick. It offers multiple windows for viewing one 
page while another one is loaded. It uses progressive rendering to enable you to view Web pages while they are still downloading. In 
addition, you can create your own menus of favorite Web sites by arranging your bookmarks in hierarchies. 
 

 
 

_____________________________________ 
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Lesson: 2  
 

 Electronic Maili 
 
 

An important application of Internet is e-mail. E in e-mail stands for electronic mail. When we transfer mail/messages from our 
computer to another computer electronically via telephone lines, it is called as e-mailing. 
Electronic mail is a widely used Internet service. It is a system for sending messages availability of the receiving host. With e mail one 
can or files to other computer users based on mailbox address, and supports mail exchange between users on the same or different 
computers. Unlike other client-server applications, e-mail lets users send anything from short letters to big files without problem 
current. With Email one can:  
 
 Send a single message to many recipients. 
 Send messages that include text, voice, video, or graphics. 
 Send messages to users on networks outside the Internet. 
 Send messages calling for a response from a computer program rather   than a user. 
 
E-mail system is like the postal system. Addresses are used to identify both the recipient and sender of a message. Messages that 
cannot be delivered within a specified amount of time are returned to the sender. Every user on the network has a private mailbox. 
Received mail is stored in the mailbox until the recipient removes or discards it.   

 

arjun@hotmail.com,   arjun@redifiFmail.com etc. 
This, however, depends upon the availability of that 
name on the specific server. 
 

E-mail has become very popular because of various 
reasons, which are: 
 

 Free of cost It is almost free of cost. The cost 
incurred is the cost of connecting to Internet. 

 Almost instant- The message is almost sent 
instantly. The only constraint is the heavy traffic on 
the URL on which the data has to be sent. 

 Various ways of making it possible- e-mail 
address can be obtained at various domains. So it is 
possible to send the message to various addresses 
at the same time in a single stroke to avoid loss of 
data. 

 Reduction of paper work the letter is not required 
to be typed on the paper rather it can be sent in the 
soft copy, so it reduces the paper work. 

 Increases efficiency - no time is wasted in typing, 
printing out, going to market to get tickets or in 
posting the letter. Everything is virtually instant so it 
is very efficient. 

 Global accessibility- Another main feature of e-
mail is that you can receive the mail from your 
house, office, cyber cafe or any other place around 
the world. Your mail box is global and you can 
access it from anywhere. Interesting, isn't it? 

 Facility to resend- if you send an e-mail and user 
says he has not got it, it is very easy to send him the 
mail again as well as it is very easy to send the 
same mail to some body else. 

 Easy maintenance of address book of friends-
maintaining records like addresses and phone 
numbers is quite easy through the address book.  

 Better than phone- Communicating with a phone 
can not be used to transfer documents. However, 
using e-mail, you can send documents (text), 
pictures etc. With case. 

 No transportation cost- Since you can e-mail from 
your desktop, you need not go to the post office. 

Electronic Mail Address 
 
Electronic mail addresses have two parts. The first part is the mailbox 
identifying name followed by an @ symbol and the domain name of 
the destination (e.g. samit @ vsnl.com) 
    

 
 
Anybody around the world can get a personal e-mail address. An e-
mail address comprises arjun@yahoo.com, shiv@vsnl.com or 
ashok@hotmail.com,   preeti@cisco.com etc. These are all e-mail 
addresses. Note the presence of @ (at the rate) symbol. There are 
two parts of e-mail address.  
 

 part before @ 
 part after @ 
The name or the word written before @ is the unique name of the 
user having the address. After @ is the name of the domain (or URL) 
from which e-mail services are hired. 
The name before @ is unique for a specified domain i.e. yahoo.com 
domain can have one arjun. But Arjun can have various arjun e-mail 
address at various domains e.g. 
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Types of E-mail addresses 
 
E-mail addresses provided by ISPs 
When you get a connection ticket from an ISP, there is a default address provided to you by the ISP. This is generally the mail 
address in which domain name (part after @) is the name of ISP's server) e.g. abcd@vsnl.com it is the mail address provided by the 
service provider VSNL Or  1234@satyamonline.com this is the mail address provided by satyam.     
Most of the time these e-mail addresses are configured on the user’s computer. This can be done through special software like MS 
Outlook, etc. The mail can also be accessed through the web sites of the ISP. The VSNL mail can be checked from their e-mail site 
named as internet.vsnl.net.in 
 
Using e-mail Websites 
There are plenty of sites which are only developed to provide FREE e-mail services to users. Most of the portals have e-mail as one 
of their important features. Some of the popular e-mail sites are: hotmail.com, email.com, yahoo.com, rediffinail.com, indya.com 
etc. When you get the e-mail address on these sites, that has the name of the server as domain name, the mail address would be: 
ashok@yahoo.com   preeti@hotmail.com  etc. 
 
Some Common Terms Related To E-Mail: 
  
 Login: For logging into the mailbox each user has to have a unique name. This is the name by which you get a mail box in a mail  

server. Ashok and Preeti are login names in the above examples. 
 Password: There is a hidden key attached to your mail box, which should only be known to you. Type the password (note you 

will see only *   symbol when you type your password). This is the key of the lock on your mail box. 
 Send: After typing the mail, when you want to send it, click on send and then it will go to the destination server. 
 Receive: The mail somebody sends you are the received mails. You get various alert messages, when you get a new mail. 
 To: This holds the address of the person, to whom you are sending the mail. 
 Cc: Carbon copy same mail can be sent to another person by typing his address in cc column.  
 Bcc: Blind carbon copy this column is also used to send the copy of the mail. However, the main difference is that the name of 

other users to whom mail has been sent would not be visible.   
 From: This holds the e-mail address of the sender that is you. 
 Attachment: In addition to the letter typed, you can also send pictures, or other files along with the mail, called as attachments. 

There is a size limitation on attachments that files not more than 1 MB in size can be sent. 
 Inbox: All the mails you receive are stored at a place called as inbox. 
 Outbox: All the mails you want to send are stored at a place called as Outbox. Reduction of paper work the letter is not required 

to be typed on the paper. 
 Send box: All the mails you have already sent are stored at a place called as sent box. 
 Reply: When you get a mail from your friend and wish to respond is called reply. 
 Forward: Sending a received mail to somebody else is forwarding. 
 Deleted: When you do not want to keep mail in inbox, outbox and send items folder, these are transferred to the deleted folder 

and from there these are deleted permanently. 
 Send to: When you want to transfer mail to some specific folders for different users, send to Is. used. 
 Folders: Different areas are defined on the mail box under different names, where mail pertaining to some related topics are 

stored, like mail from a friend named paul soddy are stored in folder paul. 
 
Outlook Express 

 
Double click on the "Outlook Express" icon on the desktop to start the program. The screen is shown below. The screen is divided into 
five main parts: 
 The pull-down menus on the top portion of the screen. 
 A toolbar containing buttons for commonly used tasks (such as Compose Message, Reply etc.) 
 A message index on the right-top of the frame. 
 A message index on the right-top of the frame. 
 Message text on the right-bottom of the frame 

 
The Above Main Parts Are Shown As Below: 
Click on the "Compose Message" button on the toolbar to open up a new message window. Where the e-mail contents are typed. 
This helps to work offline and later connect to the Internet in order to send the typed e-mail. 
Type in the "To:", "Cc:" and "Bcc:" e-mail addresses. Multiple addresses can be entered in each of these fields and should be 
separated by commas. Enter a subject in the "subject" field. TAB key can be used to move quickly from one field to the other. 
The screen below shows the typical Outlook Express - New Message screen. After composing the message in the main message 
area, press the Send button on the toolbar to send the message. The send button does not actually send your message. It only 
moves the message to a folder called "Outbox". This way it becomes convenient to first type in all the messages to be sent and later 
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send them in one go when you are connected online with the Internet. When the message is not to be sent immediately, we choose 
the "Send Later" command from the "File" menu. This moves the message to the "Drafts" folder that you may later edit or delete. 
 
Sending And Receiving E-Mail Messages 
Click on the "Send and Receive" button on the toolbar. It does the following: 
 Checks for the new mail on your mail server. 
 Sends the messages waiting to be sent in your "Outbox" folder All the received messages are placed on the "Inbox" folder 

and all the messages sent are placed in the "Sent Items" folder. 
 
Receiving Incoming Mail 
To read your incoming mail, first click on the "Send and receive" button on the toolbar to check for new messages on the mail 
server. Choose the "Inbox" folder in the folder index on the left side frame. The list of message within this folder is displayed in the 
right-top frame. Entries for unread messages are displayed in the bold font. 
Click on the “message entry” in this window. The message is displayed in the right bottom frame. We can double-click on it to open 
it in the full screen form. 
 
Replying To Mail 
We may choose to reply to a message while reading it. Click on "Reply to the Author" button on the toolbar to reply to the author of 
the message. The button "Reply to all" can be used to reply to the author and to all its recipients. 
 
Forwarding A Message 
To forward or send the message(s) received by us click on the "Forward Message” button on the toolbar. 
 
Deleting A Message 
To delete a message from any folder, highlight the message in the message index (right top frame) and click on the delete button on 
the toolbar. This will move the deleted message to the "Deleted Items" folder. Choose Empty Folder. 
 
Printing A Message 
Message can be printed by choosing Print from the File menu or by using the keyboard shortcut which is Ctrl + P together. 
 
Managing File Attachments 
Files can be attached to your e-mail messages. These files can be text files, word processing files, spreadsheets, databases, 
programs, images etc. 
 
Sending File Attachments 
To attach a file to a message that is being composed click on the "Insert File" icon while within the "New Message" composition 
window. This will bring up a browse window. Browse to the drive and directory containing the file and click "Attach". This process 
may be repeated if multiple files are to be attached to the same message. Finally click on "Send" to send the message with the 
attached file(s). 
 
Receiving File Attachments 
If the incoming message contains one or more attached files, it is indicated by a "paper clip" symbol in the message header. To save 
this attachment to a location of your choice, click on the "paper clip" icon to display a list of filenames and file size. Click on the 
filename. This brings up a dialog box. Choose "Save it to disk" and choose "OK". This will again bring up a "Browse" dialog box. 
Choose a folder to save the file. You can give a different filename. Click on Save to save the file. 
 
Working with Folders 
E-mails can be organized into different files or folders. By default, messages in Outlook Express are organized into the following 
folders: 
 
INBOX                         For all incoming messages. 
OUTBOX                     For messages to be sent 
SENT ITEMS               For messages previously sent. 
DELETED ITEM          For messages marked for deletion. 
DRAFTS                      For messages which are pending. 
 
Messages can be kept in new folders also. To make a new folder, first choose the top level folder ''Outlook Express". Choose File 
menu then choose "Folder" and then choose "New Folder". Type in the name for the folder. Click "OK". 
 

 
___________________________________ 
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Lesson: 3  
 

  Internet Protocols, Intranet, Extranet & Telnet i 
  
                                                         

A network of servers linked together by a common protocol, 
allowing access to millions of hypertext resources. It is also 
known as WWW (World Wide Web) the Web and the World a 
collection of documents on computers located throughout the 
world that are connected to each other by clickable 
hyperlinks. You need to run a browser program to access the 
Web. The highly interconnected network of hypertext servers 
(HTTP servers) that allow text, graphics, sound and video 
files to be displayed. Computer network consisting of a 
collection of internet sites that offer text, graphics, sound and 
animation resources through the hypertext transfer protocol. 
 
U.R.L. 
The address identifies the location of a Web page on the 
World Web. 
To access a Wed page one requires an address. For easy 
access of document distributed all over the world www uses 
the concept of locate. The uniform resource locator (URL) 
is a standard for defining any kind of information on the 
internet. URL defines only things. Method, host computer, and 
pathname.  URL:  http://www.google.com 
 

 
 
Method 
The method is the protocol used to retrieve the document. 
There are several different protocols that can retrieve a 
document. Gopher, FTP, HTTP, NEWS, and TELNET, are 
such protocols. 
 
Host 
The host is the computer at which the information is available. 
However, the name of the computer can be an alias. Web 
pages are usually stored in computers given alias names 
(Sub domain) that mostly begin with www 
 
Path 
Path is the pathname, of the file where the information is 
located. Path can contain slashes that separate directories 
from subdirectories and files in the UNIX operating system. 
 
HTTP 
Hypertext Transport Protocol used to transfer HTML 
documents of the World Wide Web (www). 
The Hypertext Transfer Protocol. HTTP is the primary 
protocol on which the World Wide Web operates. HTTP is the 
primary protocol on which the World Wide Wed operates. 
HTTP is an application protocol. 

TCP/IP 
Transmission Control Protocol/Internet Protocol. A protocol or 
communication between computers, used as a standard-for 
transmitting data over networks and as the basis for standard 
Internet protocols. "Transmission control protocol/Internet 
protocol." TCP/IP is a comb combined set of protocols that 
perform the transfers of data between two computers. 
Transmission Control Protocol/Internet Protocol, a set of rules 
that establish the method with which data is transmitted over the 
Internet between two computers. 
 

 
 

UDP 
User Datagram Protocol is a transmission protocol which 
transfers data through individual messages (so called datagram). 
It does not establish new connections nor it provides reliable and 
sequentional data delivery, nor it enables error correction or data 
stream control. It is used for transfer of small-sized data (i.e. 
DNS queries) or for transmissions where speed is preferred from 
reliability (i.e. real-time audio and video files transmission). 
 
FTP 
File Transfer Protocol is a method to transfer files from one 
location to another, either on local disks or via the Internet. 
File Transfer Protocol. A common method of moving files 
between two Internet sites. FTP is a special way to log into 
another Internet site for the purposes of retrieving and/or sending 
files. File transfer protocol; the method by which files are 
transferred. A protocol used to transmit files between computers 
on the Internet. 
 
TFTP 
Trivial File Transfer Protocol A simplified version of FTP that 
transfers files but does not provide password protection or user-
directory capability. It is associated with the TCP/IP family of 
protocol. TFTP depends on the connectionless datagram delivery 
service, UDP. 
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DNS (Domain Name System) 
An Internet service that translates domain names into IP addresses. Because domain names are alphabetic, they are easier to 
remember. The Internet however, is really based on IP addresses. Every time you use a domain name, therefore, a DNS service must 
translate the name into the corresponding IP address. 
 
GD (Generic Domain) 
The generic domain (also called the organization domain), divides registered hosts as per their generic behaviors. Generic domain 
names, red left to right, start with the most particular information about the host (e.g., the name of the computer) and become more 
and more general with each label until they reach the right most labels. This describes the larger group affiliations of the named host: 
the nature or the organization (e.g. edu for educational). 

 

 
 Intraneti 

 
An intranet is a private network that is contained within an enterprise. It may consist of many 
interlinked local area networks and also use leased lines in the wide area network. Typically, an 
intranet encloses connection through one or more gateway computers to the outside internet. The 
main purpose of an intranet is to share company information and computing resources among 
employees. An Intranet can also be used to facilitate working in groups and for teleconferences. 

 
There is several definition of intranet some of them are as follow: 

 
A private network of various computers with an organization. An intranet is used to share company 
information and computing resources among employees. An intranet uses regular internet protocols and in general look like a private 
version of the internet. 

 A private network inside a company or organization. 
 A private network based in internet technology that is designed to meet the internal needs for sharing information within a 

single organization of company.   
 
The difference between Intranet and Internet Design: 

 
Your intranet and your public website on the open internet are two different information spaces and should have two different user 
interface design. Intranet and Internet differ along several dimensions. 
 

 User differ: Intranet users are your own employees who know a lot about the company, its organization structure and special 
terminology and circumstances. Your internet site is used by customer who will know much less about your company and also 

gTLD intended use gTLD intended use 

aero the air transport industry. net originally for network infrastructures, now 
unrestricted 

asia companies, organizations and individuals in the Asia-Pacific 
region org originally for organizations not clearly falling 

within the other gTLDs, now unrestricted 

biz business use pro certain professions 

cat Catalan language/culture tel services involving connections between the 
telephone network and the Internet 

com commercial organizations, but unrestricted travel travel agents, airlines, hoteliers, tourism 
bureaus, etc. 

coop cooperatives xxx pornography 

edu U.S. post-secondary educational establishments jobs employment-related sites 

gov U.S. government entities at the federal, state, 
and locallevels mil the U.S. military 

info informational sites, but unrestricted mobi sites catering to mobile devices 

int international organizations established by treaty museum museums 

name families and individuals   
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careless about it. 
 The Task differ: The intranet is used for everyday work inside the company including some quit computer applications the 

internet site is mainly used to find out information about your products. 
 The type of information differs: The intranet will have many draft reports, project progress reports; human resource 

information and other detailed information whereas the internet site will have marketing information and customer support 
information. 

 Bandwidth and cross platform needs differ: Intranet often run between hundred and thousand times faster than most 
internet users. Web access, which is stuck at low-band of mid-band. It is sometimes possible to control what computers and 
s/w versions are supported on an intranet. Meaning that designs need to be less cross-platform compatible.  

 
 Extraneti  

 
This is a network where people from outside an organization can connect to a company’s internal 
intranet. This is often used when external suppliers need to communicate with your databases or remote 
business offices need to be setup. Generally these kinds of users require authentication in the form of 
usernames and passwords. 
 

 Telneti  
 
Telnet is short for Telecommunication Network. It is a virtual terminal protocol allowing a user logged on to one TCP/IP host to access 
other hosts on the network. 
One of the remarkable features of the Internet is the way it lets you use the resources of a distant computer somewhere else in the 
world. From your own home or office, you can log on to another computer, issue commands as if you were at that computers key 
board, and then gain access to all the computers resources. You do this with an Internet resource called Telenet. Telnet follows a 
client/server model, which means that you run a piece of software on your PC (the client) to use the resources of a distant server 
computer. This distant computer is called the host. 
The host allows many different clients to access its resources at the same time, It is not devoted to a single user. To use Telnet and 
the host's resources, you will need to know the address of the Internet host whose resources you want to access. 

 

 
 

 Bitneti 
 

City University of New York and University of Yale established BITNET basically to exchange information between universities. The 
basic series provided by BITNET are: 
(a)      Exchange of electronic messages 
(b)      Electronic student admission 
(c)      Remote job entry and storing research information 
 
A counterpart of BITNET in India is ER Net, which is established for educational and research purposes.  

 
 

____________________________________________ 
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Lesson: 4  
 

 E-Commerce i 
 
 
 

E-Commerce is a name given to making business possible through Internet. It can be referred to as selling to 
customers electronically and improving the way business is conducted by a company. It can be business-to-business, 
business-to-consumer, and consumer-to-consumer transactions of information, goods, and funds. 
 
Working with E-Commerce 
 
It is possible to order the goods online through Internet. The payment of the goods you purchase can be done in 
various ways: 

 Cash: When you receive the goods at home, pay for it. 
 Credit cards: Payment can be done through Credit Cards i.e. the name, number and expiry date of the card is entered and 

accordingly transaction is done. 
 E-cash: some organizations work as online buying agencies. You can purchase payment coupons by paying them cash. The coupon 

number is entered on the purchase form, and goods are delivered at your doorstep. 
 
Types of E-Commerce 
 
There are 4 types of E-Commerce transactions: 
1. B2B (Business to Business): 

It is the online selling association between two business enterprises, selling to each 
other. (a)   Purchase of raw materials, components and service for the production of   
goods and services that are to be sold. (b) Purchase of goods for consumption (c.)    
Purchases of capital equipment (d.) Construction of custom-built assets such as 
factories and refineries. 
Not only the commercial organizations fall in this category, even the non-profit or-
ganizations are the part of this group e.g. Co-operatives societies, industry 
associations, Chambers of commerce, unions, trusts, charities, NGO's, Community 
associations like sports club etc. 

2. B2G / G2B (Business to Government / Government to Business): 
It is same as B2B, but the only difference is that one of the parties in this case is a 
government organization. B2G refers to service delivery by government to business 
enterprises also referred to as 'G2B1. 

3. B2C (Business to Consumer):  
The term B2C is commonly used to refer to sale by a business enterprise to a 
Consumer. In this case Consumer is a person or an organization consuming the goods not for commercial benefit. The sample site is 
Lycos.com for online book purchases.  

4. C2C (Consumer to Consumer): 
This refers to online selling of goods from one consumer to another. A typical example is online Auctions. The sample site is baazi.com 
and other auction sites.  

 
Benefits of E-Commerce 
 
E-Commerce is used to conduct online selling and purchasing of transaction of following: 
 
(a) Documents, including articles and books. (b) Data, including statistics (c) Reference information, including dictionaries and encyclopedias 
(d) News (e) Weather & Astrological forecast (f) Various sound files, such as speeches and musical performances (g) Video and Audio files, 
including television, video-conferencing and video- clips (h) Interactive voice, such as telephone conversations and tele-conferencing (I)     
Images & graphics such as diagrams and photographs (j)  Entertainment via music, infotainment like informative articles, edutainment and 
education via multi-media etc. (k) Bookings and tickets for events like movies, plays and shows, (L) Software (m) Bank transfers of amount 
across countries (n) Stock based transactions (o) Bank loans etc. 
One important point to be noted is that transactions related to bank, stock, etc. are executed for the clients who are registered members with 
the concerned authorities. Alternatively, such registrations have to be carried out through electronic payments (credit card). However, 
transactions involving the purchase of a book or music CD etc are instant and can be done by using any of the payment modes discussed 
earlier. 
Types of products: There are mainly two types of products which can be sold through e-commerce:  
(a) Physical goods: Physical goods are products which are identified as the service or good to be provided to the person. (b) Digital goods: 
Digital goods can be delivered or performed entirely through a telecommunications network. The goods can be: (a) An item a book or an mp3 
sound file (b)   A service to be provided like teaching offline or online. 
 

________________________________________ 
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Unit-VIIi    
  

  HYPERTEXT MARKUP LANGUAGE (HTML)I 
 
 
INTRODUCTION 
Hyper Text Markup Language is the most important aspect in web site development. We write web pages that contain codes written in this 
particular language. As name implies this is a language like other high level languages, though much easier than those. We shall discuss broadly 
about different features of html in this chapter in order to get acquainted with writing simple web pages. 
 
CONCEPT OF HYPERTEXT 
Web pages are written in a relatively easy computer language. It is known as HTML, short for Hypertext Markup Language. The hypertext concept 
stems from the Apple Macintosh world. It means mutually connecting text, graphics and other data in a computer file. Simply pointing your mouse 
to a link and clicking on it, will bring up a different part of the document on your screen as you can see one specimen in figure. This method is very 
popular for documenting software. You can think HTML as the help files coming with almost all software’s. 
 
VERSIONS OF HTML 
After the emergence of HTML, several versions came with some upgrading as follows: 
 
 HTML 2.0 -  It was developed under the supervision of IETF (Internet Engineering Task Force). It came into practice in late 1994. 
 HTML 3.0 - It was a richer version of HTML. Despite never receiving consensus in standard discussion, it was continuously changing with    

the new features. 
 HTML 3.2 -  In 1996, it came into existence by the efforts of World Wide Web.     
 HTML 4.0 - It extends with mechanisms for style sheet scripting, frames, richer tables, forms etc. It is the most current version of HTML.  
 
HTML EDITORS 
HTML documents are plain-text (also known as ASCII) files that can be created using any text editor (e.g., Emacs or vi on UNIX machines; 
SimpleText on a Macintosh; Notepad on a Windows machine). You can also use word-processing software if you remember to save your document 
as "text only with line breaks". 
Some WYSIWYG editors are also available (e.g., Claris Home Page or Adobe PageMill, both for Windows and Macintosh). You may wish to try 
one of them after you learn some of the basics of HTML tagging. WYSIWYG is an acronym for "What You See Is What You Get"; it means that 
you design your HTML document visually, as if you were using a word processor, instead of writing the markup tags in a plain-text file and imag-
ining what the resulting page will look like. It is useful to know enough HTML to code a document before you determine the usefulness of a 
WYSIWYG editor, in case you want to add HTML features that your editor doesn't support. 
 
ELEMENTS OF HTML 
An HTML element is a fundamental component of the structure of a text document. Some examples of elements are heads, tables, paragraphs, and 
lists. Elements can contain plain text, other elements, or both. 
 
TAGS 
A web page consists of various types of tags. To denote the various elements in an HTML document, we use tags. HTML tags consist of a left 
angle bracket (<), a tag name, and a right angle bracket (>). Tags are usually paired (e.g., <Tag> and </Tag>) to start and end the tag instruction. 
The end tag looks just like the start tag except a slash (/) precedes the text within the brackets? 
 
ATTRIBUTES 
Some elements may include an attribute, which is additional information that is included inside the start tag. For example, you can specify the 
alignment of text (right, left or center) by including the appropriate attribute with the image source HTML code. 
 
 HTML is not case sensitive. <title> is equivalent to <TITLE> or <TiTlE>. 
 Not all tags are supported by all World Wide Web browsers. If a browser does not support a tag, it will simply ignore it. Any text 

placed between a pair of unknown tags will still be displayed, however. 
 
TO WRITE A HTML DOCUMENT 
To write a web document, follow the instructions as follows: 
 Load a text editor like Notepad. To open Notepad click Start --- Programs --- Accessories --- NotePad. 
 Write codes and save it with a HTML file. HTML files are the files having extensions .htm or. html. 
 View it in a browser of your choice e.g., Internet Explorer or Netscape Navigator. 
 
MINIMUM REQUIRED TAGS IN AN   HTML DOCUMENT 
Every HTML document should contain certain standard HTML tags. They are as follows- 
• HTML tag • Head tag • Title tag • Body tag  
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HTML Tag 
 

A SAMPLE HTML DOCUMENT: 
Each HTML document contains some certain standard HTML tags. It 
has been illustrated in example given below that shows what a minimal 
document contains. 

<HTML> 
<HEAD> 
<TITLE> 
A Basic HTML Page 
</TITLE> 
</HEAD> 
<BODY> 

                     I AM LEARNING HOW TO CREATE A WEB PAGE 
</BODY> 
</HTML> 

 
For implementing the above mentioned example, save it with .htm or 
.html extension and see the result on the browser. The effects should 
match with one in figure given below. 

 

 
HEADINGS 
 
Headings are used to arrange the contents in a systematic way. HTML 
has six levels of headings, numbered 1 through 6, with 1 being the 
largest. Headings are typically displayed in larger and/or bolder fonts 
than normal body text. The first heading in each document should be 
tagged <H1>. 
 

The syntax of the heading element is: 
 
<Hn>Heading/Sub-Heading</Hn> 
 

Where n is a number between 1 and 6 specifying the level of the 
headings. You can see the effects of different headings in example 
given below- 

 

The HTML element tells your browser that the file contains HTML-
coded information. The file extension .html also indicates this HTML 
document and must be used. It comes in a pair: <HTML> and 
</HTML>    

       Syntax:                               <HTML> 
………… 
………… 
</HTML> 

HEAD Tag 
The Head element identifies the first part of your HTML-coded 
document that contains the title. It contains title tag. It also conies 
with opening and closing tags:  <HEAD>and </HEAD>   

      Syntax:                               <HTML>  
<HEAD> 
……….. 
……….. 
</HEAD>  
</HTML> 

TITLE Tag 
The Title element contains your document title and identifies its 
content in a global context. The title is typically displayed in the title 
bar at the top of the browser window, but not inside the window. The 
title is also what is displayed on someone's hot list or bookmark list, 
so choose something descriptive, unique, and relatively short. A title 
is also used to identify your page for search engines. Generally you 
should keep your titles to 64 characters or fewer.   

        Syntax:                             <HTML> 
<Head> 
<TITLE> 

                                                        DESCRIBE YOUR TITLE 
</TITLE> 
</HEAD> 
</HTML> 

 

After implementing the Title tag as above results like this- 
 

 
 

If you leave blank between the title tags, some browsers display 
either UNTITLED or URL. 
 
BODY Tag 
The second—and largest—part of your HTML document is the body, 
which contains the content of your document (displayed within the 
text area of your browser window). The tags explained below are 
used within the body of your HTML document. 
  

Syntax:                                     <HTML> 
<HEAD> 
<TITLE> 
My First Web Page 
<TITLE> 
</HEAD> 
<BODY> 
……….. 
………. 
</BODY> 
</HTML> 
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LINE BREAK 
This tag is used to change lines with no extra blank 
spaces. It can be used for short lines of text such as 
postal addresses. This tag is represented by <BR>. See 
example - 
 

<HTML> 
<HEAD> 
<TITLE> 
A PAGE WITH BR TAG. 
</TITLE> 
</HEAD> 
<BODY> 
<PR> 
National Informatics Centre <BR> 
Chanakya Puri <BR> 
New Delhi <BR> 
</BODY> 
</HTML> 

 

The example results on the browser like this- 
 

National Informatics Centre 
Chanakya Puri 
New Delhi 
 
LISTS 
HTML supports unnumbered, numbered, and 
definition lists. You can also nest lists. 
 
NUMBERED LIST 
Numbered list is also called ordered list. It is shortened 
as OL from which the tag name! derives. It is identical 
to an unnumbered list, except it uses <OL> instead of 
<UL>. The items are tagged using the same <LI> tag. 
See example- 

<OL> 
<LI> Computer 
<LI> Modem 
<LI> Internet Connection 
<LI> Telephone Line 
</OL> 

 

After running the example 6.5, the browser displays 
result like this- 
1. Computer 
2. Modem 
3. Internet Connection 
4. Telephone Line 
 
UNNUMBERED LISTS 
Unnumbered list can be referred to as unordered list. 
To make an unnumbered or bulleted list, do the 
followings- 
 
1. Start with an opening list <UL> (for unnumbered 
list) tag 
 
2. Enter the <LI> (List Item) tag followed by the   
individual item; no closing </LI> tag is needed. 
 
3.   End the entire list with a closing list </UL> tag 
  
See example to understand how it is written. 

 

<HTML> 
<HEAD> 
<TITLE> 

                                   A Web Page Showing Different Level of Headings. 
</TITLE> 
</HEAD> 
<BODY> 
<H1> Sunday </H1> 
<H2> Monday </H2> 
<H3> Tuesday </H3> 
<H4> Wednesday </H4> 
<H5> Thursday >/H5> 
<H6> Friday </H6> 
<H7> Saturday </H7> 
</BODY> 
</HTML> 
 

                            The result should appear like one in figure given below- 
 
Sunday 
Monday 
Tuesday 
Wednesday 
Thursday 
Friday 
Saturday 

 
PARAGRAPHS 
Paragraph may consist of a single sentence or more than one sentence including 
punctuation marks and blank space. Paragraph is represented by <P>…</P> tags. 
End tag </P> is not essential to add as the browsers assume the start of paragraph 
when <P> tag is given.  See example 6.3 to understand the tag well. 
 

<HTML> 
<HEAD> 
<TITLE> 
A Page Showing Two Paragraphs 
</TITLE> 
</HEAD> 
<BODY> 
<P> 

HTML Stands for Hyper Text Markup Language. It is supposed to be a super set of 
SGML. SGML means Standard Generalized Markup Language. 

<P> 
You can create a web page using hypertext markup language. It is easy to learn and 
interesting as well. When you get a lot of pages you can assemble into a directory 
and can give it a shape of website. 

 </P> 
</BODY> 
</HTML> 

After implementing the example, the browser displays the result like one in figure 
below- 
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COMPACT ATTRIBUTE 
The COMPACT attribute can be used routinely in case your 
definition terms are very short. If, for example, you are showing 
some computer options, the options may fit on the same line as 
the start of the definition.  

<P> DIR </P> 
<DLCOMPACT> 
<DT> IP 
<DD> displays the directories and files page-wise. 
<DT> /w 
<DD> displays the directories and files width-wise. 
</DL> 

 

                               See its output in figure below- 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
NESTED LIST 
Lists can be nested. You can also have a number of paragraphs, 
each containing a nested list, in a single list item.  
 

<UL> 
<LI> Prominent Universities of India: 
<UL> 
<LI> Jawaharlal Nehru University 
<LI> Delhi University 
<LI> Aligarh Muslim University 
</UL> 
<LI> Prominent Colleges of D.U: 
<UL> 
<LI> Miranda House 
<LI> Lady Shree Ram College 
<LI> Hindu College 
</UL> 
</UL> 

 

                                  See output in figure below- 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

<UL> 
<LI> Computer 
<LI> Modem 
<LI> Internet Connection 
<LI> Telephone Line 
</UL> 

 

Example results on the browser like this- 
 Computer 
 Modem 
 Internet Connection.    
 Telephone Line 

 
DEFINITION LISTS 
A definition list (coded as <DL>) usually consists of alternating a 
definition term (coded as <DT>) and a definition description (coded as 
<DD>). Web browsers generally format the definition on a new line and 
indent it. 
 

<HTML> 
<HEAD> 
<TlTLE> 
Definition List 
</TITLE> 
</HEAD> 
<BODY> 
<DL> 
<DT> Hardware 
<DD>Examples of hardware are CPU, input device, secondary storage etc. 
<DT> Software 
<DD> It is a set of programs 
</DL> 
</BODY> 
</HTML>  

 
Codes written in example will affect like one in figure on browser:- 
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COMMENT TAG 
The comment tag is a stand-alone tag that enables you to 
include messages for your own or anyone else's future 
references. A comment always begins with a <!- and ends with 
a ->. 
 
 Example:              <! - Type your comments here -> 
 
EXTENDED QUOTATION 
Use the <BLOCKQUOTE> tag to include lengthy quotations 
in a separate block on the screen. Most browsers generally 
change the margins for the quotation to separate it from 
surrounding text.  

 
<P> Note: </P>  
<BLOCKQUOTE> 
<P>  

This page is meant for no commercial purpose. Therefore, no 
claims whatsoever can be entertained regarding any information 
published on it. 

</P> 
Authority 
</BLOCKQUOTE> 

 
After implementing the above mentioned example, the result 
will be like this-Note: 
 

This page is meant for no commercial purpose. Therefore, no 
claims whatsoever can be entertained regarding any 
information published on it. 
Authority 
 
USING LINKS 
The chief power of HTML comes from its ability to link text 
and/or an image to another document or section of a document. 
A browser highlights the identified text or image with color 
and/or underlines to indicate that it is a hypertext link (often 
shortened to hyperlink or just link). HTML's single hypertext-
related tag is <A>, which stands for anchor. 
Hypertext links can be used to move from one page to the 
other or to a specific location within the same document or 
different one. For instance, you can use links to- 
 

 display an image 
 download a program 
 send e-mail 
 use a database 
 execute a script 

 
Hyperlinks are mainly of three kinds – 
 
LINKS TO DIFFERENT WEB PAGES 
This type of link is frequently used in web pages. It takes you 
from one page to the other one. 
 
Links to Specific Sections of Current Web Pages 
 
This type of link helps navigation in the current web page. It 
takes you from one section to another section of the page. 
Several pages are so big that you can not see it at once and 
browsing may take time. In that situation, it is found very 
helpful. Clicking the concerned link available in the beginning 
directly takes you to the specified section. 

TYPE ATTRIBUTE 
Type attribute is used with <OL> tag. Using this, you can manipulate the 
way ordered list displays the effects. 
 

<HTML> 
<HEAD> 
<TITLE> 
My first web page 
</TITLE> 
</HEAD> 
<BODY> 
<OLTYPE = “I”> 
<LI> Level One Outline 
<OLTYPE = "A"> 
<LI> Level Two Outline 
<OLTYPE = "1"> 
</LI> Level Three Outline 
</OL> 
</OL> 
</OL> 
</BODY> 
</HTML> 

 

See output in figure- 
 
 
 
 
 
 
PREFORMATTED TEXT 
The PRE (Preformatted text) tag is used to display a block of "preformatted" 
text in a monospace, fixed-pitch font. You use the PRE tag to display a block 
of text "as it is", Including all spaces and hard returns. One of the primary 
uses of the PRE tag is to display text in a tabular or columnar format in 
which you want to make sure that the columns remain properly aligned. 

 

<HTML> 
<HEAD> 
<TITLE> 
My First Web Page 
<TITLE> 
</HEAD> 
<BODY> 
<PRE> 
Sales Return for First Quarter 
 

 Jan 
 

Feb 
 

Mar 
 

Total 
 $100 

 
$200 

 
$300 

 
$600 

 50 100 200 350  
 

Ram 
Shyam 
Gopal 
</PRE> 
</BODY> 
</HTML> 

 
See output in figure: 
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LINKS BETWEEN SECTIONS OF DIFFERENT DOCUMENTS 
 
Suppose you want to set a link from Sarva (sarva.html) to a specific 
section in another document (books.html). 
 

Enter the HTML coding for a link to a named anchor: 
 

      sarva.html: 
     <a href="sarva.html#SITED">Internet & E-Commerce</a>. 
 
Think of the characters after the hash (#) mark as a tab within the 
sarvaindia.html file. This tab tells your browser what should be 
displayed at the top of the window when the link is activated. In 
other words, the first line in your browser window should be the 
Internet & E-Commerce heading. Next, create the named anchor (in 
this example "SITED") in introduction.html: 
 
     <H2><A NAME="SITED">Internet & E-Commerce</Ax/H2>  
 
With both of these elements in place, you can bring a reader directly 
to the Internet reference in introduction.html. 
 
LINKS TO SPECIFIC SECTIONS WITHIN THE CURRENT DOCUMENT  
 
The technique of Links to specific sections within different a 
document is very much identical to the technique of links to specific 
sections within the current document except the filename is omitted. 
For example, to link to the IEC anchor from within Sarva, enter: 
 
     <A HREF="#SITED">Internet & E-Commerce</a> 
 
After this include the <A NAME=> tag at the place in your 
document where you want the link to jump to (<A 
NAME="IEC">Internet & E-Commerce</A>). Named anchors are 
particularly useful when you think readers will print an entire or 
when you have a lot of short information you want to place online in 
one file. 
 
MAILTO 
 
You can make it easy for a reader to send electronic mail to a 
specific person. 
 
      <A HREF="mailto:emailinfo@ host">Name<la> 
 
 
For example, enter: 
 
      <A HREF="mailto:mansoor37 76@ rediffmail.com"> 
      Contact Me</a>  
 
To create a mail window that is already configured to open a mail 
window for the editor. 
 
 
INLINE IMAGES 
 
Most Web browsers can display inline images (that is, images next 
to text) that are in X Bitmap (XBM), GIF, or JPEG format. Other 
image formats are also being incorporated into Web browsers [e.g., 
the Portable Network Graphic (PNG) format]. Each image takes 
additional time to download and slows down the initial display of a 
document. Carefully select your images and the number of images 
in a document. 
 

Links to Specific Sections of Different Web Pages 
 
This is very much identical to the above link except it takes you to a 
specific section in a different web page directly. 
 
U.R.L. 
 
The World Wide Web uses Uniform Resource Locators (URLs) to 
specify the location of files on other servers. A URL includes the type 
of resource being accessed (e.g., Web, gopher, FTP), the address of the 
server, and the location of the file. The syntax is: 
 
scheme://host. domain [:port]/path/ filename 
   

where scheme is one of- 
  

file           -    a file on your local system 
ftp           -    a file on an anonymous FTP server  
http         -    a file on a World Wide Web server  
gopher    -    a file on a Gopher server 
WAIS     -    a file on a WAIS server  
news       -    a Usenet newsgroup 
telnet      -    a connection to a Telnet-based service 

 
The port number can generally be omitted. (That means unless someone 
tells you otherwise, leave it out.) 
 
To include an anchor in your document: 
 
1.  Start the anchor with <A (include a space after the A) 
2. Specify the document you're linking to by entering the parameter  

HREF="filename" followed by a closing right angle bracket (>) 
3. Enter the text that will serve as the hypertext link in the current 

document 
4. Enter the ending anchor tag: </A> (no space is needed before the end 

anchor tag) Here is a sample hypertext reference in a file called 
introduction.html: 

 
<AHREF="introduction.html">Introduction</A> 

 
This entry makes the word Introduction the hyperlink to the document 
Introduction.html, which is in the same directory as the first document. 
You can link to documents in other directories by specifying the 
relative path from the current document to the linked document. For 
example, a link to a file introduction.html located in the subdirectory 
Sarva would be: 
 

<AHREF="Sarva/introduction.html">Introduction</A> 
 
These are called relative links because you are specifying the path to 
the linked file relative to the location of the current file. 
 
 
LINKS TO SPECIFIC SECTIONS 
 
Anchors can also be used to move a reader to a particular section in a 
document (either the same or a different document) rather than to the 
top, which is the default. This type of an anchor is commonly called a 
named anchor because to create the links, you insert HTML names 
within the document. You can also link to a specific section in another 
document. That information is presented first because understanding 
that helps you understand linking within one document. 
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HORIZONTAL RULE 
 
The HR (Horizontal Ruler) tag is a stand-alone, or empty, document 
element that allows you to add horizontal rules to your Web pages. 
 
CHANGE THE HEIGHT OF A HORIZONTAL RULE 
 
To change the height of a horizontal rule, the SIZE attribute value in 
the HR tag may be used. The value you set is the rule's height, or 
thickness, in pixels. The following example is used for creating a 
horizontal rule that is 10 pixels thick. See example: 

 
<P> This is a Normal Rule 
 <HR> 
<P> This is a 10 pixel thick horizontal 
<HR SIZE="10"> 

 
The result will be shown as one in figure below: 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
REMOVING SHADES FROM THE RULE 
 
The default setting for a rule is "shaded". To set an "unshaded" 
horizontal rule, add the NOSHADE attribute to the HR tag.  
 
         <P>This is an unshaded, 15-pixel thick horizontal rule: 
         <HR SIZE="15" NOSHADE>  
 

The produced result may be seen in figure below: 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

To include an inline image, enter: 
 

<IMG SRC=Image Name> 
 
Where ImageName is the URL of the image file. 
 
Specifying Size of Inline Images 
 
You should include two other attributes on <IMG> tags to tell your 
browser the size of the images it is downloading with the text. The 
HEIGHT and WIDTH attributes let your browser set aside the 
appropriate space (in pixels) for the images as it downloads the rest 
of the file. 
For example, to include an image named computer in a file along 
with the image's dimensions, enter:  
     
<IMG SRC=computer. if HEIGHT=100 WIDTH=65> 
 

After running the above command, you can see a big picture shrunk 
to the size (very small) as specified.  See figure given below: 
 

 

 
 
Links to Images 
 
We can link images with the text in a hypertext link. This link 
appears in a blue border. For example: 
 
     <A HREF="SUB.HTM"> <IMG SRC="FLOWERS.GIF></A> 
 
Using ALT Attribute 
 
Sometimes browsers used by your users may not be supporting the 
graphics available on your web page. In this situation, you must pass 
an alternative message to the users that makes the users understand 
what really the matter is. For example, see the following code 
 
<IMG SRC="COMPUTER.GIF" ALT="SORRY! YOUR 
BROWSERS ARE NOT SUPPORTING THE GRAPHICS"> 
 
In case you confront the same situations as mentioned above, you 
should see the result in figure below: 
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Paragraph, headings or other texts can be aligned using ALIGN 
attribute. They can be aligned in three ways- 
 
• Center • Right   • Left 
 
The syntax for this is as follows- 
        ALIGN="value" 
Where value can be replaced with left, right or center.  
 

<HTML> 
<HEAD>  
<TITLE> 
Different Alignments 
</TITLE>  
</HEAD> 
<BODY> 
<P ALIGN="CENTER"> I AM IN THE CENTER. 
<P ALIGN="LEFT"> I AM LEFT ALIGNED. 
<PALIGN="RIGHT"> I AM RIGHT ALIGNED.  
</BODY>  
</HTML>  

 

See the result of the example in figure below: 

 
CHANGING FONT SIZE AND COLOURS 
You can set or change the size and colors of the font as desired. It can 
be done using <FONT> tag. 
To specify size of the fonts, Size attribute is used with Font tag. 
Normally fonts are seven in size. It can be given a number 1 being the 
smallest through 7 being the largest. By default the font size is 3. 
 

<HTML> 
<HEAD> 
<TITLE> 
My web page 
</TITLE> 
</HEAD> 
<BODY> 
<FONT SIZE = "1 "> FONT SIZE 1 </FONT> <BR> 
<FONT SIZE = "2"> FONT SIZE 2 </FONT> <BR> 
<FONT SIZE = "3"> FONT SIZE 3 </FONT> <BR>  
<FONT SIZE = "4"> FONT SIZE 4 </FONT> <BR> 
 <FONT SIZE = "5"> FONT SIZE 5 </FONT> <BR>  
<FONT SIZE = "6"> FONT SIZE 6 </FONT> <BR>  
<FONT SIZE = "7"> FONT SIZE 7 </FONT> <BR> 
 </BODY> 
 </HTML> 

See the result in figure below: 
 
 
 
 
 
 
 
 
 
 
 
 

CHARACTER FORMATTING 
 
We use some specific formatting attributes to highlight words, 
phrases or entire sentences in a paragraph or in a page. Some of them 
are as follows- 
 
 <B>…<B> - This tag is used to set the text bold. For example  

Computer 
 <U>…</U> - This tag is used to set the text underlined. For example 

Computer 
 <I>…<I> - This tag is used to set the text italics. For example 

Computer 
 <SUB>....</SUB> - This tag is used to set the text in a subscript form. 

For example in  O2 , 2 is in    subscript form 
 <sup>....</sup> - This tag is used to set the text in a superscript form. 

For example in  a2,2 is in superscript form 
 <STRIKE>...</STRIKE> - This tag is used to set the text in a 

Strikethrough form.  
 
For example:  Computer 
 
The usage of different formatting in example given below: 
 

<HTML> 
<HEAD> 
<TITLE> Character Formatting </TITLE> 
</HEAD> 
<BODY> 

<P> B is used for <B> Bold </B> 
<P> I is used for <l> Italics </I> 
<P> U is used for <U> Underline </U> 
<P> SUB is used for <SUB> Subscript </SUB> 
<P> SUP is used for <SUP> Superscript </SUP> 
<P> STRIKE is used for <STRIKE> Strikethrough</STRIKE> 

</BODY> 
</HTML> 

 
The result will be shown as one in figure below: 
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SPECIFYING FONT COLOURS 
 
To change font colour, we use COLOR attribute with the FONT tag. We can set sixteen different colors to make fonts look attractive. They are: 
 
(i) Black (ii) White (iii) Aqua (iv) Blue (v) Fuchsia (vi) Grey (vii) Green (viii) Lime (ix) Maroon (x) Navy (xi) Olive (xii) Purple (xiii) Red 
(xiv) Silver (xv) Yellow (xvi) Steal 
 
For Example:  

 
<P><FONTSIZE = 7> 
<FONT COLOR = "AQUA">  
This is aqua. 
</FONT> 
 

When you will run the above mentioned example, you will see the text in aqua colour. 
 
SETTING THE COLOUR OF BODY BACKGROUND, TEXT AND LINK 
 
You change the color of text, links, visited links, and active links (links that are currently being clicked on) using further attributes of the <BODY> 
tag. 
 
Syntax: 
 

<BODY BGCOLOR="colorname/code"TEXT="colorname/code" LINK="colorname/code"> 
 
For example: 
 

<BODY BGCOLOR="#000000" TEXT="#FFFFFF" LINK="#9690CC"> 
 
This creates a window with a black background (BGCOLOR), white text (TEXT), and silvery hyperlinks (LINK). 
 
The six-digit number and letter combinations represent colors by giving their RGB (red, green, blue) value. The six digits are actually three two-
digit numbers in sequence, representing the amount of red, green, or blue as a hexadecimal value in the range 00-FF. For example: 000000 is 
black (no color at all), FFOOOO is bright red, OOOOFF is bright blue, and FFFFFF is white (fully saturated with all three colors). 
 
You can use the color name also instead of codes that are a bit difficult like: 
 
<BODYBGCOLOR="BLACK"TEXT="WHITE"LINK="SILVER">BACKGROUNDGRAPHICS 
 
BACKGROUND GRAPHICS 
 
Newer versions of Web browsers can load an image and use it as a background when  
displaying a page. Some people like background images and some don't. In general, if you want to include a background, make sure your text can 
be read easily when displayed on top of the image. Background images can be a texture (linen finished paper, for example) or an image of an object 
(a logo possibly). You create the background image as you do any image. The tag to include a background image is included in the <BODY> 
statement as an attribute:  
 
Syntax: 

   <BODY BACKGROUND="filename">  
 
For example: 

<HTML> 
<HEAD> 
<TITLE> 
MY BIRD  
</TITLE> 
</HEAD> 
<BODY background=format.gif> 
</BODY>  

                       </HTML>                                                                                                                                            (See the result in figure) 
 

 
________________________________________ 
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Unit-VIIIi    
  

 DATABASE HYPERTEXT MARKUP LANGUAGE (DHTML)I 
 

 
 

The previous result clearly shows that a border has been added around 
a table. You can set the border width as desired by increasing or 
decreasing the number like – 

<TABLE BORDER = "0"> adds no border. 
<TABLE BORDER = "1"> adds border. 

 

The result something like this  
 
 
 
 
ADDING CELLS TO A TABLE 
 
You can add cells as desired to your table. Just add <TD> as many as 
the number of cells you want in the table. See example. 

 
<TABLE BORDER = "2"> 
<TD> 
This is first cell. 
</TD> 
<TD> 
This is the second cell. 
</TABLE>  
 

Browser will display the output like this – 
 

 
 
 

 
ADDING ROWS TO A TABLE 
 
Like adding cells to a table, you can add rows using <TR> tag. TR 
stands for Table Row. Example shows addition of one row to a table. 
 

<TABLE BORDER = "2"> 
<TD> 
This is the first cell. 
</TD> 
<TD> 
This is the second cell. 
</TD> 
<TR> 
<TD> 
This is 1st cell and 2nd row. 
</TD> 
<TD> 
This is 2nd cell and 2nd row. 
</TD>  
</TR> 
</TABLE> 

 

Run it on a browser. You will get the result like this: 

 
ADDING SPACES TO A TABLE 

This is first cell. This is the second cell. 

This is one-cell table. 

INTRODUCTION 
In the last unit we had discussed some basics about HTML including 
different tags and attributes. This Unit discusses mainly table, form 
and frame that are indispensable in building web pages. 
 
TABLE 
Table is used to arrange data especially when it is a combination of 
text and number. It is based on rows and columns and each column 
and row has a heading. For instance, Sales-Report of a company or a 
table presenting information like post, address, phone no. etc. 
 
TABLE TAG 
Tag is usually used to instruct the browser what it should do. Like 
other tags, Table tag is written.  
The syntax is as follows: 
 

<TABLE> 
........... Contents of table........ 
</TABLE> 

 
The <TABLE> tag begins the table, you place what you want inside, 
and end the table with the </TABLE> tag. To begin adding contents 
to your table, you will need the <TD> tag. The TD stands for table 
data, which is what you will place after this tag. You end a table data 
section with the </TD> tag. Example given below illustrates HTML 
codes for a basic table with just one cell. 
 

<HTML> 
<HEAD> 
<TITLE> 
<TABLE> 
<TD> 
This is one-cell table. 
</TD> 
</TABLE> 

 
Example results like this: 
 

This is one cell table 
 
The above example does not show clearly whether it is a table or not. 
To make it look like a table we add border. 
 
ADDING BORDER TO A TABLE 
 
To get the border, we just add the border command to the <TABLE> 
tag, like this- 

<TABLE BORDER = "number"> 
 See example to know how it works - 
<TABLE BORDER = "2"> 
<TD> 
This is one-cell table. 
</TD> 
</TABLE> 

The result will be like this- 

 This is one-cell table. 
 

 

This is the first cell. This is the second cell. 

This is 1st cell and 2nd row. This is 2nd  cell and 2nd  row 
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DETERMINING THE TABLE SIZE 
 
Sometimes, you need your table in a specific size. You can 
define the width of your table to help you get the table in the 
size you would like it to be. To do this, add the width =" “ 
command to your <TABLE> tag. Place the number of pixels 
wide you would like the table to be between the double 
quotation marks. So, if you wanted a table 600 pixels long, you 
would do this: 
 

<TABLE WIDTH = "600" BORDER = "2">  
The above command makes table 600 pixels long.  
See example: 
<TABLE WIDTH = "600" BORDER = "2"> 
<TD> 
The Table is 600 pixels long. 
</TD> 
</TABLE> 

 
Example Result Below – 

 

 
 
 
 
The above output clearly illustrates your table border is much 
longer than the text it contains. 
 
ALIGNING THE CONTENTS OF THE TABLE 
 
Contents in a table can be arranged from right side, from left 
side or in the centre with the help of ALIGN=" “command. 
We add this command in <TD> tag. 
 

This command can be used in the following three ways - 
Align = "left” sets the contents in a table from left side.  
Align = "right” sets the contents in a table from right side. 
Align = "center” sets the contents in a table in the center.  
 

See Example: 
 
<TABLE WIDTH="450" BORDER="2"            
CELLSPACING="7" CELLPADDING="7"> 
<TD ALIGN = "CENTER"> 
This cell is in the center. 
</TD> 
<TD ALIGN = "RIGHT"> 
This cell is right aligned. 
</TD> 
<TD ALIGN = "LEFT"> 
This cell is left aligned. 
</TD> 
</TABLE> 
 
Example results like this - 
 

This cell is in the 
Center. 

This cell is right 
             aligned 

 

This cell is left 
 aligned 

 
In the above picture, text in the first cell is quite centered while 
second and third cells are arranged from right and left side 
respectively. 

The Table is 600 pixels long. 

There are a couple of commands you can add to the <TABLE> tag to get 
more spacing between cells. They are as follows – 
 

 
Cellspacing = “       “ 
 

Use this command to add more space around each cell. Place a number 
inside the double quotation marks. 
 

To see how it affects, replace the first line of above mentioned example with 
this one- 
 

<TABLE BORDER = "2" CELLSPACING = "12">  
 

You will see the result like this – 
 

This is the first cell This is the second cell 

This is 1st cell and 2nd row This is 2nd  cell and 2nd row 

 
 

Cellpadding = "   " 
 

This command is used to add more space inside each cell. You can place the 
number as required with double quotation marks. 
Again replace the first line with the one to see the result of the cell padding 
command. 

 
<TABLE BORDER = "2" CELLPADDING = "12">  

 
The table will look like this – 

 

This is the first cell This is the second cell 

This is 1st cell and 2nd row This is 2nd cell and 2nd  row 
 

You can also add both commands together inside <TABLE....> tag this way 
– 
 
<TABLE BORDER = "2" CELLSPACING="15" CELLPADDING="15">  
 
Which you can replace with the first line of above mentioned example .It will 

result like this – 
 

This is the first cell This is the second cell 

This is 1st cell and 2nd row This is 2nd  cell and 2nd row 

 
You can add anything inside the cell of a table. You can add a link, an image, 
heading or paragraph. 
 

 
EXAMPLE shows a hyperlink having added inside the cell. 
 

<TABLE> 
<TD> 
<A HREF = "http://www.yahoo.com"> Go Yahoo!</A> 
</TD> 
</TABLE> 

 
You will see the result like this – Go Yahoo! 
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Apart from the command mentioned above, there are a few more commands that align the contents vertically. For this, add VALIGN = " " 
command inside <TD> tag. Commands that align vertically are as follows – 
 

valign = "top" 
arranges the contents quite at the top in the cell. 
valign = "middle" 
arranges the contents in the centre of the cell. 
valign = "bottom" 
arranges the contents at bottom in the cell. 
You can see the use of these commands in example below: 
<TABLE WIDTH="550" BORDER="2" CELLSPACING="7" CELLPADDING="0”> 
<TD ALIGN = "CENTER" VALIGN = "TOP'S 
The cell is at the top. <BR> 
Really! It is top. 
</TD> 
<TD ALIGN = "CENTER" VALIGN = "MIDDLE'S 
The cell is in the middle. 
</TD> 
<TD ALIGN = "CENTER" VALIGN = "BOTTOM'S 
The cell is at bottom. 
</TD> 
</TABLE> 

 
Table as a result of example will display like this – 
 

This cell is at the top. 
Really! It is top. 

 

 
This cell is in the middle 

 

 
 

This cell is at bottom. 
 

 
The vertical alignment commands only come in useful if your table cells do not have the same number of lines inside each cell. Since the first cell 
has 2 lines and others have one line, the vertical alignment makes difference in how the table looks. Had all the cells contained one line only, there 
would have been no use of VALIGN at all. 
 
SPANNING ROWS AND COLUMNS 
You can span rows and columns. It is mainly used to write a title of rows or columns. There are two commands for this as follows – 
 
Rowspan = " " 
Defines the number of vertical table rows the cell should take up. Place the number as required inside the double quotation marks. 
 
Colspan = " " 
Defines the number of horizontal columns the cell should take up. 
For instance, the following type of table can be prepared using the codes written in example: 
 

{Hello! Mr......... 

How are you? 

 
 

 

 
<TABLE BORDER = "2">  
<TD ALIGN = "CENTER”> 
 Hello! Mr .......... 
</TD> 
<TD ROWSPAN = "2" ALIGN = "CENTER'S 
<IMG SRC = "PIC1.GIF"> 
</TD> 
<TR> 
<TD ALIGN = "CENTER”> 
How are you? 
 </TD>  
</TR>  
</TABLE>  
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Similarly, to make a table. We write html codes as written in example. 
 

8PRIDE OF CRICKET 

SACHIN 
TENDULKAR BRIAN LARA IMRAN 

KHAN  

 
EXAMPLE: 
 

<TABLE BORDER = "2" CELLPADDING = "5"> 
<TD COLSPAN = "3" ALIGN = "CENTER"> 
<B> PRIDE OF CRICKET </B> 
</TD> 
<TR> 
<TD ALIGN = "CENTERS 
SACHINTENDULKAR 
</TD> 
<TD ALIGN = "CENTERS 
BRIAN LARA 
</TD> 
<TD ALIGN = "CENTERS 
IMRAN KHAN 
</TD> 
</TR> 
</TABLE> 

In example colspan is used. We use the colspan command and set colspan="3". We get the first cell to stretch across the other three on the second 
row below it. 
 
SPECIFYING BACKGROUND COLOUR OF THE TABLE 
 
You can change the background color of the entire table, each row, or each cell. To change the background colour of the table, bgcolor=" " 
command is used like this – 
 
<TABLE BORDER = "5" BGCOLOR = "RED"> 
 
In the above command BGCOLOR has been used in the <TABLE> tag. To understand the use, see the example: 
 

<TABLE BORDER = "5" BGCOLOR = "RED"> 
<TD> 
IT IS QUITE REDDISH ! 
</TD> 
</TABLE> 

 

        Example results something like this - 
 
 
The entire table gets its background red. To change color of each cell in the table. BGCOLOR command is used in each <TD> tag. See example : 
 

<TABLE WIDTH = "75" BORDER = "2"> 
<TD BGCOLOR = "RED"> 
RED 
</TD> 
<TD BGCOLOR = "BLUE"> 
BLUE 
</TD> 
</TABLE> 

After you run the above mentioned example, figure like this appears on the browser – 
 
Both cells have different colors. The cell that contains RED has Sot red background while the cell that contains BLUE has got blue background. 
Let us see example in which a table containing two columns and two rows have been created and both rows have been provided two different 
colors. 

RED BLUE 

IT IS QUITE REDDISH 

 



 
 
 

SARVA EDUCATION (SITED) (Running- An I.T & Skill Advancement Training Programme)                                                                                                                                                            - 220 -                                                                                                                 

                                                                       

 

Visit us at:  www.sarvaindia.com                                                                 Licensed by Govt. of India                                                                       ISO 9001:2015 Certified 

 
<TABLE WIDTH = "200" BORDER = "2"> 
<TR BGCOLOR = "RED">  
<TD>RED</TD>  
<TD> AGAIN RED </TD> 
 </TR> 
<TR BGCOLOR = "BLUE">  
<TD> BLUE </TD> 
 <TD> BLUE AGAIN </TD>  
</TR> 
 </TABLE>  

 
You will see the effects of example like this - 
 
 
 
Thus, you can prepare calendar, price-list or whatsoever using tables. 
 
CREATING TABLES WITHIN TABLES 
 
Suppose you had this problem: You need to put two tables on the same line on your page. Oh no! the table tag automatically sends you to the next 
line! Well, you can set around this by placing your two tables inside one large table, thus keeping them on the same line.  
Let us start by placing one table inside another. See example: 
 

<TABLE WIDTH = "400" BORDER = "6"> 
<TD ALIGN = "CENTER"> 
<TABLE WIDTH = "300" BORDER = "2"> 
<TD ALIGN = "CENTER"> 
This is a table within a bigger table. 
</TD> 
</TABLE> 
</TD>  
</TABLE  

 
              Result of the Example on the Browser:- 
 
 
 
This can be a bit confusing at times. Just remember to keep track of which table you are in while you are writing the code. 
As for the problem at the beginning of the section, all we have to do is add another table cell to the big table, and then use a second smaller table 
inside that cell. To hide the appearance of the big table, we set the border on the big table to zero. See example: 

 
<TABLE WIDTH=”600” BORDER= “0”> 
<TD ALIGN = "CENTER"> 
<TABLE WIDTH = "275" BORDER = "4">  
<TD ALIGN = "CENTER">  
I am in the second small table! Ha! 
<TD>  
</TABLE>  
</TD ALIGN=”CENTER”> 
<TABLE WIDTH = “275” BORDER = “4”>  
</TD ALIGN=”CENTER”> 
I am in the second small table! Wow! 
<TD>  
</TABLE>  
<TD>  
</TABLE>  

 
Now we see the two inside tables 
 on the page side by side like this – 
 
 

RED AGAIN RED 

BLUE BLUE AGAIN 

 

This is a table within a bigger table. 

 
I am in the first small table! Ha! 
 

 
I am in the second small table! wow! 
 



 
 
 

SARVA EDUCATION (SITED) (Running- An I.T & Skill Advancement Training Programme)                                                                                                                                                            - 221 -                                                                                                                 

                                                                       

 

Visit us at:  www.sarvaindia.com                                                                 Licensed by Govt. of India                                                                       ISO 9001:2015 Certified 

USING FRAMES 
 

Let's have a look at elements used in the above mentioned example - 
 
<FRAMESET> 
 
This tag tells the web browser to expect a series of frames rather than a 
normal page. 
 
cols ="50%, 50%" 
 
This command inside the FRAMESET tag tells the browser to split the 
page into two columns. In this case, each column would take up 50% 
of the space on the screen. You can change the percentage to any 
number you like. You can also use pixels rather than percentage if you 
wish. If you use percentages, be sure to keep the % sign after each 
number, or the browser will read the number as a pixel value. 
 
<FRAME SRC = "FRAME1.HTM"> 
 

This tag lets you tell the browser the URL of the document in the 
frame farthest to the left. 
 
<FRAME SRC = "FRAME2.HTM"> 
 

This tag will specify the URL of the next frame, going from left to 
right. The browser will read your FRAME SRC tags for the columns 
from left to right. For this everything should be in order.  
Example: 
 

<HTML> 
<HEAD>  
<TITLE> MY AGE WITH THREE FRAMES </TITLE> 
</HEAD> 
<FRAMESET COLS = "33%, 33%, 33%"> 
<FRAME SRC = "Frame1.htm"> 
<FRAME SRC = "Frame2.htm"> 
<FRAME SRC = "Frame3.htm"> 
</FRAMESET> 
</HTML> 

 

After you implement example on browser, the effects will appear on 
the browser like one hi figure given below: 
The page now contains three columns and all are almost equal as 33% 
has been provided to each frame in the code. Rest 1% is made by the 
browser itself. If you do not want to leave it to browser, change any of 
the values to 34%. 
 

Figure: page with three different documents 

Prior to begin using frames on your web page, you will be wanting to 
know how frames work. A page with frames is really a page split 
into 2 or more sections, each containing its own html document. As 
you can see in figure given below, that shows a page with two 
frames. 
 

 
                            Figure: A page with two frames 
 
As in the figure both frames are actually two different web pages. 
The page that keeps the two frames has also its own html document. 
In this section we shall discuss how to create frames. Frame is built 
using the <FRAMESET> tag rather than <BODY> tag at the 
beginning of the document.  
See example: 

<HTML>  
<HEAD>  
<TITLE> My First Page with Frames </TITLE> 
</HEAD><FRAMESET COLS = "50%, 50%">  
<FRAME SRC = "FRAME1 .HTM">  
<FRAME SRC = "FRAME2.HTM">  
</FRAMESET>  
</HTML> 
 

Example result on the browser: 
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ADDING COLUMNS HORIZONTALLY AND VERTICALLY 
 

USING LINKING AND ATTRIBUTES ON THE FRAME 
 
Now, you can create a page with frames. But when you place a link 
inside a frame, the URL you linked to will only appear in that same 
frame! This is because a link within a frame will default to showing 
the next page inside the frame the link is. In this case you would 
certainly like to have the link put the new page in another frame, or 
come up without any frames around it. For this, just name each 
frame, and these specify the target frame in your link.  
 

See example: 
 

<HTML> 
<HEAD> 
<TITLE My Page with Linked Frames </TITLE> 
<FRAMESET cols = "20%, 80%"> 
<FRAME SRC = "FRAME1 .HTM" NAME = "Left_frame"> 
<FRAME SRC = "FRAME2.HTM" NAME = "right_frame"> 
</FRAMESET> 
</HEAD> 
</HTML> 

 

In example, each frame has got a name, you can use either frames 
name as a target inside a link tag. Indirectly, you can say you have a 
link inside the Left_frame (frame1.htm). If you want the new page 
to show up in the right_frame, you need to add the 
target="frame_name" command to your link tag. The following 
example link tag will be in the left_frame, but make the result show 
up in the right_frame: 
 
<A HREF="sarva.htm" target="right_frame"> About Sarva </A> 
 
Now the left_frame will remain unchanged, while the linked URL 
will show up in the right frame. You can link to any frame you want 
to this way. Just remember to name all of your frames so that you 
can target them. 
 
IMPORTANT ATTRIBUTES USED IN THE FRAME 
 
Some important attributes are used in the frame that you can add to 
your individual <FRAME> tags to help you control the design of 
the frames. They are as follows – 
 
scrolling = "no" 
 
This command will let you specify whether or not you want a 
scroller on the right side of the frame for users to scroll up and 
down. If you do not add this command, the browser will decide 
whether or not to add a scroller based on the length of the page 
inside the frame. If set to "yes", the frame will always have a 
scroller. If set to "no" the frame will have no scroller. 
 
border = "2" 
 
This command lets you specify the width of the frame border. You 
can set a number of your choice. 
 
resize = "no" 
 
This command lets you decide whether or not you want your 
viewers to be able to resize a frame by dragging the border across 
the page. If set "yes", users can resize the frame and if set to "no" 
the frame can not be resized. The default is yes. 
 

Suppose you want two frames vertically and one frame divided into two 
horizontal frames. For this, we use rows instead of cols for frames that 
go from top to bottom.  
 
See example: 
 

<HTML> 
 <HEAD> 
<TITLE> My Page with Mixed Frames </TITLE> 
</HEAD> 
<FRAMESET cols = "50%, 50%"> 
<FRAME SRC = "FRAME1 .HTM"> 
<FRAMESET ROWS = "50%, 50%"> 
<FRAME SRC = "FRAME2.HTM"> 
<FRAME SRC = "FRAME3.HTM"> 
</FRAMESET> 
</HTML> 

 

See result of the above mentioned example on the browser: 
 

 
                           Figure: A page based on three frames of mixed structure. 
 

The rows command reads from top to bottom, like the cols command 
reads from left to right You can have as many columns or rows as you 
like, but be sure to nest your frameset tags the way you want the frames 
to appear: 

 The first FRAMESET tag tells the browser to divide the page into two 
columns. 

 The FRAME SRC tag following it tells the browser the first columns should be 
filled withframel.htm. 

 The next FRAMESET tag is nested inside the first FRAMESET tag. This tag 
tells the browser to   divide the second column into two rows, rather than using 
a single html page to fill the column. 

 The next two FRAME SRC tags tell the browser to fill the two rows 
with frame2.htm at the topmost row and frame3.htm on the following 
row, moving from top to bottom. 

 Be sure to close all of your FRAMESET tags after they have been 
used. 
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More size 
 

CREATING A TEXT BOX 
 
After writing opening tag <FORM>, you can insert any 
element as required on a form. On your form, the most used 
element is usually a text box. Text box lets your users enter a 
line of text as required. To create this, do the followings – 
 

1. Within both form tags <FORM> and </FORM>, type the 
text you want to use as a label for the text box like <P> 
Name and press Enter. 

2. Then, type <INPUT TYPE = "text" and leave space. 
3. Type Name="name". Replace the name within the double 

quotation marks with a suitable name that describes the 
text box. 

4. Type Size = "n" to specify the width of the text box. 
Replace the n with a number required as the size of the 
text box. n is the number of characters used in the text 
box. For instance size = "20" 

5. Type MAXLENGTH="n" to limit the number of 
maximum characters used in the text box. Change the n 
with a number you want maximum characters in the text 
box. Like MAXLENGTH = "30"  

6. To end it, use the > key. To understand the entire process,  
 

See example: 
 

     <FORM METHOD = "POST" ACTION = 
      "mailto:mansoor3176@rediffmail.com"> 
     <P>Name 
     <INPUT TYPE="text" Name="text1” SIZE="20" 
      MAXLENGTH="30"> 
     </FORM>  

After you run the example, picture like this will appear on the 
browser. 
 
        Name 
 

 
CREATING A LARGE TEXT BOX 
 
The text box created in the earlier section has got a limit. 
Using that text box, You can let your users enter only one line 
in the text box. What about if your users need enter more than 
one line in the text box. In this situation, you need a text box 
that should be large and contains multiple lines. To create a 
large text box, do the followings – 
 

1. Type the text representing a label for the text box within 
both form tags <FORM> and </FORM> like - <P> 
Comments/Suggestions and press Enter. 

2. Type <TEXTAREA and press spacebar 
3. Then, type Name=" ". Within double quotation marks type a 

suitable word o name the text box. For example:  Name = 
"Suggestions" and leave space 

4. Type Rows = "n" and replace n with the number you want 
to allow your users type         the lines in the box. eg. Rows 
= "5" 

5. Type Cols="n" to specify the width of text box. Replace the 
n with the number you want to set the width of text box like 
COLS="30" 

6. Type WRAP> to use word wrap feature in the text box. 
Word wrap feature  Auto-matically changes the line when 
the column limit of the text box is over. 

7. Type </TEXTAREA> to close the tag. 

You may want to use this in place of resize="no", as not all browsers support 
the resize="no" command. Using both commands, you can safely present the 
users the scroll bar. 
 
margin width = "2" and marginheight = "2"  
 
These commands let you determine the margins between the frame and the 
contents of the frame. 
 
USING THE FORM 
 
Forms are created on web pages to get feedback. They can also be used as 
order form, form for survey on a special subject or for similar purposes. You 
can create your own form using the techniques being discussed as ahead. 
 
SETTING UP A FORM 
 
To use a form on your page, you will need two things. The HTML for the 
form and a CGI program to handle the form when it is submitted. 
To get a CGI program for you, you can see if your web server has one 
available for your use and find out from them how to use it in your HTML 
form code. Most web servers offer CGI programs for you to use for free. The 
most common program to handle a form is one that sends you the results via 
email, and this is the program most servers will provide. 
 
To create a form, two elements are specified – 
 
(1) METHOD property within <FORM> tag 
 
(2) ACTION property within <FORM> tag 
 
The METHOD command/property will almost always be set to "post". The 
other value is "get", but if you are using a program from your web server, 
you will likely be instructed to use method = "post". 
The ACTION command is asking for the address of a CGI program that will 
handle the form once it is submitted. 
 
 You will replace the: 
 
"/cgi-bin/mansoor.PI" 
 
with the exact address your server gives you to use their cgi program. If you 
are using your own program, upload the program to your server and use the 
address of your program. Before you upload a cgi program, be sure your 
server allows you to use your own cgi programs. If your server doesn't allow 
you to use your own cgi programs, don't do it. 
 
Let us know how to create some basic elements used on the form. The basic 
elements on a form are as follows – 
 
• TEXT BOX 

• CHECK BOX 

• RADIO BUTTON 

• MENU 

• SUBMIT AND RESET BUTTONS 
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See the example to look at the HTML codes. 
 

After you run the example on the browser, picture like this will 
display - 
 
 

Marital Status 
 
       Married         Unmarried 
 
CREATING A CHECK BOX 
 
You can build a set of check boxes on a form if you want visitors to 
be able to select one or more options. When creating check boxes, 
you need to specify the same information, you did while creating 
radio buttons. After understanding the information to be specified, 
do the followings to accomplish creation of check boxes – 
 
1. Type <INPUT TYPE = "checkbox" between both form tags 

<FORM> and </FORM>    and then leave space. 
2. Type Name = " " and under double quotation marks type the 

word that defines the group of check boxes like Name = "sports" 
3. Then type VALUE = " " to specify the information for each 

check box. Type the word under double quotation marks that 
describes the check box such as VALUE = "football". 

4. Type CHECKED if you want a special check box to be selected 
automatically. 

5. Type > to complete the check box. 
6. Type the text you want to use beside the checkbox. 
7. Repeat steps 1, 2, 3, 5 and 6 every time you want a check box be 

added in the set. See example to understand the html codes. 
 
<HTML> 
<HEAD>  
<TITLE> Feedback Form </TITLE> 
</HEAD> 
<P> Hobbies 
<FORMMETHOD="POST" 
ACTION="mailto:mansoor3176@rediffmail.com"> 
<INPUT TYPE="checkbox" Name="hobbies" Value="Cricket" 
CHECKED> 
Cricket<BR> 
<INPUT TYPE="checkbox" Name="hobbies" Value="Music"> 
Music<BR> 
<INPUT TYPE="checkbox" Name="hobbies" 
Value="Travelling"> 
Traveling<BR> 
</FORM> 
</HTML>  
 
After you run the example, the picture like this comes up on the 
browser 
 

Hobbies 
   Cricket 
    Music  
    Travelling 
 
CREATING A MENU 
 
You can create a menu that offers visitors a list of options to choose 
from. Normally menus are used for displaying lists of products, 
states or age groups. While creating radio buttons, you must specify 
the same thing specified in the earlier radio buttons and check boxes 
and then proceed to the following steps – 
 

<HTML> 
<HEAD> 
<TITLE> FEEDBACK FORM </TITLE> 
</HEAD> 
<P> Comments/Suggestions 
<FORMMETHOD="POST"ACTION="mailto:mansoor3176@yahoo.com"> 
<TEXTAREA Name="Suggestions" Rows="5" Cols="30" WRAP> 
</TEXTAREA> 
</HTML> 
After you run the example the browser will display like this – 
 

 
 
CREATING A RADIO BUTTON 
 
Radio button is used when your users have multiple choices to select 
and you allow them to choose one that is the most appropriate one. 
Before you create a radio button, you need provide some basic 
information to the browser as follows – 
 

 Selection of a word representing the whole group of options. It can 
be done using Name attribute. 

 Selection of a word for each radio button. Value attribute is used for 
this. 

 Selection of a word that will work as a label for each radio button. 
Now follow the instructions to create a radio button – 

 
1. Type <INPUT TYPE = "radio" between both form tags <FORM> 

and </ FORM> 
2. Type Name = " ". Name the word under double quotation marks that 

will represent the entire group of radio buttons. 
3. TYPE VALUE = " " to specify the information for one radio button. 

Type the word under double quotation marks that describes the radio 
button. 

4. Type CHECKED, if you want the radio button automatically 
selected. You can have this with only one radio button. 

5. TYPE > to complete the radio button. 
6. Type the text you want to appear beside the radio button on your web 

page. 
7. Repeat steps from 2, 3, 5 and 6 for as many radio buttons as you 

want to create.  
 

See the example to understand the HTML codes – 
 
<HTML> 
<HEAD> 
<TITLE> Feedback Form </TITLE> 
</HEAD> 
<P>Marital Status  
<FORM METHOD="POST" 
 ACTION="mailto:mansoor3176@rediffmail.com"> 
<INPUT TYPE="radio" Name="marital" Value="Married"> Married  
<INPUTTYPE="radio" Name="marital" Value="Unmarried"  
CHECKED> Unmarried 
</FORM> 
</HTML>  
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1. Type <SELECT NAME = " " between both form tags <FORM> and </ FORM>. Insert a word under double quotations that describes the menu 
you want to create. And then press SPACEBAR. For example <SELECT NAME = "COUNTRY" 

2. Type SIZE = "n" and replace n with the number of options you want readers to see in the menu  without using the scroll bar. eg. SIZE = "3" 
3. Type <OPTION VALUE = " " and insert a word under double quotations that describe^ the menu option. 
4. Type the text you want to appear for the menu option. 
5. Repeat steps 3 and 4 for each menu option you want to add. 
6. Type SELECTED if you want a particular menu selected. You can have this with one. 
 
See example to look through the HTML codes. 

CREATING A RESET BUTTON 
 
You can create a RESET button that allows your users to 
refresh the information entered by the user to create this 
button, do the followings – 
 
1. Type <INPUT TYPE = "reset" between both form tags 

<FORM> and </ FORMx 
2. Type VALUE = "   " and put a word that will appear on this 

button like VALUE =   "RESET" 
 

See example: 
 

<HTML> 
<HEAD> 
<TITLE> FEEDBACK FORM </TITLE> 
</HEAD> 
<FORM METHOD="POST"  
ACTION="mailto:mansoor3176 ©yahoo. com"> 
<INPUTTYPE="RESET" VALUE="REFRESH"> 
</FORM>  
</HTML> 

 
After you run the example, the result will be shown like this on 
the browser - 
 
 
 

So far, you have seen how to create various elements on a 
form. Now we write codes together in example to create a 
form incorporating all the elements discussed earlier. 
Example: 
 
<HTML> 
<HEAD> 
</HEAD> 
<FORM METHOD="POST" 
ACTION="mailto:mansoor3176@rediffmail.com"> 
<P> Name <INPUT TYPE="TEXT" NAME="prof» 
SIZE="20" 
MAXLENGTH="30"> 
<P> Place <INPUTTYPE="TEXT» NAME="prof" 
SIZE="20" 
MAXLENGTH="30"> 
<P> City <INPUTTYPE=" TEXT" NAME="prof" 
SIZE="20" 
MAXLENGTH="30"> 
<P> State <INPUTTYPE="TEXT" NAME="prof" 
SIZE="20" 
MAXLENGTH="30"> 
<P> Marital Status<BR> 
<INPUT TYPE="radio" Name=”marital” 
Value="Married"> Married 
<INPUT TYPE="radio" Name="marital" 
Value="Unmarried" CHECKED>Unmarried 

REFRESH 

<HTML> 
<HEAD> 
<TITLE> FEEDBACK FORM </TITLE> 
<P> Which country do you belong to? 
<FORM METHOD = "POST" 
ACTION="mailto:mansoor3176@rediffmail.com”> 
<SELECT NAME="Country" SIZE="3"> 
<OPTION VALUE = "India" Selected> India 
<OPTION VALUE = "Pakistani”> Pakistan 
<OPTION VALUE = "Nepal"> Nepal 
<OPTION VALUE = "Bangladesh"> Bangladesh 
<OPTION VALUE = "Bhutan"> Bhutan  
<OPTION VALUE = "Sri Lanka"> Sri Lanka  
<OPTION VALUE = "Malaysia"> Malaysia 
</SELECT>  
</FORM>  
</HTML> 

After implementing the codes written in example on a browser, the picture 
that appears will match with this – 
                               

Which country do you belong to? 

 
 
CREATING A SUBMIT BUTTON 
 
You can build a SUBMIT button which lets the user to click in order to store 
the information an your web server or on your e-mail account. To create 
SUBMIT button, do the followings – 
1. Type <INPUT TYPE = "Submit" between both form tags <FORM> and 

</ FORM>   and leave spaces. 
2. Type VALUE = "  ". Put the word under double quotation marks that ap-

pears on the button like VALUE = "ACCEPT"  
 

See example: 
 
<HTML> 
<HEAD> 
<TITLE> FEEDBACK FORM </TITLE> 
</HEAD> 
<FORMMETHOD="POST"ACTION="mailto:mansoor3176@yahoo.com"> 
<INPUT TYPE="SUBMIT" VALUE="ACCEPT"> 
</FORM> 
</HTML> 
 

After you run the example, the output on the browser will appear like this- 
 

 ACCEPT 
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<P>HOBBIES <BR> 
<INPUT TYPE=»CHECKBOX" NAME="HOB" VALUE="GARDENING" 
CHECKED>GARDENING<BR> 

<INPUTTYPE="CHECKBOX» NAME="HOB" VALUE="CRICKET»>CRICKET<BR> <INPUTTYPE=»CHECKBOX" 
NAME="HOB" VALUE="READING">READING<BR> 

<P> Comments/Suggestions<BR> 
<TEXTAREA Name="Suggestions" Rows="5" Cols="30" WRAP> 
</TEXTAREA> <BR> 
<BR> 
<BR> 
<INPUT TYPE="SUBMIT" VALUE="ACCEPT"> 
<INPUT TYPE="RESET" VALUE="REFRESH"> 
</FORM> 
</HTML> 
 
 
After you implement the example the effects on the browser can be shown in figure below:-  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

 
 
 
 

___________________________________________ 
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Unit-IXi    
  
 

 C LANGUAGEI 
 

 CHAPTER-1  
 

INTRODUCTORY CONCEPTS 
 
 

3.    High Level Language 
The assembly language is again a machine-oriented language and 
hence the program has to be different for different machines. The 
programmer should remember machine characteristics when he 
prepares a program. Writing a program in assembly language is 
still a slow and tedious task. High label languages are BASIC, 
COBOL, and FORTRAN etc. 
These languages consist of a set of words and symbols and one 
can write programs using these in conjunction with certain rules 
like ‘English’ languages. These languages are oriented towards 

the problem to be solved or procedures for solution rather than 
mere computer instructions. These are more user- centered than 
the machine-centered languages. They are better known as high 
level languages. 
 
The most important characteristic of a high level language is that 
it is machine independent and a program written in a high- level 
language can be run on computers of different makes with little 
or no modification. The programmer need not know the 
characteristic of that machine. However, such programs are to be 
translated into equivalent machine-code instructions before actual 
implementations. 
 
A program written in a high-level language is known as the 
source-program and can be run on different machines using 
different translators. The translated program is called the object 
program. The major disadvantage of high-level language is that 
they take extra time for conversion and thus they are less efficient 
compared to the machine-code languages. Figure shows the 
system of implementing the three levels of languages. 
 

Computer Languages   
    
The functioning of a computer is controlled by a set of instructions (called 
a computer program). These instructions are written to tell the computer. 
 
What operation to perform? Where to locate data? 
How to present result? When to make certain decisions? 
 
The communication always needs a common language or terminology. 
The language used in the communication of computer instructions is 
known as the programming language into this language. The computer has 
its own language and any communication with the computer must be in its 
language or translated into   this language. 
A language is a system of communication. We communicate to one 
another our ideas and emotions by means of language. Similarly, a 
computer language is a –mean of Communication, which is used to 
communicate between people and the (Computer). Using some computer 
language a programmer can still the computer what he wants to do. 
Computer languages divide in three parts:- 
 

1. Machine languages (low level languages) 
2. Assembly (or symbolic) languages, and 
3. High level languages 

 
1. Machine Language 
Computers are made of two-state electronic components which can un-
derstand only pulse and no-pulse (or '1' and '0') conditions. Therefore, al 
instructions 'and data should be written using binary -codes 1 and 0. The 
binary code is called the machine code or machine language  
Computer does not understand English, Hindi or Tamil. They respond 
only to machine language. Added to this, computers are not identical in 
design. Therefore, each-computer has its own machine language. 
(However, the script, 1 and 0, is the same for all computers.) This poses 
two problems for the user. First, it is a traumatic experience to understand 
and remember the various combinations of 1 'sand O's representing 
numerous data and instructions. Also, writing error-free instructions is a 
slow process. Secondly, since every machine has its own machine 
language, the user cannot communicate with other computers (if he does 
not know its language). Imagine a Tamilian making his first trip to Delhi. 
He would face enormous obstacles as soon as he moved out for shopping. 
A language barrier would prevent him from communicating. 
 
2.    Assembly Language 
An assembly language uses machine codes rather than numeric codes (as 
used in machine language). For example, ADD or A is used as a symbolic 
operation code to represent addition and SUB or S is used for subtraction. 
Memory locations containing data are given names .such as TOTAL, 
MARKS, TIME, MONTH, etc. As the computer understands only 
machine-code instructions, a program written in assembly language must 
be translated into machine language before the program is executed. , This 
translation is done by a computer program referred to as an assembler. 
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Algorithm and Flowcharts: 
 
Algorithm:   The set of instruction in a sequence manner is called algorithm. 
Flowcharts: The diagrammatic representation of program is called Flow chart. 

 
ALGORITHM AND FLOW CHART TO POST A CARD: 
 

 
 
 

 
Branching: Branching refers to the process of the following one of two more optional 
paths of computations. 

 
 
 
 
 
 
 
 
 

  

 

STEP-1.       START  
STEP-2.       PICK UP A POSTCARD        
STEP-3.       PICK UP THE PEN  
STEP-4.       WRITE ON THE POSTCARD 
STEP-5.       WRITE THE ADDRESS  
STEP-6.       GO TO THE POST-OFFICE  
STEP-7.       POST THE CARD 
STEP-8        STOP 
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LOOPING:  
 
Repeat the statement again and again is called loop. And this process is called looping. There are two types of loop. First is called DO and Test 
loop and second is called TEST and DO type loop. 
 

a) DO and Test loop:     In these loop firstly, we execute the statement    and then Test the condition. 
b) TEST and DO:          In these loop firstly, we test the condition then execute the statement. 

 

 
 

_________________________________________ 
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 CHAPTER- 2 
 

C  FUNDAMENTALS  
 

 
Structure of ‘C’ Program is given below:- 
 

#include directive(s) 
main( ) 
{ 
           declaration of constants and variables 
           sequence of instructions 
} 

 
Explanation of abovementioned structure program is as follow- 
C program is organized into routines: 
 
Main( ) –  
It represents the routine where program execution must begin and as 
the name suggests is the main or controlling routine.  
 
{ (Opening brace) & } (closing brace)- 
The  declaration of constants and variables and the language 
statements that make up the sequence of instructions contained in with 
in a function are delimited by the opening brace { and closing brace }. 
 
; (semi-colons)) –  
The declarations and executable statements within the function are 
separated by semi-colons.  
 
The C Character Set 
 
C uses the uppercase letters A to Z, the lowercase letters a to z, the 
digits 0 to 9, and certain special characters as building blocks to form 
basic program elements (e.g., constants, variables, operators, 
expressions). The special characters are listed below, 
 

 
  
Identifier 
 
The program element is called identifier.  
Identifiers consist of letters and digits, in any order, except that the 
first character must be a letter. Both upper and lowercase fetters are 
permitted, the underscore character ( _ ) can also be included to be a 
letter. An underscore is often used in the middle of an identifier. 
Example: the following names are valid identifiers. 

Introduction to ‘C’ Language 
 
‘C’ is a general-purpose structured programming language. C has 
certain features which are best suited for low jobs and certain 
features which enable the programmer to perform high level jobs, 
thus bridging the gap between the machine language & high level 
language. Earlier there was a language ‘Basic combined 
Programming Language’ called B, which was modified by Denis 
Ritchie and was implemented, at Bell Laboratories in 1972. This 
new language was called ‘C’ Language. ‘C’ is a middle-level 
language as it gives a minimal set of control and data-manipulation 
statements that they can use to define high-level constructs. It allows 
to efficiently communicating with a computer. 
 
Features of ‘C’ Language 
 
 Small Instruction Code 

The code of C Language is very small as compared to most of 
the languages. It needs few instruction codes to perform a job. 
 

 Portable 
        C Language is portable language. A language is said to be 

portable, if a program written in that language when taken to 
various other computers, runs with little or no modification.  

 
 No Formatting  
        C does not impose any format restriction on user as in COBOL; 

one can start writing from any place and end it at any place. 
 
 Efficient & Fast 
        Due to its variety of data types and powerful operators, 

programs written in C are fast & efficient.  
 
Use of ‘C’ Language 
 
C language is capable of system programming and application 
programming. System programming refers to a class of programs 
that either are part of or work with operating system of the computer. 
System programs make the computer able of performing useful 
work. System programs run very quickly.  
C could be used for many types of application like- Developing 
operating system, Assemblers, Compilers, Interpreters, Editors, 
System Utilities, Writing TSR`s, Database Application, Networks 
systems.  
 
‘C’ as a structure programming 
 
structure programming represents a procedure for describing the 
program in a series of stages or modules. It provides a clear and 
simple approach to program design. It is also called procedural 
language that is each statement in the language tells the computer to 
do something such as Get some input, add the numbers, display the 
output etc. A program in a procedural language is a list of 
instructions. The programmer creates the list of instructions and the 
computer carries them out. 
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(a)       Integer constants  
 
Integer constants do not contain decimal points, Variables can be 
declared as integers in the following ways. 
 

Int x, y; 
Short int x,y; 
Long int x,y; 

 

In the first statement, the variables x and y take integer values. In 
the second statement x, y are of the short integer type. The third 
statement declares x, y as long integer type variables. 
 
 I      Integer type data 
The keyword ‘int’ stands for the integer data type in C change its 
size is either 16 or 32 bits. 
 
II Short Integer data type 
Normally, the ‘short int’ is used to declare the short integer data 
type in C whose maximum size is 16 bits longs. 
 
III  Long integer data type  
Usually, the ‘long int’ stands for the long integer data type used in c 
and its size is 32 bits. 
 
IV Unsigned data type  
The undersigned numbers are whole numbers and always hold 
positive values and the sign bit also belongs to the value. The 
unsigned numbers may be classified into four : unsigned char, 
unsigned integer, unsigned short integer and unsigned long integer. 
The maximum size of the unsigned integer is 16 or 32 bits. 
 
(b)   Floating point constants- 
 
 Positive or negative numbers are represented in the exponential 
from (similar to scientific notation).    
 
Examples-   

9010E10 
7810.11E-11 
-10.990e8 
-1.oole-1 

 
The following floating point constant with their size: Float, Double, 
long double. 
 

 
 
(c)      Hex constants 
 
Hexadecimal numbers are integer numbers of base 16 and their 
digits are 0 to 9 and A to F (a to f). 
 
Examples- 

0x0 
0x3 
22x3 

As per the characteristic of identifier we can .classified identifier into 
variable and Constant. 
 
(a)    Variable 
(b)    Constant 

 
(a) Variables 
The value of identifier change during the programming is called 
variable. 
 
(b) Constant 
The Fix the value of identifier in during the programming is called 
Constants. There are three types of constants; string constants, numeric 
constants and character constants. 
 
 

 
 
 
1.     String constants  
 
A String constant is a sequence of alphanumeric characters enclosed in 
double quotation marks whose maximum length is 255 characters. 
Following are the examples of valid string constants:- 
 

 “The result = “ 
 “Rs. 2000,00” 
 “This is test program by Arjun” 

 
2.    Numeric Constants 
 
Numeric constants are positive or negative numbers. There are four 
types of numeric constant. Integer constant, floating point constant. hex 
constant and octal constant. An integer constant may either be a short 
integer or a long integer. A floating point constant may either be of 
single precision or double precision. 
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(d)    Octal constants 

 
 
 
Parts of C Program 
 
1.    Pre-Processor Directives,  
2.    Main Function. 
3.    Other Functions, Definition of Function etc. 
4.    All instructions write in tower case letter 
 
Example: 
 
 

 
 
 
 
 
 
 

 
 
 
 
 
 
 
 

______________________________________________ 
 

  
 
 
 
 

Octal numbers are integer numbers of base 8 and their digits are 0 
to 7. 

 
 
3.    Character Constants 
 
A character represented within single quotes denotes a character 
constant. 
 
 Here are some examples:- 
 

‘A’ 
‘a’ 
‘.’ 
, 
‘?’ 
Declaration of the character constants 
char x; 
char x,y,z; 

 
The following characters are used as non-graphic characters. The 
backslash(\) is used to denote non-graphic character and other 
special characters for specific operation. 
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CHAPTER- 3 
 

OPERATORS AND EXPRESSIONS  
 

   

Suppose, if we intended to evaluate the above expression as (x + y) * 
(x – z) 
Then the parentheses will be evaluated because it has the highest 
priority and the result will be different from the pervious expression. 
 
(5 + 6)       *      (5 – 8) 
11 * - 3 
- 33 
 
2.  Assignment Operators  
 
An assignment is used to assign back to a variable, a modified value of 
the present holding. 

 
For Example: 
 

X + = y is equal to x = x + y 
X - = y is equal to x = x - y 
 
3.   Comparison and Logical Operators  
 
The comparison operators and logical operator can be grouped into 
three. They are relational operators, equality operators and logical 
operators. 

OPERATORS 
 

 
 

1.   Arithmetic operator  

For example: if the following expression is not properly grouped 
using parentheses then the computer will evaluate as per the 
precedence. 
 

X + y * x – z   where x = 5, y = 6 and z = 8 
5  +  (6  *  5)  –  8 
(5 Z + 30) – 8 
35  –  8 
27                                                   The result is 27 
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b) Equality Operators:  
 
3.   Comma Operator : 
 
This operator is used as a separator in variable declaration. 
 
int   a, b, c: 
Float x, y, z;  

Operator, Purpose & Example 
 

 

 
 
SPECIAL OPERATORS 
 
1.   Unary Operators 
 

 
 
2.    Ternary operator (?:):  
 
These operators are used for three expressions. 
 
The Syntax: 

 
if the expression1 is true then expression2 is evaluate 
otherwise expressions will be evaluate. 
 
For Example: 
                               c=a>5:3:20    
 

If c is greater than 5 than c store 3 otherwise c store 20 
values. 
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Operators & Associativity                                                                        Summary of Operator                  
 

                
 
 
 
 
 

 
 
 

______________________________________________________ 
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CHAPTER- 4  
 
 

DATA INPUT AND OUTPUT 
 

 

 
 
THE GETS AND PUTS FUNCTIONS 
 
gets ( ) : These function is used to input one or more than string in 
variable. 
 
Example:      
                         char name[20]; 
                         void main() 
                          {                    
                        gets(name); 
                          } 
 
puts ( ) : These function is used to display one or more than string in 
variable on output. 
 
Example:    Wap for entered and display line. 
 

 

Single Character Input-The getchar Function 
Single characters can be entered into the computer using the C 
library function getchar. 
In general terms, a reference to the getchar function is written as: 
char variable = getchar (); 
 
Single character output -The putchar function 
Single characters can be displayed (i.e., written out of the computer) 
using the C library function put char.       
In general terms a reference to the putchar function is written as: 
putchar (character variable); 
 
Entering input data by the scant function 
Input data can be entered into the computer from a standard input 
device by means of the C library function scanf. 
Syntax: 

 
Conversion Character- 
It indicates the type of the corresponding date item. 
 

& -  
lt indicates the data item store in computers memory. 
 
Example: 

                Int a;   
                Scanf(“%d”,&a); 
 

 
 
Writing Output Date- The printf Function 
Output data can be written from the computer onto a standard output 
device using the library function printf.  
Syntax: 

 
 
Conversion Character- 
It indicates the type of the corresponding date item. 
Example: 

                  int a;     
                  printf("%d",a); 
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4.  Example program:  4 WAP for entered line and Display line. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

                                      Output    
                                      enter the line  
                                      India is great  
                                      India is great 
 
5.   Example program: 5 Wap for entered & display a single character  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
                                        Output 

Enter a character  
a 

 
6.  Example program: 6 Wap for Area of Circle. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

                            Output 
                           enter the radius 
                           3 
                           the area of circle=28.260000 

_______________________________________ 
 

#include<stdio.h> 
   #include<conio.h> 

void main()  
{      
char name[10]; 
clrscr(); 
printf("enter the line\n"); 
gets(name); 
puts(name); 
} 

 

#include<stdio.h> 
#include<conio.h> 
void main() 
{ 
char name; 
printf(“enter a character”); 
name=getchar(); 
putchar(name); 
getch(); 
} 

 

 

 
 
3. Example program:  3 WAP for Simple interest 

 
 
 

#include<stdio.h> 
#include<conio.h> 
void main() 
{ 
float pi=3.14,r,a; 
clrscr(); 
printf(“enter the radius\n”); 
scanf(“%f”,&r); 
a=pi*(r*r); 
printf(“the area of circle=%f”,a); 
getch(); 
} 
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CHAPTER- 5  
 
 

DECISION CONTROL STRUCTURES 
 

 
Example: if(a>b) 
                                    printf('ca is greter than b"); 
                        else 
                        if(a= =b)  
                        printf(" a is eqaul to b"); 
                        else  
                        printf (" b is greater than a");' 
 

Here, if a>b, in true it will print a is greter than b else check again 
the a = = b, in true it will print a is eqaul to b else print b is 
greater than a. 
 
3.     The conditional operator 
 
Syntax: 
 
example: 
                 int a,c; 
                 c=(a>8?3:6); 
 

Here, this statement will store 3 in c if a is greater then 8 
otherwise it will store 6 in c. 
 
4.     Switch case statement 
 
This statement uses a particular group of statements to be 
choosed from several available groups. 
 
 
 
 
 
 
 
 
 
 
 
 
 

Example program 1:    Wap for greatest among two Nos. 
 
 
 
 
 
 
 
 
 
 
 
                        
 
 
 
 
 
 

expression 1 ?expression 2:expressioh3 

Syntax: 
switch(variable) 
{ 
case constant 1: statement-1; 
break; , 
case constant n: statement-n; 
break; 
default: statement 
} 

 

#include<stdio.h> 
#include<conio.h>     
void main() 
{ 
int a,b;     
clrscr(); 
printf ("enter the value of a\n"); 
scanf("%d",&a);       
printf ("enter the value of b\n"); 
scanf("%d",&b);     
if(a>b) 
printf(" a is greater than b"); 
else 
printf(“b is greter than a"); 
getch(); 

} 

Introduction 
 
In C programming the following main type of Decision statement used for 
implementing the decision; control instruction. 
 

1. The if- statement 
2. The if- else statement 
3. The conditional operator.  
4. Switch case statement 

 
1. The if- statement 

 
 Syntax: 

               if (boolean expression ) 
               statement; 
  

 
  Example: 
                        if (a>b)  
                                  printf("a is greater then b"); 
Here, we given the condition that if a is greater then b that time the a is 
greater than b will be displayed on the screen  
 
2. The If- else statement 
 

 These statements execute   statement1 when is condition true and also 
execute    statement2.   when is condition false. 

 Syntax: 
              if (condition) 
                              statement1; 
             else 
                              statement2; 
  

Example:  
                                   if (a>b) 
                                   printf("a is greatest"); 
                                   else 
                                   printf(" b is greatest"); 
            Here, if a>b then print a is greatest statement. 
            And if condition is false then it will print b is greatest. 
           
            In use nested if we use another if in under of if 
 

Syntax: 
                If (condition1) 
                Statement1; 
else 
               if (condition2) 
               statement2; 
else 
               statements3; 
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   Example program 4: Wap for print seven day of the week. 

 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
                     
                      
 
                        
 
 
 Output 
                        enter the choice  
                        6 
                         Friday          
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 ________________________________________ 
 
 

#include<stdio.h> 
#include<conio.h> 
void main() 
{ 
int ch; 
printf(“enter the choice\n"); 
scanf(“%d”,&ch); 
switch(ch) 
{                      
case 1 : printf(“Sunday"); 
break; 
case 2 : printf ("Monday"); 
break; 
Case 3 : printf(“Tuesday"); 
break; 
case 4 : printf(“Wednesday"); 
break; 
case 5 : printf(“Thursday"); 
break; 
case 6 : printf(“Friday"); 
break; 
case 7 : printf("Saturday”); 
break; 
default: printf(" Invalid choice"); 
getch(); 

         }} 
 

Output 
                         enter the value of a 
                         5  
                         enter the value of b 
                         6 
                         b is greter than a 

 
Example program 2:    Wap for greatest among three Nos. 

 

            

 Output 
                

              enter the value of a 
               1 
               enter the value of b 
               2   
               enter the value of c 
               3 
               c is greter 

 
Example program 3:   Wap for leap year. 
 

 #include<stdio.h> 
#include<conio.h> 
void main() 
{ 
int year; 
printf(“enter the year\n”); 
scanf(“%d”,&year); 
if (year%4==0) 
printf(“the year is leap year"); 
else 
'printf("the year is not leap”); 
getch(); 
} 

  
                              Output 

                          enter the year 
                          2000 

                              the year is leap year 
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CHAPTER- 6  
 
 

LOOP CONTROL STRUCTURES 
 

 
3.     for  Statement 
 
This loop is test-Do type of loop, means first it check the condition 
and then execute the statement.  
 
 
 
 
 
 
 
 
 Exmple program 1: Wap to print 10 Nos using while loop. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
                                  
 
 
                                 Output 
                                 Print 10 number 
                                 0 
 1 
 2 
 3 
 4 
 5 
 6 
 7 
 8 
 9  

  

Syntax: 

                 for(intialization;condition;counter variable) 
                 { 
                                   statement; 
                 } 
 

Introduction 
 
1. while Statement  
2. do-while Statement 
3. for Statement  

In every loop three things are main- initialization of counter 
variable, condition, counter variable (increment/decrement 
purpose) 

 
1. while Statement  

This loop is test-Do type of loop, means first it check the condition 
and then execute the statement. 

 
 Syntax: 

              initialization of variable; 
              while(condition) 
                             { 
                                          statement 
                                          counter variable 
              }; 
 
Example: Print  ARJUN word 10 times. 
              int  i=0; 
                           while(i<10) 
                                         { 
printf(“ARJUN\n”); 
I++; 
};  
  

 
 
2.      do-while Statement 

This loop is Do-test type of loop, means first it executes the 
statement and then checks the condition   .  

 
 Syntax: 

               initialization of variable; 
                
               do  { 
                                        statement; 
                                        counter variable; 
               }while (condition );  
  

 
Example:    Print ARJUN  word 10 times.  
 

                 int  i=0; 
 
                           
                                        do  { 
print(“ARJUN\n”); 
I++ 
}while(i<9); 
  

 

 

#include<stdio.h> 

#include<conio.h> 

void main() 

{ 

int i; 

i=0; 

Clrscr (); 

printf(“Print 10 number\n”); 

while(i<10) 

{ 

printf(“%d\n”,i); 

i++; 

} 

getch(); 

} 
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Example program 3:   Wap to print 10 Nos using for loop 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
                          

                            Output 
 Print 10 number 
 0 
 1 
 2 
 3 
 4 
 5 
 6 
 7 
 8 
 9  

 
 
 
 
 
 
 
 

 
 
 

_______________________________________________ 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
#include<stdio.h> 
#include<conio.h> 
void main() 
{ 
int i; 
clrscr(); 
printf(“Print 10 number\n”); 

    for(i=0;i<10;i++) 
                { 
                printf(“%d\n”,i); 
                } 
                getch(); 
                } 
 

Example program 2:  Wap to print 10 Nos using do-white loop. 
 
   

 #include<stdio.h> 
#jnclude<conio.h> 
void main() 
{ 
int i; 
i=0; 
clrscr(); 
printf(“Print 10 number\n”); 
do  
{ 
printf(“%d\n”,i); 
i++; 
} 
while(i<10); 
getch(); 
} 

  
 
                         Output 
 Print 10 number 
 0 
 1 
 2 
 3 
 4 
 5 
 6 
 7 
 8 
 9  
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CHAPTER- 7 
 

FUNCTION 
 
 3.     Function calling 
       

In these we execute the function definition where we write these 
function.  
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
                Output 
                      WE ARE IN MAIN FUNTION 
                                I am ARJUN function 
                                I am MAHAKAL function 
                                I am SHIVA function 
                                I am NIRMALA function 

#include<stdio.h> 

#include<conio.h> 

void main(); 

void mahakal(); 

void shiva();  

void nirmala();  

void main() 

 { 

arjun();      

mahakal(); 

nirmala();  

getch(); 

}   

void arjun() 

{ 

printf(“l am ARJUN function\n”); 

} 

void mahakal() 

{ 

printf(“I am MAHAKAL function\n"); 

} 

void nirmala() 

{ 

printf(“l am NIRMALA function\n"); 

} 

void shiva() 

{ 

printf(“I am SHIVA function\n"); 

getch(); 

} 

 

Introduction 
 
The self contain program is called function. 
For create the function the following three major steps are necessary. 
 
1.    Function Prototype 
2     Function definition 
3.    Function calling 
 
1. Function Prototype 

 
In these, we define the type of function. 
As per the data type we can define function also. 
(int function, float function, double function, char function and void 
function.) 
 
In first four type of function return the value but void function not return 
nothing. 
 
 As per the use argument in function there are following type 

 
 
According to the argument there are following function: 
 
Without   argument 
 
In these we not use any argument. 
Example: 
                void arjun(); 
 
 
With   Argument 
 
In these we use any argument 
Example: 
                             void arjun(int  a,  int  b); 
 
 
With Argument and return 
                            
In these we use any argument with return type 
Example: 
                             void arjun(int  a); 
                             return(a); 
 
 
2. Function definition  

   
 In these we write the statement which we want to execute by the function. 
 
Example: 
                             void arjun() 
                             { 
                                         print(“hallo ARJUN”); 
                             } 
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Example program 3:    Wap for argument with return type function. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

_______________________________________ 
 
 
 
 
 
 
 

#include<stdio.h> 
#include<conio.h>  
void addition(int a,int b);  
void main() 
{ 
int a,b;   
clrscr(); 
printf(“ enter the value of a\n"); 
scanf(“%d",&a); 
printf(“ enter the value of b\n"); 
scanf("%d",&b); 
addition(a,&b); 
getch(); 
} 
void addition(int a,int b) 
{  
int c; 
c=a+b; 
getch(); 
        } 

Example program 2:      Wap for with argument function. 
 

 #include<stdio.h> 
#include<conio.h>  
void addition(int a,int b);  
void main() 
{ 
int a,b;   

clrscr(); 
printf(“ enter the value of a\n"); 
scanf(“%d",&a); 
printf(“ enter the value of b\n"); 
scanf("%d",&b); 
addition(a,b); 
getch(); 
} 
void addition(int a,int b) 
{  
int c; 
c=a+b; 
printf("the result of addition=%d",c); 
getch(); 
} 

  
 

         
    Output 
                                 enter the value of a, 
                                    1 
                                     enter the value of b 
                                    2 
                                    the result of addition=3                

 Output 
 Enter the value of a  
 1 
 enter the value of b 
 2 
 the result=3 
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CHAPTER- 8 
 

ARRAY 
 
Introduction 
                              Array is collection of same type of data. 
 

 Example program 2:    Wap for addition of two matrix. 
 

 
                  Output 

 
Enter the first 2*2 matrix 
1 
1 
1 
1 
enter the second 2*2 matrix 
1 
1 
1 
1 
the addition 2*2 matrix 
2          2 
2          2  

Declaration of Array 
 
 
One dimensional Array:  
 
In General definition one dimensional of array data store in one row or 
column. 
                            
             data type variable [size of array];  
                             
             Example:      int  a  [10]; 
 
Two dimensional Array:  
 
In General definition two dimensional of array data Store in one row or 
column. 
                 
           data type variable[size of array][size of array]; 
 
Example program 1 : Wap for entered and display element in array. 
 

 
                                              Output     
                                                        enter the element in array 
                                                                                1 
 2 
 3 
 4 
 5 
 6 
 7 
 8 
                                                                                9 
                                                                              10 
                                                            enter the element in array 
                                                            12345678910 
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Output 
Enter the first 2*2 matrix 
2 
2 
2 
2 
enter the second2*2 matrix 
1 
1 
1 
1 
the subtraction 2*2 matrix 

1  1 
1      1 

 

Example program3: Wap for subtraction of two matrix  
 

 
 
 
 
 
 
 

 
 
 
 
 
 
 
  
 
 
 
 
 
 
 
 

______________________________________ 
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Unit-Xi    
  
 

 C++ LANGUAGEI 
  

CHAPTER- 1  
 

‘C++’ FUNDAMENTAL 
 

 
Numeric Constants 
Numeric constants are positive or negative numbers. There are 
four types of numeric constants, integer constant and floating 
point constant, hex constant and octal constant. An integer 
constant may either be a short integer or a long integer. A 
floating point constant may either be of single precision or 
double precision. 
 

 
 

(a) Integer constants: 
 
Integer constants do not contain decimal points, Variables can 
be declared as integers in the following ways. 
                  int x, y; 
                  short   int  x;y; 
                  long int x,y; 
In the first statement, the variables x and y take integer values. 
In the second statement x, y are of the short integer type. the 
third statement declares x, y as long integer type variables. 
(i) Integer type data:- The keyword 'int’ stands for the 

integer data type in C an its size is either 16 or 32 bits. A 
16 bit integer may fall in the range of 215  to 215-1, while 
32 bit integers may fall in the range of -232  to 231  -1.  

 
(ii) Short integer data type:- Normally, the 'short int' is 

used to declare the short integer data type in C whose 
maximum size is 16 bits long. It may fall in the range 
between -32,768  to 32,767 or 215   to 215-1. 

 
(iii) Long integer data type:- Usually, the 'long int' stands 

for the long integer data type used in C++ and its size is 
32 bits, It may fall in the range of -2,147,483,648 to 
2,147.483.647 or -231  to 231- 1.   

INTRODUCTION TO C++ 
C++ is a Object oriented programming language. C++ was originally 
developed in 1983 by Bajaame Stroustrup. 
A C++ program is a collection of commands, which tell the computer to do 
"something". This collection of commands is usually called C++ source 
code, source code or just code. Commands are either "functions" or 
"keywords". Keywords are a basic building block of the language, while 
functions are, in fact, usually written in terms of simpler functions--you'll see 
this in our very first program, below. (Confused? Think of it a bit like an 
outline for a book; the outline might show every chapter in the book; each 
chapter might have its own outline, composed of sections. Each section 
might have its own outline, or it might have all of the details written up.) 
Thankfully, C++ provides a great many common functions and keywords 
that you can use. But how does a program actually start? Every program in 
C++ has one function, always named main, that is always called when your 
program first executes. From main, you can also call other functions whether 
they are written by us or, as mentioned earlier, provided by the compiler.  
 
The C++ character set 
C++ character set same as c uses the uppercase letters A to Z, the  lowercase 
letters a to z, the digits  0 to 9, and certain special characters as building 
block  to form basic program elements (e.g., constants, variables, operator, 
expressions). 
 
Identifier 
The C++ identifier is same as c programming language so refer c 
programming part.  As per the characteristic of identifier we can classify 
identifier into variable and constant. 
 
(a)    Variable       (b)    Constant 
     
(a)    Variables:  
 
The C++ Variables is same as c programming language so refer c 
programming part. 
 
(b)    Constant:  
 
The C++ Constant is, same as c programming Language so refer c 
programming part. There are three types of constants:- String constants, 
Numeric constants and Character constants. 

                                                   
String Constants 
A String constant is a sequence of alphanumeric characters enclosed in   
double quotation marks whose maximum length is 255 characters. Following 
are the examples of valid string constants. 
      
1. "The result - " 
2. "Rs. 2000,00" 
3. “This is test program by Sarva" 
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The following table summarizes the data types in C++ 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

________________________________________ 
 

(iv)    Unsigned data type:- The unsigned numbers are whole 
number s and always hold positive values and the sign 
bit also belongs toe the value. The unsigned numbers 
may be classified into four types; unsigned char, 
unsigned integer, unsigned short integer and unsigned 
long integer. The maximum size of the unsigned integer 
is 16 or 32 bits. 

 
(b)      Floating point constants- Positive or negative numbers 

are represented in the exponential form (similar to 
scientific notation). 
 
Examples: 
9010E10 

            7810.11E-11 
            -10.990e8 
            -1.oole-1       

The following floating point constant with their size: 
Float, Double, long double. 

 
(C)     Hex constants:- Hexadecimal numbers are integer 

numbers of base 16 and their digits are 0 to 9 and A 
to F (a to f). 

            Example:- 
           0x0 
          -Ox3 
           22x3.  
  
(d)     Octal constants:- Octal numbers are integer numbers of 
base 8 and their  
          digits are 0 to 7 
 

 
 
Character Constants  
 

A character represented within single quotes denotes a 
character constant. 

 
Here are some examples, 

‘A’ 
‘a’ 
‘.’ 
“?’ 
 
Declaration of .the character constants. 
char x  
char x,y,z;  
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CHAPTER- 2  
 

OPERATORS AND EXPRESSIONS 
 

OPERATORS    
The C++ Operators is same as c programming c programming part.  

 
Summary & Example of C++ Operators 
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BASIC DATA TYPES 
 

 
 
 

 
 
 

__________________________________________ 
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CHAPTER- 3 
 

DATA INPUT AND OUTPUT 
 

 
                          Output 
                          enter the value of principle 
                          1000 
                          enter the value of rate 
                          2 
                          enter the value of time 
                           2                   
                          the result of si= 40.000000 
 
Example program: 4 Wap for entered Hue and display line. 

 
                  Output 
                  enter the line  
                  India is great    
                  India is great 
 
Example program: 5 Wap for entered and display one character. 

 
Output 
enter a character 
a 

 
Example program: 6 Wap for Area of circle. 

  
                                 Output 

                     enter the radius 
                     3 
                     the area of circle=28.260000 

 
 ____________________________________________ 

Entering input data by the cin statement  
Input data can be entered into the computer from a standard input 
device   by cin statement. 
         Syntax: 

Cin>>variable; 
Int a; 
Cin>>a 

 
Writing Output Data by cout statement 
Output data can be written from the computer onto a standard output 
by cout statement.  
Syntax: 

              int a=10;  
cout«variable; 
Cout<<a;      
cout<<"INDIA" 

 
Example program: 2 Wap for Addition of two Nos. 
 

 
Output: 
enter the value of a 
6 
enter the value of b 
6 
the value of c=12 

 
Example program: 3 Wap for Simple interest 
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Syntax: 
            if (condition) 
                           statement1; 
             else                                

statement2; 
 

CHAPTER- 4 
 

DECISION CONTROL STRUCTURES 
 

Introduction 
 

In C++ programming the following main type of Decision statement used for implementing the decision control instruction same as c 
programming. 
  

1. The if- statement  
2. The if- else statement  
3. The conditional operator. 
4. Switch case statement 

 
1.    The if- statement   : 
       Syntax: 

Example: 
If  (a>b) 
printf("a is greater then b”);  
here, we given the condition that if a is greater then b that time the a is greater then b will be displayed on the 
screen.  

 
2.      The if- else statement: 

 These statements execute   statement1 when is condition true and also execute statement2   when 
is condition false. 
 

Example: 
if (a>b) 
            cout<<”a is greatest"; 
else 
            cout<<" b is greatest”; 

here, if a>b then print a is greatest statement and if condition is false then it will print b is 
greatest.  In use nested if we use another if in under of if. 
 

 
                       
Example: 

             if(a>b) 
                                cout<<" a is greter than b"; 
             else 
             else if(a==b) 
                               cout<<" a is eqaul to b"; 
             else 
                              cout<<" b is greater than a";  

 
 
 

 
here, if a>b, in true it will print a is greater than b else check again the a = = b , in true it will print a is equal to b else print b is greater than a. 
 
3.      The conditional operator 
  

 
Example: 

                           int a,c;  
                           c=(a>8?3:6); 
here, this statement will store 3 in c if 
a is greater then 8 otherwise it will 
store 6 in c.  
 
 

 
 

 
syntax: 
              expression1?expression 2:expression3 
 

Syntax: 
 

Switch(variable) 
{ 
             case constant 1: statement- 1; 
             break; 
             case constant n: statement-n; 
             break; 
             default: statement 
} 

if (boolean expression )         
statement;      

Syntax:         
        (condition1) 
        statement1; 
else 
        if (condition2)  
        statement2; 
else 
        statement3; 
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Example program 3 : Wap for leap year.  
 

 
Output  
enter the year 
2000 
the year is leap year 

 
Example program 4 : Wap for display seven day in a week. 
 

 
Output 
Enter the choice 
6 
Friday 
 
 
 
 
 
 
 
 

___________________________________________ 
 
 

Example program 1 : Wap for greatest among two Nos.   
 

 
 

Output 
enter the value of a 
5 
enter the value of b 
6 
b is greter than a 

 
Example program 2:  Wap for greatest among three Nos. 
 

 
Output 
enter the value of a 
1 
enter the value of b 
2  
enter the value of c 
3 
c is greter 
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CHAPTER- 5  
 

LOOP CONTROL STRUCTURES 
 
Introduction 
1.      while Statement 
2.      do-while Statement 
3.      for Statement  

In every loop three things are main- initialization of counter variable, condition, counter variable (increment/decrement purpose) . 
 
1.      while Statement 

These loop is test-Do type of loop, means first it check the condition and then execute the statement.    
 

 
2.      do while Statement  

This loop is Do-test type of loop, means first it executes the statement and then check the condition.  
 

 
 
Example:    Print SARVA word 10 times. 
                     Int i=0; 
                                          do { 
                     cout<<”SARVA\n”; 
                     i++; 
                     }while(i<9); 
3.      For Statement  

This loop is test-Do type of loop, moans first it checks the condition and then executes the statement. 
 

 
 
Example:  Print ARJUN word 10 times. 
        int I; 
                For(i=0;<10;i++) 
               { 
                        cout<<”SARVA”; 
               } 
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Example program 1: Wap to print 10 Nos using while loop. 
 

Example program 3 : Wap to print 10 Nos using for loop. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

______________________________________________ 
 
 

 
                     

 
 
Example program 2:   Wap to print 10 Nos using do-while loop. 
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 CHAPTER- 6   
 

FUNCTION 
Introduction 
The self contain program is called function. 
For create the function the following three major steps are necessary:- 
1.   Function  
2.   Function definition 
3.   Function calling 
 
1.   Function Prototype 

In these, we define the type of function. 
As per the data type we can define function also. 
(int function, float function. double function, char function and void function.) 
In first four type of function return the value but void function not return void 
nothing.As per the use argument in function there are following type without 
argument. In these we do not use any argument. 

 
2.    Function definition 
       In these we write the statement which we want to execute by the function. 
 

Example:        
      void sarva()                             
      {  
                 cout<<"hallo SARVA”;   
      }   

      
Example program 3:  
Wap for argument with return type 
function. 
 

 
 

                       Output 
                       Enter the value of a 
                       1 
                       enter the value of b 
                       2 
                       the result =3 
 

 
 
 

_______________________________________ 
 

Example: 
                      void sarva(); 

With Argument       
       In these we use any argument. 
Example: 
                      void sarva(int a, int  b); 

With Argument and return 
In these we use any argument with return type. 

Example: 
                     void sarva(int a);  
                     return(a); 

Example program 1:    
Wap for without argument function. 
 

 
    Output     

WE ARE IN MAIN FUNCTION 
I am ARJUN function 
I am MAHAKAL function 
I am SHIVA function  
I am NIRMALA function 

3.   Function calling         
In these we execute the function definition where we write these function. 

Example program 2:   
Wap for with argument function. 

 
 

        Output 
         enter the value of a 
         1 
         enter the value of b 
         2 
       the result of addition=3  
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CHAPTER- 7  
 

ARRAY 
 
Introduction 
Array is collection of same type of data. 
 
Declaration of Array 
 

1.  One dimensional Array:  
In general definition one dimensional of array data store in one row or column.  
data type variable[size of array];   
Example: int a[10];  

2.  Two dimensional Array:  n general definition two dimensional of array data store in one row or column. data type variable[size of array][size 
of array]; 

 

Example program 2: Wap for subtraction of two matrix 
 

 
     Output 

Enter the first 2*2 matrix 
2 
2 
2 
2 
enter the second 2.2 matrix 
1 
1 
1 
1 
the substraction 2*2 matrix 
1      1 
1      1 

 
________________________________________________ 

 

Example program 1: Wap for addition of two matrix. 

 
 

Output  
enter the first 2*2 matrix 
1 
1 
1 
1 
enter the second 2*2 matrix 
1 
1 
1 
1 
the addition 2*2 matrix 
2         2 
2         2 
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CHAPTER- 8  
 

CLASSES 
 
 
Introduction to Classes 
 
The word class is a fundamental and powerful keyword in c++. It is significantly useful as it is used to combine the data and operations of a 
structure into a single entity. The class construct provides support for hiding, abstraction, encapsulation, single inheritance, multiple inheritance, 
polimorphism and public interface functions (methods) for passing message between objects. 
 
 
Data abstraction: In oop's, the data abstraction is defined as a collection of data and methods (function).                    
 
Data Hiding: In C++, the class allows to declare data and methods as public private and protected group. 
 
Data encapsulation:  The internal data (the member data) of a class are first separated 'from the outside world (the defined class). 
 
Inheritance:  C++ allows a programmer to build hierarchy of classes. The basic feature of classes (parent classes of basic classes) can be passed 
onto the derived classes (child classes). 
 
Polymorphism: In oop, polymorphism is defined as how to carry out different processing steps by a function having the same messages. 
 
 
SPECIFYING A CLASS  
A Class specification has two parts:   
     
1.   Class declaration. 
2.   Class function definition 
 
The general form of a class declaration is: 
 
  The body of a class is enclosed within braces and terminated by a semicolon The class body contains the 
declaration of variables and functions. These functions and variables are called class members. They are 
grouped under two part namely, private and public, the class member that have been declared as In keyword 
private can be accessed only from within the class, IN public members can be accessed from outside the 
class also. 
 
Example:  Class with data and member function 
 

 

Output  
enter the date (dd-mm-year) 
12  1  99 
Today's date is = 12/1/99 
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Example:    methods are defined out of the scope of the class 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 

_________________________________________ 
 
 

Example: member functions are defined wit 
 

 
 

Output  
Enter any two numbers  
1 2 
x = 1 
y = 2 
sum = 3 
dif = -1 
mul = 6 
div = 0 
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CHAPTER- 9  
 
 

SOLVED PROGRAM 
 

 
EXAMPLE 4 : WAP TO INCREASE AND DECRESE THE INPUT 
VALUE BY 1.   

 
Output 

Enter k 
2 
the incremented value of k is 3 
enter j 
3 
The decremented value of j is 2 

 
EXAMPLE 5 : WAP TO DISPLAY AREA AND PERIMETER OF 
RACTANGGLE. 

 
 
Output 

    Enter two sides x y : 
1 4 

    Area of rectangle is 8 sqr. units 
    Perimeter of rectangle is 12 

EXAMPLE 1: WAP TO INPUT A NO. ANDTO PRINT ITS CUBE BY 
POW () FUNCTION*/ 

 
Output  

Enter any number: 
3         

            the cube of the number is: 27 
 

 
EXAMPLE 2: WAP TO DISPLAY CUBEROOT OF A NO.*/ 

 
Output 

Enter the value of a 
8 
cube root of a is 2 

 
EXAMPLE 3:   WAP TO CONVERT GRAM TO KILOGRAM. 
 

 
Output 

Enter grams 
1000 
quantity in kilogram is =1 
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Output 
Enter three sides x y z : 
3 4 5 
Area of Triangle is 6 sqr units 

 
EXAMPLE 9: WAP TO FIND THAT ENTERED YEAR IS A LEAP 
YEAR OR NOT. 
 

 
Output  

enter year       
2002    
leap year 

 
EXAMPLE 10 : WAP TO CALCULATE GROSS SALARY BY 
CONSIDERING HOUSE RENT    ALLOWANCE, DEARNESS 
ALLOWANCE.   
 

 
 
Output 

The basic salary  
500 
gross salary=Rs. 1125  

EXAMPLE 6 : WAP TO INPUT TWO VALUES & EXCHANGE THEM 
(SWAPING) BY USING THIRD TEMPORARY 
VARIABLET. 

 

 
Output 

Enter two values 
4  5 
entered values are x=4, y=5 
values after swaping x=5, y=4 

 
EXAMPLE 7 :  WAP TO FIND TOTAL EXPENSES.  

 
 
                       Output 

Enter travelling exp in Rs. 
2000 
Enter dry cleaning exp. In Rs. 
200 
Enter lodging and boarding exp. In Rs. 
300 
The total exp are Rs. 2500 

 
 EXAMPLE 8 :  WAPTO FIND AREA OF TRAINGLE. 
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Output 
Enter cp: 
200 
Enter sp:  
90 
The toss is Rs.110  

 
Example 14 : WAP TO GENERATE THE TABLE OF NUMBER 
ENTERED BY USER. 
 

 
 
     Output  

Enter the number2 
2x1 =2 
2x2=4 
2x3=6 
2x4=8 
2x5=10 
2x6=12 
2x7=14 
2x 8=16 
2x9=18 
2x10 = 20 

 
Example 15:    WAP FOR STRING COPY 
 

 
 
 

_______________________________________________ 

EXAMPLE 11 : WAP TO INPUT NO. AND FIND OUT IT IS EVEN OR 
ODD NO. 

 
Output 

enter no. 
24 
even 

  
EXAMPLE 12 :  WAPTO FIND THAT THE NO. IS DIVISIBLE BY SIX 
OR NOT. 

 

 
Output 
enter i 
36  
The number is divisible by 6 . 

 
EXAMPLE 13 :  WAP TO FIND PROFIT OR LOSS OR NO PROFIT NO 
LOSS 1N SELLING. 
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